15:00:33 <Bmagic> #startmeeting 2023-08-08 - Developer Meeting
15:00:33 <pinesol> Meeting started Tue Aug  8 15:00:33 2023 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:33 <pinesol> The meeting name has been set to '2023_08_08___developer_meeting'
15:00:42 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-08-08
15:00:48 <Bmagic> #topic Introductions
15:00:54 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:01:17 <sleary> #info sleary = Stephanie Leary, Equinox
15:01:19 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:22 <eeevil> #info eeevil = Mike Rylander, EOLI (someone snagged my nick ... grrrrr)
15:01:24 <berick> #info berick Bill Erickson, KCLS
15:01:28 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:32 <tlittle> #info tlittle = Tiffany Little, PINES
15:01:33 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:38 <Stompro> #info Stompro = Josh Stompro, LARL/NWRL
15:01:58 <sandbergja> #info sandbergja = Jane Sandberg, Princeton University Library
15:02:14 <collum> #info collum = Garry Collum, KCPL
15:02:24 <smayo> #info smayo = Steven Mayo, PINES
15:02:52 <Bmagic> Feel free to introduce yourselves as you arrive.
15:03:03 <Bmagic> #topic Action Items from Last Meeting
15:03:07 <Bmagic> #info mmorgan will explore moving LP stats to community site and automating same
15:03:19 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS.
15:03:27 <mmorgan> Just a status report at this point
15:03:41 * mmorgan is continuing to track the Launchpad stats in this sheet https://docs.google.com/spreadsheets/d/1igd02X0VjIcJrGdmcEQ34bAha8b3IHYprHkdZhcOkkE/edit?usp=sharing
15:03:53 <mmorgan> also looking into employing the Launchpad APIs, but no real progress yet.
15:04:03 <Bmagic> #info https://docs.google.com/spreadsheets/d/1igd02X0VjIcJrGdmcEQ34bAha8b3IHYprHkdZhcOkkE/edit?usp=sharing
15:04:15 <sharpsie> #info sharpsie = Chris Sharp, GPLS
15:04:25 <abneiman> mmorgan++
15:04:29 <Bmagic> mmorgan++
15:05:09 <Bmagic> This next section is void of talking points, but in case anyone wants to say anything...
15:05:12 <Bmagic> #topic OpenSRF
15:06:02 <Bmagic> nada?
15:06:25 <Bmagic> alrighty:
15:06:27 <Bmagic> #topic Evergreen
15:07:08 <abneiman> #info EG security releases on Jul 24: https://evergreen-ils.org/evergreen-security-releases-3-9-4-3-10-3-and-3-11-1/
15:07:38 <Bmagic> abneiman: excellent! Thank you.
15:08:21 <Bmagic> I suppose that's Evergreen for now
15:08:41 <Bmagic> #topic Documentation
15:08:50 <Bmagic> #info DIG Meeting rescheduled to Thursday, August 10
15:09:17 <Bmagic> #topic Documentation - Accessibility guide is now copied into the wiki. Let sleary know what you'd like to see added.
15:09:23 <Bmagic> #info https://wiki.evergreen-ils.org/doku.php?id=accessibility:start
15:09:40 <sandbergja> sleary++
15:09:50 <Bmagic> sleary++
15:09:51 <mmorgan> sleary++
15:09:56 <abneiman> sleary++
15:09:59 <tlittle> sleary++
15:10:15 <berick> sleary++
15:11:27 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:11:32 <Bmagic> incoming paste
15:11:46 <Bmagic> #info Open Bugs - 2971
15:11:46 <Bmagic> #info Pullrequests - 89
15:11:46 <Bmagic> #info Signedoff - 14
15:12:20 <Bmagic> #topic Launchpad Updates Since Last Meeting
15:12:29 <Bmagic> #info Bugs Added - 39
15:12:29 <Bmagic> #info Pullrequest tag Added - 10
15:12:29 <Bmagic> #info Signedoff tag Added - 4
15:12:29 <Bmagic> #info Fix Committed - 2
15:12:39 <Bmagic> mmorgan++
15:12:49 <sandbergja> mmorgan++
15:12:55 <Bmagic> #topic New Business
15:12:56 <sleary> mmorgan++
15:13:10 <Bmagic> #info Throw together a draft of some of this dev-facing documentation?
15:13:29 <Bmagic> #info https://wiki.evergreen-ils.org/doku.php?id=newdevs:tutorials-wanted
15:14:00 <sandbergja> I put this on the agenda.  I was wondering if we could take 10 minutes or so of this meeting to just claim items from that list, and maybe put together some skeletal drafts on the wiki
15:14:29 <sandbergja> (maybe it would make sense later in the agenda, after other business?)
15:14:48 <sleary> I don't think Terran is here today, but I think she has something cooking for the grid columns
15:15:04 <Bmagic> might as well go now, we're doing good on time
15:15:26 <Bmagic> Anyone want to claim: "How grid cell templates work"
15:15:46 <berick> i can do that.
15:15:56 <sandbergja> berick++
15:16:04 <Bmagic> berick++
15:16:06 <berick> just put some words and maybe code together?
15:16:11 <sleary> berick++
15:16:17 <mmorgan> berick++
15:16:37 <Bmagic> #action berick will make tutorial:  "How grid cell templates work"
15:16:49 <sleary> berick Yes, just a brief example of a custom template, and maybe something about how the default value is printed?
15:16:58 <sandbergja> Are these going in the newdevs namespace on the wiki?
15:17:02 <berick> i can also talk about the store service.  just toss it into this page?
15:17:09 <berick> *services
15:17:36 <Bmagic> Anyone want "Add missing field to print template"
15:17:50 <jeff> sure, I can take that one.
15:18:06 <Bmagic> #action jeff will make tutorial: "Add missing field to print template"
15:18:15 <berick> may need 2 versions for ang and angjs for print templates
15:18:18 <jeff> who is the best resource (or recording) for further context on some of these?
15:18:22 <jeff> *nod*
15:18:27 <jeff> good reminder. thanks!
15:18:29 <sleary> I think either dev or newdevs namespace is fine as long as items get added to the newdevs sidebar, which has a mix of stuff at the moment
15:18:39 <berick> jeff: i can answer anything about the ang templates
15:18:43 <sleary> jeff I added the grid items, but the others came from an older list of topics in the newdevs files
15:18:44 <tlittle> berick If you write it up, we can move it around on the wiki wherever would be a good spot for it
15:18:59 <berick> tlittle: k, thanks
15:19:10 <jeff> berick: I already had you as a resource there, I was wondering who to ask if I have questions about the question itself. :-)
15:19:17 <jeff> sleary: thanks!
15:19:32 <Bmagic> berick++ jeff++ tlittle++ sleary++
15:19:34 <berick> ah, recursive resources
15:19:57 <Bmagic> Anyone want "Do a database call (Galen’s cat counter)"
15:20:17 <sandbergja> I can, but don't know about the cat counter :-)
15:20:20 <sleary> That is another old one that I'm assuming references a talk or a demo
15:20:48 <Bmagic> #action sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:21:28 <Bmagic> It's hard to believe that Galen had anything to do with "cat"
15:21:37 <sleary> :D
15:21:47 <sharpsie> @cat
15:21:47 <pinesol> sharpsie: http://i.imgur.com/VhlQK.gif
15:22:03 <sharpsie> pinesol: nope
15:22:03 <pinesol> sharpsie: BIG LETTERS MEAN BIG IDEAS, AM I RIGHT THOUGHT LEADERS?
15:22:03 <Bmagic> next up we have "Retrieve a user's setting and do something based on its value"
15:22:18 <Bmagic> anyone want to write that one ^^ ?
15:22:57 * berick looks around for some thought leaders
15:23:19 <jeff> seeing no other takers: sure, I'll go for that one also.
15:23:24 <Bmagic> jeff++
15:23:30 <sharpsie> jeff++
15:23:40 <mmorgan> jeff++
15:23:40 <Bmagic> These are going quick! Yall rock, just one more
15:23:47 <mmorgan> sandbergja++
15:23:52 <Bmagic> #action jeff will write tutorial "Retrieve a user's setting and do something based on its value"
15:24:13 <Bmagic> last one, and the most awesome one! "Guide to the various store services" <-- any takers
15:24:26 <berick> i offered to take that one earlier
15:24:28 <jeff> berick spoke up for that one above.
15:24:31 * Bmagic tries to make it enticing
15:24:51 <Bmagic> oh, I missed that
15:24:53 <berick> oh wait, let's see how enticing it gets...
15:25:09 <Bmagic> thanks berick!
15:25:35 <Bmagic> #action berick will write enticing tutorial "Guide to the various store services"
15:25:46 <abneiman> played yourself, berick, you should've held out for fabulous prizes
15:25:53 <mmorgan> Beach read!!
15:26:16 <berick> the night was sultry
15:26:53 <abneiman> sandbergja: I heard from Galen that the cat counter references this presentation: https://evergreen-ils.org/wp-content/uploads/2019/04/Writing-Angular-for-Evergreen-Galen-Charlton.pdf
15:27:13 <Bmagic> sandbergja: anything else to add?
15:27:15 <sandbergja> abneiman++ # thanks!
15:27:53 <sandbergja> Thanks for grabbing those docs needs, and thanks for facilitating that agenda item, Bmagic!
15:27:58 <sleary> berick++ jeff++ sandbergja++
15:27:59 <sleary> thank you all!
15:28:19 <Bmagic> moving onto our next topic:
15:28:22 <Bmagic> #topic Are we ready to think about Angular 16?
15:28:39 <Bmagic> sandbergja: all in a day's work :)
15:29:15 <sleary> this was me. I don't think the upgrade to 16 is going to be nearly as annoying as 15 was. That said...
15:29:16 <Bmagic> the wiki history says "scl" added this
15:29:30 <Bmagic> ah! Take it away sleary
15:29:47 <sleary> since ng-bootstrap hasn't updated yet to reach parity with Bootstrap 5.3, we might want to wait for that
15:30:31 <sleary> 5.3 has some nice accessibility improvements
15:31:09 <eeevil> waiting_for_one_less_treadmill_mile++
15:31:23 <Bmagic> I like the sound of that
15:31:38 <sleary> I want Ang16 mainly for the ESLint rule simplification mentioned in bug 2017793 but I'm content to wait for ng-bootstrap to catch up
15:31:38 <pinesol> Launchpad bug 2017793 in Evergreen "Wishlist: Add ESLint accessibility rules" [Wishlist,Confirmed] https://launchpad.net/bugs/2017793
15:32:32 <Bmagic> waiting sounds like the plan
15:32:38 <sleary> I will go ahead and file a bug unless someone has beaten me to it in the last few minutes
15:33:14 <Bmagic> sleary++ # not seeing a new bug filed in the last few minutes
15:33:31 <Bmagic> I'm glad everyone is in the volunteer mood, because:
15:33:50 <Bmagic> #info Fall release planning / release team
15:34:44 <abneiman> yeah that was my item - I'm happy to help with wrangling & organizing
15:35:04 <abneiman> but mostly fall things are ~already happening~ so we should probably get some sense of a team & schedule together
15:35:05 <Bmagic> abneiman++
15:35:22 <Bmagic> I can't believe it's August. It's probably time to get that team setup?
15:35:33 <sleary> the linear nature of time strikes again
15:36:25 * Bmagic waves at jvwoolf. Just in time to volunteer for release team! You're hired!
15:37:14 <jvwoolf> LOL I would but I will be giving birth any day now
15:37:27 <abneiman> jvwoolf++ #multitasking
15:37:41 <abneiman> in all seriousness, we need a core committer, because I am not that
15:37:47 <Bmagic> mmorgan, Bmagic, JBoyer are 3.11. Yall wanna roll into 3.12?
15:38:23 * mmorgan is willing, but doesn't want to steal the opportunity from anyone else ;-)
15:38:57 <abneiman> like I said, I can help on the wrangling / coordinating side
15:39:19 <Bmagic> abneiman: right, you're in!
15:39:26 <mmorgan> Maybe a call for volunteers to the dev list?
15:39:42 <abneiman> and, there's in-person Hackaway this year, which will be great to include in the release planning schedule
15:39:44 * JBoyer appears to say, very much email lists
15:39:57 <Bmagic> #action Bmagic will send a call for volunteers to the dev list
15:40:18 <Bmagic> #topic Announcements
15:40:24 <Bmagic> #info Next Meeting is Tuesday, September 12th
15:40:38 <Bmagic> #info Bug Squashing Week is August 21-25
15:40:43 <Bmagic> #info https://wiki.evergreen-ils.org/doku.php?id=dev:bug_squashing
15:41:25 <Bmagic> Thats the bottom of the agenda. We have some minutes. Anyone want to add anything?
15:42:21 <Bmagic> I'll put this one in
15:42:29 <Bmagic> #info Enhanced concerto improvements (date carry) Lp 2023690
15:42:29 <pinesol> Launchpad bug 2023690 in Evergreen "Enhanced Concerto dataset (Cont.)" [Undecided,New] https://launchpad.net/bugs/2023690
15:43:04 <Bmagic> Thanks everyone!
15:43:10 <Bmagic> #endmeeting