15:00:01 <Bmagic> #startmeeting 2023-09-12 - Developer Meeting
15:00:01 <pinesol> Meeting started Tue Sep 12 15:00:01 2023 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:01 <pinesol> The meeting name has been set to '2023_09_12___developer_meeting'
15:00:13 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-09-12
15:00:20 <Bmagic> #topic Introductions
15:00:22 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:00:24 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:00:40 <berick> #info berick Bill Erickson, KCLS
15:00:44 <shulabear> #info shulabear = Shula Link, GCHR in PINES
15:00:52 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka)
15:00:54 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:00:55 <collum> #info collum = Garry Collum, KCPL
15:00:57 <eeevil> #info eeevil = Mike Rylander, EOLI
15:01:02 <sleary> #info sleary = Stephanie Leary, EOLI
15:01:14 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:17 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:01:45 <Bmagic> feel free to continue the introductions as you arrive
15:01:48 <Bmagic> #topic Action Items from Last Meeting
15:01:51 <Stompro> #info Stompro = Josh Stompro LARL/NWRL
15:01:59 <Bmagic> #info mmorgan will explore moving LP stats to community site and automating same
15:02:07 <jeff> I may not be able to be present/attentive for the entire meeting, but my two action items remain outstanding, as in, I still need to complete them. :-)
15:02:25 <Bmagic> jeff: noted
15:02:30 <mmorgan> #infor mmorgan = Michele Morgan, NOBLE
15:02:42 <Bmagic> mmorgan: any update on that?
15:02:52 <mmorgan> Just a quick update on my action item. I'm exploring the Launchpad api
15:03:22 <Bmagic> cool, we'll carry it forward
15:03:29 <Bmagic> #info berick will make tutorial: "How grid cell templates work"
15:03:56 <berick> done and one, but ..
15:04:08 <berick> i need some guidance/assistance on getting them into the right shape
15:04:15 <berick> i posted them onto https://wiki.evergreen-ils.org/doku.php?id=newdevs:tutorials-wanted
15:04:20 <terranm> #info terranm = Terran McCanna, PINES
15:05:03 <Bmagic> berick++
15:05:13 <sleary> berick++
15:05:28 <Bmagic> would that be sleary as a "shaper" ?
15:05:37 <Dyrcona> berick++
15:05:53 <Dyrcona> Well, it's a wiki. It could be anyone with credentials as a shaper.
15:06:03 * sleary will take a look
15:06:10 <briank> #info briank = Brian Kennedy, BCLC (Sitka)
15:06:49 <Bmagic> #action jeff will make tutorial: "Add missing field to print template"
15:06:56 <Bmagic> #action jeff will write tutorial "Retrieve a user's setting and do something based on its value"
15:07:05 <Bmagic> #action mmorgan will explore moving LP stats to community site and automating same
15:07:28 <berick> thanks sleary.  let me know what I can do.
15:07:42 <Bmagic> Any more discussion on shaping the markdown -> dokuwiki?
15:07:55 <sleary> berick thanks for working on these; I appreciate it!
15:08:12 <terranm> berick++
15:08:46 <Bmagic> #info sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:09:27 <Bmagic> sandbergja is probably afk
15:09:44 <Bmagic> #info Bmagic will send a call for volunteers to the dev list
15:09:52 <Bmagic> that's done
15:09:53 <sleary> not sure if sandbergja is around, but she left me a note to review her work in progress, so it's... in progress!
15:10:04 <Bmagic> sandbergja++
15:10:18 <Bmagic> sleary++
15:10:27 <Bmagic> I'll carry that action forward
15:10:35 <Bmagic> #action sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:10:43 <terranm> sleary++
15:11:09 <Bmagic> #topic Evergreen - Fall release planning / release team
15:11:29 <Dyrcona> Too late....
15:12:15 <Bmagic> #info Evergreen 3.12 Release Team meeting Friday at 2pm ET - ping abneiman for more info
15:12:32 <Bmagic> some to the meeting yall!
15:12:32 <abneiman> we'll be putting together a schedule & roadmap etc
15:12:56 <abneiman> sandbergja++ collum++ rfrasur++ mmorgan++ terranm++ # dream team
15:13:06 <terranm> abneiman++
15:13:10 <Bmagic> sandbergja++ collum++ rfrasur++ mmorgan++ terranm++ # fo sho
15:13:12 <rfrasur> #info rfrasur = Ruth Frasur, EGIN / ECDI
15:13:17 <collum> abneiman++
15:13:44 <rfrasur> (I accidentally found myself on the team)
15:13:49 <rfrasur> abneiman++
15:13:55 <abneiman> so start thinking about those roadmap entries! that's all I got for now
15:13:57 <mmorgan> abneiman++
15:13:58 <Bmagic> rfrasur: classic you
15:14:11 <abneiman> heh, rfrasur, I accidentally found myself leading the team sooooo let's go
15:14:51 <rfrasur> Bmagic - too true.  abneiman - twinsies!! (the internet can't smell my fear)
15:14:53 <sleary> abneiman I will try to listen in, at least... time permitting -.-
15:15:01 <Bmagic> It's more people than I've seen on a release team. Might be the* most
15:15:17 <terranm> If anyone would like to knock any of the staffcatalogblocker bugs out, it'd be great to be able to get closer to getting rid of the old version - https://bugs.launchpad.net/evergreen/?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3A
15:15:18 <terranm> list=FIXCOMMITTED&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=staffcatalogblocker&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes
15:15:18 <terranm> =on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
15:15:25 <abneiman> by our powers combined
15:15:51 <Bmagic> that is a URL if I've ever seen one
15:16:10 <abneiman> dangit Launchpad
15:16:19 <sleary> love Launchpad URLs, they're the bestest
15:16:59 <terranm> They're extra
15:18:02 <Bmagic> I'm going to make a pitstop at documentation
15:18:06 <Bmagic> #topic Documentation
15:18:25 <Bmagic> Would anyone like to mention a doc related thing?
15:19:19 <Bmagic> dluch couldn't be here but she thought those that were at the last meeting might throw in some info
15:19:22 <abneiman> with many thanks to Sitka, DIG is getting ready to do a big Reports docs update this week
15:19:37 <abneiman> please say git prayers for me.
15:20:15 <abneiman> an incomplete list of helpers on that long project is here: DIG (reviewing), Jennifer Pringle (writing), Susan Morrison (editing), Beth Willis (screenshots), Andrea Buntz Neiman (editing), Elizabeth Davis (editing)
15:21:10 <abneiman> and our fearless leader dluch++
15:21:14 <abneiman> for keeping the dream alive
15:21:21 <Bmagic> abneiman: your concern about the presentation of large (wide) tables on the Evergreen documentation pages is something I looked at for awhile. I think the best answer is to not use tables, but instead format the data as a bulleted list maybe?
15:22:14 <terranm> abneiman++ dluch++ dig++
15:22:22 <Bmagic> We can talk about it outside of this meeting
15:22:30 <abneiman> Bmagic: thanks for looking. In the case of the table in question, for Global Flags, I'm not sure bulleted lists is really an adequate substitute. But I'll keep poking.
15:22:39 <Bmagic> abneiman++ dluch++ dig++
15:22:57 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:23:03 <Bmagic> #info Open Bugs - 3023
15:23:09 <Bmagic> #info Pullrequests - 91
15:23:12 <Bmagic> #info Signedoff - 19
15:23:32 <Bmagic> #topic Launchpad Status since last meeting
15:23:35 <Bmagic> #info Bugs Added - 69
15:23:37 <Bmagic> #info Pullrequest tag Added - 43
15:23:40 <Bmagic> #info Signedoff tag Added - 34
15:23:42 <Bmagic> #info Fix Committed - 32
15:23:51 <Bmagic> mmorgan++
15:24:11 <Bmagic> we're flying through this meeting
15:24:23 <Bmagic> but we might spend some time on this one
15:24:27 <Bmagic> #topic New Business - LP#2032835: Should we merge OpenSRF into Evergreen?
15:24:34 <Dyrcona> Yes.
15:24:44 <Bmagic> lol
15:24:56 <Bmagic> <-- thinks the same: Yes.
15:25:24 <Dyrcona> I think it would make sense to wait for Redis to replace Ejabberd however.
15:25:33 <berick> i opened the LP after working bug 2017941, where i was reminded of the complexity of managing 2 separate projects.
15:25:33 <pinesol> Launchpad bug 2017941 in OpenSRF "Migrate from Ejabberd to Redis for OpenSRF Messaging" [Wishlist,Confirmed] https://launchpad.net/bugs/2017941
15:26:09 <berick> and really just started wondering if it was worth it to keep the separated.
15:26:38 <rfrasur> Should this be added as a topic for the hackaway?
15:26:38 <Stompro> +1 to combining them.
15:27:02 <sandbergja> +1 to combining
15:27:06 <Dyrcona> Yes, it could be done during the hack-away, maybe, or at least started.
15:27:20 <Bmagic> rfrasur: you don't think we can just take care of this problem here and now. I have the merge button right here.
15:27:25 <berick> heh
15:27:31 <shulabear> +1 to combining
15:27:37 <berick> is anyone opposed to the idea?
15:27:51 <kmlussier> Are there any potential downsides to merging?
15:28:02 <rfrasur> lol, I mean...if you have the button, push it.  Otherwise...I'll add to the hackaway discussion list
15:28:12 <Bmagic> This is something I've heard talked about before. And I'm a little foggy about what some of the talking points were.
15:28:12 <kmlussier> #info kmlussier is Kathy Lussier, NOBLE
15:28:42 <JBoyer> kmlussier: potentially smearing the lines more between front and back ends, but we're basically building sql in the UI, so I don't think it makes much difference.
15:28:59 <berick> kmlussier: one downside, a big change to one (e.g. adding redis suspport) means the other has to wait.
15:29:00 <Dyrcona> kmlussier: Not really. We're the only project that uses OpenSRF as far as I've been able to find.
15:29:11 <JBoyer> Though I also like the idea of waiting until OpenSRF is talking over Redis.
15:29:13 <berick> however that example (redis) is pretty darn rare
15:29:30 <berick> agreed post-Redis make more sense
15:29:37 <shulabear> berick++ jboyer++
15:29:58 <Bmagic> berick++
15:29:59 <kmlussier> OK, I'm convinced. I may have already been convinced before I asked the question.
15:30:13 <jeffdavis> if there's consensus here, might make sense to send a heads-up message to the dev and general lists for broader feedback?
15:30:44 <mmorgan> +1 to combining
15:30:48 <Dyrcona> jeffdavis: Do I hear you volunteering for an action item?
15:30:51 <mmorgan> +1 to sending that message
15:30:57 <Bmagic> sure, berick: would you like to compose the email?
15:30:57 <jeffdavis> lol what have I done
15:31:08 <JBoyer> Probably a good idea either way, I think if there's more discussion to be had it'll more likely be via email than LP comments
15:31:25 <berick> yes i can email
15:31:28 <JBoyer> ("good idea" -> emailing)
15:31:33 <Dyrcona> berick++
15:31:41 <Bmagic> #action berick will post something to the email list about merging OpenSRF into Evergreen
15:31:55 <mmorgan> berick++
15:31:56 <Bmagic> #info https://bugs.launchpad.net/opensrf/+bug/2032835
15:31:56 <pinesol> Launchpad bug 2032835 in OpenSRF "Discussion: Merge OpenSRF Into Evergreen?" [Wishlist,New]
15:32:15 * rfrasur has added it to hackaway lineup too.
15:32:25 <JBoyer> I don't remember if / how it changes the appearance in the minutes, but there is also #link
15:32:35 <Bmagic> oh
15:32:48 <berick> thanks rfrasur.  there will be plenty yet to discuss
15:32:51 <Bmagic> #link https://bugs.launchpad.net/opensrf/+bug/2032835
15:33:07 <Bmagic> #topic LP#1999823: concurrent changes to EG and OpenSRF required; testing requested
15:33:14 <jeffdavis> I can speak to this
15:33:20 <Bmagic> #link https://bugs.launchpad.net/opensrf/+bug/1999823
15:33:20 <pinesol> Launchpad bug 1999823 in OpenSRF "Name collision causes apache gateway modules to fail when mod_shib is installed" [Medium,Confirmed]
15:33:38 <Bmagic> go ahead jeffdavis
15:33:50 <JBoyer> Yeah, so, see above about making changes across 2 different but related projects. :D
15:34:14 <jeffdavis> basically some of the C functions in OpenSRF and EG need to be renamed to avoid collisions; it's currently an issue when using Shibboleth for SSO on Ubuntu but I think that's just one potential problem case
15:34:57 <jeffdavis> there are branches for both OpenSRF and EG making the necessary changes, this is a request for some folks besides me and JBoyer to try running those branches and see if anything breaks
15:35:26 <Bmagic> jeffdavis: we might be candidates for testing these branches in the coming months
15:35:34 <Dyrcona> I can have a look without sso enabled.
15:35:54 <jeffdavis> that would be great! and yeah, SSO is not needed to test the branches I think
15:36:03 <jeffdavis> also, once the changes are committed to EG we'll need to update the minimum required version of OpenSRF
15:36:09 <JBoyer> And note, if it helps, you don't necessarily have to setup a whole shibboleth setup to test them, testing them "plain" helps, as does just enabling the modules that shibboleth uses and testing then too.
15:37:09 <Dyrcona> jeffdavis: Mind if I steal the bug from you?
15:37:16 <jeffdavis> Please do!
15:37:16 <Bmagic> jeffdavis: I was thinking that too, which means that the commits will need to take place on a major Evergreen release cycle (not bug fix cycle)
15:38:08 <Dyrcona> Well, it *could* be a bug fix cycle, but that would be a) unusual for us and b) a pain for sites to upgrade.
15:38:28 <Bmagic> right, those reasons brought me to that thought
15:38:48 <jeffdavis> It's a bit tricky because this is a bug that prevents an existing feature from working, but the need for an OpenSRF update does make headaches
15:39:01 <Dyrcona> We've don it before, though I can think of specific release numbers.
15:39:03 <Bmagic> jeffdavis++
15:39:06 <Bmagic> JBoyer++
15:39:10 <Bmagic> Dyrcona++
15:39:22 <Dyrcona> s/can/can't/
15:39:29 <Dyrcona> anyway...
15:39:38 <jeffdavis> FWIW we are hoping to go live with SSO for a few of our libraries this month, so we'll need to deploy the changes on 3.9
15:40:10 <jeffdavis> we can deal with backporting locally at Sitka but it's a bit of an added version if the changes aren't in EG until 3.12
15:40:16 <jeffdavis> *added burden
15:40:40 <Dyrcona> Well, I can test with 3.10 as well as main.
15:41:28 <Bmagic> our container setup makes it fairly trivial to stand up a test server with certain patches on OpenSRF/Evergreen.
15:41:44 <Dyrcona> I don't think much has changed in the C code, so a backport should be trivial.
15:41:58 <sandbergja> Would these be considered breaking changes to OpenSRF's C API?  If so, should we cut a 4.0.0 of OpenSRF with these changes?
15:42:07 <JBoyer> The Big Fix, that can't be broken by further OS updates, would be to modify our library build process to *only* export certain functions, rather than all of them. :/
15:43:01 <JBoyer> sandbergja, Not breaking, we can get by with only *adding* new functions, rather than removing any. So old Eg would work fine on new OSRF, but not the other way around.
15:43:07 <Dyrcona> sandbergja: I'd like to reserve 4.0 for OpenSRF over redis and merged with Evergreen, but that remains to be seen.
15:43:52 <sandbergja> JBoyer: ahh, that makes sense.  Thanks!
15:44:04 <Bmagic> the redis change to OpenSRF does seem like a big version number increment
15:44:11 <Dyrcona> JBoyer++
15:44:13 <sandbergja> totally
15:44:31 <Bmagic> #topic Announcements
15:44:36 <Bmagic> #info Congratulations to new core committer, Josh Stompro!
15:44:37 <Dyrcona> Maybe we should jump to 5.0?
15:44:47 <Dyrcona> Stompro++
15:44:48 <Bmagic> Stompro++
15:44:48 <shulabear> stompro++
15:44:51 <terranm> Stompro++
15:44:52 <sandbergja> Stompro++ # congrats!
15:44:52 <sleary> Stompro++
15:44:53 <JBoyer> Stompro++ !
15:44:59 <Stompro> Thanks, appreciate it.
15:45:05 <mmorgan> Stompro++
15:45:21 <rfrasur> Stompro++
15:45:30 <collum> Stompro++ +++++
15:45:52 <Bmagic> so, we have arrived at the end of the monster book
15:45:58 <Bmagic> #info Next meeting is Tuesday, October 10th
15:46:04 <Dyrcona> :)
15:46:11 <abneiman> Stompro++
15:46:12 <rfrasur> Bmagic++
15:46:14 <Bmagic> #endmeeting