15:02:10 <Bmagic> #startmeeting 2023-10-10 - Developer Meeting
15:02:10 <pinesol> Meeting started Tue Oct 10 15:02:10 2023 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:10 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:10 <pinesol> The meeting name has been set to '2023_10_10___developer_meeting'
15:02:20 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-10-10
15:02:29 <Bmagic> #topic Introductions
15:02:38 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:02:45 <terranm> #info terranm = Terran McCanna, PINES
15:02:47 <collum> #info collum = Garry Collum, KCPL
15:02:48 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:02:48 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:03:02 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:05 <shulabear> #info shulabear = Shula Link, GCHRL
15:03:19 <Stompro> #info Stompro = Josh Stompro, LARL and NWRL
15:03:32 <berick> #info berick Bill Erickson, KCLS
15:03:49 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:03:56 <eeevil> #info eeevil = Mike Rylander, EOLI
15:04:02 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:04:02 <sleary> #info sleary = Stephanie Leary, EOLI
15:04:17 <Bmagic> feel free to introduce yourselves as you arrive
15:04:24 <Bmagic> #topic Action Items from Last Meeting
15:04:33 <Bmagic> #info jeff will make tutorial: "Add missing field to print template"
15:04:49 <Bmagic> #info jeff will write tutorial "Retrieve a user's setting and do something based on its value"
15:04:56 <jeff> both tutorials remain on my todo list, and I expect that I'll be able to spend time on then by the next dev meeting.
15:05:06 <Bmagic> jeff++
15:05:29 <Bmagic> #info mmorgan will explore moving LP stats to community site and automating same
15:05:38 <mmorgan> Still exploring capabilities of the Launchpad api for this. That's all I have to report right now. I did add stats to the agenda for this meeting.
15:05:49 <Bmagic> mmorgan++
15:06:02 <Bmagic> #info sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:06:18 <sandbergja> Partially done!
15:07:07 <sleary> @sandbergja asked me to take a look at the draft, and I have not had a chance. It is on my agenda!
15:07:07 <pinesol> sleary: git diff origin/hamster
15:07:19 <dluch> jeff+ mmorgan++ sandbergja++
15:07:31 <Bmagic> sandbergja++
15:07:40 <Bmagic> sleary++
15:07:53 <Bmagic> #info berick will post something to the email list about merging OpenSRF into Evergreen
15:08:17 <berick> done
15:08:21 <shulabear> Jeff++ mmorgan++ sandbergja++
15:08:29 <Bmagic> berick++
15:08:44 <dluch> berick++
15:08:55 <dluch> sleary++
15:09:23 <Bmagic> carrying the action forward, incoming
15:09:27 <Bmagic> #action jeff will make tutorial: "Add missing field to print template"
15:09:32 <Bmagic> #action jeff will write tutorial "Retrieve a user's setting and do something based on its value"
15:09:37 <Bmagic> #action mmorgan will explore moving LP stats to community site and automating same
15:09:41 <Bmagic> #action sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:10:03 <Bmagic> #topic OpenSRF
15:10:23 <Bmagic> any last minute things on OpenSRF that didn't make it onto the agenda?
15:11:20 <Bmagic> #topic Evergreen -  3.12 Release Schedule & Roadmap
15:11:30 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap#release_schedule
15:11:54 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.12
15:12:07 <abneiman> the bugs-with-signoffs link is huge & ugly, sorry
15:12:55 <abneiman> anyway, those are the release things, any questions?
15:12:58 <Bmagic> #link https://bugs.launchpad.net/evergreen/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=pullrequest+
15:12:59 <Bmagic> signedoff&field.tags_combinator=ALL&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
15:13:02 <Bmagic> eeesh
15:13:06 <abneiman> cough
15:13:15 <abneiman> toldya :)
15:13:16 <mmorgan> gesundheit
15:13:17 <Dyrcona> Well, that's Launchpad for ya.
15:13:21 <Bmagic> hopefully that makes it through the parse
15:13:27 <dluch> Dang, lol
15:13:31 <dluch> https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-10-10
15:13:44 <dluch> oops, ignore that, sorry
15:13:55 <Bmagic> abneiman++
15:13:56 <abneiman> anyway, things with signoffs! any committers in the room, please feel free to review and commit!
15:14:13 <shulabear> Abneiman++
15:14:14 <dluch> abneiman++
15:14:21 <sandbergja> abneiman++
15:14:24 <abneiman> feature slush is the Monday after Hackaway, so coming up quick - get those features in for review :)
15:14:26 <sandbergja> I think those monday review meetings have been going well.  Please feel free to stop by if you haven't yet had the chance!  We've been able to move 5 pull requests forward, including getting 2 committed.
15:14:35 <Bmagic> #topic Evergreen - Jane is hosting weekly review meetings on Mondays at 2pm ET
15:14:37 <abneiman> sandbergja++ for the code review meetings, btw, which I have not yet been able to attend
15:14:39 <Bmagic> :)
15:14:51 <berick> sandbergja++ # indeed, great idea
15:14:52 <dluch> sandbergja++
15:14:53 <mmorgan> sandbergja++
15:14:58 <Bmagic> sandbergja++
15:14:58 <shulabear> Sandbergja++
15:15:06 <collum> sandbergja++
15:15:56 <Bmagic> #topic Documentation
15:16:09 <Bmagic> #info DIG Meeting this Thursday, October 12, at 11am/12pm/1pm/2pm
15:16:16 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings:20231012-agenda
15:16:22 <dluch> Nothing to add to what I put on the agenda about Thursday's meeting
15:16:33 <Bmagic> dluch++
15:16:35 <terranm> sandbergja++
15:17:55 <Bmagic> we're going fast, feel free to type something and slow us down
15:18:00 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:18:09 <Bmagic> #info Open Bugs - 3072
15:18:09 <Bmagic> #info Pullrequests - 94
15:18:09 <Bmagic> #info Signedoff - 21
15:18:14 <Bmagic> #topic Launchpad Status since last meeting
15:18:19 <Bmagic> #info Bugs Added - 55
15:18:19 <Bmagic> #info Pullrequest tag Added - 19
15:18:19 <Bmagic> #info Signedoff tag Added - 8
15:18:19 <Bmagic> #info Fix Committed - 12
15:18:44 <Bmagic> #topic New Business - Should we interfile nightwatch tests into the typical eg2/src/app directory (bug 2036831)? - Jane
15:18:44 <pinesol> Launchpad bug 2036831 in Evergreen "Move nightwatch tests into the same directory as the code they test" [Wishlist,Confirmed] https://launchpad.net/bugs/2036831
15:18:45 <mmorgan> Lots to test, lots to commit :)
15:18:57 <Bmagic> #link https://bugs.launchpad.net/evergreen/+bug/2036831
15:19:16 <sandbergja> Ooh, This came up in the newdevs group!  Especially from sleary, so please jump in if I get something wrong :-)
15:19:31 <Bmagic> mmorgan++ # thanks for doing the stats! it's nice to see them like that
15:20:04 <sandbergja> the idea was to reduce some of the maintenance burden of the nightwatch tests by making it clear when a particular UI has some nightwatch tests that exercise it
15:20:25 <sandbergja> And one easy way to do that is to just house them in the same directories
15:20:31 <sandbergja> like we already do with the unit tests
15:20:48 <sleary> ah yes! I am 100% on board with doing more Nightwatch tests, but (as I am also rearranging our markup on a daily basis) I want to make sure it's easy to find the test that corresponds to the file you're looking at
15:20:48 <sandbergja> So what do you think?
15:21:31 <Bmagic> I've been confused by this before, but I figured that there was a reason for it that predates me
15:21:38 <berick> any concerns about moving them?
15:21:42 <berick> certainly makes sense
15:22:08 <berick> having the .html and .ts files side by side has been a huge help
15:22:17 <berick> just as an example
15:22:41 <sleary> sandbergja: it's relatively easy to change the command to run all the tests from a directory to a filename pattern, right?
15:22:42 <terranm> It will also be easier to see if there are things that should have Nightwatch tests that do not
15:22:55 <Bmagic> I'm all about file folder organization, and it makes sense to me to have related things together.
15:23:05 <shulabear> +1 to having tests in the same directory as the code being tested
15:23:24 <sandbergja> sleary: theoretically, yes, it should be just changing the config file.  I haven't actually tried it though
15:23:34 <sleary> sandbergja++
15:24:23 <sandbergja> Cool!  I'm not hearing any objections.  Anybody interested in taking this one on?
15:24:23 <Bmagic> do we vote maybe?
15:24:43 <sandbergja> ooh, vote sounds fun
15:25:31 <Bmagic> hah, lets see if I can pull that off
15:26:31 <Bmagic> #startvote Shall we move the tests to related places in the Evergreen codebase yes, or no
15:26:31 <pinesol> Unable to parse vote topic and options.
15:26:36 <Bmagic> lol
15:27:02 <Bmagic> #startvote Shall we move the tests to related places in the Evergreen codebase? yes, no
15:27:02 <pinesol> Begin voting on: Shall we move the tests to related places in the Evergreen codebase? Valid vote options are yes, no.
15:27:02 <pinesol> Vote using '#vote OPTION'. Only your last vote counts.
15:27:15 <Bmagic> #vote yes
15:27:17 <shulabear> #vote yes
15:27:22 <Dyrcona> #vote yes
15:27:26 <sandbergja> #vote yes
15:27:26 <collum> #vote yes
15:27:34 <mmorgan> #vote yes
15:27:38 <Bmagic> #showvote
15:27:38 <pinesol> yes (6): shulabear, sandbergja, mmorgan, Bmagic, Dyrcona, collum
15:27:46 <Bmagic> voting is still open
15:27:59 <Bmagic> #endvote
15:27:59 <pinesol> Voted on "Shall we move the tests to related places in the Evergreen codebase?" Results are
15:27:59 <pinesol> yes (6): shulabear, sandbergja, mmorgan, Bmagic, Dyrcona, collum
15:28:04 <Bmagic> that was fun
15:28:07 <berick> heh, "the tests" to "the places".   we're still talking about nightwatch yes?
15:28:12 <terranm> Sorry, "yes" - heh
15:28:17 <dluch> lol
15:28:27 <berick> #vote yes
15:28:30 <Bmagic> yeah, nightwatch, sorry I didn't specify
15:28:39 <terranm> #vote yes
15:29:14 <Bmagic> thanks all, moving on
15:29:15 <sleary> #vote yes
15:29:15 <Bmagic> #topic Announcements
15:29:25 <Bmagic> Anyone want to announce anything?
15:29:32 <Dyrcona> Bmagic, you have to #endvote
15:29:49 <Bmagic> Dyrcona: I did, at least it shows that for me
15:29:54 <dluch> yep
15:29:57 <Dyrcona> Yeah, I missed it, sorry.
15:30:09 <Dyrcona> Someone voted late.
15:30:44 <Bmagic> The bot didn't count the three late votes, but the results are clear: yes
15:32:12 <Bmagic> looping back to that topic actually, do we need volunteers to do the work?
15:33:38 <Bmagic> Crickets
15:33:41 <abneiman> lol
15:33:50 <shulabear> I'm not sure what all would be involved, but I'd be willing to learn
15:34:05 <sandbergja> shulabear++
15:34:18 <shulabear> If it's more than "move files and make a consistent naming scheme"
15:34:33 <Bmagic> sandbergja: maybe at your next meeting, we can go over it?
15:34:57 <sandbergja> Sure, if you're available then shulabear
15:35:25 <terranm> sandbergja++ shulabear++
15:35:33 <mmorgan> shulabear++
15:35:42 <sandbergja> if not, I'm happy to be on hand with any questions you have shulabear
15:35:57 <sandbergja> ^on hand to answer
15:36:11 <shulabear> Assuming my girlfriend's surgical consult that morning doesn't run long, I should be free
15:36:29 <Bmagic> #action sandbergja will go over the Nightwatch test reorg with folks at the Monday at 2pm ET meeting or another time as available
15:36:30 <shulabear> Put it on my calendar
15:36:51 <shulabear> Sandbergja++
15:37:17 <Bmagic> sandbergja++
15:37:35 <Bmagic> We're technically in the Announcements topic so..
15:37:38 <Bmagic> #info Next Meeting is Tuesday, November 14th
15:38:31 <Bmagic> Anyone want to add anything before we close?
15:38:41 <mmorgan> I didn't put this on the agenda, bug just want to throw bug 2002693 out there for additional eyes.
15:38:41 <pinesol> Launchpad bug 2002693 in Evergreen "Logging out on a page with a pcrud call floods browser with errors" [High,Confirmed] https://launchpad.net/bugs/2002693
15:39:06 <mmorgan> I'll be adding comments soon and would appreciate anyone's attention.
15:39:13 <dluch> shulabear++ sandbergja++
15:39:14 <sandbergja> mmorgan++
15:39:23 <shulabear> Mmorgan++
15:39:40 <dluch> mmorgan++
15:39:40 <Bmagic> #info Hack-a-way is coming up!
15:39:45 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=hack-a-way:hack-a-way-2023
15:39:56 <sandbergja> it occured to me that we should probably merge bug 2035287 before moving the nightwatch tests.  Make them work first before messing with them hahaha
15:39:56 <pinesol> Launchpad bug 2035287 in Evergreen "e2e tests are failing" [Undecided,New] https://launchpad.net/bugs/2035287
15:39:59 <Bmagic> mmorgan++
15:41:36 <Bmagic> thanks sandbergja, that looks like a good one to take care of
15:42:14 <Bmagic> alrighty, see some of you in a couple weeks!
15:42:21 <Bmagic> #endmeeting