15:00:01 <Bmagic> #startmeeting 2023-11-14 - Developer Meeting
15:00:01 <pinesol> Meeting started Tue Nov 14 15:00:01 2023 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:01 <pinesol> The meeting name has been set to '2023_11_14___developer_meeting'
15:00:08 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-11-14
15:00:14 <Bmagic> #topic Introductions
15:00:18 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:00:26 <Dyrcona> #info Dyrcona = Jason Stephenson, C/W MARS
15:00:37 <shulabear> #info shulabear = Shula Link, GCHRL in PINES
15:00:39 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:00:39 <csharp_> #info csharp_ = Chris Sharp, GPLS
15:00:41 <terranm> #info terranm = Terran McCanna, PINES
15:00:42 <Stompro> #info Stompro = Josh Stompro, LARL
15:00:48 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:00:49 <collum> #info collum = Garry Collum, KCPL
15:00:52 <sleary> #info sleary = Stephanie Leary, Equinox
15:00:55 <smayo> #info smayo = Steven Mayo, PINES
15:01:28 <Bmagic> #topic Action Items from Last Meeting
15:01:31 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:01:39 <Bmagic> #info jeff will write tutorial "Retrieve a user's setting and do something based on its value"
15:02:00 <Bmagic> #info jeff will make tutorial: "Add missing field to print template"
15:02:14 <Bmagic> go ahead jeff, what's up?
15:02:38 <abneiman> #infor abneiman = Andrea Buntz Neiman, EOLI
15:03:03 <jeff> nothing to report, still happy to do soon when I make the time, if anyone feels incredibly motivated and in possession of free time feel free to let me know. :-)
15:03:39 <Bmagic> #action jeff will make tutorial: "Add missing field to print template"
15:03:44 <Bmagic> #action jeff will write tutorial "Retrieve a user's setting and do something based on its value"#action jeff will write tutorial "Retrieve a user's setting and do something based on its value"
15:03:46 <Bmagic> whoops
15:03:52 <Bmagic> I wonder what that will do
15:03:59 <eeevil> #info eeevil = Mike Rylander, eoli
15:04:03 <sandbergja> #info sandbergja = Jane Sandberg, PUL/independent
15:04:08 <Bmagic> #info mmorgan will explore moving LP stats to community site and automating same
15:04:15 * mmorgan has nothing to report this month, busy with the release.
15:04:15 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:04:28 <Bmagic> no problem, carrying forward
15:04:35 <Bmagic> #action mmorgan will explore moving LP stats to community site and automating same
15:04:42 <Bmagic> #info sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"#info sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:04:51 <Bmagic> #info sandbergja will go over the Nightwatch test reorg with folks at the Monday at 2pm ET meeting or another time as available
15:05:00 <Bmagic> go ahead sandbergja
15:05:04 <sandbergja> kinda fidddling with my partial draft for the tutorial
15:05:18 <sandbergja> probably need to check back with me next time :-)
15:05:32 <Bmagic> no problem
15:05:33 <sleary> sandbergja I looked at what you sent me a while back and it's looking great
15:05:34 <sandbergja> we didn't get around to moving the nightwatch tests, but we got them working!
15:05:42 <sandbergja> sleary++ # thanks for the review!
15:05:44 <terranm> sandbergja++
15:05:50 <Bmagic> #action sandbergja will write tutorial: "Do a database call (Galen’s cat counter)"
15:05:56 <smayo> sandbergja++
15:05:58 <shulabear> sandbergja++
15:06:03 <Bmagic> sandbergja++ mmorgan++ jeff++
15:06:57 <Bmagic> The agenda is sparse, anyone want to talk about the blank ones?
15:07:17 <abneiman> yes
15:07:28 <Bmagic> abneiman which
15:07:41 <abneiman> Evergreen release!
15:07:49 <terranm> Tomorrow at 3pm Eastern in the New Devs time slot we'll be walking through the build of 3.12 beta
15:07:50 <Bmagic> #topic Evergreen release
15:07:54 <abneiman> I tried to edit the doc but can't multitask
15:07:58 <abneiman> yes, what terranm says
15:08:14 <abneiman> also, FBF stats here: https://wiki.evergreen-ils.org/doku.php?id=dev:bug_squashing:2023-11
15:08:18 <abneiman> all_yall++
15:08:19 <terranm> https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11
15:08:28 <Bmagic> I refreshed and I see new stuff
15:08:43 <abneiman> and terranm++ sandbergja++ and mmorgan++ for many lovely merges
15:08:54 <Bmagic> #link  https://wiki.evergreen-ils.org/doku.php?id=dev:bug_squashing:2023-11
15:09:03 <abneiman> though there is a test conflict to talk about below in the agenda
15:09:06 <Bmagic> terranm++ sandbergja++ mmorgan++
15:09:07 <terranm> 3.12 (currently) has an even 100 patches committed
15:09:10 <sleary> terranm++ sandbergja++ mmorgan++
15:09:23 <shulabear> terranm++ mmorgan++ sandbergja++
15:09:23 <Bmagic> haha, we should stop so we can have that cool number
15:09:44 <sleary> almost all the accessibility bugs that had good branches have been committed; it's pretty great
15:10:09 <terranm> There are a few more small bug fixes that I may squeeze in to ruin that good number
15:10:22 <sandbergja> csharp++ eevil++ berick++ # also were in on the committing frenzy
15:10:45 <abneiman> anyway that's all, we are frozen as far as features go and lookng good for an early December release
15:10:53 <sleary> csharp++ eevil++ berick++
15:10:57 <Bmagic> terranm: that just means we have to make 200
15:11:03 <terranm> lol
15:11:18 <Bmagic> 101 is good too because: Disney
15:11:21 <terranm> Well, we have over 3000 LP tickets to choose from
15:11:42 <abneiman> info: New Devs Release Building Party tomorrow here --> https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11
15:11:52 <abneiman> lemme try that again
15:11:58 <Bmagic> sure
15:11:59 <abneiman> #info: New Devs Release Building Party tomorrow here --> https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11
15:12:13 <Bmagic> that should make it into the meeting notes
15:12:18 <abneiman> yay, computers
15:12:23 <sleary> I think Launchpad will need a thorough cleaning-out once we get rid of the last Dojo and AngularJS interfaces
15:12:38 <abneiman> sleary I cannot wait for that day
15:12:50 <Bmagic> wouldn't that be sweet!?
15:13:07 <terranm> I am chomping at the bit
15:13:13 <sandbergja> There are some tickets that have an opensrf/evergreen pair, in which the evergreen one has been merged but the opensrf version still needs a review, merge, and release
15:13:20 * eeevil plans to live long enough to watch the bodies of his old dojo bugs float downstream
15:13:31 <Bmagic> We probably never thought we'd be using Dojo in 2023
15:13:43 <terranm> Pictures eeevil with a long white beard
15:14:01 <Bmagic> anything else on Evergreen release topic?
15:14:13 <csharp_> eeevil++
15:14:30 <abneiman> not from me
15:14:33 <Bmagic> #topic Documentation
15:14:38 <Bmagic> dluch is out today, anyone want to fill in?
15:15:36 <abneiman> I believe there are currently zero uncommitted docs PRa
15:15:38 <abneiman> PRs
15:15:42 <abneiman> so that is  a fun stat
15:15:55 <sandbergja> woohoo!
15:16:00 <Bmagic> wowsa!~
15:16:02 <sandbergja> abneiman++
15:16:09 <Bmagic> abneiman++
15:16:16 <mmorgan> abneiman++
15:16:20 <shulabear> abneiman++
15:16:50 <Bmagic> that's probably a good note to end that topic with
15:16:52 <csharp_> so when are we free to commit to main again? after tomorrow?
15:17:00 <csharp_> oh sorry - off topic
15:17:06 <sandbergja> any time you want charp_
15:17:11 <Bmagic> #info zero uncommitted docs PRa
15:17:20 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:17:27 <Bmagic> inc paste
15:17:27 <csharp_> k - just didn't want to step on the release team's toes
15:17:28 <sandbergja> we already started up a rel_3_12 branch
15:17:38 <csharp_> sandbergja: awesome! thanks!
15:17:38 <Bmagic> #info Open Bugs - 3138
15:17:39 <Bmagic> #info Pullrequests - 85
15:17:39 <Bmagic> #info Signedoff - 4
15:17:49 <Bmagic> #topic Launchpad Status since last meeting#topic Launchpad Status since last meeting
15:17:51 <Bmagic> lol
15:18:05 <Bmagic> #topic Launchpad Status since last meeting
15:18:13 <Bmagic> #info Bugs Added - 88
15:18:14 <Bmagic> #info Pullrequest tag Added - 19
15:18:14 <Bmagic> #info Signedoff tag Added - 8
15:18:14 <Bmagic> #info Fix Committed - 12
15:18:21 <csharp_> sandbergja: sometimes that's not done until the beta is actually created - good that you went ahead with it
15:18:39 <mmorgan> Bmagic: Fix Committed = 102!
15:19:26 <mmorgan> Signedoff 78, pullrequested 90.
15:20:39 <terranm> bugsquashers++
15:20:55 <mmorgan> bugsquashers++
15:21:49 <abneiman> mmorgan++ # correcting the record!
15:21:52 <Bmagic> mmorgan++
15:22:08 <Bmagic> #topic New Business - Getting `ng lint` rolling again (bug 1850473) - Jane
15:22:08 <pinesol> Launchpad bug 1850473 in Evergreen "Discussion item: make sure we are using the very best angular linting rules" [Low,Confirmed] https://launchpad.net/bugs/1850473 - Assigned to Galen Charlton (gmc)
15:22:21 <Bmagic> #link https://bugs.launchpad.net/evergreen/+bug/1850473
15:22:22 <eeevil> I have a question/topic that I didn't get onto the agenda, while we're gathered (when it's time for "any other topics?")
15:22:43 <Bmagic> eeevil: no prob, I just started one, so maybe after this section?
15:23:10 <sandbergja> ooh, yes!  We used to have an automated friend called ng lint.  It would catch formatting issues and let you know about common gotchas of where bugs could hide
15:23:11 <eeevil> Bmagic: on your mark, sir.
15:23:23 <sandbergja> I think I messed it up at one point
15:23:30 <sandbergja> so now it always just says that everything's fine
15:23:43 <Bmagic> sandbergja: interesting
15:23:48 <terranm> "Nothing to see here"
15:24:00 <sandbergja> I want to turn it back on, and it was suggested on that ticket that we do it... now
15:24:05 <sandbergja> after feature freeze for 3.12
15:24:48 <Bmagic> do we know what the problem is?
15:24:51 <sandbergja> So, this PR would basically touch every new file that has changed since ng lint stopped working, making the changes that it would have complained about previously
15:25:29 <sandbergja> Yeah, there was a part of it (tslint) that was deprecated in favor of eslint.  We migrated, but apparently migrated without any rules enabled hahaha
15:25:41 <sandbergja> or very few, at least
15:26:23 <Bmagic> sandbergja: that bug seems to be assigned to gmcharlt, did you want it?
15:27:10 <sandbergja> I think so, as long as: people are okay with it getting pullrequested, reviewed, and merged in a short timeframe
15:27:39 <Bmagic> you're wanting to get it on rel_3_12?
15:28:03 <Bmagic> lol, I see the last few comments... ok
15:28:08 <sandbergja> The sooner the better, as far as I'm concerned.  Because the longer we wait, the harder it will be to implement
15:28:30 <sandbergja> So I guess I'm checking for concerns, alternative timing proposal, and/or commitments to review and merge
15:28:42 <sandbergja> berick++ for reviewing it previously, by the way
15:29:24 <Bmagic> What are the implications of merging? I suppose it could break the release?
15:29:44 <sandbergja> just causing a ton of merge conflicts on outstanding PRs, I think
15:29:53 <sleary> it will break all the other outstanding branches
15:30:07 <sleary> although as eeevil pointed out in the comments, git should be able to deal with most of the conflicts
15:30:28 <Bmagic> I see, so all devs need to be aware, and expect to get asked to deal with their code after the merge, like fast?
15:30:52 <JBoyer> And, with all of the recent activity, we're likely at a low point in branches affected, so now's as good a time as any.
15:31:00 <eeevil> well, at least be prepared to get a rebase request
15:31:06 <Bmagic> JBoyer: right!
15:31:22 <sleary> winter break rebase party? :)
15:31:42 <Bmagic> It sounds like we need to do it during a period such as this, so lets?
15:31:44 <abneiman> ain't no party like a rebase party
15:32:13 <shulabear> bmagic++ sandbergja++
15:32:26 <sandbergja> Cool, I'll re-do my PR -- stay tuned.  Thanks, all!
15:32:28 <Bmagic> sandbergja: you wanna lead the endeavour?
15:32:29 <sleary> sandbergja I'll coordinate with you on the axe rules
15:32:40 <sandbergja> sleary++ # sounds good!
15:33:03 <terranm> There are only 88 outstanding pullrequests right now, which is much lower than normal
15:33:22 <Bmagic> sandbergja++ sleary++
15:33:38 <sleary> sandbergja++ # thanks for staying on top of linting!
15:33:50 <Bmagic> thanks again sandbergja! next....
15:33:56 <Bmagic> #topic New Business - Test failures, including at least one critical regression (bug 2043437) - Jane
15:33:56 <pinesol> Launchpad bug 2043437 in Evergreen "Three test failures on rel_3_12 and main" [Critical,New] https://launchpad.net/bugs/2043437
15:34:00 <Bmagic> #link https://bugs.launchpad.net/evergreen/+bug/2043437
15:34:18 <sandbergja> oh god, I have a bunch in a row :-D
15:34:26 <Bmagic> yes, yes you do
15:34:32 <sandbergja> we have 3 failing tests, one of which points to a major problem
15:34:48 <sandbergja> tests++ # catching that before we released it to users!
15:35:05 <sandbergja> specifically, the holdings view doesn't load (maybe just a missing import or something)
15:35:07 <terranm> sandbergja++ tests++
15:35:32 <sandbergja> I feel pretty strongly we should take care of those before building a beta.
15:35:53 <mmorgan> +1
15:35:56 <sandbergja> But I don't know that I'll have much time to look into them
15:36:40 <sandbergja> Dyrcona already started looking at the perl one, and posted some notes
15:37:02 <Dyrcona> When I said that I don't know how to fix the syntax error, I should have said that it's not obvious to me what's wrong.
15:37:16 <Bmagic> the course reserves issue is fine because the test is bad, so we're looking at the holdingsView.spec.ts issue, and the query issue
15:37:52 <sleary> we should fix the bad test since the problem is obvious, but yes
15:38:19 <Bmagic> agreed on fixing the test. Should each of the three things be it's own bug so folks can claim them?
15:38:59 <Dyrcona> Well, we could use a collab branch to avoid separate bugs, but I'll let the consensus decide.
15:40:03 <Bmagic> I assume this pause is because everyone is reading the bug
15:40:22 <sandbergja> :-)
15:41:26 <Bmagic> Dyrcona: that query works on two of my test systems
15:42:39 <Dyrcona> Bmagic: It blew up for me on a 3.12 vm with stock concerto and Pg 15. I tried the function by itself with different parameters.
15:43:16 <Bmagic> Just the query? Not integrated in Evergreen?
15:43:20 <Dyrcona> Different parameters, I mean interger array and string that should have matched.
15:43:39 <Dyrcona> Just the function by itself, as well as the query I pasted.
15:43:51 <Dyrcona> The query comes from the error output of the test.
15:44:01 <JBoyer> Fun thing: it worked for me on eg3.11 / pg15 and broke on 3.11 / pg14.
15:44:11 <Bmagic> ok, yes, it breaks on newer versions of the database
15:44:18 <Bmagic> bugsquash machine throws the error
15:44:45 <sandbergja> JBoyer++
15:44:47 <sandbergja> Bmagic++
15:44:54 <sandbergja> Dyrcona++
15:45:02 <sandbergja> that seems like a very good clue
15:45:10 <JBoyer> I suspect it's potentially a matter of db age. the 3.11 system where it worked has been upgraded for years, the one where it failed was built fresh today. I'm not sure the pg versions matter
15:45:14 <Dyrcona> I thought it might be Pg version dependent, but didn't take the time to try it on other versions.
15:45:18 <Bmagic> well, I guess we can all hammer on it, first one to merge wins!
15:45:55 <Bmagic> JBoyer: I was thinking it had to do with Evergreen's DB upgrade's. Not PG version
15:46:32 <Dyrcona> JBoyer: You could compare the old database's implementation of pg_int_wrapper with the stock one in 3.12. A git blame might also help...
15:46:49 <Bmagic> let's move this to post-meeting
15:46:52 <Dyrcona> JBoyer: Gotcha.
15:46:57 <JBoyer> Bmagic, +1
15:47:06 <Bmagic> #topic New Business - How can we get computers running our tests regularly again? - Jane
15:47:11 <eeevil> I'll also look at the search one, later
15:47:14 <sandbergja> #info for anybody wanting to run the tests, or try it out: https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa#types_of_tests
15:47:36 <Bmagic> sandbergja++
15:47:53 <mmorgan> sandbergja++
15:48:15 <sandbergja> I am just feeling fired up about tests, and wanted to see if there's capacity for getting buildbot running them automatically for us, or some new solution
15:48:45 <Bmagic> sandbergja: where's the buildbot now? (I've never known where that lives and who's in charge of it)
15:49:13 <shulabear> sandbergja++
15:49:14 <sandbergja> no clue.  Was it an EOLI server?
15:49:45 <abneiman> phasefx, wasn't buildbot your project once upon a time?
15:50:36 <phasefx> Dan Scott
15:50:51 <JBoyer> The original buildbot was retired ages ago, back when it could still build eg on Fedora. The more recent qa tester that dropped the results in here was more recently retired from our equipment also, because I have a lot going on and it was having trouble that pushed it to the bottom of the list.
15:50:55 <phasefx> but it was on the same server as the live tester
15:50:56 <abneiman> ahh, the long longago
15:51:09 <abneiman> I was thinking of live tester, right, thanks phasefx
15:51:21 <JBoyer> Until there's time to dig myself out it may be worth exploring what GH actions can do for us
15:51:50 <JBoyer> Provided it doesn't require setting up payments or anything like that.
15:52:01 <Bmagic> sandbergja had something building something on GH a couple years ago? Maybe that was docs
15:52:15 <sandbergja> docs and ng lint
15:52:28 <sandbergja> the ng lint always passes, for reasons mentioned above hahaha
15:52:33 <Bmagic> haha
15:52:50 <Bmagic> not sure if we've arrived at anything I can put down as action
15:53:15 <sandbergja> I can investigate getting more tests into gh actions, if there aren't concerns with tying ourselves more to that platform
15:53:48 <Bmagic> #action sandbergja will investigate getting more tests into gh actions
15:53:54 <JBoyer> It doesn't have to be the projects definitive home to provide a useful function, even if temporarily,
15:54:12 <Bmagic> almost out of time
15:54:14 <Bmagic> #topic Keep an eye out for Angular 17 / Bootstrap 5.3 upgrade blockers and note them on bug 2043490 - Stephanie
15:54:14 <pinesol> Launchpad bug 2043490 in Evergreen "Angular 17 + Bootstrap 5.3 Upgrade" [Wishlist,New] https://launchpad.net/bugs/2043490
15:54:14 <kmlussier> sandbergja++ tests++
15:54:14 <JBoyer> (so long as it's still easy to run tests locally)
15:54:19 <Bmagic> #link https://bugs.launchpad.net/evergreen/+bug/2043490
15:54:30 <Bmagic> sleary: go for it
15:54:47 <sleary> ah! So, I went ahead and opened a bug for the next big Angular/Bootstrap upgrade, which should be less painful than the last one
15:55:01 <Bmagic> sleary++
15:55:28 <Bmagic> #topic Other (eeevil)
15:55:31 <sleary> I haven't looked too closely into what's involved on the Angular side, so I wanted to ask you all to keep an eye on that as you skim your news, and add comments to that bug if you find any potential blockers other than the ng-bootstrap accordion issue listed
15:55:40 <sandbergja> sleary++
15:55:45 <eeevil> #info I've requested we keep XMPP as the default OpenSRF transport in EG main for the time being. There's no redis release of OpenSRF yet, so support is only in a side branch, and having redis be the default will make dev (especially backport-focused dev, like bug fixes) more painful because you can't just switch branches and test the code.  Also, I'm not convinced that it's deeply understood by more folks than berick, and that puts a lot of pressure
15:55:45 <eeevil> on him to Fix All The Things if Things need Fixing.  I'm asking here for any strong objections to applying the 2 existing commits that will make that so, as it is now for rel_3_12.  Barring any, I'll pick those commits into main and life will be a little simpler for all the not-testing-redis cases, for now.
15:56:33 <eeevil> (separately, I think I know where the search test failure is coming from, and I'll poke at it early tomorrow)
15:57:30 <Bmagic> eeevil: and when we've all installed and tested redis, then make it default?
15:58:10 <eeevil> Bmagic: well, and when more-than-Bill can help work on it, ideally, but yes. "when it and we are ready"
15:58:34 <eeevil> it's not something we should force Right Now, IMNSHO. but, hopefully, soon
15:58:50 <eeevil> for a definition of soon somewhere between "months" and "geologic time"
15:58:52 <jeff> +1 for reverting especially in light of us not having an OpenSRF 4 release that supports redis yet, and revisit / re-consensus at a near-future date
15:59:17 <Bmagic> I think everyone was super excited at the hack-away and we all wanted it. But IIRC, the change to Evergreen was non-breaking
15:59:30 <Bmagic> it was a few commented out config lines?
15:59:37 <eeevil> and now I become a pumpkin!
15:59:47 <Bmagic> eeevil++
16:00:00 <jeff> eeevil: on a related note, OpenSRF 4 before Evergreen 3.12 release, so that experimental redis support can be experimented with by using two released (and not branch/dev) versions?
16:00:25 <jeff> (any objections to that last, I think I was asking)
16:00:51 <Bmagic> not sure where that leaves it. Anyone object to keeping Evergreen main XMPP. I think we're keeping XMPP on Evergreen main for the time being. Just so we're clear
16:01:22 <eeevil> Bmagic: that's not true today, in main. redis is the default right now
16:01:25 <eeevil> as of yesterday
16:01:31 <eeevil> I want to revert to xmpp, yes
16:01:49 <Bmagic> got it, ok, revert is on the table - anyone want to put in their 2 cents?
16:02:08 <eeevil> pumpkin time, though. sorry. I'll apply the patches, or not, based on consensus!
16:02:12 <Bmagic> lata
16:02:16 <JBoyer> +1 to defaulting main back to XMPP while still including the commented-out redis bits so it's easy to switch if you know what you're doing
16:02:36 <Bmagic> thanks JBoyer!
16:03:02 <Bmagic> sounds like a revert then. No problem. eeevil will do the honors it sounded like
16:03:05 <Bmagic> #topic Announcements
16:03:13 <Bmagic> #info Next Meeting is Tuesday, December 12th
16:03:20 <Bmagic> #endmeeting