#evergreen: 2023-12-12 - Developer Meeting
Meeting started by Dyrcona at 15:00:24 US/Eastern
(full logs).
Meeting summary
- 
  - Agenda at
    https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2023-12-12
    (Dyrcona,
    15:00:43)
 
 
- Introductions (Dyrcona, 15:00:52)
  - Dyrcona = Jason Stephenson, CW MARS.
    (Dyrcona,
    15:01:03)
- jeff = Jeff Godin, Traverse Area District
    Library (TADL) (jeff,
    15:01:16)
- dluch = Debbie Luchenbill, MOBIUS (and
    DIG) (dluch,
    15:01:20)
- JBoyer = Jason Boyer, EOLI (JBoyer,
    15:01:27)
- mmorgan = Michele Morgan, NOBLE (mmorgan,
    15:01:28)
- sandbergja = Jane Sandberg, PUL and
    independent (sandbergja,
    15:01:30)
- briank = Brian Kennedy, Sitka (briank,
    15:01:34)
- collum = Garry Collum (KCPL) (collum,
    15:01:35)
- sleary = Stephanie Leary, EOLI (sleary,
    15:01:44)
- abneiman = Andrea Buntz Neiman, EOLI
    (abneiman,
    15:01:50)
- shulabear = Shula Link, GCHRL in GPLS
    (shulabear,
    15:02:09)
 
 
- Action Items from Last Meeting (Dyrcona, 15:02:59)
  - jeff will make tutorial: "Add missing field to
    print template" (Dyrcona,
    15:03:27)
- jeff will write tutorial "Retrieve a user's
    setting and do something based on its value" (Dyrcona,
    15:03:27)
- ACTION: jeff will
    write tutorial "Retrieve a user's setting and do something based on
    its value" (Dyrcona,
    15:03:27)
- sandbergja will write tutorial: "Do a database
    call (Galen’s cat counter)" (Dyrcona,
    15:04:35)
- scottangel = Scott Angel, MOBIUS (scottangel,
    15:04:42)
- jeff is not taking that action this meeting,
    and we'll see about striking it in the minutes. (Dyrcona,
    15:04:56)
- berick Bill Erickson, KCLS (berick,
    15:05:36)
- eeevil Mike Rylander, EOLI (eeevil,
    15:06:16)
- mmorgan will explore moving LP stats to
    community site and automating same (Dyrcona,
    15:10:00)
- ACTION: mmorgan will
    explore moving LP stats to community site and automating same
    (Dyrcona,
    15:10:38)
- sandbergja will investigate getting more tests
    into gh actions (Dyrcona,
    15:11:00)
- bug 2044141 adds the OPAC js tests to run in
    github actions (Dyrcona,
    15:12:05)
- ACTION: sandbergja
    will see if gh actions can run the pgtap tests (Dyrcona,
    15:12:50)
 
 
- OpenSRF Releases (Dyrcona, 15:13:41)
  - OpenSRF 3.2.4 and 3.3.0-beta released
    2023-12-05 (Dyrcona,
    15:13:41)
 
 
- Evergreen Releases (Dyrcona, 15:16:27)
  - Evergreen 3.12 release candidate available
    2023-12-06 (Dyrcona,
    15:16:27)
- 3.12.0 build & release planned for
    12/13/2023 (abneiman,
    15:17:28)
 
 
- Documentation (Dyrcona, 15:21:19)
  - Lots of new documentation has been merged into
    main! (Dyrcona,
    15:21:19)
- Problem with Antora docs build has been
    identified and fixed (thanks BMagic!) (Dyrcona,
    15:21:19)
- A PINES library employee, who is also a
    technical writing grad student, will be tackling a Docs project at
    the beginning of 2024! DIG is very excited! (Dyrcona,
    15:21:19)
 
 
- Hatch (Dyrcona, 15:22:43)
  - JBoyer and berick are looking into changes
    required for Chrome Manifest V3, since V2 is going away.
    (Dyrcona,
    15:23:13)
 
 
- Launchpad Status (as of noon Eastern) (Dyrcona, 15:24:18)
  - Snaphot (Dyrcona,
    15:24:18)
- Open Bugs - 3069 (Dyrcona,
    15:24:18)
- Pullrequests - 87 (Dyrcona,
    15:24:18)
- Signedoff - 3 (Dyrcona,
    15:24:18)
- Updates Since Last Meeting (Dyrcona,
    15:24:18)
- Bugs Added - 75 (Dyrcona,
    15:24:18)
- Pullrequest tag Added - 36 (Dyrcona,
    15:24:19)
- Signedoff tag Added - 23 (Dyrcona,
    15:24:19)
- Fix Committed - 34 (Dyrcona,
    15:24:20)
 
 
- New Business (Dyrcona, 15:27:45)
 
- Point Release Schedule -> http://list.evergreen-ils.org/pipermail/evergreen-dev/2023-December/000696.html (Dyrcona, 15:27:59)
  - Bmagic=Blake GH, MOBIUS (Bmagic,
    15:29:06)
- ACTION: Dyrcona will
    summarize release coordination discussion and followup on the
    development mailing list. (Dyrcona,
    16:16:40)
 
 
- Announcements (Dyrcona, 16:16:58)
  - Next meetting is Tuesday, January 9,
    2024 (Dyrcona,
    16:17:12)
 
Meeting ended at 16:19:02 US/Eastern
(full logs).
Action items
  - jeff will write tutorial "Retrieve a user's setting and do something based on its value"
- mmorgan will explore moving LP stats to community site and automating same
- sandbergja will see if gh actions can run the pgtap tests
- Dyrcona will summarize release coordination discussion and followup on the development mailing list.
Action items, by person
  -  Dyrcona 
    - Dyrcona will summarize release coordination discussion and followup on the development mailing list.
 
-  jeff 
    - jeff will write tutorial "Retrieve a user's setting and do something based on its value"
 
-  mmorgan 
    - mmorgan will explore moving LP stats to community site and automating same
 
-  sandbergja 
    - sandbergja will see if gh actions can run the pgtap tests
 
People present (lines said)
  - Dyrcona (117)
- JBoyer (27)
- abneiman (27)
- jeff (23)
- sandbergja (19)
- dluch (18)
- mmorgan (15)
- Bmagic (13)
- sleary (5)
- pinesol (5)
- shulabear (3)
- collum (2)
- scottangel (2)
- berick (1)
- jeffdavis (1)
- briank (1)
- eeevil (1)
Generated by MeetBot 0.1.4.