#evergreen: 2024-01-09 - Developer Meeting

Meeting started by Bmagic at 15:00:02 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-01-09 (Bmagic, 15:00:11)

  1. Introductions (Bmagic, 15:00:17)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:20)
    2. Dyrcona = Jason Stephenson, C/W MARS (Dyrcona, 15:00:22)
    3. shulabear = Shula Link, GCHRL in PINES (shulabear, 15:00:32)
    4. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:52)
    5. Stompro = Josh Stompro, LARL & NWRL (Stompro, 15:00:54)
    6. sleary = Stephanie Leary, Equinox (sleary, 15:01:15)
    7. berick Bill Erickson, KCLS (berick, 15:01:15)
    8. terranm = Terran McCanna, PINES (terranm, 15:01:34)

  2. Action Items from Last Meeting (Bmagic, 15:02:05)
    1. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:02:20)
    2. JBoyer = Jason Boyer, EOLI (JBoyer, 15:02:30)
    3. eeevil = Mike Rylander, EOLI (eeevil, 15:02:44)
    4. sandbergja = Jane Sandberg, PUL and independent (sandbergja, 15:02:58)
    5. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:03:12)
    6. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:03:44)
    7. sandbergja will see if gh actions can run the pgtap tests (Bmagic, 15:03:50)
    8. ACTION: sandbergja will see if gh actions can run the pgtap tests (Bmagic, 15:04:16)
    9. Dyrcona will summarize release coordination discussion and followup on the development mailing list. (Bmagic, 15:04:22)
    10. Done! (Dyrcona, 15:04:24)
    11. collum = Garry Collum, KCPL (collum, 15:04:40)

  3. OpenSRF (Bmagic, 15:05:53)
  4. Documentation (Bmagic, 15:18:26)
    1. DIG met last week and discussed plans for 2024, including documenting things from 3.12 that are needed (abneiman, 15:19:31)
    2. We are also working with an intern who is reviewing Evergreen Indiana documentation & revising it for inclusion in main (abneiman, 15:19:59)
    3. and this bug from sandbergja could use a little love & would make some DIGgers very happy lp1930099 (abneiman, 15:20:45)
    4. Next DIG Meeting: Thursday, February 1 (Bmagic, 15:21:37)

  5. Launchpad Status (as of noon Eastern) (Bmagic, 15:23:06)
    1. Open Bugs - 3076 (Bmagic, 15:23:11)
    2. Pullrequests - 95 (Bmagic, 15:23:11)
    3. Signedoff - 5 (Bmagic, 15:23:11)

  6. Launchpad Status since last meeting (Bmagic, 15:23:14)
    1. Bugs Added - 58 (Bmagic, 15:23:18)
    2. Pullrequest tag Added - 29 (Bmagic, 15:23:19)
    3. Signedoff tag Added - 10 (Bmagic, 15:23:19)
    4. Fix Committed - 14 (Bmagic, 15:23:19)

  7. New Business - The Voluntary Product Accessibility Template / Accessibility Conformance Report on the OPAC is available, and new Launchpad bugs have been filed for all the issues noted in the report (Bmagic, 15:23:39)
    1. https://wiki.evergreen-ils.org/doku.php?id=accessibility:vpat (Bmagic, 15:23:51)

  8. talk about releases some more (Bmagic, 15:27:24)
    1. ACTION: GalenCharlton will open LP bug with the official proposal for git commit message release-note (Bmagic, 15:41:05)
    2. ACTION: GalenCharlton update the release note script to look for the release-note tags (Bmagic, 15:41:52)
    3. ACTION: GalenCharlton write up the release-notes convention for the dev wiki somehwere (Bmagic, 15:42:08)
    4. ACTION: Stompro write up the release-notes convention for the dev wiki somehwere (stolen action from GalenCharlton) (Bmagic, 15:46:02)

  9. Announcements (Bmagic, 15:56:26)
    1. Next Meeting is Tuesday, February 13th (Bmagic, 15:56:31)


Meeting ended at 15:56:38 US/Eastern (full logs).

Action items

  1. mmorgan will explore moving LP stats to community site and automating same
  2. sandbergja will see if gh actions can run the pgtap tests
  3. GalenCharlton will open LP bug with the official proposal for git commit message release-note
  4. GalenCharlton update the release note script to look for the release-note tags
  5. GalenCharlton write up the release-notes convention for the dev wiki somehwere
  6. Stompro write up the release-notes convention for the dev wiki somehwere (stolen action from GalenCharlton)


Action items, by person

  1. GalenCharlton
    1. GalenCharlton will open LP bug with the official proposal for git commit message release-note
    2. GalenCharlton update the release note script to look for the release-note tags
    3. GalenCharlton write up the release-notes convention for the dev wiki somehwere
    4. Stompro write up the release-notes convention for the dev wiki somehwere (stolen action from GalenCharlton)
  2. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same
  3. sandbergja
    1. sandbergja will see if gh actions can run the pgtap tests
  4. Stompro
    1. Stompro write up the release-notes convention for the dev wiki somehwere (stolen action from GalenCharlton)


People present (lines said)

  1. Bmagic (73)
  2. GalenCharlton (41)
  3. Dyrcona (17)
  4. abneiman (12)
  5. sandbergja (9)
  6. eeevil (9)
  7. pinesol (6)
  8. shulabear (6)
  9. mmorgan (6)
  10. JBoyer (5)
  11. sleary (4)
  12. terranm (4)
  13. Stompro (3)
  14. berick (2)
  15. collum (1)


Generated by MeetBot 0.1.4.