15:06:29 <Bmagic> #startmeeting 2024-02-13 - Developer Meeting
15:06:29 <pinesol> Meeting started Tue Feb 13 15:06:29 2024 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:29 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:29 <pinesol> The meeting name has been set to '2024_02_13___developer_meeting'
15:06:35 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-02-13
15:07:02 <Bmagic> #topic Introductions
15:07:07 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:07:22 <Stompro> #info Stompro = Josh Stompro, LARL
15:07:22 <gmcharlton> #info gmcharlton = Galen Charlton, Equinox
15:07:28 <terranm57> #info terranm57 = Terran McCanna, PINES
15:07:29 <shulabear> #info shulabear = Shula Link, GCHRL
15:07:29 <collum> #info collum = Garry Collum, KCPL
15:07:31 <csharp_> #info csharp_ = the actual and only Chris Sharp
15:07:41 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:07:41 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:07:52 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:07:56 <berick> #info berick Bill Erickson, KCLS
15:08:04 <Bmagic> #topic Action Items from Last Meeting
15:08:09 <Bmagic> #info mmorgan will explore moving LP stats to community site and automating same
15:08:17 * mmorgan has been poking at Dyrcona's launchpad api scripts and was able to retrieve bug counts, so a bit of progress.
15:08:33 <Bmagic> mmorgan++
15:08:33 <mmorgan> That's all I have for now.
15:08:38 <Bmagic> carry it forward?
15:08:48 <mmorgan> Yep!
15:08:59 <Bmagic> #action mmorgan will explore moving LP stats to community site and automating same
15:09:05 <Bmagic> #info sandbergja will see if gh actions can run the pgtap tests
15:09:38 <Bmagic> skipping
15:09:43 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:09:46 <Bmagic> #info GalenCharlton will open LP bug with the official proposal for git commit message release-note
15:09:55 <Bmagic> #action sandbergja will see if gh actions can run the pgtap tests
15:10:26 <gmcharlton> So, the bug is opened: https://bugs.launchpad.net/evergreen/+bug/2051946
15:10:26 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] - Assigned to Galen Charlton (gmc)
15:10:32 <gmcharlton> ah, sorry, wrong one
15:10:34 <gmcharlton> just a moment
15:10:55 <gmcharlton> this is the one: https://bugs.launchpad.net/evergreen/+bug/2051874
15:10:55 <pinesol> Launchpad bug 2051874 in Evergreen "new script to extract information for release notes from commit messages" [Wishlist,New]
15:11:13 <gmcharlton> and it comes with a pull request
15:11:22 <gmcharlton> so, additional feedback welcome
15:12:18 <Bmagic> gmcharlton++
15:12:30 <shulabear> gmcharlton++
15:12:42 <Dyrcona> gmcharlt++
15:12:55 <Dyrcona> I should be able to take a look.
15:13:04 <gmcharlton> Dyrcona++
15:13:23 <Bmagic> :)
15:13:44 <Bmagic> this next one is yours also
15:13:45 <Bmagic> #info GalenCharlton update the release note script to look for the release-note tags
15:14:38 <Bmagic> I thought maybe that was more along the lines of: update the release script to include the release note portion
15:15:00 <gmcharlton> yeah - I think the action items got a bit squished during the previous meeting
15:15:03 <Bmagic> but I suppose you killed both birds with one LP?
15:15:21 <gmcharlton> the first bug I mentioned, bug 2051946, is the one to instituate a commit message template
15:15:21 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:15:37 <gmcharlton> that bug is open, but now I need to devise a template and create a pull request
15:16:10 <Bmagic> ok, shall we make that an action for you?
15:16:10 <gmcharlton> so I'll take an action item to create a Git commit message type and update bug 2051946
15:16:15 <gmcharlton> yes please
15:16:35 <Bmagic> #action gmcharlton - create a Git commit message type and update bug 2051946
15:16:35 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:17:26 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=dev:git#commit_messages
15:18:03 <Bmagic> I suppose Stompro did his thing?
15:18:07 <Stompro> I added examples to the dev:git page and updated a few other pages that referenced creating the release notes with stubs just so the new ability gets noticed.
15:18:08 <gmcharlton> he did
15:18:13 <gmcharlton> Stompro++
15:18:20 <Bmagic> Stompro++
15:18:48 <gmcharlton> also, on the general topic, there's a comment from abneiman on the release-tag bug that I'd like to mention now, as it might affect the template
15:19:03 <gmcharlton> namely, seeing if we can setting for a tense to use for the one-liner release notes
15:19:08 <Bmagic> please, the rest of the agenda is almost empty, so go ahead
15:20:05 <gmcharlton> abneiman: do you have any preference one way or another?
15:20:09 <Bmagic> hmmm
15:20:35 <gmcharlton> (comment is https://bugs.launchpad.net/evergreen/+bug/2051874/comments/9)
15:20:35 <pinesol> Launchpad bug 2051874 in Evergreen "new script to extract information for release notes from commit messages" [Wishlist,New] - Assigned to Jason Stephenson (jstephenson)
15:20:41 <abneiman> sorry, I was just here for the band names
15:21:15 <Bmagic> I like the "s" - inferring that the following code does* the thing. Though from a documentation context, I'd say without the s, but maybe a "d" instead. Like "Removed" X, "Fixed" Y
15:21:21 <abneiman> personally I tend to go with the more active (to my ears) version: "Fixes an issue..." "Restores the ability..." "Adds a something or another"
15:21:48 <kmlussier> +1
15:21:59 <gmcharlton> abneiman: be it. "Megadeth fixes the accessibility issue." "Chanticleer updates the MARC tag tables"
15:22:01 <gmcharlton> etc.
15:22:09 <abneiman> but, I don't really have a strong preference, just a preference for consistency (hobgoblins or not)
15:22:23 <abneiman> gmcharlton++ # actual lol
15:22:51 <Bmagic> s! Esss it issss!
15:23:27 <Dyrcona> We could go with just "Fix an issue...."
15:23:39 <shulabear> all release notes should be in passive voice /jk
15:24:03 <Bmagic> lol, Dyrcona
15:24:14 <dluch> Yeah, I think with the s
15:24:26 <dluch> shulabear lol
15:24:28 <Bmagic> so, where does this lead us? Should this be formal somewhere?
15:24:57 <gmcharlton> suggestion in the Git commit message template (and the wiki page) would be where to put it, I think
15:25:22 <Bmagic> Stompro? want that one?
15:25:31 <Stompro> Sure
15:25:47 <Bmagic> #action Stompro will formalize the tense usage in the release-note message
15:26:25 <Bmagic> I would like to open the floor for any topic that anyone would like to mention? I dropped the ball and forgot to email the list yesterday, attempting to get the agenda a bit more filled out
15:26:37 <Dyrcona> While we're at it can we get better commit messages in general? Some folks don't follow guidelines.
15:27:07 <Bmagic> it'd be neat if git would flat refuse to commit if it's not in our format :)
15:27:15 <terranm57> Bmagic I added one to New Business
15:27:18 <gmcharlton> yeah, I think that's going to be a matter of nudging
15:27:27 <kmlussier> Bmagic: That's what core committers are for.
15:27:40 <Bmagic> terranm57++
15:27:50 <gmcharlton> (though as I'm sure many of you have observed, I'm also quite willing to edit commit messages)
15:28:00 <Bmagic> kmlussier++ # I'm picking up your sublty
15:28:42 <Bmagic> moving on!
15:28:50 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:28:55 <Bmagic> incoming!!!
15:29:14 <Bmagic> lol, gmcharlt took incoming seriously
15:29:18 <Bmagic> #info Open Bugs - 3091
15:29:19 <Bmagic> #info Pullrequests - 107
15:29:19 <Bmagic> #info Signedoff - 8
15:29:30 <Bmagic> #topic Launchpad Status since last meeting
15:29:34 <Bmagic> #info Bugs Added - 62
15:29:34 <Bmagic> #info Pullrequest tag Added - 39
15:29:34 <Bmagic> #info Signedoff tag Added - 13
15:29:34 <Bmagic> #info Fix Committed - 23
15:29:52 <Bmagic> #topic New Business - New Launchpad tag: "caching"
15:30:30 <Bmagic> who has "caching" ?
15:30:43 <terranm57> lol
15:31:07 <terranm57> Caching might have been gmcharlton's since I saw some tickets get added
15:31:21 <Bmagic> oh shoot, he disconnected
15:31:37 <Bmagic> gotta wait for the ol' cable modem to power cycle
15:31:48 <Bmagic> poof, he's back
15:32:00 <gmcharlton> so, did y'all fix all the bugs while I was gone?
15:32:21 <terranm57> We just assigned them all to you
15:32:21 <Bmagic> gmcharlton: we're here: "New Launchpad tag: "caching""
15:32:34 <gmcharlton> terranm57: fair
15:32:47 <gmcharlton> so regarding the caching tag, just a heads-up that I added it today
15:33:00 <terranm57> gmcharlton, did you add it to the "official list" too?
15:33:12 <gmcharlton> intended as a catch-all for issues where caching is just too. dang. much.
15:33:15 <Bmagic> gmcharlton++ # moving and shaking!
15:33:26 <gmcharlton> I did also making it an official tag
15:33:42 <terranm57> I'll add it here - https://wiki.evergreen-ils.org/doku.php?id=dev:lp_tags
15:33:45 <gmcharlton> but of course, now's the time to revert that if somebody has a serious objection or wishes an alternative name
15:34:09 <Bmagic> when do we tag bugs with it?
15:35:00 <gmcharlton> Bmagic: basically, any bug where a value gets cached, then changed, but then there's no obvious way to refresh the caching without server-side action such as an Apache restart
15:35:07 <terranm57> "caching" works for me
15:35:30 <gmcharlton> it would cover both settings and configuration data as well as things like cached images and files served from the webserver (including Javascript)
15:35:49 <Bmagic> ok, makes sense. Documenting that on the wiki would be good. terranm is getting that covered
15:35:53 <Dyrcona> Yeah, "caching" is OK. If we need another for browser cache, we can add that.
15:36:23 <Bmagic> #action terranm will make LP tag "caching" official
15:36:28 <terranm57> If we want to break it up, please do so like caching-server, caching-browser, etc.
15:36:39 <terranm57> Bmagic - done!
15:37:00 <Bmagic> terranm57: and confirmed! I see it. Wow, that has to be some kind of record
15:37:01 <gmcharlton> my overall goal: without compromising speed, to make it possible to change something or do an upgrade and see the new stuff without anything more than a page refresh
15:37:11 <gmcharlton> (or at least, a cache-clearing action that you can get at via the staff client)
15:37:27 <Dyrcona> Well, why not drop the "ing?" Particularly if there are two: browser-cache, server-cache?
15:38:08 <Bmagic> CTR+f the tags wiki page for "cach" - no results but the new one
15:38:41 * Bmagic waves at mantis, ongoing dev meeting atm
15:39:03 <Dyrcona> I'm not sure we'd need a tag for browser cache, though. So, don't mind me.
15:39:30 <Bmagic> we're good then, with the "caching" tag? I mean, it's already official
15:40:09 <gmcharlton> I think for the moment that there's no need to split the tag
15:40:19 <Bmagic> sounds good to me
15:40:26 <Bmagic> #topic New Business - 3.next / 4.0 release team & schedule?
15:40:40 <abneiman> that's mine
15:40:40 <Bmagic> strap in, this might be a long one
15:40:42 <abneiman> just a poke
15:40:59 <abneiman> I mean, I don't have anything to say other than, hey we should talk or at least think about this?
15:41:11 <abneiman> anyone want to take the lead?
15:41:33 <abneiman> for that matter, are we settled on whether this will be 3.13 or 4.0?
15:41:41 <abneiman> anyway, discuss!
15:41:43 <Dyrcona> I have been meaning to start a larger conversation about releases because I don't think our current model is working.
15:42:52 <abneiman> agreed that that is a larger convo that needs to be had; but for this month I just don't want another month to go by without a relteam for the spring
15:43:22 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=dev:evergreen:release_checklist
15:43:39 <Dyrcona> Well, our last release was three months late. Do we think we're really ready for another?
15:44:42 <Bmagic> Dyrcona: point release?
15:44:43 <abneiman> part of that was we didn't get a rel team together till three months late... and we're already running late on the spring, so, is the answer to run later? or to get people to step up now and try to get a schedule together?
15:45:09 <csharp_> is anyone experimenting with RediSRF? that seems to be one of the factors for 3.X vs 4.0
15:45:24 <Bmagic> csharp_: I am! nothing to report yet though
15:45:37 <gmcharlton> csharp_: yep
15:45:51 <Bmagic> I'm planning on putting it into production for a 3.12.1 upgrade
15:45:58 <csharp_> we should also consider an LTS (long term support) 3.X for people not ready to move to RediSRF/Rust
15:46:03 <Dyrcona> That schedule is unrealistic given our current experience. I think we should do 1 release per year, if we wish to do the full tarball dance.
15:46:14 <terranm57> From a user perspective, I would expect a 4.0 version to be fully Angularized.
15:46:21 <berick> Bmagic: nice!
15:46:38 <shulabear> terranm57++
15:46:39 <sleary> another factor is that we have some Angularizations coming up (Reports, Acq A&B) that would let us remove some older interfaces, but we might want a version where they overlap... what terranm57 said
15:46:42 <dluch> terranm57: same
15:46:43 <csharp_> at the Hackaway we talked about changing up the release timings iirc
15:47:03 <Dyrcona> abneiman: To answer your specific question: Yes, I think we should push the spring release back depending.
15:47:07 <Bmagic> sounds like we don't want 4.0 to be the next* release name
15:47:15 <csharp_> I don't think it fits
15:47:18 <sleary> I agree
15:47:38 <abneiman> Equinox has a couple large features -- alluded to by sleary -- that IMO should predate a 4.0/redis
15:47:39 <sleary> I would love for 4.0 to have some visual polish, and the UI group is working on some things, but they will not all be ready for spring
15:47:39 <Dyrcona> Someone has started targeting bugs at 4.0-beta, fwiw.
15:47:53 <Bmagic> 3.13 rolls off the togue anyway!
15:47:57 <abneiman> I'd love to see a spring release but we need volunteers
15:48:19 <csharp_> and we have to do 3.13 so we can get to Evergreen Pi!
15:48:21 <Dyrcona> I also think we should follow the trend of using YY.MM for releases. Many more projects are doing that now.
15:49:03 <Bmagic> I'm not opposed to changing the numbering system, but we might want to take that to the mailing list?
15:49:09 <Dyrcona> As for the next release, do we think there are enough new feature ready now to justify another "major" release?
15:49:17 <csharp_> we based the twice a year thing on Ubuntu, and we're actually a bit more like Fedora (late all the time)
15:49:33 <sleary> I do not love the year/month numbering, just because last-minute release schedule changes would force us to edit a lot of docs and things
15:50:00 <abneiman> there will be a whole pile of potential major features shortly, once I know what a release schedule looks like ....
15:50:04 <gmcharlton> noting that the 4.0 series / 4.0-beta tags in LP are easily renamed
15:50:16 <Dyrcona> Bmagic: Right, I was gong to add that changing the numbering and reducing the number of releases should be part of that larger conversation. However, I think it is worth mentioning as we discuss the next release.
15:50:21 <Bmagic> actually that is a good point, don't we have a bunch of code that relies on the numbers to be in sequence like that?
15:50:37 <csharp_> gmcharlton right - and *all* of this is kinda arbitrary in the end :-)
15:51:07 <gmcharlton> next release, Evergreen ΞΎ!
15:51:18 <Dyrcona> What csharp_ just said is why I prefer dated releases. The numbers are arbitrary.
15:51:23 <csharp_> PINES does annual upgrades and we'll do whatever version is newest at that time
15:51:50 <Dyrcona> gmcharlton: You're proposing we got the rote of TeX and increment 1 digit of Pi for earch new release?
15:51:54 <Dyrcona> :)
15:51:55 <abneiman> so, no release team volunteers? We're just gonna talk about numbers?
15:52:04 <berick> annual here too fwiw, but it seems we're veering into a huge tangent :)
15:52:08 <Bmagic> Dyrcona: would you like to take the action of leading the numbering discussion on the mailing list?
15:52:08 <berick> abneiman++
15:52:11 <Bmagic> I'll be on the team!
15:52:29 <shulabear> I'll volunteer again. I'm not extremely useful, but I'm a body!
15:52:33 <abneiman> Bmagic++
15:52:33 <terranm57> Bmagic++
15:52:40 <Dyrcona> abneiman: I am not convinced that we're ready for another release. Why not open the Lp bugs with the new features, firt?
15:52:45 <Dyrcona> first...
15:52:45 <Bmagic> shulabear++
15:52:47 <csharp_> Bmagic++ shulabear++
15:52:53 <Dyrcona> Bmagic: No, I'm not taking an action.
15:53:00 <Bmagic> :)
15:53:02 <berick> Dyrcona: seems like something the release team could discuss?
15:53:11 <terranm57> Why not choose the release team and let them take a closer look at when there is enough new good stuff?
15:53:13 <abneiman> Dyrcona: standby and I will give you a list of bugs in LP
15:53:32 <csharp_> makes sense to me, berick & terranm57
15:53:44 <Bmagic> shulabear: it's you and me! We got this.
15:54:20 <shulabear> bmagic: oh lord we're in trouble
15:54:29 <Bmagic> (You're telling me :))
15:54:29 <Dyrcona> We can put it to a vote if you like. I'm just not prepared to volunteer at the moment
15:54:57 <berick> it's been a while, but I can assist w/ the release team this time.  just tell me what to do
15:55:09 <Bmagic> berick++ # glad to have you along
15:55:10 <terranm57> Bmagic I can't commit to being on the release team again this time, but I can help with organizing feedback fest for it
15:55:10 <csharp_> berick++
15:55:24 <csharp_> we all have your back
15:55:33 <abneiman> https://bugs.launchpad.net/evergreen/+bug/1993823
15:55:33 <pinesol> Launchpad bug 1993823 in Evergreen "wishlist: Angular Reports Interface" [Wishlist,Confirmed] - Assigned to Andrea Neiman (aneiman)
15:55:33 <abneiman> https://bugs.launchpad.net/evergreen/+bug/2006970
15:55:34 <abneiman> https://bugs.launchpad.net/evergreen/+bug/2039609
15:55:34 <pinesol> Launchpad bug 2006970 in Evergreen "wishlist: Acquisitions Sprint B: Angular Invoicing and Claiming" [Wishlist,New] - Assigned to Jason Etheridge (phasefx)
15:55:34 <abneiman> https://bugs.launchpad.net/evergreen/+bug/2006969
15:55:35 <Bmagic> terranm++ # I love this stone soup we're making
15:55:35 <pinesol> Launchpad bug 2039609 in Evergreen "wishlist: Acquisitions Sprint A - Z39.50 and other fixes" [Wishlist,New] - Assigned to Mike Rylander (mrylander)
15:55:36 <pinesol> Launchpad bug 2006969 in Evergreen "wishlist: enhanced MARC editor rewrite" [Wishlist,Confirmed] - Assigned to Stephanie Leary (stephanieleary)
15:55:38 <csharp_> but I'm unable to take on new things right now
15:55:46 <csharp_> holy craznap
15:56:05 <abneiman> noting that those 4 that I linked are in the final stages of internal cleanup and I expect PRs on all of them within the month
15:56:12 <sleary> those are just the big ones :)
15:56:12 <abneiman> so, yes, there are features
15:56:13 <terranm57> nice!
15:56:19 <Bmagic> lol, that's all?
15:56:20 <gmcharlton> berick: Bmagic: shulabear: if it helps, I am willing to do a one-shot session to go over some of the details; and I'm pretty sure that there are other recent release team members who could help me out
15:56:45 <shulabear> gmcharlton++ I'd appreciate that, for one.
15:56:48 <Bmagic> gmcharlton++ we can use all the help we can get
15:56:48 <berick> i'm interested
15:57:07 <sleary> I can help out with the release
15:57:21 <gmcharlton> I'll send out a call for scheduling said session
15:57:31 <terranm57> There's also a recording in one of the New Devs meetings - https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11
15:57:32 <Bmagic> gmcharlton: I was just about to ask that
15:57:51 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=newdevs:meetings:agenda-2023-11
15:58:26 <Bmagic> abneiman++ I think you accomplished your goal
15:58:29 <Dyrcona> Rolling the release itself isn't that hard if enough people who have the proper permissions are around.
15:58:34 <terranm57> IIRC, the recording doesn't cover the translation stuff, which is quite a few more steps
15:58:58 <abneiman> also, https://bugs.launchpad.net/evergreen/+bug/2043142 (and security bug #1917821) as well as a pile of bugfixes on Item Alerts, Holdings Editor, and a bunch of fixes for Experimential Angular Circ.
15:58:58 <pinesol> Launchpad bug 2043142 in Evergreen "wishlist: Reports security improvements" [Wishlist,New] - Assigned to Mike Rylander (mrylander)
15:59:09 * abneiman drops mic
15:59:16 <terranm57> abneiman++
15:59:20 <Bmagic> real quick, with the 30 seconds
15:59:22 <abneiman> thanks for letting me, uh, yell-spire you
15:59:27 <Bmagic> #topic New Business - Next Bug Squashing Week?
15:59:27 <mmorgan> abneiman++
15:59:32 <terranm57> It's time to plan the next Bug Squashing Week - Maybe the week of February 26 or week of March 18?
15:59:58 <abneiman> and I can help with relteam comms & release notes, etc. but can't take a big role
16:00:16 <shulabear> abneiman++
16:00:33 <Bmagic> terranm57: My schedule allows for either week
16:00:38 <terranm57> Bmagic++
16:01:06 <terranm57> I'm inclined to push it back to March unless anyone wants it sooner
16:01:24 <Bmagic> nope, that's fine!
16:01:37 <abneiman> +1 to March, I can even promise some shiny new features to test :-D
16:01:38 <terranm57> Cool beans, I'll put it on the calendar and do all my stuff
16:01:46 <abneiman> and some buffed-up old features
16:02:01 <Bmagic> terranm++
16:02:11 <Bmagic> #endmeeting