#evergreen: 2024-03-12 - Developer Meeting

Meeting started by Bmagic at 15:00:03 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-03-12 (Bmagic, 15:00:11)

  1. Introductions (Bmagic, 15:00:17)
    1. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:00:20)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:21)
    3. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:00:23)
    4. Stompro = Josh Stompro, LARL (Stompro, 15:00:37)
    5. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:00:37)
    6. terranm = Terran McCanna, Georgia PINES (terranm, 15:00:41)
    7. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:00:43)
    8. kmlussier = Kathy Lussier, NOBLE (kmlussier, 15:00:44)
    9. sleary = Stephanie Leary, Equinox (sleary, 15:00:46)
    10. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:52)
    11. berick Bill Erickson, KCLS (berick, 15:01:01)
    12. smayo = Steven Mayo, Georgia PINES (smayo, 15:01:02)
    13. sandbergja = Jane Sandberg, PUL (sandbergja, 15:01:17)

  2. Action Items from Last Meeting (Bmagic, 15:01:27)
    1. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:01:31)
    2. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:02:00)
    3. sandbergja will see if gh actions can run the pgtap tests (Bmagic, 15:02:05)
    4. eeevil = Mike Rylander, EOLI (eeevil, 15:03:41)
    5. gmcharlt_ - create a Git commit message type and update bug 2051946 (Bmagic, 15:04:10)
    6. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:05:29)
    7. Stompro will formalize the tense usage in the release-note message (Bmagic, 15:05:59)
    8. collum = Garry Collum, KCPL (collum, 15:07:37)
    9. agreed that release-notes tag will use present tense: 'fixes', 'updates' etc. (abneiman, 15:10:21)
    10. terranm will make LP tag "caching" official (Bmagic, 15:11:18)

  3. Evergreen (Bmagic, 15:12:40)
    1. The next point releases are scheduled for March 20th (during bug squashing week). Should we push them back a week to the 27th so that our energies aren't divided between the two? Also, who'd like to help with the release? (Bmagic, 15:12:47)

  4. Documentation (Bmagic, 15:14:45)
    1. DIG met March 7, will meet again during Bug Squashing Week, then at the Hackfest (Bmagic, 15:14:50)
    2. updated release schedule here: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap (abneiman, 15:15:40)
    3. Documentation for Angular Staff Catalog is almost done! (Bmagic, 15:16:45)
    4. Pre-3.12 docs now have links to current Reports docs (Bmagic, 15:18:33)
    5. We'll be identifying missing 3.12 documentation to work on for Bug Squashing Week (Bmagic, 15:18:51)
    6. https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:documentation_needs (Bmagic, 15:18:55)

  5. Launchpad Status (as of noon Eastern) (Bmagic, 15:20:14)
    1. Open Bugs - 3126 (Bmagic, 15:20:31)
    2. Pullrequests - 98 (Bmagic, 15:20:31)
    3. Signedoff - 12 (Bmagic, 15:20:31)

  6. Launchpad Status since last meeting (Bmagic, 15:20:40)
    1. Bugs Added - 59 (Bmagic, 15:20:44)
    2. Pullrequest tag Added - 27 (Bmagic, 15:20:44)
    3. Signedoff tag Added - 26 (Bmagic, 15:20:44)
    4. Fix Committed - 31 (Bmagic, 15:20:44)

  7. New Business - Call for volunteer to give the development update at the conference (Bmagic, 15:20:55)
    1. redavis = Ruth Davis, Evergreen Indiana and other stuff (redavis, 15:23:08)

  8. New Business - Barriers to getting things committed (Bmagic, 15:23:12)
  9. New Business - Dev documentation: volunteer needed to update versioning page (Bmagic, 15:37:17)
    1. https://wiki.evergreen-ils.org/doku.php?id=versioning (Bmagic, 15:37:38)

  10. New Business - Dev documentation: volunteer needed to update versioning page (Bmagic, 15:53:31)
    1. https://wiki.evergreen-ils.org/doku.php?id=versioning (Bmagic, 15:55:10)

  11. New Business - Possible hackfest (or other date) discussion on Evergreen releases - see email (Kathy) (Bmagic, 15:55:31)
    1. http://list.evergreen-ils.org/pipermail/evergreen-dev/2024-February/000740.html (Bmagic, 15:55:41)

  12. Community calendar (Kathy) (Bmagic, 15:58:46)
    1. Next Meeting is Tuesday, April 9th 2024 (Bmagic, 16:03:21)


Meeting ended at 16:03:28 US/Eastern (full logs).

Action items

  1. mmorgan will explore moving LP stats to community site and automating same
  2. gmcharlt - create a Git commit message type and update bug 2051946


Action items, by person

  1. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same


People present (lines said)

  1. Bmagic (102)
  2. abneiman (51)
  3. dluch (31)
  4. Dyrcona (29)
  5. kmlussier (24)
  6. sleary (21)
  7. csharp_ (19)
  8. sandbergja (17)
  9. terranm (17)
  10. mmorgan (15)
  11. pinesol (12)
  12. jeffdavis (9)
  13. redavis (8)
  14. jeff (5)
  15. eeevil (5)
  16. Stompro (4)
  17. smayo (3)
  18. JBoyer (2)
  19. berick (1)
  20. collum (1)


Generated by MeetBot 0.1.4.