#evergreen: 2024-04-09 - Developer Meeting

Meeting started by Bmagic at 15:00:01 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-04-09 (Bmagic, 15:00:09)

  1. Introductions#topic Introductions (Bmagic, 15:00:17)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:21)
    2. Dyrcona = Jason Stephenson, C/W MARS, Inc. (Dyrcona, 15:00:27)
    3. phasefx = Jason Etheridge, EOLI (phasefx, 15:00:36)
    4. berick Bill Erickson, KCLS (berick, 15:00:45)
    5. Stompro = Josh Stompro, LARL (Stompro, 15:00:57)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:00)
    7. sleary = Stephanie Leary, EOLI (sleary, 15:01:06)
    8. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:56)

  2. Action Items from Last Meeting (Bmagic, 15:02:11)
    1. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:02:19)
    2. sandbergja = Jane Sandberg, PUL (sandbergja, 15:02:35)
    3. https://docs.google.com/spreadsheets/d/1igd02X0VjIcJrGdmcEQ34bAha8b3IHYprHkdZhcOkkE/edit?usp=sharing (mmorgan, 15:02:40)
    4. JBoyer = Jason Boyer, EOLI (JBoyer, 15:04:19)
    5. scottangel = Scott Angel, MOBIUS (scottangel, 15:07:19)
    6. gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:08:26)
    7. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:12:23)
    8. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:12:33)

  3. Launchpad Status (as of noon Eastern) (Bmagic, 15:12:50)
    1. Open Bugs - 3063 (Bmagic, 15:13:01)
    2. Pullrequests - 92 (Bmagic, 15:13:02)
    3. Signedoff - 13 (Bmagic, 15:13:02)

  4. Launchpad Status since last meeting (Bmagic, 15:13:07)
    1. Bugs Added - 42 (Bmagic, 15:13:11)
    2. Pullrequest tag Added - 43 (Bmagic, 15:13:11)
    3. Signedoff tag Added - 34 (Bmagic, 15:13:11)
    4. Fix Committed - 37 (Bmagic, 15:13:11)

  5. New Business - LP#1017990 - let's deprecate and/or remove the open-ils.circ.holds.create APIs! (Bmagic, 15:13:23)
    1. eeevil == Mike Rylander, EOLI (eeevil, 15:27:24)
    2. ACTION: Bmagic will write announcement+blog post for deprication of open-ils.circ.title_hold.is_possible and open-ils.circ.holds.create[.override] (Bmagic, 15:31:19)
    3. ACTION: JBoyer will throw a branch on lp 1017990 to loudly inform the logs something is still calling that ^ (JBoyer, 15:31:57)
    4. https://bugs.launchpad.net/evergreen/+bug/1017990 (Bmagic, 15:32:30)

  6. New Business - LP#2042158 - should we recommend disabling Postgres JIT? (Bmagic, 15:33:14)
    1. https://bugs.launchpad.net/evergreen/+bug/2042158 (Bmagic, 15:33:21)
    2. ACTION: eeevil will open a bug for cross-column stats targets (Bmagic, 15:47:43)

  7. New Business - Redis licensing change / discussion of potential replacement (Bmagic, 15:49:00)
  8. New Business - Release branch proposals – anything we can move forward with? (Bmagic, 15:56:14)
    1. http://list.evergreen-ils.org/pipermail/evergreen-dev/2024-March/000777.html (Bmagic, 15:56:24)

  9. Announcements (Bmagic, 16:13:11)
    1. Next Meeting is Tuesday, May 14th 2024 (Bmagic, 16:13:17)


Meeting ended at 16:13:22 US/Eastern (full logs).

Action items

  1. gmcharlt - create a Git commit message type and update bug 2051946
  2. mmorgan will explore moving LP stats to community site and automating same
  3. Bmagic will write announcement+blog post for deprication of open-ils.circ.title_hold.is_possible and open-ils.circ.holds.create[.override]
  4. JBoyer will throw a branch on lp 1017990 to loudly inform the logs something is still calling that ^
  5. eeevil will open a bug for cross-column stats targets


Action items, by person

  1. Bmagic
    1. Bmagic will write announcement+blog post for deprication of open-ils.circ.title_hold.is_possible and open-ils.circ.holds.create[.override]
  2. eeevil
    1. eeevil will open a bug for cross-column stats targets
  3. JBoyer
    1. JBoyer will throw a branch on lp 1017990 to loudly inform the logs something is still calling that ^
  4. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same


People present (lines said)

  1. Bmagic (94)
  2. Dyrcona (25)
  3. eeevil (22)
  4. berick (18)
  5. sandbergja (16)
  6. mmorgan (10)
  7. pinesol (7)
  8. jeff (6)
  9. JBoyer (5)
  10. sleary (2)
  11. Stompro (2)
  12. phasefx (1)
  13. kenstir (1)
  14. scottangel (1)


Generated by MeetBot 0.1.4.