#evergreen: 2024-05-14 - Developer Meeting

Meeting started by Bmagic at 15:00:02 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-05-14 (Bmagic, 15:00:10)

  1. Introductions (Bmagic, 15:00:16)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:20)
    2. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:00:30)
    3. kmlussier = Kathy Lussier, NOBLE (kmlussier, 15:00:34)
    4. sandbergja = Jane Sandberg, PUL (sandbergja, 15:00:36)
    5. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:00:39)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:46)
    7. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:00:47)
    8. jvwoolf= Jessica Woolford, Bibliomation (jvwoolf, 15:01:01)
    9. shulabear = Shula Link, GCHRL (shulabear, 15:01:22)
    10. scottangel = Scott Angel, MOBIUS (scottangel, 15:02:14)
    11. berick Bill Erickson, KCLS (berick, 15:02:18)
    12. Stompro = Josh Stompro, Lake Agassiz Regional Library (LARL) (Stompro, 15:03:03)

  2. Action Items from Last Meeting (Bmagic, 15:03:33)
    1. gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:03:41)
    2. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:04:34)
    3. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:04:42)
    4. collum = Garry Collum, KCPL (collum, 15:04:47)
    5. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:05:04)
    6. Bmagic will write announcement+blog post for deprecation of open-ils.circ.title_hold.is_possible and open-ils.circ.holds.create[.override] (Bmagic, 15:05:09)
    7. JBoyer will throw a branch on lp 1017990 to loudly inform the logs something is still calling that ^ (Bmagic, 15:06:01)
    8. redavis = Ruth Davis, ECDI (redavis, 15:08:05)
    9. ACTION: Dyrcona will take a look at bug 1017990 for merging into main and 3.13 (Bmagic, 15:13:40)
    10. eeevil will open a bug for cross-column stats targets (Bmagic, 15:14:40)
    11. ACTION: eeevil will open a bug for cross-column stats targets (Bmagic, 15:16:46)

  3. Evergreen 3.13 beta release tarball is available (Bmagic, 15:19:09)
    1. https://evergreen-ils.org/downloads/Evergreen-ILS-3.13-beta.tar.gz (Bmagic, 15:19:30)

  4. Launchpad Status (as of noon Eastern) (Bmagic, 15:22:43)
    1. Open Bugs - 3087 (Bmagic, 15:22:53)
    2. Pullrequests - 88 (Bmagic, 15:22:53)
    3. Signedoff - 8 (Bmagic, 15:22:53)

  5. Launchpad Status since last meeting (Bmagic, 15:23:00)
    1. Bugs Added - 47 (Bmagic, 15:23:05)
    2. Pullrequest tag Added - 30 (Bmagic, 15:23:05)
    3. Signedoff tag Added - 22 (Bmagic, 15:23:05)
    4. Fix Committed - 36 (Bmagic, 15:23:05)

  6. New Business - LP#2042158 - should we recommend disabling Postgres JIT? (Bmagic, 15:23:17)
    1. https://bugs.launchpad.net/evergreen/+bug/2042158 (Bmagic, 15:23:22)
    2. ACTION: eeevil will see about merging bug 2042158 (Bmagic, 15:33:05)

  7. New Business - commit formatting and "infrastructure" commits (see discussion in LP#2039609) (Bmagic, 15:34:03)
    1. https://bugs.launchpad.net/evergreen/+bug/2039609 (Bmagic, 15:34:16)
    2. Should LP bug references be required in commit messages? (Bmagic, 15:34:34)
    3. https://wiki.evergreen-ils.org/doku.php?id=dev:git#commit_messages (kmlussier, 15:37:10)
    4. ACTION: kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits (Bmagic, 15:49:50)
    5. https://wiki.evergreen-ils.org/doku.php?id=newdevs:git:create (shulabear, 15:50:21)

  8. New Business - Scheduling a release discussion - https://doodle.com/meeting/participate/id/av9JXRme - Kathy (Bmagic, 15:54:48)
  9. Announcements (Bmagic, 15:58:08)
    1. 3.14 has a roadmap (Bmagic, 15:58:15)
    2. https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.14 (Bmagic, 15:58:19)
    3. Next Meeting is Tuesday, June 11th 2024 (Bmagic, 15:59:38)


Meeting ended at 16:00:10 US/Eastern (full logs).

Action items

  1. gmcharlt - create a Git commit message type and update bug 2051946
  2. mmorgan will explore moving LP stats to community site and automating same
  3. Dyrcona will take a look at bug 1017990 for merging into main and 3.13
  4. eeevil will open a bug for cross-column stats targets
  5. eeevil will see about merging bug 2042158
  6. kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits


Action items, by person

  1. Dyrcona
    1. Dyrcona will take a look at bug 1017990 for merging into main and 3.13
  2. eeevil
    1. eeevil will open a bug for cross-column stats targets
    2. eeevil will see about merging bug 2042158
  3. kmlussier
    1. kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits
  4. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same


People present (lines said)

  1. Bmagic (105)
  2. csharp_ (34)
  3. Dyrcona (25)
  4. kmlussier (24)
  5. redavis (18)
  6. eeevil (18)
  7. mmorgan (15)
  8. pinesol (11)
  9. shulabear (9)
  10. jeffdavis (7)
  11. dluch (7)
  12. berick (6)
  13. sandbergja (5)
  14. jvwoolf (2)
  15. collum (1)
  16. mantis1 (1)
  17. scottangel (1)
  18. Stompro (1)


Generated by MeetBot 0.1.4.