#evergreen: 2024-06-11 - Developer Meeting

Meeting started by Bmagic at 15:00:01 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-06-11 (Bmagic, 15:00:08)

  1. Introductions (Bmagic, 15:00:15)
    1. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:00:17)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:19)
    3. terranm = Terran McCanna, PINES (terranm, 15:00:27)
    4. redavis = Ruth Davis, ECDI (redavis, 15:00:32)
    5. sleary = Stephanie Leary, EOLI (sleary, 15:00:34)
    6. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:00:36)
    7. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:42)
    8. kmlussier is Kathy Lussier, NOBLE (kmlussier, 15:00:45)
    9. berick Bill Erickson, KCLS (berick, 15:00:49)
    10. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:03)
    11. LindaJansova is Linda Jansova, Osvobozena knihovna, Czech Republic (LindaJansova, 15:01:09)
    12. shulabear = Shula Link, GCHRL (shulabear, 15:01:35)
    13. eeevil = Mike Rylander, EOLI (eeevil, 15:01:36)
    14. smayo = Steven Mayo, PINES (smayo, 15:01:57)

  2. Action Items from Last Meeting (Bmagic, 15:02:16)
    1. gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:02:24)
    2. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:04:33)
    3. mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:04:37)
    4. ACTION: mmorgan will explore moving LP stats to community site and automating same (Bmagic, 15:05:12)
    5. Dyrcona will take a look at bug 1017990 for merging into main and 3.13 (Bmagic, 15:05:23)
    6. csharp_ is Chris Sharp, GPLS (csharp_, 15:07:06)
    7. ACTION: Dyrcona will take a look at bug 1017990 (Bmagic, 15:08:59)
    8. eeevil will open a bug for cross-column stats targets (Bmagic, 15:09:13)
    9. ACTION: eeevil will open a bug for cross-column stats targets (Bmagic, 15:11:44)
    10. eeevil will see about merging bug 2042158 (Bmagic, 15:11:53)
    11. kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits (Bmagic, 15:13:09)
    12. ACTION: kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits (Bmagic, 15:13:50)

  3. Evergreen (Bmagic, 15:14:36)
    1. 3.13.0 is released (Bmagic, 15:14:44)

  4. Launchpad Status (as of noon Eastern) (Bmagic, 15:17:29)
    1. Open Bugs - 3050 (Bmagic, 15:17:36)
    2. Pullrequests - 82 (Bmagic, 15:17:36)
    3. Signedoff - 11 (Bmagic, 15:17:36)

  5. Launchpad Status since last meeting (Bmagic, 15:17:42)
    1. Bugs Added - 43 (Bmagic, 15:17:47)
    2. Pullrequest tag Added - 12 (Bmagic, 15:17:47)
    3. Signedoff tag Added - 11 (Bmagic, 15:17:47)
    4. Fix Committed - 21 (Bmagic, 15:17:47)

  6. New Business - translation infrastructure: eliminate Launchpad in favor of POEditor - Stephanie/3.13 team (Bmagic, 15:17:57)
    1. ACTION: redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor (Bmagic, 15:29:38)

  7. New Business - LP#2060734: changes to the release process (Bmagic, 15:31:12)
  8. New Business - Outstanding roadblocks to merging OpenSRF Redis? (Bmagic, 15:32:12)
  9. New Business - Backport guidelines? What should be backported? - Stephanie/code review team (Bmagic, 15:46:10)
    1. ACTION: redavis will look at making a regular calendar event for translation work in lock step with point releases (Bmagic, 15:58:24)

  10. Announcements (Bmagic, 16:01:54)
    1. Next Meeting is Tuesday, July 9th 2024 (Bmagic, 16:02:06)


Meeting ended at 16:04:47 US/Eastern (full logs).

Action items

  1. gmcharlt - create a Git commit message type and update bug 2051946
  2. mmorgan will explore moving LP stats to community site and automating same
  3. Dyrcona will take a look at bug 1017990
  4. eeevil will open a bug for cross-column stats targets
  5. kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits
  6. redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
  7. redavis will look at making a regular calendar event for translation work in lock step with point releases


Action items, by person

  1. abneiman
    1. redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
  2. Dyrcona
    1. Dyrcona will take a look at bug 1017990
    2. redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
  3. eeevil
    1. eeevil will open a bug for cross-column stats targets
  4. EvaCe
    1. redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
  5. kmlussier
    1. kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits
  6. LindaJansova
    1. redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
  7. mmorgan
    1. mmorgan will explore moving LP stats to community site and automating same
  8. redavis
    1. redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
    2. redavis will look at making a regular calendar event for translation work in lock step with point releases


People present (lines said)

  1. Bmagic (111)
  2. redavis (37)
  3. Dyrcona (36)
  4. abneiman (27)
  5. sleary (24)
  6. csharp_ (21)
  7. kmlussier (20)
  8. berick (17)
  9. pinesol (16)
  10. LindaJansova (14)
  11. mmorgan (10)
  12. eeevil (10)
  13. jeff (9)
  14. terranm (7)
  15. shulabear (4)
  16. shulabear75 (4)
  17. smayo (2)
  18. EvaCe (1)


Generated by MeetBot 0.1.4.