15:00:17 <abneiman> #startmeeting 2024-07-09 Developer Meeting
15:00:17 <pinesol> Meeting started Tue Jul  9 15:00:17 2024 US/Eastern.  The chair is abneiman. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <pinesol> The meeting name has been set to '2024_07_09_developer_meeting'
15:00:33 <abneiman> #info agenda: https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-07-09#new_business
15:00:54 <abneiman> eh, sorry for the jump link. Y'all will figure it out.
15:01:01 <abneiman> #topic Introductions
15:01:24 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:01:30 <abneiman> who are you all, anyway? Please use format #info, nick, name, affiliation
15:01:30 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:01:35 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:40 <phasefx_> #info phasefx_ = Jason Etheridge, EOLI
15:01:46 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:01:47 <smayo> #info smayo = Steven Mayo, PINES
15:01:49 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:55 <terranm> #info terranm = Terran McCanna, PINES
15:01:56 <sleary> #info sleary = Stephanie Leary, EOLI
15:02:21 <berick> #info berick Bill Erickson, KCLS
15:02:55 <abneiman> welcome, all. If you come in late please feel free to introduce yourself!
15:03:00 <abneiman> #topic Action Items from Last Meeting
15:03:11 <abneiman> #info gmcharlt - create a Git commit message type and update bug 2051946
15:03:14 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:03:31 <eeevil> #info eeevil = Mike Rylander, EOLI
15:03:34 <abneiman> I believe this is still pending
15:03:37 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:04:14 <abneiman> #info mmorgan will explore moving LP stats to community site and automating same
15:04:23 <mmorgan> Rather than keeping this as a recurring action item, I would like to move this to a launchpad ticket where it can evolve with community input.
15:04:32 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:04:38 <abneiman> good call, mmorgan
15:04:49 <abneiman> would you like an action item to convert the action item? :)
15:04:50 <collum> #info collum = Garry Collum, kcpl
15:05:05 <mmorgan> Yes! happy to open a ticket
15:05:08 <redavis> mmorgan++
15:05:10 <sleary> mmorgan++
15:05:20 <abneiman> #action mmorgan will open a ticket for  moving LP stats to community site & automating same
15:05:23 <abneiman> mmorgan++
15:05:28 <abneiman> next...
15:05:42 <abneiman> #info eeevil will open a bug for cross-column stats targets
15:06:07 <abneiman> eeevil, anything to report?
15:06:08 <eeevil> eventually, yes, I will ...
15:06:11 <shulabear> #info shulabear = Shula Link, GCHRL
15:06:17 <abneiman> noted
15:06:38 <abneiman> #action eeevil will open a bug for cross-column stats targets
15:06:40 <abneiman> oh and ...
15:06:48 <abneiman> #action gmcharlt - create a Git commit message type and update bug 2051946
15:06:49 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:06:58 <abneiman> and because it's that kind of day, back up the agenda to...
15:07:08 <abneiman> #info Dyrcona will take a look at bug 1017990
15:07:10 <pinesol> Launchpad bug 1017990 in Evergreen "Possible to bypass holds placement limits via direct API calls" [Medium,Confirmed] https://launchpad.net/bugs/1017990 - Assigned to Jason Stephenson (jstephenson)
15:07:36 <Dyrcona> I haven't really had time, yet. Also does this need to be a meeting item, other than it was brought up here?
15:08:10 <abneiman> nope, it was just on the agenda as an action from last time. Will drop it for next meeting.
15:08:26 <abneiman> #info kmlussier will update wiki (commit message standards) to include details about shared components/pullrequest rule for LP tagging on multi-commits
15:08:34 <JBoyer> It does serve as a reminder to some of us that our branches are broken. (it me, I'm us. er, somehting like that)
15:08:40 <abneiman> #info kmlussier has done this: https://wiki.evergreen-ils.org/doku.php?id=dev:git&do=diff&rev2%5B0%5D=1712683062&rev2%5B1%5D=1720473693&difftype=sidebyside
15:08:45 <abneiman> kmlussier++
15:09:07 <abneiman> she notes "I did not update the new devs wiki page on Git for Windows because there are no instructions on the page for modifying the commit message at a later time."
15:09:08 <redavis> kmlussier++
15:09:11 <mmorgan> kmlussier++
15:09:21 <dluch> kmlussier++
15:09:22 <shulabear> kmlussier++
15:09:32 <abneiman> #info redavis, Dyrcona, abneiman, LindaJansova, EvaCe will investigate and see what it will take to move our translations to POEditor
15:09:42 <abneiman> we did have this meeting! it feels like it was a long time ago.
15:10:09 <abneiman> does someone not-me want to give a quick summary?
15:10:13 <Dyrcona> I think I'm supposed to do something related to that... and it does seem like a long time ago.
15:10:32 <redavis> It does feel like a long time ago. We did walk through POEditor plans and Galen was able to get some new functionality added.
15:11:30 <redavis> Because of the Project's non-profit status, it didn't cost anything.  But now, we're looking at what it'll take to make decisions and port stuff (if deemed useful) from Launchpad to POEditor.
15:11:33 <scottangel> #info scottangel = Scott Angel, MOBIUS
15:11:52 <abneiman> redavis++
15:11:55 <sleary> redavis to clarify, does that mean that we were missing some things that should have been available to us on the open source / non-profit plan we're on?
15:12:06 <redavis> Yes
15:12:12 <sleary> thanks
15:12:16 <mmorgan> redavis++
15:12:20 <redavis> Hold and I'll bring up what they were.  Carry on.
15:12:21 <dluch> redavis++
15:12:26 <sleary> redavis++
15:12:27 <abneiman> #info quoting redavis: We did walk through POEditor plans and Galen was able to get some new functionality added. Because of the Project's non-profit status, it didn't cost anything.  But now, we're looking at what it'll take to make decisions and port stuff (if deemed useful) from Launchpad to POEditor.
15:12:55 <abneiman> final action item:
15:13:01 <abneiman> #info redavis will look at making a regular calendar event for translation work in lock step with point releases
15:13:20 <abneiman> I believe there was also progress on this, yes?
15:13:22 <redavis> So, I wouldn't say that THAT has been done exactly...
15:13:48 <Dyrcona> We do plan to have extra time for translations in the 3.14 release cycle.
15:13:58 <abneiman> redavis++ Dyrcona++
15:13:59 <redavis> But we did build some extra time into the next release cycle to accommodate more time for translations and talked about how that might continue for other releases, but it point or major
15:14:19 <redavis> s/but it/be it
15:14:43 <Dyrcona> Regarding POEditor: They turned on GitHub/Gitlab integration for us and are willing to turn on other features according to gmcharlt.
15:15:00 <abneiman> redavis: do you want the action item to carry forward? There is a larger discussion that should continue, but in terms of the calendar event?
15:15:04 <Dyrcona> I think I'm supposed to look into getting the integration to work.
15:15:15 <redavis> Right.  GitHub/GitLab integrations, translation memory, history and audit logs.
15:15:27 <sleary> nice!
15:15:46 <redavis> abneiman, I feel wholly unprepared to answer that competently, so I'll say "yes."
15:15:51 <abneiman> Dyrcona: as today's action item fairy, I am ready and able to give you an action for that in this meeting if you wish :-D
15:16:05 <abneiman> #action redavis will look at making a regular calendar event for translation work in lock step with point releases
15:16:54 <redavis> abneiman, I think more than making the regular calendar event, extra time for translation work needs to be added into release cycle procedure.
15:17:24 <abneiman> redavis: both, I think, since we at least make a nominal effort to calendar point releases
15:17:44 <redavis> abneiman++ #truth_has_been_spoken
15:17:49 <Dyrcona> abneiman: That's OK. I'll take an action to look into git integration with POEditor.
15:18:19 <abneiman> #action: Dyrcona will look into git integration with POEditor
15:18:23 <abneiman> Dyrcona++
15:18:39 <abneiman> anything else from last week's actions?
15:18:49 <abneiman> or last month's, even? what is time.
15:18:52 <sleary> Dyrcona++ redavis++ abneiman++
15:19:09 * redavis clarifies that POEditor offers no subscription fee to open source projects - not non-profit.
15:19:24 <berick> Dyrcona++ redavis++ abneiman++
15:19:27 <abneiman> #info redavis clarifies that POEditor offers no subscription fee to open source projects - not non-profit.
15:19:34 <abneiman> good clarification redavis
15:19:37 <mmorgan> Dyrcona++ redavis++ abneiman++
15:19:48 <abneiman> moving along
15:19:56 <abneiman> #topic Release info
15:20:16 <abneiman> #info two OpenSRF releases! https://evergreen-ils.org/evergreen-and-opensrf-security-releases-evergreen-3-10-5-3-11-6-3-12-4-3-13-1-opensrf-3-2-5-and-3-3-1/
15:20:38 <abneiman> #info also, Evergreen security releases! https://evergreen-ils.org/evergreen-and-opensrf-security-releases-evergreen-3-10-5-3-11-6-3-12-4-3-13-1-opensrf-3-2-5-and-3-3-1/
15:20:47 <abneiman> hahaha that's the same link, genius
15:21:00 <abneiman> anyway, ++ to all who helped get those out
15:21:07 <dluch> ++
15:21:09 <mmorgan> Indeed!
15:21:21 <abneiman> as a reminder:
15:21:26 <terranm> everybody++
15:21:39 <abneiman> #info 3.14 Roadmap is here: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap - mark your calendars!
15:21:56 <abneiman> and, a ninja edit of the agenda from me, your erstwhile meeting leader ...
15:22:53 <abneiman> #info given that we just did a security release, is there any intent to do a further July point release (for non-security bugfixes) or are we waiting til August?
15:23:09 <abneiman> discuss!
15:23:28 <redavis> If we're adding reminders (I was going to wait until announcements, but will do it now) - there is...as abneiman just stated a scheduled monthly maintenance/point release on the books for next week.
15:23:39 <abneiman> also, gmcharlt++ eeevil++ sandbergja++ Dyrcona++ # security release
15:23:54 <sandbergja> +1 to a July maintenance release
15:24:06 <sandbergja> and I can help out with it
15:24:12 <abneiman> I'm available for release notes next week
15:24:14 <abneiman> sandbergja++
15:24:15 <redavis> also +1 to the maintenance release, and I can do...something.
15:24:23 <redavis> sandbergja++
15:24:24 <abneiman> redavis++
15:24:36 <shulabear> sandbergja++ redavis++
15:24:46 <abneiman> sounds like it's a go
15:24:52 * mmorgan is willing to help also
15:25:09 <redavis> I'll go ahead and send out a reminder to the list(s) tomorrow for anyone who wasn't here today.
15:25:10 <dluch> sandbergja++ redavis++ abneiman++ mmorgan++
15:25:15 <abneiman> #info yes, Virginia, there will be a July point release
15:25:32 <redavis> abneiman++
15:25:38 <abneiman> #action sandbergja, abneiman, redavis, and mmorgan will put out said point release
15:25:42 <abneiman> mmorgan++
15:25:51 <abneiman> now that the karma is all in order. next item!
15:25:52 <jeffdavis> thanks all!
15:26:09 <abneiman> #topic Launchpad stats
15:26:20 <abneiman> Snapshot
15:26:20 <abneiman> Open Bugs - 3108
15:26:20 <abneiman> Pullrequests - 95
15:26:20 <abneiman> Signedoff - 11
15:26:20 <abneiman> Edit
15:26:21 <abneiman> Updates Since Last Meeting
15:26:24 <abneiman> Bugs Added - 76
15:26:26 <abneiman> Pullrequest tag Added - 20
15:26:28 <abneiman> Signedoff tag Added - 6
15:26:30 <abneiman> Fix Committed - 8
15:27:08 <abneiman> decent progress over the last month. any questions / comments on those?
15:27:34 <abneiman> mmorgan++ # for the stats
15:27:41 <mmorgan> progress++
15:27:41 <abneiman> onward!
15:27:49 <abneiman> #topic New Business
15:28:14 <abneiman> #info Can we make some progress on some of these issues? http://irc.evergreen-ils.org/evergreen/2024-03-12#i_547284
15:28:30 <sandbergja> I put this on here.  I think I lied when calling it "new business" hahaha
15:28:40 <abneiman> "eternal business"
15:28:49 <terranm> lol
15:28:55 <mmorgan> Everything old is new again :)
15:28:57 <dluch> lol
15:29:00 <sandbergja> I was hoping we could go back to the previous discussion, and pull out one or two bitesize items that we could make progress on *in this meeting*
15:29:49 <abneiman> ok - did you have your eye on a couple items in particular?
15:29:55 <redavis> fer sure.  But I do like the idea of someone being able to checkout a virtual machine.  Just used that in a class and it was delightful.
15:29:59 <sandbergja> so not like move git hosting or setting up a VM checkout system,  but... like more guidance on backporting.  Or doing something proactive about existing pull requests without test plans
15:30:49 <jeffdavis> Would a "needstestplan" tag be useful or is that just kicking the can down the road some more?
15:30:56 <redavis> jeffdavis++
15:30:58 <sleary> was just thinking that, jeffdavis
15:31:13 <abneiman> it's certainly a start
15:31:16 <abneiman> jeffdavis++
15:31:26 <Dyrcona> For testing, we do have this old document: https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa
15:31:43 <Dyrcona> It basically says, you must include tests.
15:32:29 <jeffdavis> I think " a plan for how to test if the fix works" is not necessarily the same as the automated tests contemplated there.
15:32:43 <jeffdavis> Although automated tests are certainly ideal.
15:32:49 <sleary> correct.
15:32:52 <abneiman> yes, I was going to say - not everything is automatically-testable
15:32:54 <redavis> I think there are both code tests and feature tests.
15:33:04 <sleary> and I think that document is not entirely up to date with our current translation process.
15:33:42 <abneiman> and in fact, we do have  a "needstest" LP tag which indicates that an automated test is needed (and is often misapplied by people who think it means "please test this")
15:34:08 <sandbergja> It seems to me that the automated test part of that document has been more or less ignored for 9 years...  It is pretty unusual to see any code submitted _with_ automated tests.
15:34:57 <Dyrcona> True. We have not been enforcing it. Commit messages explaining how to test have been acceptable, too.
15:34:58 <redavis> there's a nuance differentiating needstest and needstestplan
15:36:29 <Dyrcona> I'm not sure we were all that strict with the 2.8 and 2.9 releases mentioned in the document, but it's a start.
15:36:46 <sandbergja> I'm hearing no strong objections to a needstestplan tag
15:37:10 <redavis> +1 to needstestplan tag
15:37:20 <sandbergja> And the page Dyrcona mentioned has a nice example of a test plan in a commit message
15:37:46 <redavis> It seems that that page could also do with a nice update, but I can't volunteer for that.
15:37:47 <abneiman> no, but I will point out that with one exception, the needstest tag is on bugs that haven't seen any action in 3+ years
15:39:05 * mmorgan likes the idea of using Launchpad tags, but we need to make sure the tags are more like action items than reasons to kick the can down the road.
15:39:13 <abneiman> this ^^^^
15:39:24 <redavis> abneiman, I can envision the needstestplan used on a consternating lp ticket during BSW where a tester might need more info to set up their test. "help me!"
15:39:40 <abneiman> good point, redavis
15:40:02 <jeffdavis> I will say I committed something today because abneiman asked for eyes on the 3.14 roadmap, and the fix had a test plan and no merge conflict.
15:40:03 <abneiman> "The disambiguation of uses of Lauchpad tags: an Evergreen Conference Panel and / or drinking game"
15:40:15 <redavis> lol!
15:40:17 <abneiman> jeffdavis++
15:40:22 <sandbergja> nice, jeffdavis!
15:40:25 <redavis> jeffdavis++
15:40:31 <mmorgan> jeffdavis++
15:40:38 <dluch> jeffdavis++
15:40:39 <jeffdavis> So reminders can work. Maybe sharing a "bugs to look at" list regularly would encourage that?
15:41:01 <abneiman> Tags are good, and comments along with tags are even better.
15:41:03 <Dyrcona> jeffdavis++ # The collab group looked at it yesterday, too. I thought some from that meeting was going to commit it.
15:41:03 <redavis> re: EVGILS Panel vs. drinking game.  Porque no los dos?
15:41:18 <abneiman> jeffdavis: I like that idea, but who will produce that list?
15:41:46 <sleary> could we add a new item to the stats in this meeting for bugs that have newly added "needstestplan" tags?
15:42:16 <mmorgan> +1
15:42:38 <smayo> sleary++
15:42:40 <abneiman> well, in that case, "needswork" and "needsrebase" should also be on that list
15:42:59 <sandbergja> One etiquette question (which I think might be part of not kicking the can down the road): if a pullrequest gets a needstestplan applied, can anybody reply on launchpad with the test plan?  Or would it have to tbe the original patch author.
15:43:08 <mmorgan> I also like the idea of a bugs to look at list.
15:43:11 <redavis> that's a cool idea.  clarifying question - would needstestplan only go on pull requested tickets?
15:43:21 <redavis> sandbergja++
15:43:32 <sleary> redavis I think so
15:43:42 <redavis> sleary++
15:43:51 <shulabear> redavis++
15:44:00 <Dyrcona> sandbergja: In keeping the bazaar atmosphere, I think anyone could offer  a test plan, though it would be better coming from the original patch author.
15:44:30 <abneiman> yes, I was basically typing what Dyrcona just said re test plan
15:44:32 <redavis> Dyrcona++
15:44:34 <mmorgan> I also think anyone could offer a test plan.
15:44:36 <sandbergja> Dyrcona++
15:44:42 <shulabear> Dyrcona++
15:44:55 <abneiman> and +1 to the tag being only applicable to pr'd items
15:45:06 <jeffdavis> IMO it should be an expectation that the author provides the test plan, but I agree anyone could do it.
15:45:20 <abneiman> OK, so, I think we have a few items of agreement here:
15:45:41 <redavis> And maybe worth noting that there might be people who excel at test plans but not other stuff and vice versaish.
15:45:52 <shulabear> redavis++
15:45:54 <sandbergja> redavis: good point
15:46:26 <sleary> I think we've occasionally gotten test plans from the first signoff person.
15:46:52 <abneiman> 1) [someone] will create a needstestplan tag, which will be appplied to PR'd bugs if a test plan is lacking and needed; 2) we prefer if all PR'd bugs ALREADY have a test plan from the patch author, but if not, anyone can provide them; 3) mmorgan will update the LP stats monthly pull to include new uses of needswork, needsrebase, and needstestplan
15:46:59 <mmorgan> Providing test plans could be a good fit for folks that use Evergreen and not so much write code.
15:47:08 <abneiman> is that an accurate summary? does anyone want to take the first item as an action?
15:47:23 <redavis> I do envision that this might be a nice entry point for community contribution as well.
15:47:49 <sandbergja> I can make the tag right now
15:48:06 <mmorgan> I would think it could be a good entry point. A good bug squasing week activity!
15:48:16 <mmorgan> sandbergja++
15:48:17 <abneiman> sandbergja++ # the best kind of action items are the ones already done!
15:48:28 <abneiman> ok, for the minutes:
15:48:57 <redavis> sandbergja++
15:49:08 <abneiman> #info agreed upon the following: 1) sandbergja will create a needstestplan tag, which will be appplied to PR'd bugs if a test plan is lacking and needed; 2) we prefer if all PR'd bugs ALREADY have a test plan from the patch author, but if not, anyone can provide them; 3) mmorgan will update the LP stats monthly pull to include new uses of needswork, needsrebase, and needstestplan
15:49:13 <terranm> It will need to be added to https://wiki.evergreen-ils.org/doku.php?id=dev:lp_tags as well - I can do that
15:49:19 <abneiman> terranm++
15:49:22 <redavis> terranm++
15:49:33 <Dyrcona> I think there's actually and #agreed command for the bot.
15:49:39 <abneiman> moving along, or any other discussion here? did we meet your goal of bitesize actionable items here, sandbergja?
15:49:39 <Dyrcona> s/and/an/
15:49:51 <terranm> To make sure I'm right, needstestplan should be applied to tickets needing testing instructions, correct? (I had to step away, so trying to catch up)_
15:50:00 <sleary> yes
15:50:05 <terranm> thx
15:50:20 <sandbergja> I'm good!  Thanks all!
15:50:27 <abneiman> everyone++
15:50:31 <abneiman> next item
15:50:57 <abneiman> #info several items on the 3.14 roadmap are already pullrequested, and two are signed off - can these get some eyes to avoid last minute merge scrambling?
15:51:01 <abneiman> this was from me.
15:51:28 <abneiman> oops, links are helpful: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.14
15:52:00 <abneiman> jeffdavis already took one of these on, so there are now TWO features committed for 3.14!
15:52:10 <dluch> woot!
15:52:11 <eeevil> side note, I'm happy that evergreen pi will be a spoooooky release right by Halloween :D
15:52:14 <abneiman> and yes, I will give myself a related action
15:52:35 <abneiman> #action abneiman will review existing EOLI PRs for test plans
15:52:53 <phasefx_> we could just keep versioning in the pattern of pi, but it wouldn't be rational
15:52:57 <Dyrcona> eeevil: Should we do what tex does and increment 1 digit of pi for each future release?
15:53:20 <Dyrcona> phasefx_++
15:53:27 <abneiman> phasefx_++
15:53:35 <abneiman> but I mean, if y'all are done...
15:53:37 <abneiman> ahem.
15:53:42 <redavis> phasefix_++
15:53:55 <redavis> phasefx_++ #too
15:53:57 <dluch> phasefx_++
15:54:17 <smayo> A spooky release with dark mode on the roadmap? Very spooky.
15:54:17 <phasefx_> we're all nerds
15:54:34 <abneiman> (I'm just forging ahead, you nerds) there are 3 pullrequests and 2 signoffs on that 3.14 roadmap. Perhaps instead of a Last Minute Merge Melee, we can look at some of those earlier?
15:54:37 <sleary> smayo we should put a ghost easter egg in there somewhere
15:54:44 <eeevil> alliterative code names: pumpkin pi
15:54:59 <redavis> There are couple of those that are still in or pre-testing.
15:55:09 <abneiman> good point, redavis
15:55:33 <sleary> yes, and a few not finished at all--although dark mode is getting pretty close!
15:55:56 <redavis> Also, I'll go do a root around LP and see if there are some other things that should be added to the roadmap as well.
15:56:14 <jeffdavis> I'm kind of scared to commit bug 2043142 because it's so big, even though folks here at Sitka have tested and signed off on it. Does a non-EOLI person need to commit it?
15:56:14 <pinesol> Launchpad bug 2043142 in Evergreen "wishlist: Reports security improvements" [Wishlist,New] https://launchpad.net/bugs/2043142
15:56:35 <abneiman> AFAIK these are ready for review:
15:56:35 <abneiman> Add PostgreSQL 16 support bug 2037656 – pullrequested & signedoff
15:56:36 <pinesol> Launchpad bug 2037656 in Evergreen "Add Support for PostgreSQL 16" [Wishlist,Confirmed] https://launchpad.net/bugs/2037656
15:56:36 <abneiman> Experimental Angular Circulation update (alerts, messages, notes; accessibility)  bug 2065344 – pullrequested
15:56:36 <abneiman> Rename Any Parts label bug 1902120 – pullrequested
15:56:38 <abneiman> Reports security improvements bug 2043142 – pullrequested & signedoff
15:56:38 <pinesol> Launchpad bug 2065344 in Evergreen "Angular Circ: notes & messages; UI & accessibility omnibus" [Undecided,New] https://launchpad.net/bugs/2065344
15:56:38 <abneiman> Various changes to the release process bug 2060734 – pullrequested
15:56:40 <pinesol> Launchpad bug 1902120 in Evergreen "Rename 'All parts' to 'Any part' in hold placement screen" [Wishlist,Confirmed] https://launchpad.net/bugs/1902120
15:56:41 <pinesol> Launchpad bug 2060734 in Evergreen "Various changes to the release process" [Undecided,Confirmed] https://launchpad.net/bugs/2060734 - Assigned to Jason Stephenson (jstephenson)
15:56:51 <redavis> jeffdavis, that's preferable.
15:57:16 <Dyrcona> Regarding Lp 2043142: Someone at CW MARS told me it likely would not affect us because we don't let library staff create templates. Otherwise, we would probably have tested it by now.
15:57:17 <pinesol> Launchpad bug 2043142 in Evergreen "wishlist: Reports security improvements" [Wishlist,New] https://launchpad.net/bugs/2043142
15:57:28 <sandbergja> out of curiosity, does bug 2043142 have a test plan?
15:58:28 <abneiman> sandbergja: there is a tech ref doc and an extensive commit message, but not necessarily a "do A and get B" test plan
15:58:52 <Dyrcona> I have actually been looking at Lp 2060734, and I should go ever it again. I think I'd like to suggest/make some modifications.
15:58:53 <pinesol> Launchpad bug 2060734 in Evergreen "Various changes to the release process" [Undecided,Confirmed] https://launchpad.net/bugs/2060734 - Assigned to Jason Stephenson (jstephenson)
15:59:05 <abneiman> which, does point to a wrinkle that I of all people should've thought of, which is, what's the difference between a bugfix test plan and a feature test plan
15:59:11 <Dyrcona> typos--
15:59:32 <sandbergja> Dyrcona++ # thanks for reviewing that
15:59:48 <Dyrcona> sandbergja++ Thanks for taking it on.
15:59:50 <sandbergja> abneiman: good question
16:00:27 <Dyrcona> yeah, bug fix tests should be easier than new features, unless the feature is really simple.
16:00:55 <abneiman> because with features, it's not as simple as "do A and get B" - which is why we (Equinox) try to include documentation and tech ref docs with new features, along with extensive commit messages
16:01:19 <abneiman> but, if you all would rather us put out more formal test plans, I can work on that as well
16:01:59 <abneiman> however, we are at the top of the hour so maybe "test plans for big features" could be a future topic
16:02:19 <sandbergja> yeah, that might be where it gets trickier
16:02:59 <dluch> +1
16:03:07 <redavis> also +1
16:03:36 <abneiman> #action discussion item for next meeting: test plans for big features
16:03:44 <abneiman> that even might be a worthy hackaway topic
16:03:46 <abneiman> anyway.
16:04:06 <abneiman> anything else to discuss? Anything that I forgot? Any parting words of wisdom?
16:04:30 <redavis> stay hydrated
16:04:43 <eeevil> never start a land war in ... oh, nevermind
16:04:47 <abneiman> #agree we're all gonna stay hydrated
16:04:50 <dluch> lol
16:04:52 <redavis> eeevil++
16:04:58 <shulabear> never got up against a sicilian when death is on the line.
16:05:01 <abneiman> going once
16:05:02 * mmorgan want some pi(e)
16:05:05 <eeevil> shulabear++
16:05:05 <redavis> shulabear++
16:05:13 <abneiman> going twice ...
16:05:17 <dluch> shulabear++
16:05:20 <abneiman> it's been real y'all
16:05:21 <terranm> Cheers y'all
16:05:22 <abneiman> #endmeeting