#evergreen: 2024-08-13 - Developer Meeting

Meeting started by Bmagic at 15:00:04 US/Eastern (full logs).

Meeting summary

    1. Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-08-13 (Bmagic, 15:00:10)

  1. Introductions (Bmagic, 15:00:14)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:00:18)
    2. scottangel = Scott Angel, MOBIUS (scottangel, 15:00:28)
    3. redavis - Ruth Frasur Davis, ECDI (redavis, 15:00:28)
    4. Stompro = Josh Stompro, LARL (Stompro, 15:00:30)
    5. sandbergja = Jane Sandberg, PUL (sandbergja, 15:00:33)
    6. sleary = Stephanie Leary, Equinox (sleary, 15:00:34)
    7. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:36)
    8. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:00:37)
    9. collum = Garry Collum, KCPL (collum, 15:00:39)
    10. smayo = Steven Mayo, PINES (smayo, 15:00:46)
    11. berick Bill Erickson, KCLS (berick, 15:01:02)
    12. eeevil = Mike Rylander, EOLI (eeevil, 15:01:16)
    13. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:01:38)
    14. terranm = Terran McCanna, PINES (terranm, 15:01:50)

  2. Action Items from Last Meeting (Bmagic, 15:01:50)
    1. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:06)
    2. mmorgan will open a ticket for moving LP stats to community site & automating same (Bmagic, 15:02:33)
    3. https://launchpad.net/bugs/2076932 (Bmagic, 15:02:39)
    4. https://launchpad.net/bugs/2076932 (Bmagic, 15:03:21)
    5. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:03:54)
    6. jvwoolf = Jessica Woolford, Bibliomatin (jvwoolf, 15:04:52)
    7. eeevil will open a bug for cross-column stats targets (Bmagic, 15:05:43)
    8. ACTION: eeevil will open a bug for cross-column stats targets (Bmagic, 15:06:15)
    9. gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:06:28)
    10. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (Bmagic, 15:07:09)
    11. redavis will look at making a regular calendar event for translation work in lock step with point releases (Bmagic, 15:07:18)
    12. ACTION: redavis will look at making a regular calendar event for translation work in lock step with point releases (Bmagic, 15:08:09)
    13. Dyrcona will look into git integration with POEditor (Bmagic, 15:08:16)
    14. ACTION: Dyrcona will look into git integration with POEditor (Bmagic, 15:10:15)
    15. sandbergja, abneiman, redavis, and mmorgan will put out said point release (Bmagic, 15:10:21)
    16. abneiman will review existing EOLI PRs for test plans (Bmagic, 15:11:40)
    17. abneiman will add a discussion item for next meeting: test plans for big features (Bmagic, 15:14:16)

  3. Evergreen (Bmagic, 15:15:15)
    1. Roadmap: Evergreen Development Roadmap (Bmagic, 15:15:20)
    2. https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap (Bmagic, 15:15:25)
    3. Maintenance releases 3.11.7, 3.12.5, 3.13.2 on July 19. (Bmagic, 15:23:20)
    4. Merge Pause on Friday, August 16. Should be able to lift pause on Tuesday, August 20. (Bmagic, 15:23:40)
    5. 3.13.3 and 3.12.6 monthly maintenance releases on Wednesday, August 21. (Bmagic, 15:23:53)
    6. Bug squash week for 3.14 release, August 26-30. (Bmagic, 15:27:11)

  4. Documentation (Bmagic, 15:29:11)
    1. DIG met on August 1 (Bmagic, 15:29:15)
    2. We are running our style guide through Vale to find errors in the docs. Images without alt tags was first–all fixed now! Next up is consistent word use for certain terms (Bmagic, 15:29:20)
    3. Plans to work on docs bugs and especially reviewing older bugs during Bug Squashing Week (Bmagic, 15:29:35)
    4. Next meeting, September 5 (Bmagic, 15:29:42)

  5. Launchpad Status (as of noon Eastern) (Bmagic, 15:33:44)
    1. Open Bugs - 3119 (Bmagic, 15:33:57)
    2. Pullrequests - 96 (Bmagic, 15:33:57)
    3. Signedoff - 15 (Bmagic, 15:33:57)

  6. Launchpad Status since last meeting (Bmagic, 15:34:04)
    1. Bugs Added - 69 (Bmagic, 15:34:08)
    2. Pullrequest tag Added - 29 (Bmagic, 15:34:08)
    3. Signedoff tag Added - 18 (Bmagic, 15:34:08)
    4. Needswork tag Added - 2 (Bmagic, 15:34:08)
    5. Needstestplan tag Added - 0 (Bmagic, 15:34:09)
    6. Needsrebase tag Added - 5 (Bmagic, 15:34:10)
    7. Fix Committed - 22 (Bmagic, 15:34:12)

  7. New Business - (Jane) How can we encourage more automated testing?, What are current barriers to writing and running the automated tests? (Bmagic, 15:34:19)
    1. https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa (Bmagic, 15:34:35)
    2. https://wiki.evergreen-ils.org/doku.php?id=dev:angular_dev_best_practices (sleary, 15:41:19)
    3. https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa (sleary, 15:42:55)
    4. https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:common_qa_problems might also be relevant (sleary, 15:43:27)
    5. ACTION: sleary and sandbergja will create/consolidate the test writing wiki page(s) (Bmagic, 15:45:30)
    6. https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:common_qa_problems (Bmagic, 15:46:55)
    7. https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa (Bmagic, 15:47:03)
    8. ACTION: sandbergja will make it easier for folks to know how to run the tests in single file mode and all-mode (Bmagic, 15:56:57)

  8. New Business - Hatch extension 'may soon no longer be supported' Hatch Chrome Extension (Bmagic, 15:57:33)
    1. https://chromewebstore.google.com/detail/hatch-native-messenger/ppooibdipmklfichpmkcgplfgdplgahl (Bmagic, 15:57:42)
    2. ACTION: berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed (Bmagic, 15:59:43)

  9. New Business - DokuWiki needs updating (Bmagic, 15:59:57)
    1. ACTION: Bmagic will work on upgrading the version of DokuWiki (Bmagic, 16:02:54)

  10. (ABN) Test plans for big features? (Bmagic, 16:03:06)
  11. Announcements (Bmagic, 16:08:09)
    1. Next Meeting is Tuesday, September 10th 2024 (Bmagic, 16:08:18)
    2. Hack-A-Way, November 12-14 in Boston, MA (Bmagic, 16:08:27)


Meeting ended at 16:08:34 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. gmcharlt - create a Git commit message type and update bug 2051946
  3. redavis will look at making a regular calendar event for translation work in lock step with point releases
  4. Dyrcona will look into git integration with POEditor
  5. sleary and sandbergja will create/consolidate the test writing wiki page(s)
  6. sandbergja will make it easier for folks to know how to run the tests in single file mode and all-mode
  7. berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed
  8. Bmagic will work on upgrading the version of DokuWiki


Action items, by person

  1. berick
    1. berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed
  2. Bmagic
    1. Bmagic will work on upgrading the version of DokuWiki
  3. eeevil
    1. eeevil will open a bug for cross-column stats targets
  4. jeff
    1. berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed
  5. redavis
    1. redavis will look at making a regular calendar event for translation work in lock step with point releases
  6. sandbergja
    1. sleary and sandbergja will create/consolidate the test writing wiki page(s)
    2. sandbergja will make it easier for folks to know how to run the tests in single file mode and all-mode
  7. sleary
    1. sleary and sandbergja will create/consolidate the test writing wiki page(s)
  8. UNASSIGNED
    1. gmcharlt - create a Git commit message type and update bug 2051946
    2. Dyrcona will look into git integration with POEditor


People present (lines said)

  1. Bmagic (142)
  2. redavis (35)
  3. sleary (31)
  4. sandbergja (29)
  5. abneiman (22)
  6. mmorgan (17)
  7. dluch (16)
  8. shulabramble (14)
  9. terranm (9)
  10. jeff (8)
  11. jvwoolf (7)
  12. pinesol (6)
  13. eeevil (4)
  14. berick (3)
  15. Stompro (3)
  16. collum (1)
  17. smayo (1)
  18. scottangel (1)


Generated by MeetBot 0.1.4.