15:00:04 <Bmagic> #startmeeting 2024-08-13 - Developer Meeting
15:00:04 <pinesol> Meeting started Tue Aug 13 15:00:04 2024 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:04 <pinesol> The meeting name has been set to '2024_08_13___developer_meeting'
15:00:10 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-08-13
15:00:14 <Bmagic> #topic Introductions
15:00:18 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:00:28 <scottangel> #info scottangel = Scott Angel, MOBIUS
15:00:28 <redavis> #info redavis - Ruth Frasur Davis, ECDI
15:00:30 <Stompro> #info Stompro = Josh Stompro, LARL
15:00:33 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:00:34 <sleary> #info sleary = Stephanie Leary, Equinox
15:00:36 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:37 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:00:39 <collum> #info collum = Garry Collum, KCPL
15:00:46 <smayo> #info smayo = Steven Mayo, PINES
15:01:02 <berick> #info berick Bill Erickson, KCLS
15:01:16 <eeevil> #info eeevil = Mike Rylander, EOLI
15:01:35 <Bmagic> feel free to introduce yourself as you arrive
15:01:38 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:50 <terranm> #info terranm = Terran McCanna, PINES
15:01:50 <Bmagic> #topic Action Items from Last Meeting
15:02:02 <Bmagic> mmorgan - should I skip?
15:02:06 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:02:19 <mmorgan> Bmagic: I opened the bug - bug 2076932
15:02:21 <pinesol> Launchpad bug 2076932 in Evergreen "Launchpad Statistics Tracking" [Undecided,New] https://launchpad.net/bugs/2076932
15:02:26 <Bmagic> oh!
15:02:33 <Bmagic> #info mmorgan will open a ticket for moving LP stats to community site & automating same
15:02:39 <Bmagic> #info https://launchpad.net/bugs/2076932
15:02:51 <sandbergja> mmorgan++
15:02:51 <redavis> mmorgan++
15:02:57 <Bmagic> mmorgan++
15:02:59 <shulabramble> mmorgan++
15:03:06 <mmorgan> Feel free to add code, ideas, etc.
15:03:21 <Bmagic> #link https://launchpad.net/bugs/2076932
15:03:22 <pinesol> Launchpad bug 2076932 in Evergreen "Launchpad Statistics Tracking" [Undecided,New]
15:03:23 <Bmagic> I meant link
15:03:54 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:04:02 <Bmagic> Any discussion on that?
15:04:47 <mmorgan> Hopefully the bug will gather some! I will add some of the scripts I tried with lp api.
15:04:51 <dluch> mmorgan++
15:04:52 <jvwoolf> #info jvwoolf = Jessica Woolford, Bibliomatin
15:05:03 <Bmagic> mmorgan: great work
15:05:18 <Bmagic> I do like knowning the big picture
15:05:40 <Bmagic> ok, next up
15:05:43 <Bmagic> #info eeevil will open a bug for cross-column stats targets
15:06:00 <eeevil> ha! nope... not this month :(
15:06:15 <Bmagic> #action eeevil will open a bug for cross-column stats targets
15:06:21 <Bmagic> no worries
15:06:28 <Bmagic> #info gmcharlt - create a Git commit message type and update bug 2051946
15:06:29 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:06:39 <abneiman> Galen is away
15:06:42 <eeevil> I'll make a stub soon, but $someone will need to spend time digging through "slow" query logs...
15:06:56 <Bmagic> eeevil++
15:07:09 <Bmagic> #action gmcharlt - create a Git commit message type and update bug 2051946
15:07:18 <Bmagic> #info redavis will look at making a regular calendar event for translation work in lock step with point releases
15:07:39 <redavis> gonna give that a pass this month.  I've not forgotten though.
15:07:59 <redavis> please carry over to next month
15:08:01 <Bmagic> ok, perfect. Thanks for keeping it in mind
15:08:09 <Bmagic> #action redavis will look at making a regular calendar event for translation work in lock step with point releases
15:08:16 <Bmagic> #info Dyrcona will look into git integration with POEditor
15:09:41 <redavis> Dyrcona is out of office currently
15:09:54 <Bmagic> oh, lol, I was about to say something like "must be a lot of typing"
15:10:01 <Bmagic> but I see he's MIA
15:10:15 <Bmagic> #action Dyrcona will look into git integration with POEditor
15:10:21 <Bmagic> #info sandbergja, abneiman, redavis, and mmorgan will put out said point release
15:10:37 <abneiman> hey we deffo did that
15:10:47 <sandbergja> yeah, with Dyrcona's help!
15:10:47 <redavis> Said point releases went out on July 19. 3.11.7, 3.12.5 and 3.12.2
15:10:53 <Bmagic> deffo cool!
15:10:56 <sleary> sandbergja++ abneiman++ redavis++ mmorgan++
15:10:57 <mmorgan> :)
15:11:01 <redavis> with Dyrcona's immense help
15:11:12 <jvwoolf> sandbergja++ abneiman++ redavis++ mmorgan++
15:11:16 <jvwoolf> Dyrcona++
15:11:16 <Bmagic> sandbergja++ abneiman++ redavis++ mmorgan++ Dyrcona++
15:11:16 <mmorgan> sandbergja++ abneiman++ redavis++ Dyrcona++
15:11:25 <sleary> Dyrcona++
15:11:35 <redavis> Dyrcona++ sandbergja++ abneiman++ mmorgan++
15:11:40 <Bmagic> #info abneiman will review existing EOLI PRs for test plans
15:11:57 <shulabramble> Dyrcona++ sandbergja++ abneiman++ mmorgan++
15:12:47 <abneiman> I reviewd them but did not add test plans to any. Will do so in advance of BSW.
15:13:08 <Bmagic> abneiman++
15:13:24 <sandbergja> abneiman++ # that's awesome
15:13:34 <shulabramble> abneiman++
15:13:43 <redavis> abneiman++
15:13:46 <dluch> abneiman++
15:13:47 <Bmagic> want that carried?
15:14:05 <jvwoolf> abneiman++
15:14:08 <abneiman> nah
15:14:16 <Bmagic> #info abneiman will add a discussion item for next meeting: test plans for big features
15:14:31 <abneiman> I ninja-edited that into the agenda 10 minutes ago :)
15:14:37 <Bmagic> I see that, lol
15:14:48 * redavis was also ninja editing
15:14:48 <dluch> sandbergja++ abneiman++ redavis++ mmorgan++ (belatedly, lol)
15:14:56 <Bmagic> alright, that does it for last meeting stuffs
15:15:15 <Bmagic> #topic Evergreen
15:15:17 <dluch> ninja-editing++
15:15:20 <Bmagic> #info Roadmap: Evergreen Development Roadmap
15:15:25 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:16:00 <redavis> Um...the 3.14 release team has been meeting...
15:16:04 <shulabramble> ninjas++ editing++
15:16:15 <Bmagic> i guess it's 3 o' clock .14 somewhere
15:16:36 <jvwoolf> redavis: Should we share the Launchpad tracking sheet? Or is it not ready for prime time yet?
15:16:36 <Bmagic> who's working on the pi graphic for the release?
15:16:53 <redavis> It's Dyrcona, Stompro, jvwoolf, and myself
15:17:14 <redavis> jvwoolf, I think it's fine to share, but definitely a working document
15:17:33 <Bmagic> feel free to hash link it
15:18:10 <redavis> Stompro and Dyrcona worked through some postgresql 16 and ubuntu 24 things and that all is "ready to go."  Next up is Bug Squash Week...
15:18:32 <Bmagic> whoohoo!
15:18:41 <Bmagic> new_postgres++
15:18:50 <redavis> The 3.14 roadmap wiki page is a living document as always but here is what's shaping up so far - https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.14
15:19:30 <redavis> Here's our launchpad tracking sheet right now...https://docs.google.com/spreadsheets/d/1xodq5mLdU7Cjlw-gi8KYAyI6wmfGKRYUE7LYDdpscJY/edit?usp=sharing
15:20:07 <Bmagic> I love the organization of it
15:20:21 <Bmagic> friggin_spreadsheets++
15:20:31 <redavis> So, there are a lot of things that had a 3.next target that were just kind of hanging on each release.  We're working on going through those, but others might want to take a look.  We also have page as yet unpopulated for things we might pass on to Terran for BSW
15:20:37 <abneiman> whoa, total spreadsheet props
15:20:38 <jvwoolf> redavis++ #for keeping us on task
15:20:42 <abneiman> redavis++
15:20:43 * redavis also loves a spreadsheet
15:20:56 <sleary> thank you all for cleaning out the 3.next target
15:21:00 <terranm> Nice!
15:21:15 <terranm> redavis++
15:21:15 <redavis> All the LP foo from jvwoolf on that.
15:21:20 <redavis> jvwoolf++
15:21:22 <terranm> jvwoolf++
15:21:25 <Bmagic> jvwoolf++
15:21:47 <abneiman> jvwoolf++
15:22:03 <Bmagic> release_team++
15:22:11 <shulabramble> jvwoolf++ redavis++
15:22:17 <sandbergja> jvwoolf++ redavis++ Stompro++ Dyrcona++
15:22:18 <mmorgan> Dyrcona++ jvwoolf++ redavis++ Stompro++
15:22:25 <sandbergja> 3.14 is going to be so cool!
15:22:30 <shulabramble> stompro++ dyrcona++
15:22:31 * sleary wishes a happy tenth birthday to several of those 3.next bugs
15:22:38 <Bmagic> Dyrcona++ jvwoolf++ redavis++ Stompro++
15:22:53 <dluch> redavis++ jvwoolf++ Stompro++ Dyrcona++
15:22:55 <redavis> Oh...I guess we're talking about releases.  There are going to be some point releases next week (please volunteer ye ol' buildmasters)
15:23:03 <Bmagic> lol, ten years! Like a fine wine. But don't drink 'em
15:23:20 <Bmagic> #info Maintenance releases 3.11.7, 3.12.5, 3.13.2 on July 19.
15:23:25 <abneiman> lolsob
15:23:40 <Bmagic> #info Merge Pause on Friday, August 16. Should be able to lift pause on Tuesday, August 20.
15:23:53 <Bmagic> #info 3.13.3 and 3.12.6 monthly maintenance releases on Wednesday, August 21.
15:24:14 <Bmagic> redavis prompted me to info those
15:24:33 <sandbergja> are they on the 19th or 21st?
15:24:34 <redavis> Volunteers for building the releases will be heartily compensated (with many accolades of praise...until the next release(s))
15:24:40 <Bmagic> I'm availablel for building next week
15:25:00 <sandbergja> oh whoops, I was reading the July thing, ignore me
15:25:06 <redavis> Bmagic++
15:25:21 <sandbergja> I could help on the 21st too
15:25:23 * mmorgan can help
15:25:24 <redavis> sandbergja, I wrote the stuff and still asked the exact same question to myself more than once.
15:25:53 <abneiman> I signed myself up for release notes, which I can do early next week
15:26:08 <Bmagic> abneiman++
15:26:09 <redavis> Great.  I'll send out an email to bmagic, sandbergja, abneiman (cuz I see your release notes name on the spreadsheet) to see if we can schedule a quick talk time.
15:26:19 <Bmagic> redavis++
15:26:22 <Bmagic> good idea
15:26:25 <sleary> I might be around, but at the very least I can help with web uploading/updating
15:26:30 <sandbergja> redavis++
15:26:33 <Bmagic> sleary++
15:26:34 <redavis> sleary++
15:26:42 <mmorgan> redavis: I can help too.
15:26:48 <Bmagic> mmorgan++
15:26:58 <redavis> lol, alright, including all y'all!
15:27:03 <Bmagic> blamo
15:27:11 <Bmagic> #info Bug squash week for 3.14 release, August 26-30.
15:27:17 <Bmagic> terranm++
15:27:50 <redavis> terranm++
15:28:02 <mmorgan> terranm++
15:28:04 <sleary> terranm++
15:28:12 <shulabramble> terranm++
15:28:12 <terranm> Yep 10 year anniversary, let's make it good!
15:28:17 <sandbergja> terranm++
15:28:27 <jvwoolf> terranm++
15:28:33 <redavis> 10 year anniversary and PIE!!!!!
15:28:33 <Bmagic> I can't believe it, we've been doing BSW for 10 years, OMG
15:28:48 <dluch> terranm++
15:29:09 <Bmagic> moving onto docs
15:29:11 <Bmagic> #topic Documentation
15:29:15 <Bmagic> #info DIG met on August 1
15:29:20 <Bmagic> #info We are running our style guide through Vale to find errors in the docs. Images without alt tags was first–all fixed now! Next up is consistent word use for certain terms
15:29:35 <Bmagic> #info Plans to work on docs bugs and especially reviewing older bugs during Bug Squashing Week
15:29:42 <Bmagic> #info Next meeting, September 5
15:29:50 <Bmagic> dluch you have the floor
15:31:23 <dluch> Sorry, I was distracted, lol
15:31:43 <dluch> I don't have anything else to add. Any questions? Any other DIGgers want to add/comment?
15:32:13 <Bmagic> cool about Vale
15:32:39 <Bmagic> dluch++
15:32:51 <shulabramble> dluch++ bmagic++
15:32:52 <dluch> shoutout to sandbergja for Vale!
15:33:01 <Bmagic> sandbergja++
15:33:01 <redavis> dluch++ DIG++
15:33:02 <dluch> sandbergja++
15:33:08 <shulabramble> sandbergja++
15:33:08 <redavis> sandbergja++
15:33:09 <dluch> DIG++
15:33:16 <Bmagic> DIG++
15:33:37 <mmorgan> sandbergja++
15:33:44 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:33:54 <Bmagic> hit the deck, we got incoming!
15:33:57 <Bmagic> #info Open Bugs - 3119
15:33:57 <Bmagic> #info Pullrequests - 96
15:33:57 <Bmagic> #info Signedoff - 15
15:34:04 <Bmagic> #topic Launchpad Status since last meeting
15:34:08 <Bmagic> #info Bugs Added - 69
15:34:08 <Bmagic> #info Pullrequest tag Added - 29
15:34:08 <Bmagic> #info Signedoff tag Added - 18
15:34:08 <Bmagic> #info Needswork tag Added - 2
15:34:09 <Bmagic> #info Needstestplan tag Added - 0
15:34:10 <Bmagic> #info Needsrebase tag Added - 5
15:34:12 <Bmagic> #info Fix Committed - 22
15:34:19 <Bmagic> #topic New Business - (Jane) How can we encourage more automated testing?, What are current barriers to writing and running the automated tests?
15:34:33 <sandbergja> ok, my turn to paste some stuff:
15:34:35 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa
15:34:41 <sandbergja> During the 3.12 and 3.13 release process, we found a number of big issues that we were able to resolve before cutting the release, for example:
15:34:49 <sandbergja> an unpredictable intermittent failure in search, a bug that prevented users from adding new action trigger event defs, a case where I had committed the wrong patch from a launchpad ticket, one where the holdings view wouldn't load, and a major accessibility regression that detached form inputs from their labels across the client.
15:35:02 <sandbergja> And the way we found those was by one of our automated tests failing, alerting us to the issue, which is great!  Very nice that we discovered those before they were in production.
15:35:09 <sandbergja> However, it makes me think how many more regressions we could be catching if we'd been writing and running tests more often over the past 9 years.
15:35:15 <sandbergja> So... I'd like to know: how can we get there?  What barriers can we iron out around automated testing?
15:36:12 <redavis> sandbergja++
15:36:36 <shulabramble> sandbergja++
15:37:12 <Bmagic> those node nightwatch tests are clever. Automating the process of clicking on the interface like a human would. Not sure what the barriers are? Hard to write?
15:38:22 <sleary> IIRC there are two (maybe three?) different QA/guideline documents for contributions that have different instructions, and we need to consolidate them into one coherent process.
15:38:40 <Bmagic> consolidate! +1. Got links?
15:38:48 <Stompro> For me personally it is just the time it takes to create the tests, but I know if I do it more often it wouldn't take me as long.
15:39:15 <sleary> working on links
15:40:01 <sandbergja> Stompro++ sleary++ Bmagic++
15:41:05 <Bmagic> giving sleary a minute
15:41:19 <sleary> https://wiki.evergreen-ils.org/doku.php?id=dev:angular_dev_best_practices
15:42:44 <Bmagic> I know there is one out ther esomewhere for PG and one for perl
15:42:55 <sleary> https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa
15:43:08 <Bmagic> there it is
15:43:16 <Bmagic> that's the one I was thinking of
15:43:18 <Bmagic> sleary++
15:43:24 <sandbergja> consolidating and refining those seems like a great place to start
15:43:27 <sleary> https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:common_qa_problems might also be relevant
15:44:07 <terranm> +1 to a single page just about writing tests
15:44:12 <Bmagic> do we need to make assignments around this?
15:44:14 <sleary> sandbergja I will be happy to help with that... about a month from now, lolsob
15:44:27 <Bmagic> sleary++
15:44:40 <terranm> sleary++ sandbergja++
15:44:41 <shulabramble> +1 to a page about writing tests
15:44:56 <sandbergja> a month sounds great!  And I'm also happy to help as needed!
15:45:03 <mmorgan> +1 to a page about writing, and also running them
15:45:09 <jeff> do we need to do anything to remove barriers to running the tests? i.e., is setting up an environment where you can run the tests challenging or not-well-documented?
15:45:09 <redavis> sandbergja++ sleary++
15:45:14 <sleary> I know that sandbergja has given a couple of talks in New Devs about test-driven development, and we can pull things from those meeting archives
15:45:26 <redavis> jeff, good question
15:45:30 <Bmagic> #action sleary and sandbergja will create/consolidate the test writing wiki page(s)
15:45:57 <terranm> It always makes sense when I watch Jane do it, but then confusion returns
15:46:02 <Bmagic> jeff: the docker container image now days is including the pre-reqs which is nice
15:46:14 <sleary> jeff I think there is one quirk around Firefox, but it's mentioned in the eg2 CHEAT SHEET doc
15:46:52 <Bmagic> Imma preserve those wiki urls
15:46:54 <sandbergja> for me, reloading a test database from scratch can take a while, and a clean db is necessary for some of the tests
15:46:55 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:common_qa_problems
15:47:03 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa
15:47:49 <Bmagic> I added a feature to the the dev container, which I find myself using a bunch, that automates the creation of new databases by editing a text file
15:47:51 <sleary> the e2e tests take a while to run, and the syntax for running them on a single file or directory is not easy to remember
15:48:18 <sandbergja> true sleary
15:48:35 <sleary> we can probably script our way out of that problem :)
15:48:42 <sandbergja> Bmagic I know you've told me this before, but I gotta start using the dev containers!
15:49:05 <Bmagic> sandbergja: the water is fine, lol
15:49:57 <Bmagic> the takeaway was consolidating the wiki pages
15:50:13 <Bmagic> shall we add something else?
15:50:54 <sleary> maybe step 2 can be writing some simple example tests or pinpointing old ones as good examples for basic tasks
15:50:54 <sandbergja> maybe as part of that process we can look into the syntax for nightwatch on a single file or directory -- whether it is a docs fix or a script fix?
15:51:11 <sleary> sandbergja++
15:52:05 <Bmagic> making sure I'm understanding: making the test run differently depending on what was committed?
15:52:31 <sleary> running the tests on only the files you changed rather than the whole Angular project
15:52:48 <Bmagic> gotcha, and what's missing for that to work?
15:52:54 <sleary> memorable syntax
15:52:59 <Bmagic> documentation is missing basically?
15:53:15 <sleary> it's documented in the Nightwatch docs, but it's hard to remember
15:53:20 <sleary> not sure it's in our cheat shee
15:53:22 <sleary> sheet
15:53:36 <eeevil> I would appreciate a how-to, for sure. fwiw
15:53:47 <sandbergja> so better syntax and better docs perhaps
15:54:18 <Bmagic> maybe a wrapper that takes some evergreen-community arguments. like ./wrapper --one-test path/to/file
15:54:40 <sleary> that's what I was thinking, but docs would be simpler :)
15:54:54 <Bmagic> docs would be simplier :)
15:55:25 <dluch> docs++ ;-)
15:55:29 <Bmagic> I suppose that can be part of the same action? Or woudl you like a new action? Anyone want to put their name on it?
15:56:03 <sleary> that should probably be a separate action from the wiki page consolidation
15:56:42 <Bmagic> would you like to have it?
15:56:48 <sandbergja> you could put my name on it
15:56:57 <Bmagic> #action sandbergja will make it easier for folks to know how to run the tests in single file mode and all-mode
15:57:09 <Bmagic> sandbergja++
15:57:10 <sleary> sandbergja++
15:57:14 <sandbergja> thanks everyone!
15:57:20 <sleary> thanks for bringing up this topic!
15:57:22 <mmorgan> sandbergja++
15:57:28 <Bmagic> we're coming up on the hour
15:57:33 <Bmagic> #topic New Business - Hatch extension 'may soon no longer be supported' Hatch Chrome Extension
15:57:42 <Bmagic> #link https://chromewebstore.google.com/detail/hatch-native-messenger/ppooibdipmklfichpmkcgplfgdplgahl
15:57:57 <shulabramble> sandbergja++
15:57:58 <dluch> sandbergja++
15:58:09 <berick> count me in for helping with Hatch work.  hopefully i can pitch in starting next week
15:58:25 * berick runs off to another meeting
15:58:27 <jeff> happy to help / help test.
15:58:30 <Bmagic> berick++
15:58:32 <Bmagic> jeff++
15:58:47 <sandbergja> berick++ jeff++
15:58:48 <mmorgan> csharp opened bug 2004058
15:58:54 <jeff> also, noting for the benefit of any who have the ability to make use of policies across their chrome fleet:
15:58:58 <jeff> > Enterprises using the ExtensionManifestV2Availability policy to ensure the continued functioning of Manifest V2 extensions in their organization will have one additional year - until June 2025 - to migrate the Manifest V2 extensions in their organization. Browsers with the policy enabled won't be impacted by the rollout of the deprecation until that time.
15:59:07 <jeff> ( from https://developer.chrome.com/docs/extensions/develop/migrate/mv2-deprecation-timeline )
15:59:16 <jeff> I'll also add that to the bug as a comment.
15:59:34 <mmorgan> berick++ jeff++
15:59:43 <Bmagic> #action berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed
15:59:57 <Bmagic> #topic New Business - DokuWiki needs updating
16:00:30 <sleary> that was me! Just a note for those of us who have website/db access; we should update
16:00:41 <dluch> berick++ jeff++
16:00:46 <Bmagic> I see, you mean upgrade dokuwiki version
16:00:49 <sleary> yes
16:01:00 <Bmagic> cool, who usually does that?
16:01:16 <Bmagic> do we have a dev environment to make sure the upgrade works before doing it for real?
16:01:38 <abneiman> I think has fallen on Rogan and/or Galen the last few times
16:01:42 <sleary> csharp_ most likely. I think I can, but I'm reluctant to touch things without taking time to make my own backups
16:02:29 <Bmagic> I can help too :)
16:02:54 <Bmagic> #action Bmagic will work on upgrading the version of DokuWiki
16:03:06 <Bmagic> #topic (ABN) Test plans for big features?
16:03:24 <Bmagic> We're almost done... sorry we're going over
16:03:32 <abneiman> yes, so, briefly
16:03:50 <abneiman> what does the community want to / need to see out of test plans for new features?
16:04:10 <abneiman> things that are beyond the scope of "X is broken, install patch Y, follow steps 1 2 3, profit"
16:04:41 <Bmagic> are you finding that certain things need more than our bsw and bff ?
16:04:52 <abneiman> asking because several EOLI feature PRs are either forthcoming soon, or carryovers from 3.13, and I want to make sure I'm doing what is needed to facilitate review & commit of those things
16:05:11 <Stompro> I always appreciate notes on how to configure the system if certain lib settings need to be enabled, etc.
16:05:34 <jeff> varies, but maybe starting with: "here is a summary of / pointer to description of what this code should add/change/fix; here is a recommended way to test / how we tested; here are special considerations / gotchas"?
16:05:45 <abneiman> Stompro++ jeff++
16:05:48 <mmorgan> What Stompro said. Also if certain data is needed.
16:05:48 <abneiman> both helpful thanks
16:05:56 <abneiman> mmorgan++
16:06:19 <redavis> Stompro++ jeff++ mmorgan++
16:06:34 <abneiman> and Bmagic, regarding BSW, I acknowlege that it's hard to test big features when there's a lot of other fixes flying around ... which is fine, IMO, that's what BSW is about.
16:06:52 <Bmagic> Stompro++ jeff++ mmorgan++
16:07:19 <Bmagic> abneiman++ # I think I took your query the wrong direction after reading Stompro, jeff and mmorgan's ideas
16:07:21 <abneiman> like I said, I want to make sure we're doing what we can to faciliate merges of features. And to maybe offer similar guidelines to other feature developers
16:07:36 <sandbergja> abneiman++
16:07:43 <shulabramble> abneiman++
16:07:56 <mmorgan> abneiman++
16:08:05 <Bmagic> thanks all, just a couple things and we're outta here
16:08:09 <Bmagic> #topic Announcements
16:08:10 <abneiman> anyway, I appreciate the thoughts shared ... any others can come to me here, or directly at abneiman@equinoxoli.org and I'll put them.... somewhere public
16:08:14 <terranm> abneiman++
16:08:16 <dluch> abneiman++
16:08:18 <Bmagic> #info Next Meeting is Tuesday, September 10th 2024
16:08:27 <Bmagic> #info Hack-A-Way, November 12-14 in Boston, MA
16:08:34 <Bmagic> #endmeeting