15:00:18 <Bmagic> #startmeeting 2024-09-10 - Developer Meeting
15:00:19 <pinesol> Meeting started Tue Sep 10 15:00:18 2024 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <pinesol> The meeting name has been set to '2024_09_10___developer_meeting'
15:00:24 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-09-10
15:00:28 <Bmagic> #topic Introductions
15:00:32 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:00:42 <Dyrcona> #info Dyrcona = Jason Stephenson, C/W MARS, Inc.
15:00:45 <eeevil> #info eeevil = Mike Rylander, EOLI
15:00:47 <csharp_> #info csharp_ = Chris Sharp, GPLS
15:00:49 <collum> #info collum = Garry Collum, KCPL
15:00:51 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:56 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:01:32 <berick> #info berick Bill Erickson, KCLS
15:01:44 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:02:08 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:02:11 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:02:26 <Bmagic> welcome everyone!
15:02:28 <sleary> #info sleary = Stephanie Leary, EOLI
15:02:35 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:02:50 <Bmagic> #topic Action Items from Last Meeting
15:02:55 <Bmagic> #info eeevil will open a bug for cross-column stats targets
15:03:13 <sleary> the cataloging meeting is running a little long today; some people will be with us in a moment
15:03:22 <eeevil> Bmagic: one day, he will.
15:03:26 <Bmagic> sleary: no prob
15:03:34 <Bmagic> #action eeevil will open a bug for cross-column stats targets
15:03:58 <Bmagic> probably the same for the next one
15:03:59 <Bmagic> #info gmcharlt - create a Git commit message type and update bug 2051946
15:04:00 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:04:24 <terranm> #info terranm = Terran McCanna, PINES
15:05:02 <Bmagic> #action gmcharlt - create a Git commit message type and update bug 2051946
15:05:03 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:05:38 <Bmagic> redavis: welcome, just in time for your action item!
15:05:55 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:05:56 <Bmagic> #info redavis will look at making a regular calendar event for translation work in lock step with point releases
15:06:32 <redavis> Hah!  Okay, well, I've discovered I'm not sure how to do anything in lockstep.  Other than be mindful that there needs to be time for translations.
15:07:18 <Bmagic> maybe the release manager(s) should do the calendar piece?
15:07:20 <csharp_> @who is mindful and demure?
15:07:20 <pinesol> troy is mindful and demure.
15:07:49 <Dyrcona> Time has been set aside in the 3.14 release plan for translations.
15:08:08 <redavis> In doing the regular maintenance releases, it seems reasonable to perhaps note that translations might lag behind by a release.
15:08:53 <Bmagic> good point
15:09:27 <Bmagic> I'm not sure if we're dancing around making an official change to our workflow or not
15:09:33 <redavis> For a major release, it's "easy" to build in a translation period.  For point releases, because the expectation is that they happen more regularly with a much quicker turnaround, making a longer merge pause doesn't seem like a great idea.
15:09:59 <abneiman> is it reasonable (since we're better at regular point releases) that we could have a convention of, say, translations for x.y.4 features go in to x.y.5?
15:10:19 <redavis> abneiman++ #my recommendation exactly.
15:10:25 <jvwoolf> #info jvwoolf is Jessica Woolford, Bibliomation
15:10:34 <Dyrcona> We could also just not backport string changes.... *ducks*
15:10:43 <Bmagic> and the change really boils down to some language to that effect in the release email/blog post?
15:10:45 <jvwoolf> (Sorry for the tardiness, will read the backscroll!)
15:11:03 <Bmagic> jvwoolf: no worries at all
15:11:03 <shulabramble> abneiman++
15:11:06 <sleary> backporting strings is necessary for many accessibility changes, which often involve ARIA labels. Sorry.
15:11:14 <abneiman> that ^^
15:11:44 <abneiman> Bmagic: words in the post but also communication to / from the point release teams and translation folks
15:12:18 <Bmagic> so maybe a reminder every month, prior to point release via email to the list?
15:12:24 <redavis> I'm gonna defer on wording.  It's worth noting that once a version goes out of support in terms of new releases (other than security), there might be one more release that is exclusively translation content
15:13:02 <abneiman> this is also where we should get input from our translators, none of whom are here I believe
15:13:15 <Dyrcona> Am I mistaken that the main concern was having time for translations during a major release? Did we discuss point releases much (at all?) during that meeting?
15:13:33 <redavis> The action item was about point releases.
15:14:34 <Bmagic> I think we can table this?
15:14:43 <redavis> It seems like the major release issue isn't one. If I'm understanding things
15:15:40 <Bmagic> should someone send a message out to the community with a suggestion/idea on how to move forward?
15:15:47 <abneiman> maybe the point-release aspect can be a hackaway discussion, and before that, we can intentionally solicit feedback from translators
15:16:26 <abneiman> if so, I can take that action item (solicitation of feedback)
15:16:28 <dluch> abneiman++
15:16:30 <redavis> I think that's a good idea.
15:16:33 <redavis> abneiman++
15:17:08 <Bmagic> #action abneiman will intentionally solicit feedback from translators about translation work in lock step with point releases
15:17:11 <redavis> And I'd like to ask that my action item not be carried forward.
15:17:16 <Bmagic> :)
15:17:31 <Bmagic> ok abneiman++
15:17:38 <abneiman> and it's more of a two-step than a lockstep, but whatevs. Moving on!
15:17:48 <Bmagic> gotta keep our schedule!
15:17:49 <Bmagic> #info Dyrcona will look into git integration with POEditor
15:17:55 <Dyrcona> I looked into it, and the POEditor project owner has to set up the git integration.
15:18:29 <Bmagic> do we need to send message to gmcharlt in order to proceed?
15:19:22 <redavis> It might have already been done but, if not, yes.
15:19:59 <Dyrcona> I contacted gmcharlt through the form on POEditor.
15:20:08 <Bmagic> #action waiting on
15:20:12 <Bmagic> whoops
15:20:36 <Bmagic> #action waiting on gmcharlt for access to POEditor for git integration
15:20:51 <Bmagic> #info sleary and sandbergja will create/consolidate the test writing wiki page(s)
15:21:03 <sleary> sandbergja and I will meet later this week to work on that
15:21:09 <sleary> carry forward, please
15:21:13 <Bmagic> #action sleary and sandbergja will create/consolidate the test writing wiki page(s)
15:21:19 <Bmagic> #info sandbergja will make it easier for folks to know how to run the tests in single file mode and all-mode
15:21:24 <Bmagic> I guess that's the same thing?
15:21:31 <sleary> yes
15:21:38 <Bmagic> #info berick and jeff will look at making Hatch look better in the chrome store, so that it's not removed
15:21:43 <Bmagic> #info     berick: added pullrequest for bug 2076921
15:21:44 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:21:50 <jeff> berick has a branch / pullrequest for the Manifest V3 changes, and I've just grabbed the bug to test. The changes look like they were "routine" and not "we hav to completely change our approach", so I'm cautiously optimistic. :-)
15:22:15 <berick> yeah, was less intrusive than I expected
15:22:16 <Bmagic> jeff++
15:22:18 <Bmagic> berick++
15:22:20 <mmorgan> berick++
15:22:22 <mmorgan> jeff++
15:22:23 <jeff> other testing welcome, especially if you feel your environment may be unusual (though this changes the extension, and not the native messenger / locally installed bits)
15:22:24 <csharp_> jeff++
15:22:28 <csharp_> berick++
15:22:29 <shulabramble> jeff++ berick++
15:22:29 <berick> hatch is luckily a pretty simple extension, the extension part anyway
15:22:29 <jeff> berick++
15:22:43 <dluch> berick++ jeff++
15:23:09 <Bmagic> who is the one that installs/updates the extension in the store?
15:23:19 <berick> i should have access
15:23:27 <berick> galen does too, maybe others
15:23:35 <jeff> I think the next step assuming successful testing will be to do a short beta test in the Chrome web store, to ensure that the V2 -> V3 upgrade doesn't introduce any unexpected "hey you have to re-re-enable this 'sideloaded' extension" problems, etc.
15:23:48 <Bmagic> jeff: perfect
15:24:14 <Bmagic> we need a sign-off, merge, and beta version in the store?
15:24:58 <berick> and likely some docs around Firefox, since I had to break the manifests into one file per browser
15:25:15 <jeff> prettyty much. please carry forward as testing in progress, and I hope/expect we should have progress to report next meeting.
15:25:42 <jeff> assuming my keyboard / terminal stops repeating my letters. :-P
15:25:59 <dluch> lol
15:26:02 <Bmagic> #action bug 2076921 expected to get more testing and merged, and beta uploaded to store
15:26:04 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:26:11 <Bmagic> #info Bmagic will work on upgrading the version of DokuWiki
15:26:18 <Bmagic> I did it! Thank you, thank you
15:26:22 <Bmagic> just kidding, I did nothing
15:26:32 <Bmagic> csharp_ did though! right?
15:26:35 <sleary> the wiki has been upgraded
15:26:41 <sleary> I added the tags plugin while I was there
15:26:54 <csharp_> it was sleary I think
15:26:57 <Bmagic> sleary++
15:27:00 <dluch> sleary++
15:27:01 <mmorgan> sleary++
15:27:10 <shulabramble> sleary++
15:27:39 <Bmagic> #topic Evergreen
15:27:39 <Dyrcona> sleary++
15:27:43 <sandbergja> sleary++
15:27:44 <Bmagic> #info Point releases 9/18 - signups here BuildMaster Coordination
15:27:48 <Bmagic> #link https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit?usp=sharing
15:29:17 <Bmagic> funny, we have a Hatch topic but we've pretty much covered it already
15:29:23 <redavis> Bmagic++ abneiman++
15:30:29 <Bmagic> get your signups!
15:30:37 <Bmagic> #topic Documentation
15:30:46 <Bmagic> #info  Documentation Interest Group (DIG) met on Sept. 5
15:30:51 <Bmagic> #info      Defined many terms to run through Vale (https://vale.sh/) for documentation consistency checks
15:30:56 <Bmagic> #info      Discussed last Vale spreadsheet and getting as many of those fixed by October's meeting as possible
15:31:02 <Bmagic> #info      October's meeting with focus on 3.14 documentation needs
15:31:09 <Bmagic> #info      Question (went to listserv, too): This bug: https://docs.evergreen-ils.org/docs/latest/opac/visibility_on_the_web.html is orphaned in the docs. Is it still a valid page? Is the part about SKOS Support that says “This is an experimental, "under-the-hood" feature that will be built upon in subsequent releases.” correct? Is it still an experimental feature?
15:31:38 <Bmagic> #link https://vale.sh/
15:31:40 <Bmagic> #link https://docs.evergreen-ils.org/docs/latest/opac/visibility_on_the_web.html
15:33:08 <Bmagic> I think* it's related to Dan Scotts work?
15:33:11 <Bmagic> https://stuff.coffeecode.net/2017/evergreen-progressive-web-app/#/
15:33:16 <dluch> That last one, the Question...on the email, it was identified as added by sandbergja and the repective release notes and launchpad bug. But is it still experimental? Does it need to be not orphaned anymore
15:33:17 <dluch> ?
15:33:53 <Bmagic> maybe not related, but it reminds me of his 2017 presentation
15:34:24 <sandbergja> Just a note regarding vale: there is a pull request ready on bug 2076555, to make sure that we keep up our high standards in future docs work :-)
15:34:24 <pinesol> Launchpad bug 2076555 in Evergreen "Add vale for linting documentation" [Undecided,New] https://launchpad.net/bugs/2076555
15:34:38 <dluch> sandbergja++
15:34:43 <sleary> sandbergja++
15:34:55 <Bmagic> sandbergja++
15:35:24 <redavis> sandbergja++
15:35:25 <shulabramble> sandbergja++
15:36:09 <dluch> And if no one knows anymore, does that mean we can lose that section/page?
15:36:15 <Bmagic> I think it should be linked in the nav somewhere
15:36:48 <sleary> I don't think we should lose that--but I'm just now looking at it. I will review
15:36:59 <abneiman> Bmagic: within the OPAC section? or elsewhere?
15:37:01 <dluch> Thanks, sleary!
15:37:12 <Bmagic> maybe system admin
15:37:14 * abneiman thinks it belongs elsewhere
15:37:29 <abneiman> yeah, admin, or what we used to call admin_initial_setup
15:37:37 <Bmagic> "System Configuration and Customization"
15:37:38 * dluch agrees with abneiman
15:37:48 * sleary disagrees :) but will have more thoughts later
15:38:05 <Bmagic> #info  Next DIG meeting is October 3.
15:38:13 <dluch> :-D
15:38:39 <Bmagic> anything else on docs?
15:38:58 <dluch> Not from me! Unless there are questions?
15:39:28 <Bmagic> other than: I think our docs site is really rockin' these days
15:39:42 <dluch> DIG++
15:39:58 <Bmagic> DIG++ # indeed
15:40:35 <Bmagic> I was worried we wouldn't make this meeting in an hour, and now I starting to feel like we're going to end early :)
15:40:45 <Bmagic> #topic Launchpad Status (as of noon Eastern)
15:40:47 <Bmagic> incoming!!!
15:40:55 <Bmagic> #info Open Bugs - 3141
15:40:55 <Bmagic> #info Pullrequests - 71
15:40:55 <Bmagic> #info Signedoff - 24
15:40:55 <Bmagic> #info Needswork - 87
15:40:55 <Bmagic> #info Needstestplan - 3
15:40:56 <Bmagic> #info Needsrebase - 26
15:41:00 <Bmagic> #topic Launchpad Status since last meeting
15:41:04 <Bmagic> #info Bugs Added - 61
15:41:04 <Bmagic> #info Pullrequest tag Added - 40
15:41:05 <Bmagic> #info Signedoff tag Added - 10
15:41:07 <Bmagic> #info Needswork tag Added - 13
15:41:09 <Bmagic> #info Needstestplan tag Added - 3
15:41:11 <Bmagic> #info Needsrebase tag Added - 6
15:41:15 <Bmagic> #info Fix Committed - 40
15:41:18 <Bmagic> #topic New Business - Preparing for OPAC template upgrade to Bootstrap 5: rewrite jQuery-specific JS wherever possible, please. - SL
15:41:31 <sleary> ah, that's me
15:41:34 <redavis> I've created (for my own purposes) a tracking spreadsheet of LP tickets for 3.14 - https://docs.google.com/spreadsheets/d/1nVuknGBCOSUxBFId0bORVrJYw4Un0mD0kqr67d_AJ84/edit?usp=sharing
15:42:00 <Bmagic> yummy! tracking
15:42:04 <redavis> Just a note that there are several things that have signoffs and need someone to commit to committing them.
15:42:26 <jvwoolf> redavis++
15:42:31 <jvwoolf> It's a beautiful thing
15:42:35 <redavis> Keeping in mind that there will also be a merge pause for the upcoming point releases...so...plan accordingly?
15:42:40 <dluch> redavis++
15:42:59 <sleary> so I've been working on accessibility in the Bootstrap OPAC templates (PR forthcoming) and, as part of that project, assessing what it would take to upgrade our default theme to Bootstrap 5. The changes would be extensive enough that I'm not recommending that we do it in this branch/release, but...
15:43:19 <redavis> sleary, maybe next?
15:43:30 <sleary> Bootstrap 5 doesn't require jQuery as a dependency anymore, so it would behoove us to get rid of our jQuery code wherever we can and slim down our page load
15:43:50 <Bmagic> RIP jQuery
15:43:54 <sleary> there is not much, and I think I'm removing about 90% of it as part of this project: the password eye, dialogs, and tooltips
15:43:58 <Bmagic> you were such a good friend
15:44:05 <sleary> (not removing those features, just removing the jQuery-specific code)
15:44:29 <sleary> upshot: if you find any jQuery that is *not* related to any of those three things, and you can rewrite it as vanilla JS, please do so
15:44:36 <dluch> Sounds like a good candidate for Evergreen 4.0...
15:44:40 <sleary> indeed
15:44:44 <jeff> sleary++ thanks!
15:44:47 <dluch> sleary++
15:44:53 <redavis> yes, and also "slim down our page load"
15:45:03 <redavis> that's a thing of delight and beauty
15:45:06 <redavis> sleary++
15:45:08 <Bmagic> carousels?
15:45:18 <sleary> performance is the next big topic on my to-do list, now that we've made a significant dent in accessibility issues
15:45:32 <sleary> Bmagic good question. I haven't looked closely at Glide yet
15:45:51 <jeff> sleary: "don't introduce any new jQuery-specific JS", "rewrite/remove as encountered" for now, and then active hunting will be part of the final prep for upgrpgrading to Bootstrap 5?
15:46:00 <sleary> jeff: exactly
15:46:11 <jeff> there are those fun doubled letters making new words for me again. "upgrpgrading"
15:46:21 <sleary> I will send that to the list; I added this ~15 minutes before the meeting :)
15:47:02 <sandbergja> A note that I'm also trying to remove dojo from the opac js.  So... I don't think anybody was planning to do so, but don't add any new dojo to the opac either plz?
15:47:16 <sleary> sandbergja++
15:47:34 <dluch> sandbergja++
15:47:36 <Dyrcona> Well, we have plans to eliminate dojo completely, so sandbergja++
15:47:54 <sleary> I will fill this in with more info later: https://wiki.evergreen-ils.org/doku.php?id=opac:bootstrap5
15:48:04 <Bmagic> Glide is "Dependency-free"
15:48:14 <sleary> Bmagic++
15:48:16 <jeffdavis> ebook API stuff needs to be rewritten to not be dojo-based - I presumed we'd move it to jQuery, would be good to know if there should be a different target for that
15:48:16 <sandbergja> woah nice, way to go Glide!
15:48:26 <Bmagic> #link https://wiki.evergreen-ils.org/doku.php?id=opac:bootstrap5
15:48:28 <jeff> At the appropriate time, I recommend we drive a stake through both jQuery and Dojo, just to be safe.
15:48:56 <sleary> jeffdavis yes please. I can lend a hand with rewrites
15:48:57 <redavis> jeff++
15:49:01 <sleary> jeff++
15:49:02 <sandbergja> jeffdavis: I'm glad you mentioned that, I was wondering about that
15:49:06 <Bmagic> sure! It seems like we don't have a lot* of jQuery and dojo code integrated anymore
15:49:17 <dluch> jeffdavis++
15:49:26 <sandbergja> can it be accurately tested with the test ebook, or would it need to be done with an Overdrive subscription?
15:49:26 <dluch> jeff++
15:49:34 <Bmagic> jeffdavis++ jeff++
15:49:38 <sleary> Bmagic that is my impression, but there may be random pockets of stuff I haven't unearthed
15:50:03 <Bmagic> fewer_dependencies++
15:50:31 <jeffdavis> sandbergja: it's been a long time since I touched it, but the test stuff ought to be enough to confirm that the UI is working IIRC
15:50:46 <sleary> and I will note that it will still be possible to include jQuery if you want it for your custom theme; I just want to eliminate its weight from our default templates, since most of what it does can be done in plain JS these days
15:51:06 <Bmagic> sleary++ # yes!
15:51:50 <Bmagic> ok, anything else on that?
15:52:18 <sandbergja> just to return to my favorite soapbox, it's much easier to write automated tests for opac js behavior that does not rely on external dependencies
15:52:36 <sandbergja> so fewer_dependencies++ for that reason too!
15:52:55 <sleary> sandbergja++ automated_testing++
15:52:57 <shulabramble> plain_js++
15:53:09 <Bmagic> a win, win, and probably another win too
15:53:26 <Bmagic> less is more and more is better and better is...
15:53:37 <Bmagic> That just about wraps us up, but I'd like to add two things real quick, since we're all here
15:53:47 <Bmagic> #topic redis
15:53:58 <Bmagic> anyone had a look at this more?
15:54:25 <sleary> I believe berick is using it in production now?
15:54:44 <berick> yes
15:54:54 <berick> in production app and sip servers
15:54:57 <Bmagic> It's planned for OpenSRF 4.0. bug 2017941
15:54:57 <pinesol> Launchpad bug 2017941 in OpenSRF "Migrate from Ejabberd to Redis for OpenSRF Messaging" [Wishlist,Confirmed] https://launchpad.net/bugs/2017941
15:55:20 <sandbergja> let's merge it!
15:55:24 <sandbergja> at least that's my vote
15:55:31 <Bmagic> we're running it on production as well
15:55:52 <Bmagic> I figured the only way we're going to know if it "works" is to do it for real
15:56:02 <jeffdavis> There was a question about Redis vs Valkey, wasn't there?
15:56:13 <Bmagic> with a finger on a button waiting for it to break, ready to swap containers back to ejabberd
15:56:36 <Bmagic> jeffdavis: right, I think* we're still waiting on Valkey to get "ready" ?
15:56:38 <berick> jeffdavis: that question is basically answered.  redis ok for now, when valkey is ready,we'll migrate
15:57:14 <jeffdavis> ah ok
15:57:49 <Bmagic> I know i said quick, so I just wanted to bring it up "real quick" - I think I got what I wanted
15:57:58 <Bmagic> #topic passing the dev-meet-runner-torch
15:58:18 <Bmagic> anyone want to take my place? I've been at this for more than a year now
15:59:30 <Bmagic> ok then.... lol
15:59:30 * csharp_ turns up music to drown out the crickets
15:59:42 <shulabramble> I'd be willing to give it a swing.
15:59:49 <csharp_> shulabramble++
15:59:51 <Bmagic> shulabramble++
15:59:56 <sandbergja> shulabramble++
16:00:02 <mmorgan> shulabramble++
16:00:03 <sleary> shulabramble++
16:00:13 <dluch> shulabramble++
16:00:18 <redavis> shulabramble++
16:00:26 <redavis> bmagic++
16:00:32 <dluch> bmagic++
16:00:34 <Bmagic> thank you! I don't think anyone will fight you
16:00:58 <Bmagic> I'll talk to you offline if you would like to go over the details
16:01:02 <jeffdavis> shulabramble++ Bmagic++
16:01:09 <Bmagic> #topic Announcements
16:01:13 <Bmagic> #info Next Meeting is October 8, 2024
16:01:14 <shulabramble> That would be lovely, thank you.
16:01:17 <Bmagic> #info Hack-A-Way, November 12-14 in Boston, MA
16:01:24 <Bmagic> #endmeeting