15:00:16 <Bmagic> #startmeeting 2024-10-08 - Developer Meeting
15:00:16 <pinesol> Meeting started Tue Oct  8 15:00:16 2024 US/Eastern.  The chair is Bmagic. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <pinesol> The meeting name has been set to '2024_10_08___developer_meeting'
15:00:23 <Bmagic> #info Agenda at https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-10-08
15:00:28 <Bmagic> #topic Introductions
15:00:32 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:00:42 <terranm> #info terranm = Terran McCanna, PINES
15:00:44 <csharp_> #info csharp = Chris Sharp, GPLS
15:00:45 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:00:46 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:00:49 <collum> #info collum = Garry Collum, KCPL
15:00:51 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:00:52 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:00:58 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:00:58 <berick> #info berick Bill Erickson, KCLS
15:00:59 <sleary> #info sleary = Stephanie Leary, EOLI
15:01:06 <eeevil> #info eeevil = Mike Rylander, EOLI
15:01:49 <Bmagic> feel free to introduce yourself as you arrive
15:01:55 <smayo> #info smayo = Steven Mayo, PINES
15:02:00 <Bmagic> shulabramble has arrived :)
15:02:00 <scottangel> #info scottangel = Scott Angel, MOBIUS
15:02:11 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:02:22 <shulabramble> Where are we? :)
15:02:24 <redavis> shulabramble++ #!!!
15:02:26 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:02:27 <Bmagic> shulabramble: would you like to pick it up?
15:02:33 <Bmagic> we're at intro's
15:03:02 <shulabramble> I'll pick it up. Hopefully power is back for good.
15:03:03 <Bmagic> there's a way to hand it off
15:03:06 <briank> #info Brian, Sitka
15:04:21 <Bmagic> #commands
15:04:21 <pinesol> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #reject #rejected #restrictlogs #save #showvote #startmeeting #startvote #topic #unchair #undo #unlurk #vote
15:04:21 <shulabramble> do we know the way to hand it off?
15:04:48 <Bmagic> I think anyone can issue the commands, so you go ahead
15:04:55 <Bmagic> I might have to end it though
15:05:01 <csharp_> how many developers does it take to run a meeting bot?
15:05:05 <shulabramble> #chair shulabramble
15:05:16 <Dyrcona> shulabramble++
15:05:19 <Bmagic> #chair shulabramble
15:05:19 <pinesol> Current chairs: Bmagic shulabramble
15:05:26 <Bmagic> there we go
15:05:35 <shulabramble> Here we gooooo
15:05:37 <sleary> I love that halp is a valid command
15:06:08 <Dyrcona> For when the regular help ain't cuttin' it.
15:06:14 <Bmagic> lol
15:06:17 <Bmagic> Dyrcona++
15:06:31 <shulabramble> Okay, let's get started, people can keep doing introductions while we get going.
15:06:52 <shulabramble> #topic Actions
15:07:30 <shulabramble> #info eeevil will open a bug for cross-column stats targets
15:07:53 <eeevil> ha! no, not yet. one day...
15:08:48 <shulabramble> okay then!
15:09:03 <shulabramble> #action eeevil will open a bug for cross-column stats targets
15:09:43 <shulabramble> any more discussion about that right now?
15:10:25 <eeevil> not unless someone else has the time to dig into it and find a likely first target
15:10:58 <shulabramble> Anyone?
15:11:12 <Dyrcona> I have a question or two, but they can wait.
15:11:33 <shulabramble> eeevil++ Dyrcona++
15:11:39 <shulabramble> moving on
15:12:01 <shulabramble> #info gmcharlt - create a Git commit message type and update bug 2051946
15:12:02 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:13:02 <abneiman> I don't think gmcharlt is available for this meeting
15:13:18 <shulabramble> Got it, so we'll move on to you :)
15:13:28 <shulabramble> #action gmcharlt - create a Git commit message type and update bug 2051946
15:13:29 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:14:03 <shulabramble> #info will intentionally solicit feedback from translators about translation work in lock step with point releases; feedback solicited 10/07/2024
15:14:14 <shulabramble> #info will intentionally solicit feedback from translators about translation work in lock step with point releases; feedback solicited 10/07/2024
15:14:25 <shulabramble> abneiman, that is.
15:14:38 <abneiman> #info Linda and Eva gave me some very thoughtful feedback which I'll share below in new business
15:15:01 <shulabramble> abneiman++
15:15:09 <Bmagic> abneiman++
15:15:19 <redavis> abneiman++
15:15:23 <Dyrcona> abneiman++
15:15:29 <shulabramble> #info waiting on gmcharlt for access to POEditor for git integration
15:15:37 <shulabramble> #action waiting on gmcharlt for access to POEditor for git integration
15:15:50 <shulabramble> #info sleary and sandbergja will create/consolidate the test writing wiki page(s)
15:16:08 <sleary> #info in progress! We will have more to report next month / at hackaway
15:16:31 <Dyrcona> sleary++ sandbergja++
15:17:04 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
15:17:08 <Bmagic> sleary++ sandbergja++
15:17:12 <shulabramble> sleary++ sandbergja++
15:17:27 <shulabramble> #info bug 2076921 expected to get more testing and merged, and beta uploaded to store
15:17:28 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:17:38 <redavis> sleary++ sandbergja++
15:17:51 <jeff> testing in progress, will coordinate with berick later this week
15:18:09 <redavis> jeff++ berick++
15:18:10 <shulabramble> yay! jeff++
15:18:12 <shulabramble> berick++
15:18:20 <Dyrcona> jeff++ berick++
15:18:23 <sleary> jeff++ berick++
15:18:55 <shulabramble> #action bug 2076921 expected to get more testing and merged, and beta uploaded to store
15:18:56 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:19:10 <shulabramble> #topic updates
15:19:30 <shulabramble> #info OpenSRF
15:19:43 <Dyrcona> Oh!
15:19:50 <Bmagic> :)
15:20:04 <Dyrcona> #info Opensrf 3.2.5 and 3.3.2 were released last ... Tuesday?
15:20:17 <shulabramble> Dyrcona++
15:20:18 <redavis> something like that
15:20:25 <redavis> Dyrcona++
15:20:31 <mmorgan> Dyrcona++
15:20:32 <Bmagic> I'm Ron Burgundy?
15:20:44 <sleary> Dyrcona++
15:20:47 <Dyrcona> The last week or so has been a blur.
15:20:49 <Bmagic> Dyrcona++
15:21:35 <shulabramble> #info Evergreen & The Feedback Fest
15:21:56 <Dyrcona> Bmagic++ for finishing up the beta release while I was unavailable.
15:22:06 <abneiman> Dyrcona++ Bmagic++
15:22:07 <shulabramble> Bmagic++
15:22:13 <redavis> Bmagic++
15:22:30 <sleary> Bmagic++
15:22:36 <redavis> Feedback Fest is ongoing through Thursday.
15:22:38 <Bmagic> 'twas my pleasure, always happy to help
15:22:40 <Dyrcona> redavis++ jvwoolf++ Release notes, organization, etc.
15:22:44 <shulabramble> Any word on 3.14rc?
15:22:55 <shulabramble> redavis++ jvwoolf++
15:23:03 <redavis> We're still on schedule for next Wednesday
15:23:05 <Dyrcona> Well, it should be out next week pending results of the feedback fest.
15:23:17 <abneiman> redavis++ jvwoolf++
15:23:34 <sleary> super extra kudos to everyone who's been learning new skills to help test the accessibility bugs!
15:23:39 <shulabramble> #info 3.14rc on target for Wednesday Oct 16
15:23:40 <terranm> 10 new bugs reported, but not all of them are related to 3.14
15:23:46 <redavis> I've updated the agenda with that. Also terranm++ for doing two rounds of feedback for this reason.
15:23:48 <shulabramble> testers++
15:23:49 <abneiman> release team: if I have additions/corrections for release notes should I let you know or just push a correction?
15:23:51 <shulabramble> terranm++
15:24:06 * redavis looks at Dyrcona
15:24:15 <redavis> abneiman, I think you can just push them.
15:24:23 <Dyrcona> abneiman: It's OK with me if you just push them.
15:24:44 <redavis> https://docs.google.com/spreadsheets/d/1w8GJdVRtC-AO9VwMI9R6TNa4RrFE14_Se43x-RLIjvw/edit?gid=0#gid=0
15:25:03 <redavis> Please run 3.14 through its paces.  There are several new things in it.
15:25:04 <abneiman> thanks both
15:25:28 <redavis> As well as a bazillion accessibility fixes.
15:26:15 <redavis> Also, just a note that we've added a series for 3.15 pending any decisions about 4.0.
15:26:48 <redavis> Which will probably/definitely be talked about at the Hack-A-Way
15:26:51 <abneiman> I think evergreen-ils.org just hiccuped
15:26:58 <abneiman> wiki, website, git all timing out
15:27:22 <csharp_> abneiman: eh?
15:27:40 <terranm> It's okay for me
15:27:48 <abneiman> csharp_: local problem, perhaps
15:27:51 <redavis> okay here
15:28:03 <abneiman> sorry, country internet. carry on.
15:28:13 <csharp_> @band add Country Internet
15:28:13 <pinesol> csharp_: Band 'Country Internet' added to list
15:28:35 <Dyrcona> git.evergreen-ils.org was a bit slow to let me in.
15:29:02 <redavis> oh nooooooo
15:29:18 <Dyrcona> I'll install updates on the git server later this week. Looks like it has a few waiting.
15:29:30 <csharp_> Dyrcona++
15:29:37 <Dyrcona> Seems fine now that I'm in.
15:29:50 <csharp_> Bmagic: looks like it's back on you ;-)
15:29:58 <Bmagic> ha
15:29:59 <shulabramble> #chair
15:29:59 <pinesol> Current chairs: Bmagic shulabramble
15:30:03 <csharp_> oh - there's shulabramble
15:30:25 <shulabramble> This isn't even hurricane related internet chaos :)
15:30:37 <Bmagic> I hate computers
15:30:44 <Dyrcona> Just the typical Internet chaos.
15:30:51 <terranm> Computers are the worst
15:30:58 <shulabramble> the butlerian jihad cannot come soon enough
15:30:58 <mmorgan> A little drama at the dev meeting!
15:31:00 <abneiman> computers--
15:31:14 <sleary> electricity was a mistake
15:31:19 <csharp_> computers: it's okay, they don't mean it
15:31:35 <terranm> bring back the clay tablets
15:31:37 <shulabramble> let me just paint my hand and slap it on the cave wall
15:31:41 <redavis> lol "electricity was a mistake"
15:31:57 <redavis> It's just nature, baby
15:32:08 <abneiman> "In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
15:32:17 <Dyrcona> abneiman++
15:32:20 <shulabramble> taming the electron to make it make decisions was a bad idea
15:32:22 <sleary> abneiman++
15:32:23 <shulabramble> abneiman++
15:32:28 <mmorgan> abneiman++
15:32:30 <csharp_> Douglas_Adams++
15:32:34 <redavis> abneiman++
15:32:45 <terranm> So good
15:33:10 <shulabramble> where are we now? still on 3.14 related discussion?
15:33:28 <Bmagic> I believe so
15:33:30 <Dyrcona> I think we can move on to point releases next week?
15:33:51 <shulabramble> abneiman -- you have a note in the agenda about point releases?
15:34:13 <abneiman> yep, just wondering if we're in a position to do them or if we should wait a week (or cancel) because of 3.14-rc?
15:34:32 <redavis> IIRC, we'd discussed postponing.
15:34:50 <Dyrcona> If they're postponed, it might be good to coincide with 3.14.0, or is that also too much at once?
15:35:06 <redavis> I dunno.  Is it? lol
15:35:17 <redavis> Theoretically, it's not.
15:35:20 <csharp_> prolly fine
15:35:22 <redavis> too much
15:35:23 <abneiman> I think given the general overlap with the monthly team and the 3.14 team it might be too much but I'm only on one of those teams :)
15:35:54 <Bmagic> let the release flow
15:36:02 <redavis> I think if we say "let's do it" now, that's enough time to gear up for it to coincide.
15:36:23 <Dyrcona> Are we talking about 3 or 4 simultaneous releases?
15:36:35 <redavis> I believe it's 3.
15:36:49 <abneiman> 3 - .12, .13, .14
15:36:55 <redavis> yes. three
15:36:57 <Dyrcona> We've done that before, but it usually takes an extra day or so.
15:37:02 <Bmagic> 3.11 has a commit on it since last time?
15:37:15 <redavis> is it security Bmagic?
15:37:26 <Dyrcona> Bmagic: I think it does, but it's not worth releasing, in my opinion.
15:37:44 <Bmagic> it's docs
15:38:12 <Dyrcona> Yeah.
15:38:15 <Bmagic> so, a new release 3.11 would be identical to last months
15:38:16 <Dyrcona> I looked, too.
15:38:33 <abneiman> my bust, I thought it was ok to patch old docs things
15:38:45 <Bmagic> totally fine abneiman
15:38:48 <abneiman> becuase that doesn't require an acutal release to be made
15:38:48 <Dyrcona> It's fine to patch old docs.
15:38:59 <Bmagic> our docs site will incorporate the changes nightly
15:39:03 <abneiman> right
15:39:08 <redavis> abneiman++
15:39:14 <shulabramble> abneiman++
15:39:47 <shulabramble> so do we have a consensus on doing three point releases alongside 3.14.0, or do we want to delay?
15:40:03 <redavis> So, all that to say, 3 releases.
15:40:12 <redavis> https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit?gid=0#gid=0
15:40:29 <redavis> I'll update this for the releases in a minute unless abneiman is already on it.
15:40:56 <abneiman> 3 releases unless someone from security team feels strongly about another 3.11
15:41:04 <abneiman> redavis++
15:41:13 <shulabramble> redavis++
15:43:07 <abneiman> and it looks like 3.12 and 3.13 only have a handful of things on them so hopefully not too onerous
15:43:35 <sleary> I will have some keyboard shortcut fixes for 3.13 (MARC editor) hopefully
15:43:55 <redavis> It'd be good to have some help building/testing tarballs at the least.
15:45:59 <shulabramble> anyone want to volunteer to help the security team with tarball tests?
15:46:16 <redavis> Oh, release team...sorry.
15:46:31 <shulabramble> anyone want to volunteer to help the release team with tarball tests? :)
15:46:54 <redavis> Just fill out that buildmaster sheet if you want to.
15:47:03 <redavis> Think about it.  Dream about it.
15:47:15 <shulabramble> Meditate on it at second level.
15:47:44 <redavis> Definitely. Let it permeate your now and visions of the future.
15:48:18 <shulabramble> Build the tarball. Let the tarball build you.
15:48:26 <shulabramble> okay, I think that bit has gone as far as it's gonna.
15:48:49 <redavis> lol shulabramble++
15:49:06 <Bmagic> shulabramble++
15:49:48 <shulabramble> so, do we have a consensus on doing security releases for 3.12 & 3.13 alongside the 3.14 release, or do we want to delay security releases to Oct 23?
15:50:10 <Dyrcona> So, these are regular point releases. I'm not aware of any pending security patches.
15:50:32 <redavis> Dyrcona++
15:50:40 <shulabramble> do we have a consensus on doing point releases for 3.12 & 3.13 alongside the 3.14 release, or do we want to delay security releases to Oct 23? Dyrcona++
15:50:58 <Dyrcona> It seems like we do.
15:50:59 <redavis> +1 to doing point releases alongside 3.14
15:51:36 <mmorgan> The calendar has maintenance releases scheduled for Oct 23 already
15:51:46 <abneiman> sorry, yeah, I just ninja-edited the calendar
15:51:57 <mmorgan> abneiman++
15:52:09 <shulabramble> abneiman++
15:52:26 <redavis> abneiman++ ninja_editing++
15:53:40 <shulabramble> okay then
15:54:19 <shulabramble> #action Point releases for 3.12 and 3.13 are targeted for October 16 alongside the release of 3.14
15:54:42 <shulabramble> Moving on...
15:54:55 <shulabramble> #info Hatch
15:55:02 <shulabramble> Any changes or movement on that?
15:55:22 <redavis> October 22, sorry. October 16 is RC
15:55:26 <abneiman> #info releases actually on 10/16 :)
15:55:38 <abneiman> I MEAN 10/22
15:55:42 <abneiman> ignore me
15:56:00 <Dyrcona> Just what was discussed under action items about bug 2076921
15:56:01 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:56:06 <abneiman> #info releases actually for realsies on 10/22
15:56:08 <shulabramble> I am unable to read. Please excuse me, I have only recently returned to civilization after a hurricane :)
15:56:25 <redavis> shulabramble++
15:56:42 <redavis> civilization=overrated
15:56:48 <mmorgan> shulabramble++
15:57:00 <shulabramble> #info For realsies Point releases forĀ  3.12 and 3.13 are targeted for October 22 alongside 3.14
15:57:20 <shulabramble> Okay, moving on
15:57:25 <shulabramble> #info Documentation
15:58:23 <shulabramble> any word from the docs team or DIG?
15:59:07 <abneiman> #info DIG is working on 3.14 docs, if you have docs to share please email evergreen-documentation@list.evergreen-ils.org
15:59:14 <shulabramble> abneiman++
16:00:12 <shulabramble> ... i just realized I've been doing things wrong with meetbot, but we will survive.
16:00:42 <shulabramble> anything else docs related?
16:01:00 <Dyrcona> shulabramble++ No worries.
16:01:20 <shulabramble> Dyrcona++
16:01:36 <shulabramble> Okay, then we have incoming
16:01:54 <shulabramble> #topic Launchpad Status (as of Noon Eastern)
16:02:42 <shulabramble> #info
16:02:47 <shulabramble> #info Open Bugs - 3154
16:02:58 <shulabramble> #info Pullrequests - 88
16:03:06 <shulabramble> #info Signedoff - 14
16:03:16 <shulabramble> #info Needwork - 84
16:03:23 <shulabramble> #info Needstestplan - 3
16:03:30 <shulabramble> #info Needsrebase - 27
16:03:49 <shulabramble> #topic Launchpad Updates since last meeting
16:03:57 <shulabramble> #info Bugs Added - 63
16:04:08 <shulabramble> #info Pullrequest tag Added - 35
16:04:15 <shulabramble> #info Signedoff tag Added - 20
16:04:28 <shulabramble> #info Needswork tag Added - 0
16:04:37 <shulabramble> #info Needstestplan tag Added - 0
16:04:50 <shulabramble> #info Needsrebase tag Added - 3
16:04:59 <shulabramble> #info Fix Committed - 36
16:05:12 <shulabramble> I'll have that streamlined next month, hopefully
16:05:21 <shulabramble> #topic New Business
16:05:31 <kmlussier> #info kmlussier = Kathy Lussier, NOBLE
16:05:35 <terranm> shulabramble++
16:05:52 <shulabramble> abneiman string freeze timing w/r/t point releases?
16:06:02 <abneiman> since we're at time I'll take that to the listserv
16:06:26 <shulabramble> #action abneiman will take that discussion to the listserv
16:06:48 <shulabramble> #info Hackaway local planning requests
16:07:04 <kmlussier> Hi! Just a couple of time-sensitive things.
16:07:27 <shulabramble> kmlussier++
16:07:35 <scottangel> shulabramble++
16:07:42 <kmlussier> We are trying to pin down the logistics for transportation to/from airport. Please fill out the form at https://forms.gle/trJw2j9pKL1PjexR7 ASAP so that we know when you're arriving and departing.
16:08:30 <terranm> The PINES team doesn't know yet because we're not allowed to purchase our plane tickets until 30 days prior to the flight due to state rules
16:08:30 <kmlussier> Putting my social activities hat on, I also wanted to get an idea if there was interest from a lot of folks to schedule one dinner at this game cafe. If so, I'll book a private room, which requires some lead time.
16:08:38 <kmlussier> https://thecastlebeverly.com/
16:08:57 <Dyrcona> I've been there. It's a fun little place.
16:09:03 <kmlussier> terranm: OK, good to know. Thanks!
16:09:20 <abneiman> terranm: dude, that is a terrible rule and I'm so sorry y'all have to deal with that
16:09:21 <kmlussier> You can let me know about the cafe post meeting.
16:09:30 <terranm> I would be in for the game cafe. Also, there are at least 3 of us that would be into the Prince-themed place
16:09:41 <kmlussier> terranm: Yay!
16:09:50 <shulabramble> #info let kmlussier know about The Castle interest
16:09:56 <terranm> abneiman: It's ridiculous, and we end up paying twice as much for tickets because we have to wait so long.
16:10:03 <shulabramble> One more point of discussion:
16:10:30 <shulabramble> Next month's meeting is during the Hack-A-Way; do we want to move it to another day?
16:11:19 <Dyrcona> Have we done it during the hack-away before?
16:11:28 <kmlussier> Yes, we have.
16:11:31 <abneiman> yeah
16:11:41 <Dyrcona> Well, then, we could keep the same time and date.
16:11:43 <terranm> I think it's been fine to keep it during the hackaway before
16:11:48 <shulabramble> okay then
16:11:52 <shulabramble> #topic Announcements
16:11:59 * redavis is down for the castle and prince
16:12:07 <shulabramble> #info Next Meeting is Tuesday, November 12, 2024
16:12:29 <shulabramble> Anything else?
16:12:59 <shulabramble> We're 12 minute past the hour, so speak now or forever hold your peace (or at least until November 12).
16:13:46 <shulabramble> Alright, then, if there's nothing more
16:13:51 <shulabramble> #endmeeting