15:00:09 <shulabramble> #startmeeting 2024-11-12 - Developer Meeting
15:00:09 <pinesol> Meeting started Tue Nov 12 15:00:09 2024 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <pinesol> The meeting name has been set to '2024_11_12___developer_meeting'
15:00:29 <shulabramble> Agenda is here: https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-11-12
15:00:43 <shulabramble> #topic Introductions
15:01:01 <shulabramble> #intro Shula Link, GCHRL
15:01:04 <abneiman> #info abneiman - Andrea Buntz Neiman, Equinox
15:01:10 <shulabramble> #info Shula Link, GCHRL
15:01:11 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:20 <sleary> #info sleary = Stephanie Leary, Equinox
15:01:25 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:42 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:02:08 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:02:12 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:02:17 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:02:28 <collum> #info collum = Garry Collum, KCPL
15:02:33 <terranm> #info terranm = Terran McCanna, PINES
15:02:57 <abneiman> jeff: you have a twin staying at the hackaway hotel because I thought I saw you last night
15:03:35 <shulabramble> People can keep doing intros as we get going. :)
15:03:35 <eeevil> #info eeevil = Mike Rylander, EOLI
15:03:36 <berick> #info berick Bill Erickson KCLS
15:03:51 <shulabramble> #topic Actions
15:03:51 <smayo> #info smayo = Steven Mayo, PINES
15:03:53 <csharp_> #info csharp, Chris Sharp, GPLS
15:04:00 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:04:05 <Rogan> #info rogan, Rogan Hamby EOLI
15:04:15 <shulabramble> #topic eeevil will open a bug for cross-column stats targets
15:04:22 <dguarrac> #info dguarrac = Dan Guarracino, OWWL Library System
15:04:34 <kmlussier> #info Kathy Lussier, NOBLE
15:04:42 <eeevil> I have not, yet.
15:05:22 <scottangel> #info scottangel = Scott Angel, MOBIUS
15:05:28 <shulabramble> we'll punt it on down the road then unless there's some other discussion on that?
15:05:45 <eeevil> "move on down, move on down the road"
15:06:02 <eeevil> (yes, let us punt it)
15:06:06 <shulabramble> don't carry nothing that could be a load
15:06:10 <shulabramble> #action eeevil will open a bug for cross-column stats targets
15:06:27 <shulabramble> #topic gmcharlt - create a Git commit message type and update bug 2051946
15:06:28 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:06:39 <csharp_> @decide scottangel or eeevil
15:06:39 <pinesol> csharp_: go with scottangel
15:07:06 <abneiman> I don't think gmcharlt is available for this meeting
15:07:41 <shulabramble> okay then.
15:07:45 <shulabramble> #action gmcharlt - create a Git commit message type and update bug 2051946
15:07:46 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:08:13 <shulabramble> #topic waiting on gmcharlt for access to POEditor for git integration
15:08:26 <shulabramble> And I assume the same for this unless there's any discussion to be had?
15:08:59 <abneiman> I will ping gmcharlt in our channel about that 2nd one since Dyrcona is awaiting access
15:09:09 <shulabramble> abneiman++
15:09:23 <shulabramble> #action waiting on gmcharlt for access to POEditor for git integration
15:09:40 <shulabramble> #topic sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
15:10:25 <sandbergja> ooh!  We did some work in the wiki.  We haven't had a chance to coordinate something for the hackaway
15:10:35 <sleary> I have not made much progress on my part of that, so let's kick that to next month, please!
15:10:40 <abneiman> sandbergja++ sleary++
15:10:44 <shulabramble> sandbergja++ sleary++ got it
15:11:01 <shulabramble> and a belated eeevil++
15:11:07 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month / at hackaway
15:11:13 <sandbergja> very happy if people discuss tests at hackaway though :-D
15:11:31 <shulabramble> #topic bug 2076921 expected to get more testing and merged, and beta uploaded to store
15:11:32 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:12:19 <berick> jeff did some testing, many thanks
15:12:27 <shulabramble> jeff++
15:12:40 <abneiman> jeff++
15:12:45 <sandbergja> jeff++
15:12:56 <Bmagic> jeff++
15:13:10 <berick> there's one cosmetic issue I may try to address, but regardless we should plan the roll out
15:13:14 <berick> to the chrome store
15:13:23 <sleary> jeff++ berick++
15:13:27 <shulabramble> berick++
15:13:30 <mmorgan> jeff++
15:13:32 <abneiman> berick:++
15:13:36 <mmorgan> berick++
15:13:38 <berick> i'm not 100% on what all the options are for partial roll outs, so research needed there
15:13:43 <Dyrcona> jeff++ berick++
15:14:08 <shulabramble> hooray! that's good news.
15:14:11 <sandbergja> berick++
15:14:27 <shulabramble> moving along at a fair clip
15:15:01 <shulabramble> do we need an action meeting on this for next month?
15:15:22 <berick> shulabramble: for the Hatch stuff?
15:15:26 <shulabramble> aye.
15:15:29 <kmlussier> jeff++ berick++
15:15:37 <berick> yeah.. i'll take on figuring out a roll out plan
15:15:46 <shulabramble> berick++
15:16:05 <berick> also, hopefully not necessary, but if Google forces our hand, we'll just roll out... I'm guessing
15:16:31 <shulabramble> #action berick will work on a rollout plan for hatch update -- bug 2076921
15:16:32 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:16:45 <shulabramble> #topic Timing of string freezes w/r/t point releases
15:16:52 <abneiman> that was me so please stand by for wall of text
15:17:10 * shulabramble cedes the floor.
15:17:24 <abneiman> I emailed several in our translations group (Linda, Eva, Jane, and Jennifer Pringle) suggesting a couple options, to wit:
15:17:26 <abneiman> 1) Adding translations in the next point release - e.g., translations for 3.13.4 will go in as part of 3.13.5
15:17:26 <abneiman> 2) Proactively notifying translators of merged bugs with translation strings needed
15:17:26 <abneiman> 3) Calling for a mini "string freeze" a few days before the general point release freeze is called.
15:18:03 <abneiman> the general consensus was that 2 is preferable-but-more-challenging and 3 is also OK
15:18:24 <pinesol> News from commits: Docs: Update linked_libraries.adoc with upcoming closures info <https://git.evergreen-ils.org/?p=Evergreen.git;a=commitdiff;h=06b19c1b470b968929762194e77a0a44d29dc1f3>
15:18:36 <abneiman> We are trying to schedule a discussion for hackaway but getting the timing that will work for both Czeckia and PST is challenging
15:18:57 <abneiman> so, that's my report if anyone has any questions / comments / thoughts, I cede the floor back :)
15:19:40 <abneiman> and I guess all of that should've been under an info tag so
15:20:05 <abneiman> #info please see the preceding several lines in the transcript for information on translation timing for point release
15:20:28 <shulabramble> abneiman++
15:20:34 <sandbergja> abneiman++
15:20:46 <jeff> abneiman++
15:20:47 <Dyrcona> abneiman++
15:20:51 <sleary> would a new LP tag be helpful for denoting bugs that involve string changes?
15:20:54 <kmlussier> abneiman++
15:21:14 <abneiman> sleary: yes, I think so. And it's a small concrete step that we can take :)
15:22:54 <shulabramble> sleary: volunteering to make that new tag? :)
15:23:25 <sleary> sure
15:23:31 <sandbergja> sleary++
15:24:02 <shulabramble> #action sleary will make a new LP tag denoting bugs that involve string changes
15:24:05 <shulabramble> sleary++
15:24:12 <jeffdavis> Do we have automated testing (or some such thing) to flag when a string has been added/changed?
15:24:15 <abneiman> sleary++
15:24:43 <shulabramble> jeffdavis++ for the question
15:25:28 <abneiman> jeffdavis: I do not know - sandbergja? sleary?
15:25:54 <sleary> I do not know of any automated ways to do that at the moment
15:26:09 <sandbergja> jeffdavis: I'm not aware of anything.  I don't think that the translation files we generate are very easy to compare, at least on the PO side.
15:26:40 <sandbergja> lots of timestamps and line number changes hide the actual string changes
15:26:59 <sandbergja> not that it couldn't be done!
15:27:24 <sandbergja> on the angular side it might be a bit easier
15:28:01 <shulabramble> anyone want to look into the feasibility of that probable regex festival?
15:28:49 <jeff> it's not a boring problem. what output/actions would be useful if we had such testing/monitoring?
15:29:37 <shulabramble> (to be clear, I love regex problems, so that's a *good* thing)
15:29:49 <abneiman> @band add Probably Regex Festival
15:29:49 <pinesol> abneiman: Band 'Probably Regex Festival' added to list
15:29:54 <phasefx> for angular at least, the build process tells us when strings aren't translated (at all?). I'm not sure how it works or if it's reliable, fwiw
15:29:59 <Dyrcona> shulabramble: Now, you've got 2 problems.
15:30:54 <sandbergja> jeff: good question.  I don't know -- send an email to translators?
15:31:22 <sandbergja> (but maybe not send them a new email every single time a typo is corrected?)
15:31:49 <sandbergja> it seems like a question for the translators maybe
15:32:10 <abneiman> if we can get a meeting scheduled at hackaway we can pose said question
15:32:39 <abneiman> jihpringle is the only one I see in channel right now
15:33:33 <shulabramble> it's a thing for discussion, at the least. we can come back to it in December after translator feedback?
15:33:55 <abneiman> sure
15:34:02 <jihpringle> if it's going to send emails we'd need a way to specify what we want the emails for (currently we only translate the OPAC)
15:34:18 <shulabramble> jeff++ abneiman++ jihpringle++
15:34:28 <shulabramble> phasefx++
15:35:06 <abneiman> jihpringle++
15:35:32 <shulabramble> #action revisit feasibility of automated testing for string changes
15:36:14 <shulabramble> alrighty, moving on
15:36:21 <shulabramble> #topic Updates
15:36:50 <shulabramble> There's nothing on the agenda for these, but I know we had an Evergreen update since the last meeting.
15:37:03 <shulabramble> so 3.14 release team++
15:37:26 <Bmagic> +1
15:37:28 <phasefx> release_team++
15:38:47 <shulabramble> is it time to assemble a 3.15 release team?
15:39:12 <phasefx> still think it should be 3.145
15:39:22 <Dyrcona> No, it's time to assemble a 4.0 release team.
15:39:38 <shulabramble> dyrcona++
15:39:46 <abneiman> I believe the 3.15/4.0 release team appointment will happen this week at hackaway
15:39:54 <shulabramble> abeneiman++
15:40:22 <shulabramble> abneiman++
15:40:52 <shulabramble> Next up: Launchpad Status was not updated on the Agenda.
15:41:13 <mmorgan> shulabramble: did you reload?
15:41:32 * Dyrcona volunteers for OpenSRF 4.0 release.
15:41:41 <shulabramble> mmorgan: yes
15:42:44 <mmorgan> Oops, updated the wrong page, I think.
15:42:54 <shulabramble> mmorgan++ it happens :)
15:43:29 <sandbergja> Dyrcona++
15:43:31 <sandbergja> mmorgan++
15:43:38 <shulabramble> dyrcona++
15:43:53 <Bmagic> Dyrcona++
15:45:17 <shulabramble> Wall of text incoming!
15:45:30 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:46:25 <shulabramble> #info Open Bugs - 3108
15:46:36 <shulabramble> #info Pullrequests - 93
15:46:51 <shulabramble> #info Signedoff - 13
15:47:01 <shulabramble> #info Needswork - 82
15:47:11 <shulabramble> #info Needstestplan - 3
15:47:21 <shulabramble> #info Needsrebase - 24
15:47:33 <shulabramble> #topic Launchpad Updates Since Last Meeting
15:47:40 <shulabramble> #info Bugs Added - 76
15:47:47 <shulabramble> #info Pullrequest tag Added - 25
15:47:58 <shulabramble> #info Signedoff tag Added - 21
15:48:06 <shulabramble> #info Needswork tag Added - 0
15:48:14 <shulabramble> #info Needstestplan tag added - 0
15:48:23 <shulabramble> #info needsrebase tag added - 0
15:48:31 <shulabramble> #info Fix Committed - 20
15:48:47 <shulabramble> mmorgan++ thank you :)
15:49:04 <shulabramble> #topic New Business
15:49:20 <shulabramble> #topic Discussion of IRC as home of meetings vs. video or an alternative text platform (abneiman)
15:49:24 <abneiman> hi again
15:49:34 <abneiman> It's hackaway and I'm throwing that bomb
15:49:44 <sandbergja> ker blam
15:49:49 <abneiman> but, more seriously, this came up in the Outreadh discussion earlier today
15:50:06 <abneiman> AFAIK all other community meetings are now held on zoom or other video chat
15:50:15 <abneiman> I understand that many of us are text-driven people
15:50:21 <abneiman> I understand that there are concerns about transparency
15:50:40 <abneiman> BUT! I also consider IRC to be unfriendly and a barrier to especially new participants
15:50:55 <berick> for this, we're just talking meetings?  not wholesale irc replacement?
15:50:59 <abneiman> so I'd like y'all, the developers, to consider moving dev meetings out of IRC into an video platform
15:51:31 <abneiman> A wholesale IRC replacement could also be discussed (slack, discord, etc.) but my particular bone to pick is text based meetings :)
15:51:35 <sleary> berick wholesale IRC replacement is a different discussion that we also need to have; this is just about dev meetings
15:51:46 <terranm> +1
15:51:50 <berick> considering every meeting I ever do for work is a video meeting.. i'm fine with it
15:52:28 <Dyrcona> I have a concern with a F/OSS project using proprietary software for meetings or infrastructure.
15:52:38 <abneiman> obviously, shulabramble, as current head of the dev meetings your opinion is key here as well
15:52:47 <kmlussier> In terms of transparency concerns, could we post the Zoom transcripts?
15:52:53 <sleary> we use proprietary software for many other things at this point, so I don't feel that we need to make that a priority among our considerations
15:53:07 <abneiman> +1 to Zoom transcripts
15:53:12 <shulabramble> if so, i'll have to cede running the meetings; my current work setup restricts my ability to do video meetings as the Monday group can attest.
15:53:30 <abneiman> hmmm
15:53:31 <sleary> +1 to transcripts
15:53:33 <sandbergja> There is also jitsi, if we want to use video meeting but use open source software
15:54:00 <Bmagic> I'm fine with video meetings. I assume we've already jumped the account ownership hurdle?
15:54:06 <ianskelskey> Im all for no more IRC
15:54:25 <shulabramble> if the consensus is moving to Zoom or another platform, I'm fine handing over the reigns.
15:54:26 <Bmagic> Ianskelskey: haha, one step at a time
15:54:37 <csharp_> I'm a pragmatist, so I'm okay with majority rule, but Dyrcona is correct that it's kind of a bad look for a F/LOSS project to use proprietary stuff
15:54:38 <ianskelskey> It is unfriendly for new devs.
15:54:42 <sleary> Bmagic the org has a Zoom account that are used for most of the other meetings
15:54:54 * shulabramble has a sentimental attachment to IRC but agrees it's a barrier.
15:55:07 <abneiman> I would like us to seriously consider it, especially since we (including the TEP board) has been meeting on the community Zoom account for quite some time now
15:55:08 <Bmagic> gotcha, no problem with the account and sharing credentials, and scheduling I assume then?
15:55:10 <csharp_> we've already broken that seal, but this kind of drift is what happens
15:55:26 <sleary> Bmagic right
15:55:34 <Bmagic> cool, I vote zoom then
15:55:42 <Bmagic> (because it's already setup)
15:55:44 <shulabramble> csharp_++
15:55:57 <ianskelskey> And I think the onboarding process for new devs is one of our big weaknesses. Evergreen could be a great first open source contribution for students, new devs etc, but getting into it is kind of a nightmare.
15:56:08 <abneiman> THIS ^^ is a problem we know we have
15:56:11 <sleary> +1
15:56:15 <terranm> +1
15:56:21 <smayo> +1
15:56:22 <ianskelskey> Well. There it is from the perspective of a new dev
15:56:25 <tlittle> +1
15:56:47 <redavis> ianskelskey++
15:56:51 * phasefx buries his EG2Gopher project
15:56:57 <abneiman> And NewDevs group has done amazing work here, but trying to connect with other devs is an area where we could be better - sharing knowledge etc. is ALSO a big part of open source
15:57:06 <Bmagic> phasefx: lol
15:57:15 <shulabramble> ianskelskey -- it might be interesting to hear some other barriers you've noticed.
15:57:23 <Bmagic> isn't newdev meetings held via zoom already?
15:57:25 <sandbergja> I am not a fan of IRC, but it would be a shame to exclude shulabramble :-(
15:57:30 <sleary> Bmagic yes
15:57:54 <shulabramble> as i don't think IRC is one of the biggest hurdles.
15:58:12 <abneiman> I do not want to exclude shulabramble either. And there is a text component to zoom / other video platforms but I get that it's hard for someone to run a meeting that way
15:58:22 <sleary> Including people who participate by text is something we discussed quite a bit in Outreach! We do want to make sure that those folks can still participate (and even lead meetings)! The text chat feature in Zoom is pretty solid.
15:58:39 <shulabramble> It's solid, but people have to actively remember to look at it.
15:58:52 <sleary> that is true
15:59:41 <shulabramble> and, as someone who prefers text-based communication, it's not great. it's meant to augment video communication, not be a parallel mode of primary communication in Zoom.
15:59:58 <Bmagic> all* of the other Evergreen meetings are using our Zoom account? The only one left is the dev meeting?
16:00:04 <abneiman> well, I don't know if it's time to call for a vote, but I did want to start the conversation and I appreciate all y'all's thoughts
16:00:20 <sleary> Bmagic New Devs and Outreach sometimes use Google Meet. All the others use Zoom as far as I know.
16:00:37 <abneiman> I think Outreach uses google meet
16:00:44 <sleary> My thought was that we'd put out a survey to the devs list
16:00:47 <Bmagic> it makes is seem like IRC is "reserved" for devs then
16:01:27 <smayo> Can confirm I've been scared to post in IRC because I didn't know enough yet
16:01:37 <sleary> :(
16:01:37 <Bmagic> I felt the same way smayo
16:01:57 <abneiman> I guess the real issues is that I find video meetings to be more productive than text meetings
16:02:00 <mmorgan> IRC is def intimidating for some
16:02:06 <abneiman> IMNSHO
16:02:47 <Bmagic> I agree that when it comes to meetings, seeing faces goes a long way to convey whatever it is you're trying to convey
16:02:51 <shulabramble> I'm an ancient of the internet; I was on IRC back as a teenager 30 years ago good lord...
16:02:52 <terranm> Trying to communicate anything complicated is difficult in short texts
16:02:53 <abneiman> and, since onboarding new devs is a prolem we know we have, I'd really like us to consider having dev meeting ELSEWHERE
16:02:57 <eeevil> if zoom had an option where it didn't open 42 windows, most duplicated for SOME REASON, I could be convinced
16:03:07 <csharp_> (not being confrontational...) would people feel more confident posting in this chat, just on Slack or similar?
16:03:31 <csharp_> like the content of the chat wouldn't be that different, no?
16:03:59 <Bmagic> csharp_: I think you're right, but that might be a different discussion
16:04:16 <JBoyer> lobbin' some bombs because I was encouraged to mention some options: Mattermost is a good slack-like that can be self-hosted and Koha has already moved to it. Matrix is more complicated to setup / use I think but I use it for some personal stuff.
16:04:28 <Bmagic> Or are you proposing the dev meeting remain in text format, but just on a different platform?
16:05:02 <redavis> Are we saying that we'd like to commit to supporting a self-hosted communication tool in addition to other community stuff?
16:05:16 <csharp_> JBoyer: we just talked about Mattermost/Matrix at our table too
16:05:25 <csharp_> now we're raging against Teams
16:05:26 <eeevil> re slack, I'd prefer free (both senses), but if some org (like TEP???) to pay for non-truncating slack, that'd be great
16:05:41 <eeevil> but mattermost++
16:06:01 <phasefx> shulabramble: I remember telnet talkers, too
16:06:05 <abneiman> but, it's also the top of the hour and I know sandbergja has a pending new biz item too. So, I can commit to making a survey for the dev list about meeting locations.
16:06:11 <Bmagic> this seems to be shifting to non-meeting platforms? Or am I misunderstanding?
16:06:16 <redavis> Slack would cost approximately $120 for the pro version with not-for-profit pricing.
16:06:17 <csharp_> suggestion: set up a mattermost instance in EC2 or similar
16:06:28 <redavis> annually
16:06:43 <shulabramble> abneiman++
16:06:44 <csharp_> redavis: very reasonable
16:06:50 <Dyrcona> #action csharp to setup mattermost on EC2
16:06:54 <terranm> I think the issue is that text-based just isn't as welcoming as video/screen-sharing based. Switching to a different text-based system wouldn't help.
16:06:54 <Bmagic> lol
16:07:07 <abneiman> agreed with terranm
16:07:14 <mmorgan> also agree
16:08:09 <collum> Could we try a video/screen-sharing meeting, just once, to see how it goes?
16:08:22 <Bmagic> I agree with video platform for meetings. Does mattermost accomodate?
16:08:38 <sleary> Is there a compelling reason to try out other platforms when we already have Zoom?
16:08:47 <Bmagic> right, what sleary said
16:09:00 <Dyrcona> sleary: Probably not so much.
16:09:01 <eeevil> sleary: because zoom is the worst? /me ducks
16:09:13 <shulabramble> how about we let abneiman do a survey and we can discuss on listserv?
16:09:31 <abneiman> +1
16:09:32 <Bmagic> I agree with eeevil about the suckage of zoom. But it's not a hill I'm willing to die on
16:10:03 <tlittle> I think we're having two different conversations and somewhat mixing them up: moving away from IRC for chat talking vs moving to a video meeting platform specifically for meetings
16:10:18 <abneiman> tlittle: yes, I think they're worthy of separate listserv convos
16:10:20 <Rogan> and I think this topic is about the meetings
16:10:31 <abneiman> my concern here is THIS meeting
16:10:31 <shulabramble> video chat is my ancient enemy, but this isn't me running a CotC game.
16:10:56 <shulabramble> We're past the hour, and still have another topic to discuss, so how about we go with:
16:11:05 <Bmagic> All* video platforms suffer from the same basic issue: the audio... the video.. the mute, everyone needs to click all the buttons and be familiar. zoom, fine
16:11:23 <shulabramble> #action abneiman will poll concerning moving the developer's meeting from IRC to a different platform
16:11:48 <shulabramble> and we can discuss that on the listserv
16:11:57 <abneiman> shulabramble++ # wranglin
16:12:03 <berick> shulabramble++
16:12:06 <redavis> shulabramble++
16:12:10 <Bmagic> shulabramble++
16:12:10 <redavis> abneiman++
16:12:18 <sandbergja> shulabramble++
16:12:21 <sandbergja> abneiman++
16:12:22 <shulabramble> abneiman++
16:12:30 <shulabramble> I own four cats. I have experience.
16:12:35 <scottangel> shulabramble++
16:12:39 <shulabramble> #topic Okay to merge LP 2055796? berick mentioned "unclear if there's any additional decision processes re: adding github actions"
16:12:41 <pinesol> Launchpad bug 2055796 in Evergreen "Have github actions run pgtap tests for us" [Undecided,Confirmed] https://launchpad.net/bugs/2055796 - Assigned to Bill Erickson (berick)
16:12:43 <smayo> shulabramble++
16:12:47 <shulabramble> sandbergja?
16:12:59 <sandbergja> yes, pasting some text
16:13:03 <sandbergja> The back story: we used to have our tests automatically running regularly (2x/day?), and alerting IRC if there was a test failure.  This has not worked for some time, so currently we don't find out about those bugs we've added to Evergreen until somebody runs the tests manually (which may be a while later).  Github offers free infrastructure for running tests, so a year ago, we decided to explore
16:13:18 <sandbergja> I have a pull request to get our pgtap (database) tests running automatically on github actions, berick has reviewed it but mentioned "unclear if there's any additional decision processes re: adding github actions".
16:13:24 <sandbergja> I figured this was the place to ask. :-)
16:13:45 <phasefx> testing would be easier with simpler installations... *runs away*
16:13:55 <sandbergja> phasefx++
16:14:00 <sandbergja> 100% agree
16:14:05 <redavis> phasefx++ #also hahahahahah
16:14:10 <shulabramble> phasefx++
16:14:14 <smayo> Bmagic++ docker
16:14:34 <sandbergja> trying to install an eg-compatible ejabberd in github actions has me totally stumped
16:14:42 <sandbergja> so I can't wait for redis to be merged
16:14:47 <sandbergja> but I'm getting off topic hahaha
16:15:30 <berick> any objections to running pgtap tests via github actions? going once?
16:15:32 <Bmagic> berick says "strong +1 to merging"
16:15:39 <Bmagic> no objections at all
16:15:55 <phasefx> no objections to anyone maintaining testing infrastructure
16:16:17 <abneiman> tests++
16:16:17 <berick> didn't think so, but it's kind of new, so..
16:16:20 <berick> sandbergja++
16:16:31 <shulabramble> sandbergja++
16:16:34 <redavis> sandbergja++
16:16:39 <sandbergja> berick++ # thanks for the review!
16:16:46 <abneiman> sandbergja++ berick++
16:16:50 <jeff> other than there being some github-specific metadata files in the repo, is there any practical effect/impact that you're concerned about?
16:17:06 <berick> jeff: nope, just covering bases
16:17:07 <mmorgan> sandbergja++
16:17:15 <jeff> good deal!
16:17:25 <jeff> sandbergja++ berick++
16:17:34 <redavis> berick++
16:18:00 <shulabramble> berick++
16:18:25 <phasefx> berick: just main?
16:18:48 <Bmagic> I find it interesting that the server upon which the test run, presumabely don't have the perl dependencies? But that's fine for the scope of the tests?
16:18:53 * phasefx belatedly pulls up the ticket
16:19:28 <shulabramble> #action it is okay to merge lp2055796, sandberg and berick will attend
16:19:46 <shulabramble> wrangling before we go a full half hour over
16:19:52 <shulabramble> #topic Announcements
16:20:08 <berick> phasefx: yes just main
16:20:13 <berick> i'm assuming, anyway
16:20:29 <sandbergja> I just want it merged somewhere :-D
16:20:36 <shulabramble> #info Next Dev Meeting on 2024-12-10
16:20:43 <shulabramble> Any other announcements?
16:21:06 <Bmagic> Evergreen rocks
16:21:18 <mantis> Bmagic++
16:21:22 <shulabramble> bmagic++
16:21:41 <Bmagic> :)
16:21:46 <shulabramble> #info "Evergreen Rocks" -- bmagic, 2024-11-12
16:22:08 <abneiman> so say we all
16:22:15 * berick salutes
16:22:32 <Dyrcona> shulabramble++
16:22:37 <shulabramble> so mote it be, y'all. and if there's nothing further.
16:22:44 <shulabramble> #endmeeting