#evergreen: 2024-12-10 - Developer Meeting

Meeting started by shulabramble at 15:00:08 US/Eastern (full logs).

Meeting summary

  1. Introductions (shulabramble, 15:00:48)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:01:02)
    2. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:01:19)
    3. sandbergja = Jane Sandberg, PUL (sandbergja, 15:01:20)
    4. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:01:22)
    5. berick Bill Erickson, KCLS (berick, 15:01:23)
    6. redavis = Ruth Frasur Davis, ECDI (redavis, 15:01:27)
    7. mantis = Gina Monti, Bibliomation (mantis, 15:01:32)
    8. briank = Brian Kennedy, BCLC (briank, 15:01:35)
    9. Stompro = Josh Stompro, LARL (Stompro, 15:01:41)
    10. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:41)
    11. sleary = Stephanie Leary, Equinox (sleary, 15:02:26)

  2. Action Items from November's Meeting (shulabramble, 15:03:36)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:03:46)

  3. eeevil will open a bug for cross-column stats targets (shulabramble, 15:03:53)
    1. ACTION: eeevil will open a bug for cross-column stats targets (shulabramble, 15:04:44)

  4. gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:05:14)
    1. ACTION: gmcharlt - create a Git commit message type and update bug 2051946 (shulabramble, 15:07:16)
    2. ACTION: waiting on gmcharlt for access to POEditor for git integration (shulabramble, 15:07:37)
    3. sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:08:04)

  5. berick will work on a rollout plan for hatch update - bug 2076921 (shulabramble, 15:11:37)
  6. sleary will make a new LP tag denoting bugs that involve string changes (shulabramble, 15:12:43)
    1. ACTION: sleary will make a new LP tag denoting bugs that involve string changes (shulabramble, 15:13:07)

  7. revisit feasibility of automated testing for string changes (shulabramble, 15:13:29)
    1. ACTION: sandbergja and sleary will revisit feasibility of automated testing for string changes (shulabramble, 15:18:54)

  8. abneiman will poll concerning moving the developer's meeting from IRC to a different platform (shulabramble, 15:19:41)
    1. ACTION: abneiman will poll concerning moving the developer's meeting from IRC to a different platform (shulabramble, 15:21:07)

  9. it is okay to merge lp2055796, sandbergja and berick will attend (shulabramble, 15:21:37)
  10. Updates (shulabramble, 15:24:29)
  11. Evergreen (shulabramble, 15:24:34)
  12. Release team members needed, signup https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit?usp=sharing (shulabramble, 15:25:06)
  13. Point releases next week? (shulabramble, 15:25:21)
  14. Hatch (shulabramble, 15:41:48)
    1. Open Bugs - 3157 (shulabramble9, 15:47:00)
    2. Pullrequests - 97 (shulabramble9, 15:47:00)
    3. Signedoff - 7 (shulabramble9, 15:47:01)
    4. Needswork - 84 (shulabramble9, 15:47:01)
    5. Needstestplan - 2 (shulabramble9, 15:47:02)
    6. Needsrebase - 24 (shulabramble9, 15:47:02)
    7. Bugs Added - 82 (shulabramble9, 15:47:03)
    8. Pullrequest tag Added - 30 (shulabramble9, 15:47:04)
    9. Signedoff tag Added - 16 (shulabramble9, 15:47:04)
    10. Needswork tag Added - 3 (shulabramble9, 15:47:05)
    11. Needstestplan tag Added - 0 (shulabramble9, 15:47:05)
    12. Needsrebase tag Added - 0 (shulabramble9, 15:47:06)
    13. Fix Committed - 31 (shulabramble9, 15:47:06)

  15. Announcements (shulabramble, 15:50:28)
    1. Next Meeting is 14 January 2025 (shulabramble, 15:50:44)


Meeting ended at 15:52:23 US/Eastern (full logs).

Action items

  1. eeevil will open a bug for cross-column stats targets
  2. gmcharlt - create a Git commit message type and update bug 2051946
  3. waiting on gmcharlt for access to POEditor for git integration
  4. sleary will make a new LP tag denoting bugs that involve string changes
  5. sandbergja and sleary will revisit feasibility of automated testing for string changes
  6. abneiman will poll concerning moving the developer's meeting from IRC to a different platform


Action items, by person

  1. abneiman
    1. abneiman will poll concerning moving the developer's meeting from IRC to a different platform
  2. sandbergja
    1. sandbergja and sleary will revisit feasibility of automated testing for string changes
  3. sleary
    1. sleary will make a new LP tag denoting bugs that involve string changes
    2. sandbergja and sleary will revisit feasibility of automated testing for string changes
  4. UNASSIGNED
    1. eeevil will open a bug for cross-column stats targets
    2. gmcharlt - create a Git commit message type and update bug 2051946
    3. waiting on gmcharlt for access to POEditor for git integration


People present (lines said)

  1. shulabramble (65)
  2. redavis (26)
  3. shulabramble9 (21)
  4. abneiman (21)
  5. Dyrcona (15)
  6. berick (13)
  7. sandbergja (12)
  8. sleary (9)
  9. mmorgan (9)
  10. pinesol (7)
  11. Bmagic (7)
  12. jeff (7)
  13. phasefx (3)
  14. mantis (1)
  15. briank (1)
  16. Stompro (1)
  17. JBoyer (1)


Generated by MeetBot 0.1.4.