15:00:08 <shulabramble> #startmeeting 2024-12-10 - Developer Meeting
15:00:08 <pinesol> Meeting started Tue Dec 10 15:00:08 2024 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <pinesol> The meeting name has been set to '2024_12_10___developer_meeting'
15:00:24 <shulabramble> We're off to the races!
15:00:48 <shulabramble> #topic Introductions
15:01:02 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:01:19 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:01:20 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:22 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:23 <berick> #info berick Bill Erickson, KCLS
15:01:27 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:01:32 <mantis> #info mantis = Gina Monti, Bibliomation
15:01:35 <briank> #info briank = Brian Kennedy, BCLC
15:01:41 <Stompro> #info Stompro = Josh Stompro, LARL
15:01:41 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:42 <phasefx> phasefx = Jason Etheridge, EOLI
15:02:26 <sleary> #info sleary = Stephanie Leary, Equinox
15:03:22 <shulabramble> People can keep introducing themselves as we get rolling
15:03:36 <shulabramble> #topic Action Items from November's Meeting
15:03:46 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:03:53 <shulabramble> #topic eeevil will open a bug for cross-column stats targets
15:04:21 <sleary> eeevil is out, but I believe that will need to carry forward
15:04:44 <shulabramble> #action eeevil will open a bug for cross-column stats targets
15:05:14 <shulabramble> #topic gmcharlt - create a Git commit message type and update bug 2051946
15:05:15 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:06:11 <shulabramble> Is gmcharlt around or do we need to kick the can on his projects right now?
15:06:46 <abneiman> I do not think gmcharlt is available right now
15:07:01 <shulabramble> Okay, then
15:07:16 <shulabramble> #action gmcharlt - create a Git commit message type and update bug 2051946
15:07:17 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:07:37 <shulabramble> #action waiting on gmcharlt for access to POEditor for git integration
15:08:04 <shulabramble> #info sleary and sandbergja will report progress on test writing wiki pages next month
15:08:19 <sleary> I've been out sick; please carry forward
15:08:24 <sleary> (sorry sandbergja!)
15:08:37 <shulabramble> Aww! Hope you're feeling better.
15:08:38 <sandbergja> no problem!
15:08:45 <redavis> Just throwing the agenda here for new people - https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2024-12-10
15:09:08 <sandbergja> one note: outside of what sleary and I were working on, I figured out how to run perl unit tests with the perl debugger
15:09:17 <shulabramble> redavis++ thanks, I've had an interesting day and that slipped my mind.
15:09:21 <sandbergja> and added my notes here in case they are useful for anyone: https://wiki.evergreen-ils.org/doku.php?id=dev:testing:debugging_perl_unit_tests
15:09:24 <shulabramble> sandbergja++
15:09:24 <sleary> sandbergja++
15:09:35 <berick> sandbergja++
15:09:42 <redavis> shulabramble++ #no worries
15:09:49 <redavis> sandbergja++
15:10:07 <Dyrcona> related to what sandbergja said, I've been meaning to update documentation on debugging Perl services with Evergreen. We had a successful attempt during the hack-away.
15:10:11 <mmorgan> sandbergja++
15:10:30 <sandbergja> Dyrcona++
15:10:32 <shulabramble> dyrcona++
15:10:37 <sandbergja> perl_debugger+-
15:10:56 <shulabramble> the perl debugger is a morally neutral agent.
15:10:59 <redavis> Dyrcona++
15:11:37 <shulabramble> #topic berick will work on a rollout plan for hatch update - bug 2076921
15:11:38 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:11:50 <shulabramble> berick want to discuss that when we get to the hatch updates section?
15:11:57 <berick> either way
15:12:00 <berick> sure
15:12:43 <shulabramble> #topic sleary will make a new LP tag denoting bugs that involve string changes
15:12:53 <sleary> whoops! on it
15:13:07 <shulabramble> #action sleary will make a new LP tag denoting bugs that involve string changes
15:13:16 <redavis> sleary++
15:13:29 <shulabramble> #topic revisit feasibility of automated testing for string changes
15:13:34 <shulabramble> berick++ sleary++
15:15:47 <shulabramble> anything on this?
15:16:04 <abneiman> tbh I don't recall whose action item that is
15:16:20 <shulabramble> neither do i.
15:18:09 <sleary> sandbergja is that something we can add to our QA list?
15:18:25 <sandbergja> Sure!  Sounds fun
15:18:54 <shulabramble> #action sandbergja and sleary will revisit feasibility of automated testing for string changes
15:18:57 <sleary> sandbergja++
15:19:02 <shulabramble> sandbergja++ sleary++
15:19:04 <sandbergja> sleary++
15:19:41 <shulabramble> #topic abneiman will poll concerning moving the developer's meeting from IRC to a different platform
15:20:12 <abneiman> haven't done that, also out sick (and I did want to talk to you about that first shulabramble as the current convener of said meeting)
15:20:46 <shulabramble> abneiman++ can do. i think you have my email? easiest way to handle talking for me right now.
15:20:54 <shulabramble> hope you're feeling better as well.
15:21:07 <shulabramble> #action abneiman will poll concerning moving the developer's meeting from IRC to a different platform
15:21:37 <shulabramble> #topic it is okay to merge lp2055796, sandbergja and berick will attend
15:21:39 <abneiman> shulabramble: yes I have your emial, thanks
15:21:51 <shulabramble> zipping through this agenda at top speed.
15:22:17 <Dyrcona> Lp 2055796
15:22:18 <pinesol> Launchpad bug 2055796 in Evergreen "Have github actions run pgtap tests for us" [Medium,Fix committed] https://launchpad.net/bugs/2055796
15:22:29 <Dyrcona> That's done.
15:22:34 <berick> yeah
15:23:00 <shulabramble> dyrcona++ berick++
15:23:10 <Dyrcona> Well, I think someone else did it.
15:23:30 <redavis> Dyrcona++ berick++
15:23:32 <Dyrcona> berick++ sandbergja++
15:23:47 <shulabramble> sandbergja++ is the merging party
15:24:11 <mmorgan> sandbergja++
15:24:29 <shulabramble> #topic Updates
15:24:34 <shulabramble> #topic Evergreen
15:25:06 <shulabramble> #topic Release team members needed, signup https://docs.google.com/spreadsheets/d/1gZayHfF7qK0zwLMEAXt-PbKBMiAM_F6EZguqzIYceBY/edit?usp=sharing
15:25:21 <shulabramble> #topic Point releases next week?
15:25:24 <Dyrcona> Before we move on, I have an idea about the spreadsheet.
15:25:38 <shulabramble> the floor is yours, Dyrcona
15:25:40 <abneiman> yeah I also have words about Rel team before we move on
15:25:49 <Dyrcona> Does anyone else think it would be useful to add a column for updating translations?
15:25:53 <abneiman> yes
15:25:57 <redavis> also yes
15:25:57 <mmorgan> yes
15:25:59 <shulabramble> yes
15:26:29 <Dyrcona> OK. I'll add one after the meeting. Should it be two? one for lp and one for poeditor, or just 1 column per release?
15:26:37 <mmorgan> Dyrcona++ for doing the translation pieces for the last point releases.
15:26:49 <shulabramble> dyrcona++
15:26:49 <redavis> also, I think it'd be worthwhile to make a copy of the spreadsheet that's owned by someone active in the EG community or with an evergreen-ils.org something.
15:27:02 <shulabramble> redavis++
15:27:02 <Dyrcona> I have a copy, but it's out of date.
15:27:10 <redavis> that'd require some relinking in places.
15:27:20 * mmorgan would vote for 2 columns, since they are two different processes.
15:27:33 <redavis> mmorgan++
15:27:40 <redavis> +1 to 2 columns
15:27:52 <abneiman> In the past, Dan Wells has been amenable to transferring ownership of things - does someone want to reach out to him?
15:28:42 <abneiman> I can do so if no one else wants to.
15:28:52 <redavis> abneiman++
15:28:57 <shulabramble> abneiman++
15:29:00 <jeff> I think we'd have better luck reaching out to the individual from Dan's former employer who has recently participated in the list / sought advice from the list.
15:29:27 <Dyrcona> I think this might be on his personal Google account. I'm not entirely sure, though.
15:29:52 <abneiman> oh, is Dan no longer with Calvin College? It does appear to be on a calvin.edu domain
15:29:57 <abneiman> It = the spreadsheet owner
15:30:25 <JBoyer> Being a GSheet, I think we're just a "Make a Copy" away from solving the problem
15:30:29 <Dyrcona> Yes, Dan is no longer with Calvin College.
15:30:36 <redavis> JBoyer, that was my thinking
15:30:58 <abneiman> yeah, then I agree with making a copy - does someone with an evergreen-ils.org email want to do that?
15:31:00 <redavis> Just get through the point releases and then make a copy and relink things
15:31:06 * redavis can do it
15:31:25 <shulabramble> redavis++
15:31:39 <redavis> I'll do it prior to two weeks from today
15:31:46 <abneiman> honestly, if you want to be really lazy, put a link to the new sheet at the top of the old one with an admonishment to update links
15:32:14 <jeff> "make a copy" is fine, but keep in mind that it loses all revision history.
15:32:19 <redavis> Oh, that's a good idea. But will also make sure that any wiki links point to the new one.
15:32:31 <jeff> (which may or may not matter here)
15:32:43 <redavis> jeff, true. We'll link it up so that that's there until the original burns up in the sun.
15:32:45 <abneiman> so speaking of that sheet, and since many of you are looking at it
15:33:00 <abneiman> 3.15 is in need of volunteers for both more-technical and less-technical roles
15:33:24 <abneiman> I'm aiming to have a kickoff meeting before Christmas hahahahahaha so ... please sign up!
15:34:24 <redavis> We also need some tarball builders/testers for next week (up to three builders, and one with lupin access)
15:34:26 <shulabramble> abneiman++
15:34:33 <abneiman> and to anticipate the question, I've already shaken the Equinox tree; you're getting me & phasefx this time around but no one else is available for this release
15:34:59 <abneiman> yes, also point releases next weel
15:35:24 <Dyrcona> I can't promise my availability next week, so we're likely going to need some new faces for lupin access, translations, and at least 1 core committer.
15:36:08 <redavis> Dyrcona++
15:36:15 <shulabramble> dyrcona++
15:37:44 <phasefx> I can do whatever core committer stuff is needed, with some moral support
15:37:49 <shulabramble> phasefx++
15:37:53 <redavis> phasefx++
15:37:57 <sandbergja> phasefx++
15:38:10 <phasefx> Hand holding, pep talk, chocolate...
15:38:18 <sandbergja> I can build and test a tarball
15:38:24 <shulabramble> sandbergja++
15:38:26 * mmorgan can probably help with point releases next week
15:38:31 <redavis> I'll call a meeting for the point releases once some more spots are filled out. So, email imminent today or tomorrow for that.
15:38:33 <sandbergja> mmorgan++
15:39:01 <redavis> And I see mantis in there as well.
15:39:01 <shulabramble> mmorgan++ redavis++
15:39:01 <abneiman> phasefx++ sandbergja++ mmorgan++
15:39:01 <Dyrcona> redavis++ mmorgan++
15:39:20 <abneiman> redavis++ mantis++
15:39:23 <Dyrcona> mantis++
15:39:43 <shulabramble> mantis++
15:39:45 <Bmagic> phasefx++ sandbergja++ mmorgan++ mantis++
15:40:00 <Bmagic> mdriscoll++
15:41:34 <shulabramble> moving on,
15:41:48 <shulabramble> #topic Hatch
15:41:54 <shulabramble> berick, the floor is yours.
15:42:23 <berick> i'm going to upload the new version to the Chrome store this week
15:42:24 <berick> prob tomorrow
15:42:29 <berick> it will not be set to auto-publish
15:42:36 <berick> review may take a few days
15:42:46 <berick> if all is well, I'll publish it next Tuesday morning
15:43:07 <redavis> berick++
15:43:13 <berick> we now have at least 3 people who have access
15:43:17 <Bmagic> berick++
15:43:18 <mmorgan> berick++
15:43:23 <sandbergja> berick++
15:44:01 <berick> and I think that's it
15:44:22 <abneiman> berick++
15:44:25 <shulabramble9> berick++
15:45:45 <jeff> berick++
15:45:53 <shulabramble9> Let's see if i can continue running the meeting or have to wait to get my name back.
15:46:05 <Bmagic> lol
15:46:24 <shulabramble9> #topic Launchpad Status as of Noon Eastern
15:46:48 <shulabramble9> Wall of text incoming!
15:46:59 <shulabramble9> #topic Launchpad Status (as of noon Eastern)
15:46:59 <shulabramble9> #topic Snapshot
15:47:00 <shulabramble9> #info Open Bugs - 3157
15:47:00 <shulabramble9> #info Pullrequests - 97
15:47:01 <shulabramble9> #info Signedoff - 7
15:47:01 <shulabramble9> #info Needswork - 84
15:47:02 <shulabramble9> #info Needstestplan - 2
15:47:02 <shulabramble9> #info Needsrebase - 24
15:47:03 <shulabramble9> #topic Updates Since Last Meeting
15:47:03 <shulabramble9> #info Bugs Added - 82
15:47:04 <shulabramble9> #info Pullrequest tag Added - 30
15:47:04 <shulabramble9> #info Signedoff tag Added - 16
15:47:05 <shulabramble9> #info Needswork tag Added - 3
15:47:05 <shulabramble9> #info Needstestplan tag Added - 0
15:47:06 <shulabramble9> #info Needsrebase tag Added - 0
15:47:06 <shulabramble9> #info Fix Committed - 31
15:47:37 <shulabramble9> #topic New Business
15:48:22 <jeff> just in case, I just added your shulabramble9 client as a chair.
15:48:31 <jeff> hah, and now the old one's gone.
15:48:49 <shulabramble> Look, this is just how my day is going.
15:48:57 <Bmagic> jeff++ # that's what you get for helping, lol
15:49:01 <shulabramble> I am utterly unsurprised.
15:49:04 <shulabramble> jeff++
15:49:32 <sleary> sometimes Tuesdays are two Mondays in a trench coat.
15:49:45 <Bmagic> haha
15:49:51 <mmorgan> :)
15:49:53 <jeff> agreed.
15:49:56 <shulabramble> this Tuesday has been two Mondays with a blackjack
15:50:13 <berick> heh
15:50:28 <shulabramble> #topic Announcements
15:50:44 <shulabramble> #info Next Meeting is 14 January 2025
15:51:13 <shulabramble> Anyone have anything else to announce?
15:51:38 <redavis> shulabramble++
15:52:13 <shulabramble> then, coming in under an hour...
15:52:23 <shulabramble> #endmeeting