15:00:03 <shulabramble> #startmeeting 2025-01-14 - Developer Meeting
15:00:03 <pinesol> Meeting started Tue Jan 14 15:00:03 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:03 <pinesol> The meeting name has been set to '2025_01_14___developer_meeting'
15:00:18 <shulabramble> #topic Introductions
15:00:36 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:40 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:00:42 <phasefx> @info phasefx = Jason Etheridge, EOLI
15:00:42 <pinesol> phasefx: (info <url|feed>) -- Returns information from the given RSS feed, namely the title, URL, description, and last update date, if available.
15:00:43 <terranm> #info terranm = Terran McCanna, PINES
15:01:06 <collum> #info collum = Garry Collum,  KCPL
15:01:10 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:13 <phasefx> #info phasefx = Jason Etheridge, EOLI :-)
15:01:15 <sleary> #info sleary = Stephanie Leary, EOLI
15:01:31 <eeevil> #info eeevil = Mike Rylander, EOLI
15:02:01 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:02:13 <berick> #info berick Bill Erickson, KCLS
15:02:20 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:02:38 <Dyrcona> #info Dyrcona = Jason Stephenson, C/W MARS
15:02:49 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:03:26 <shulabramble> People can continue to introduce themselves as they file in. :)
15:03:38 <shulabramble> #topic Action Items from Last Meeting
15:03:51 <shulabramble> #topic eeevil will open a bug for cross-column stats targets
15:04:05 <eeevil> I'm sure he will ... one day!
15:04:12 <eeevil> but today is not that day
15:04:26 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:04:28 <shulabramble> can kicked!
15:04:32 <shulabramble> #action eeevil will open a bug for cross-column stats targets
15:04:40 <jeff> (missed it by THAT much)
15:04:48 <shulabramble> #topic gmcharlt - create a Git commit message type and update bug 2051946
15:04:49 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:05:26 <shulabramble> is gmcharlt around, or should we just put both of his action items off for another month?
15:05:31 <abneiman> I don't think he's around for this meeting
15:06:00 <shulabramble> does anyone want to reach out to him about this or POEditor access?
15:06:56 <Dyrcona> The thing about POEditor is gmcharlt is apparently the only one who can do it. According to POEditor, it has to be the project owner who sets up git integration.
15:07:10 <shulabramble> dyrcona++
15:07:16 <abneiman> I will reach out to him
15:07:22 <shulabramble> abneiman++
15:07:40 <mmorgan> abneiman++
15:07:44 <abneiman> he has been poked
15:08:01 <shulabramble> #action abneiman will reach out to gmcharlt concerning bug 2051946 and POEditor git integration
15:08:02 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:08:22 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month
15:08:37 <sleary> carry over, please! sorry to keep kicking this down the road
15:08:56 <shulabramble> that's fine! I mistyped so it's already kicked :)
15:09:02 <sleary> :)
15:09:06 <shulabramble> #topic sleary will make a new LP tag denoting bugs that involve string changes
15:09:21 <sleary> whoops, that slipped my mind. Will do it this afternoon
15:09:30 <shulabramble> #action sleary will make a new LP tag denoting bugs that involve string changes
15:09:35 <shulabramble> sleary++
15:09:45 <shulabramble> #topic sandbergja and sleary will revisit feasibility of automated testing for string changes
15:09:59 <sandbergja> also please carry over!
15:10:01 <sleary> second verse, same as the first
15:10:12 <shulabramble> #action sandbergja and sleary will revisit feasibility of automated testing for string changes
15:10:23 <shulabramble> #topic abneiman will poll concerning moving the developer's meeting from IRC to a different platform
15:10:54 <abneiman> ask not for whom the can kicks
15:10:58 <abneiman> it kicks for thee!
15:10:59 <terranm> lol
15:11:01 <Dyrcona> Heh
15:11:01 <redavis> lol!
15:11:01 <berick> heh
15:11:07 <sandbergja> hahaha
15:11:16 <shulabramble> abneiman++
15:11:22 <shulabramble> world class can punter
15:11:32 <shulabramble> #action abneiman will poll concerning moving the developer's meeting from IRC to a different platform
15:11:50 <shulabramble> #topic Updates
15:12:00 <redavis> Evergreen - Monthly maintenance releases for 3.13.8 and 3.14.3 are in process right now. They're due out tomorrow, but it will likely be Thursday, January 16 before they're announced.
15:12:12 <shulabramble> redavis++
15:12:45 <terranm> maintenance_release_team++
15:13:03 <abneiman> and 3.15 has a schedule up and team meetings have commenced! https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:13:20 <redavis> abneiman++
15:13:24 <shulabramble> abneiman++ 3.15_release_team++
15:13:38 <abneiman> please populate roadmap if you have features: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.15
15:13:41 <Dyrcona> redavis++
15:13:55 <abneiman> redavis++
15:14:01 <shulabramble> Anything for docs?
15:14:30 <redavis> Not sure if this is the place for it, but there will be a bugsquash week at the end of the month for 3.15 facilitated by the intrepid terranm
15:14:46 <shulabramble> #info Evergreen - Monthly maintenance releases for 3.13.8 and 3.14.3 are in process right now. They're due out tomorrow, but it will likely be Thursday, January 16 before they're announced.
15:14:57 <mmorgan> terranm++
15:15:00 <shulabramble> #info 3.15 has a schedule up and team meetings have commenced!
15:15:02 <redavis> (sorry...typed too slow to get it into the 3.15 release update
15:15:08 <shulabramble> terranm++
15:15:21 <redavis> terranm++
15:15:28 <shulabramble> #info 3.15 -- please populate roadmap if you have features
15:15:46 <abneiman> terranm++ # hooray for BSW
15:15:49 <terranm> bugsquash for all the things Jan 27-31, feedback fest for 3.15 March 31-April 4
15:16:06 <shulabramble> #info BSW at the end of the month
15:16:19 <shulabramble> #info BSW Jan 27-31
15:16:39 <shulabramble> #info Feedback Fest for 3.15 March 31 - April 4
15:17:23 <shulabramble> If that's it for updates, then prepare thyself for Wall O' Text
15:17:41 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:17:42 <shulabramble> #topic Snapshot
15:17:42 <shulabramble> #info Open Bugs - 3198
15:17:43 <shulabramble> #info Pullrequests - 99
15:17:43 <shulabramble> #info Signedoff - 5
15:17:44 <shulabramble> #info Needswork - 85
15:17:44 <shulabramble> #info Needstestplan - 2
15:17:45 <shulabramble> #info Needsrebase - 24
15:17:45 <shulabramble> #topic Updates Since Last Meeting
15:17:46 <shulabramble> #info Bugs Added - 66
15:17:46 <shulabramble> #info Pullrequest tag Added - 18
15:17:47 <shulabramble> #info Signedoff tag Added - 13
15:17:47 <shulabramble> #info Needswork tag Added - 1
15:17:48 <shulabramble> #info Needstestplan tag Added - 0
15:17:48 <shulabramble> #info Needsrebase tag Added - 1
15:17:49 <shulabramble> #info Fix Committed - 20
15:18:22 <shulabramble> #topic New Business
15:18:37 <shulabramble> There's nothing on the agenda, but is there anything that needs discussion?
15:19:24 <shulabramble> Are we about to have a meeting clock in at under 25 minutes?
15:19:35 <jeff> berick++ for a successful and uneventful update to the Hatch Chrome Extension
15:19:45 <redavis> daaaaaahhhng
15:19:49 <terranm> berick++
15:19:49 <sleary> berick++
15:19:50 <mmorgan> berick++
15:19:52 <shulabramble> berick++ yes, that was so painless I don't think anyone noticed.
15:19:55 <mmorgan> jeff++
15:19:56 <collum> berick++
15:20:01 <shulabramble> jeff++
15:20:04 <collum> jeff++
15:20:12 <redavis> berick++
15:20:35 <abneiman> berick++
15:20:35 <shulabramble> And if that's all...
15:20:38 <redavis> Ooooohhhh...one more thing. Conference stuff
15:20:46 <shulabramble> !!!! redavis++
15:20:51 <shulabramble> the floor is yours
15:21:12 <redavis> The call for session proposals is live. The "deadline" is January 31. https://evergreen-ils.org/2025-evergreen-international-online-conference/
15:21:47 <redavis> The theme is Emerging Technologies...and we're looking for pre-conference and regular conference session proposals.
15:22:05 <redavis> I know everyone here is an extrovert who loves expounding on things...
15:22:09 <shulabramble> #topic Evergreen Online Conference 2025 -- Emerging Technologies
15:22:24 * redavis has completed her pitch.
15:22:40 <shulabramble> #info Call for session proposals is live. Deadline is January 31 -- https://evergreen-ils.org/2025-evergreen-international-online-conference/
15:22:59 <mmorgan> redavis: Are there many submissions yet?
15:23:17 <redavis> Uhhhh...I don't think so. Let me check.
15:23:46 <redavis> newp
15:23:58 <mmorgan> Plenty of opportunities!
15:24:27 <redavis> So, please...submit. Fun fact.  My first conference in 2012, I still remember berick, eeevil, and phasefx having things to say about git.
15:24:43 <csharp_> buncha gits
15:24:44 <redavis> (In the Indianapolis Hyatt)
15:24:45 <shulabramble> All positive, I assume?
15:25:12 <redavis> I mean, I was a library director without much context...so git was still a little over my technological head.
15:25:18 <redavis> positive is relative
15:25:32 <redavis> but MEMORABLE and now positive
15:25:52 <shulabramble> redavis++
15:26:02 <shulabramble> Okay, anyone have any other last minute business?
15:27:03 <shulabramble> In that case...
15:27:07 <shulabramble> #endmeeting