15:00:07 <shulabramble> #startmeeting 2025-02-11 - Developer Meeting
15:00:07 <pinesol> Meeting started Tue Feb 11 15:00:07 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <pinesol> The meeting name has been set to '2025_02_11___developer_meeting'
15:00:16 <shulabramble> #topic Introductions
15:00:27 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:00:32 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:33 <sleary> sleary = Stephanie Leary, Equinox OLI
15:00:35 <redavis> #info redavis = Ruth Frasur, ECDI
15:00:41 <berick> #info berick Bill Erickson, KCLS
15:00:43 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:00:49 <collum> #info collum = Garry Collum, KCPL
15:00:49 <sleary> #info sleary = Stephanie Leary, Equinox OLI
15:01:03 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:05 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:25 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox OLI
15:02:19 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka)
15:02:24 <csharp_> csharp = Chris Sharp, GPLS
15:02:31 <tslittle> #info tslittle = Tiffany Little, PINES
15:02:36 <csharp_> #info csharp = Chris Sharp, GPLS
15:02:37 <smayo> #info smayo = Steven Mayo, GPLS
15:03:02 <shulabramble> People can continue their introductions as we get rolling
15:03:21 <shulabramble> #topic Action Items From January
15:03:33 <shulabramble> #topic eeevil will open a bug for cross-column stats targets
15:05:00 <shulabramble> i'm taking it eeevil is not around to discuss this?
15:05:32 <terranm> #info terranm = Terran McCanna, PINES
15:06:13 <shulabramble> Kicking it down the road like I'm Jake Elliott
15:06:17 <shulabramble> #action eeevil will open a bug for cross-column stats targets
15:06:40 <shulabramble> #topic abneiman will reach out to gmcharlt concerning bug 2051946 and POEditor git integration
15:06:41 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:06:55 <abneiman> I have done half of that
15:07:18 <shulabramble> what's the word?
15:07:25 <abneiman> gmcharlt has promised to reach out about POeditor git stuff prior to the next point release cycle next week
15:07:39 <shulabramble> abneiman++ gmcharlt++
15:07:42 <abneiman> the other item is still pending
15:08:21 <shulabramble> #action awaiting word from gmcharlt concerning bug 2051946
15:08:22 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:08:47 <shulabramble> #action gmchartl will reach out about POeditor git stuff prior to the next point release cycle
15:09:04 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month
15:09:22 <sleary> some small progress has been made! more to come.
15:09:39 <shulabramble> sleary++ sandbergja++
15:10:42 <shulabramble> #topic sleary will make a new LP tag denoting bugs that involve string changes
15:10:49 <sleary> it hath been created. https://bugs.launchpad.net/evergreen/+bugs?field.tag=i18n-new-strings
15:10:58 <shulabramble> sleary++ again!
15:11:02 <sleary> I am tagging things on the 3.15 roadmap that I know involve string changes
15:11:23 <sleary> please pitch in, if your code got committed and you know it will need translator attention
15:12:09 <shulabramble> #info it hath been created. https://bugs.launchpad.net/evergreen/+bugs?field.tag=i18n-new-strings
15:12:32 <abneiman> sleary++
15:13:01 <shulabramble> #info if your code has been committed and you need it needs translator attention please attach the new tag
15:13:18 <shulabramble> i cannot type today. or count.
15:13:50 <shulabramble> #topic abneiman will poll concerning moving the developer's meeting from IRC to a different platform
15:14:11 <abneiman> mmmm yes I suppose you & I should talk about that shulabramble ... someday
15:14:17 <terranm> I'll add the new tag to the official tags list
15:14:18 <abneiman> why does time keep happening
15:14:24 <shulabramble> terranm++
15:14:28 <redavis> lol, abneiman
15:14:35 <shulabramble> look, with everything else going on...
15:14:40 <csharp_> abneiman: because inertia
15:14:59 <sleary> terranm I just did
15:15:00 <redavis> csharp_: add "why does time keep happening?" to quotes
15:15:04 <redavis> please
15:15:07 <terranm> nvm sleary has that page locked
15:15:15 <csharp_> @quote add < abneiman> why does time keep happening
15:15:15 <pinesol> csharp_: The operation succeeded.  Quote #250 added.
15:15:27 <redavis> csharp_++
15:15:32 <abneiman> csharp_++
15:15:36 <shulabramble> csharp_++
15:15:44 <sleary> terranm it took me a minute to remember where that page was :)
15:16:05 <terranm> sleary++
15:16:20 <shulabramble> sleary++
15:17:08 <shulabramble> #action abneiman will discuss moving the developer's meeting with shulabramble and poll the community
15:17:25 <shulabramble> #topic Updates
15:17:33 <shulabramble> #topic Release Info
15:17:48 <redavis> Please sign up - https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:18:02 <redavis> point releases are due out next week.
15:18:13 <shulabramble> #topic Evergreen
15:18:33 <shulabramble> #info Please sign up - https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:18:38 <redavis> We specifically need help with translations and
15:18:49 <redavis> And that's about it, actually for the point releases
15:19:02 <shulabramble> redavis++
15:19:05 <redavis> It'll be 3.14.4 and 3.13.9
15:19:28 <redavis> Oh, we need a builder for 3.13.9 (and the parts that go along with that)
15:19:29 <abneiman> redavis++
15:20:10 <redavis> And tester (apologies - my attention is fragmented)
15:20:34 <shulabramble> #topic Documentation
15:20:53 <shulabramble> #info Documentation Interest Group met on Thursday, Feb. 6
15:21:02 <shulabramble> #info Had a recap from BSW
15:21:08 <redavis> Also, it is likely that this will be the last maintenance release wrangling I can do - so it would be good for someone else to think about it for March.
15:21:17 <shulabramble> #info Went over previous months' actions and updates
15:21:27 <shulabramble> #info Live demo of using Github for docs submissions
15:21:31 <shulabramble> redavis++
15:21:40 <shulabramble> #info Next meeting: Thursday, March 6
15:21:57 <shulabramble> Anything else documentation related from anyone?
15:23:04 <shulabramble> Silence is complicity in my speedrun of the agenda :)
15:23:19 <shulabramble> Which means it's time to have an incoming wall o' text
15:23:29 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:23:30 <shulabramble> #topic Snapshot
15:23:30 <shulabramble> #info Open Bugs - 3221
15:23:31 <shulabramble> #info Pullrequests - 73
15:23:31 <shulabramble> #info Signedoff - 17
15:23:32 <shulabramble> #info Needswork - 86
15:23:32 <shulabramble> #info Needstestplan - 2
15:23:33 <shulabramble> #info Needsrebase - 25
15:23:33 <shulabramble> #topic Updates Since Last Meeting
15:23:34 <shulabramble> #info Bugs Added - 69
15:23:34 <shulabramble> #info Pullrequest tag Added - 48
15:23:35 <shulabramble> #info Signedoff tag Added - 61
15:23:35 <shulabramble> #info Needswork tag Added - 9
15:23:36 <shulabramble> #info Needstestplan tag Added - 0
15:23:36 <shulabramble> #info Needsrebase tag Added - 1
15:23:37 <shulabramble> #info Fix Committed - 55
15:24:04 <shulabramble> #topic New Business
15:24:11 <shulabramble> Anything new we need to discuss?
15:25:26 <shulabramble> I feel like everyone is operating in stunned silence these days, to be honest.
15:25:37 <shulabramble> #topic Announcements
15:25:46 <shulabramble> #info Next Meeting is 11 March 2025
15:26:21 <shulabramble> Anyone have anything more to announce right now? Good news? a moment of joy?
15:26:50 <mmorgan> This goes back to releases
15:26:58 <redavis> mmorgan++
15:27:03 * phasefx looks for Rod Serling
15:27:05 <shulabramble> mmorgan++
15:27:25 <mmorgan> abneiman organized a meeting of folks experienced with building for the 3.15 team.
15:27:35 <terranm> My moment of joy was how much got accomplished during BSW
15:27:39 <sleary> Galen's document on new tables and columns is a thing of joy, and I'm going to make a similar one for grid UIs
15:27:51 <shulabramble> terran++ sleary++
15:28:01 <shulabramble> terranm++
15:28:03 <mmorgan> It was helpful in may ways, but it should be noted that more folks now have access to do translations for releases.
15:28:06 <abneiman> moment of joy: Monday code review merged two roadmap items for 3.15 https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.15
15:28:18 <redavis> mmorgan++
15:28:23 <terranm> monday-code-review++
15:28:30 <shulabramble> gmcharlt++ abneiman++ monday-code-review++
15:28:43 <shulabramble> bug-squashers++
15:28:46 <mmorgan> code-review = moments-of-joy
15:29:29 <shulabramble> mmorgan that is very, very true
15:29:29 <redavis> And, if I may, we need someone to volunteer for translations for the point releases and/or 3.15.
15:29:31 <sleary> the committers met on Monday morning to welcome tslittle and review committing workflows (for those of us also relatively new to the process)
15:29:57 <shulabramble> #info volunteers needed for translations for point releases and/or 3.15
15:30:35 <mmorgan> committers-meeting++
15:30:48 <shulabramble> tslittle++
15:30:50 <mmorgan> tslittle++
15:32:03 <shulabramble> and 37 (octal) minutes after we began
15:32:13 <shulabramble> #endmeeting