15:00:07 <shulabramble> #startmeeting 2025-03-11 - Developer Meeting
15:00:07 <pinesol> Meeting started Tue Mar 11 15:00:07 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:07 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <pinesol> The meeting name has been set to '2025_03_11___developer_meeting'
15:00:19 <shulabramble> And we're off!
15:00:34 <shulabramble> #topic Introductions
15:00:38 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:00:38 <kmlussier> #info kmlussier is Kathy Lussier, NOBLE
15:00:50 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:00:52 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:00:53 <briank> #info briank = Brian Kennedy, BCLC
15:00:53 <phasefx> #info phasefx = Jason Etheridg, EOLI
15:00:54 <redavis> #info redavis = Ruth Frasur Davis, Evergreen Collaborative Development Initiative (ECDI)
15:01:00 <shulabramble> #info shulabramble = Shula Link, GCHRL (and Clarabelle the Stuffed Bunny joins me today)
15:01:00 <mmorgan1> #info mmorgan = Michele Morgan, NOBLE
15:01:23 <smayo> #info smayo = Steven Mayo, PINES
15:01:25 <abneiman> Clarabelle++
15:01:43 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:02:47 <sleary> #info sleary = Stephanie Leary, EOLI
15:02:56 <mantis> # info mantis = Gina Monti, Bibliomation
15:03:00 <terranm> #info terranm = Terran McCanna, PINES
15:03:19 <eeevil> #info eeevil = Mike Rylander, EOLI
15:04:14 <shulabramble> Latecomers can continue to make introductions as we get going
15:04:27 <shulabramble> #topic Action Items from Last Meeting
15:04:50 <shulabramble> #topic eeevil will open a bug for cross-column stats targets
15:05:28 * eeevil looks in the tuit basket, sees none growing ...
15:05:36 <eeevil> not yet :(
15:05:57 <shulabramble> #action eeevil will open a bug for cross-column stats targets
15:06:20 <shulabramble> #topic awaiting word from gmcharlt concerning bug 2051946
15:06:21 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:07:04 <shulabramble> who was in contact with Galen about this? probably should've made a note of that in the action item :)
15:07:48 <abneiman> nominally me, but I can promise that his tuits basket is similarly empty
15:08:44 <shulabramble81> Anything on the the git commit message template?
15:08:59 <Dyrcona> It doesn't have to be gmcharlt who creates a commit template.
15:09:30 <shulabramble81> True enough. Does anyone want to volunteer to take this on?
15:09:51 <Dyrcona> I'll at least have a look to see what's required.
15:09:58 <shulabramble81> Dyrcona++
15:10:05 <Bmagic> Dyrcona++
15:10:11 <redavis> Dyrcona++
15:10:34 <shulabramble81> #action Dyrcona will look into bug 2051946
15:10:36 <pinesol> Launchpad bug 2051946 in Evergreen "institute a Git commit message template" [Wishlist,New] https://launchpad.net/bugs/2051946 - Assigned to Galen Charlton (gmc)
15:11:13 <Dyrcona> I know how to add one locally at least.
15:11:33 <shulabramble81> #topic gmcharlt will reach out about POeditor git stuff prior to next point release cycle
15:11:54 <abneiman> this has been done, AFAIK
15:12:06 <abneiman> but anyone who is actually a POeditor user should confirm
15:12:41 <shulabramble> do we have a POeditor in the house?
15:12:54 <redavis> I believe that mantis is now.
15:13:08 <redavis> And perhaps also mmorgan
15:13:16 <sleary> and Dyrcona, I believe
15:13:21 <redavis> Yes
15:14:31 <mantis> I was only able to do it once so far in the releases
15:14:46 * mmorgan is a POeditor, what am I looking for?
15:15:02 <Dyrcona> I don't know if we have git integration with POEditor. I haven't heard anything and haven't looked.
15:16:53 <shulabramble> so what I think I'm hearing is we need testing to confirm the integration?
15:17:20 <redavis> shulabramble, I guess so.
15:17:30 <abneiman> sounds that way, I can ping gmcharlt again
15:17:46 <shulabramble> abneiman++ redavis++
15:17:52 <redavis> Or someone to verify/confirm that gmcharlt did follow up.
15:17:59 <redavis> abneiman++
15:18:28 <shulabramble> #action abneiman will follow up with gmcharlt cf. git POeditor integration
15:18:39 <mmorgan> In POeditor, I see GitLab and GitHub in 'Integrations', but those both lead to: 'You do not have the right plan to access this feature'
15:18:50 <Dyrcona> I'm looking at POEditor, and I can't tell.
15:19:33 <Dyrcona> Under the project settings, it looks like integration still needs to be set up.
15:20:25 <abneiman> can any poeditor admin do that?
15:20:39 <Dyrcona> Nope. Only the project owner.
15:20:40 <redavis> It needed to be the "owner"
15:20:49 <redavis> Which is gmcharlt
15:20:51 <abneiman> bleh ok
15:20:59 <Dyrcona> "Integrations with Git hosting services can be used to easily transfer strings between POEditor and Git repos. They can be set up by the project owner (user or organization)."
15:21:46 <abneiman> let's move on, I'll post an update later if I have one
15:21:53 <shulabramble> abneiman++
15:21:56 <redavis> abneiman++
15:22:13 <Bmagic> maybe we should first, make an agenda item to get that account under an EG generic account rather than an individual?
15:22:40 <shulabramble> I was going to ask if that's a bottleneck we need to address
15:23:32 <Dyrcona> Well, in the long run, yes.
15:24:08 <Bmagic> I'll take the action item if you want
15:24:26 <shulabramble> and transferring ownership would have to be discussed with gmcharlt
15:24:30 <shulabramble> bmagic++
15:25:10 <shulabramble> #action Bmagic will look into transferring POeditor account ownership to a generic EG account
15:25:33 <shulabramble> #topic sleary and sandbergja will report progress on test writing wiki pages next month
15:26:18 <sleary> still in progress
15:26:30 <shulabramble> sleary++
15:26:36 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month
15:26:47 <shulabramble> and the last item from last month...
15:26:56 <shulabramble> #topic abneiman will discuss moving the developer's meeting with shulabramble and poll the community
15:27:09 * abneiman waves hands
15:27:11 <abneiman> nope nope
15:27:15 <shulabramble> i know this hasn't happened but will one day! :)
15:27:21 <abneiman> someday
15:27:24 <Bmagic> IRC for life
15:27:30 <Dyrcona> Heh.
15:27:30 <redavis> ugh
15:27:34 <Bmagic> lol
15:27:48 <abneiman> I lowkey hate IRC meetings but I have just been swamped
15:28:00 * shulabramble tattoos #evergreen 4 lyfe on her forearm.
15:28:03 <Bmagic> lowkey <- hilarious
15:28:36 <Bmagic> say it fast and it sound like a Marvel character
15:28:37 <mmorgan> shulabramble++
15:28:42 <shulabramble> abneiman++ we'll get around to it before 2026
15:28:46 <shulabramble> hopefully
15:28:50 * abneiman knocks on wood
15:28:52 <eeevil> obligatory https://xkcd.com/1782/
15:29:05 <mantis> xkcd++
15:29:17 <shulabramble> xkcd++
15:29:17 <redavis> And Skype just closed
15:29:29 <redavis> (or is closing)
15:29:34 <shulabramble> I'm fully in favor of the galactic consciousness singularity
15:29:39 <abneiman> eeevil++
15:29:42 <Bmagic> eeevil++
15:29:47 <redavis> eeevil++
15:29:55 * redavis wants a nap before the singularity
15:30:03 <shulabramble> Bene Gesserit mind melding or something in the wake of the Butlerian Jihad
15:30:08 <shulabramble> eeevil++
15:30:19 <redavis> ugh. bene gesserit. I want another nap.
15:30:21 <Dyrcona> shulabramble++
15:30:31 <Dyrcona> eeevil++
15:30:35 <shulabramble> #action abneiman will discuss moving the developer's meeting with shulabramble and poll the community
15:30:47 <shulabramble> #topic Updates
15:30:58 <abneiman> ... at some point hopefully prior to the singularity and/or the heat death of the universe
15:31:18 <redavis> heat_death_of_the_universe++
15:31:23 <shulabramble> if it takes until the singularity, it takes until the singularity. at least that will make the discussion easier.
15:31:24 <Dyrcona> The singularity has already come. You just haven't noticed, yet.
15:31:35 <abneiman> sob
15:31:40 <Bmagic> agreed
15:31:41 <shulabramble> twist: the singularity uses IRC internally.
15:31:48 <Bmagic> hence: we're in IRC
15:31:48 <Dyrcona> Though, I guess it depends on what you mean by singularity.
15:31:51 <redavis> shulabramble++
15:32:11 <phasefx> other than polish, I don't know why web interface to IRC isn't good enough for people ;)
15:32:15 <eeevil> let's just use slac-- oh...
15:32:39 <shulabramble> there's nothing on the agenda re:Updates for OpenSRF, Evergreen, or Hatch. Any news on those fronts that needs reporting?
15:32:46 <abneiman> yes there is! refresh!
15:32:57 <redavis> phasefx, it allows people too much flexibility to "multi-task"
15:33:14 <shulabramble> abneiman++
15:33:18 <abneiman> feature slush is tomorrow - please pullrequest those feature!
15:33:23 <shulabramble> #topic Evergreen
15:33:29 <phasefx> redavis: ah, we're wanting cameras
15:33:45 <shulabramble> #info Feature Slush is 12-03-2025
15:33:53 <redavis> phasefx, if that's what it takes for engagement and attention...
15:34:37 <abneiman> #info request from core committers to review / signoff / merge features prior to freeze, currently scheduled for Tuesday March 18
15:34:45 <shulabramble> #info Beta 3.15 scheduled for Wednesday 26-03-2025
15:34:47 <abneiman> #info https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:3.15
15:34:56 <shulabramble> abneiman++
15:35:09 <redavis> This also brings up the question of monthly maintenance releases
15:35:13 <mmorgan> abneiman++
15:35:16 <redavis> Maintenance releases 3.14.4 and 3.13.9 were released in February with very little drama. Many thanks to the release team.
15:35:16 <redavis> Maintenance releases 3.14.5 and 3.13.10 are currently scheduled for March 19. Currently there are 4 commits for 3.14.5 and 2 for 3.13.10. With the upcoming major release of 3.15, could/should these releases be postponed?
15:35:17 <eeevil> <voice style="bernie"> I AM ONCE AGAIN ASKING FOR YOUR SUPPORT </> ... or, at least eyes, for looking at https://bugs.launchpad.net/evergreen/+bug/2067414, the RESTful API server
15:35:17 <pinesol> Launchpad bug 2067414 in Evergreen "wishlist: RESTful API for Patron Tools" [Wishlist,Confirmed]
15:35:21 <abneiman> hold please, I'm not done with 3.15
15:35:32 <shulabramble> #info Feedback fest 3/31-4/4
15:35:45 <abneiman> (this is why I hate IRC meetings in case anyone cared or was wondering)
15:35:53 <redavis> abneiman++
15:36:03 <Dyrcona> You'd still have this problem in other venues, no?
15:36:30 <abneiman> from EOLI, I can tell you that RESTful API is pullrequested and eeevil is here to answer questions. We will likely be slapping pullrequests on Item Alerts Notes and Tags, as well as Quipu eCard, before the end of the day tomorrow
15:37:14 <abneiman> and no, Dyrcona, in my not-so-limited experience, crosstalk in videoconferencing meetings is far less disruptive
15:37:22 <shulabramble> as someone who likes IRC, it's easier to set one person as "having the floor" in Zoom or similar
15:37:37 <Dyrcona> Oh... Videoconferencing......
15:37:38 <abneiman> anyway. Anyone else who wants to mention / advocate for / call attention to features please do so
15:37:52 <abneiman> as we try valiantly to stay on topic for more than 90 seconds
15:38:22 <Bmagic> what is time anyway?
15:38:26 <Dyrcona> I don't have anything to advocate for, but I'll see if I can look at some of the things you mentioned, like ecard.
15:38:37 <jeffdavis> I think the REST API feature bears some broader community input before being committed.
15:38:41 <shulabramble> dyrcona++
15:38:48 <abneiman> regardless, given the amount of committers in this here IRC meeting, I'd appreciate if y'all can review and move along anything on that 3.15 feature list
15:38:51 <eeevil> I'd DEARLY love eyes on https://bugs.launchpad.net/evergreen/+bug/2091748 which is an ingest performance improvement
15:38:52 <pinesol> Launchpad bug 2091748 in Evergreen "Concurrent browse entry update/insert" [Undecided,New]
15:39:11 <abneiman> jeffdavis: are there particular concerns you have with API?
15:40:30 <jeffdavis> Yes. I will post a comment on the LP bug. Right now I'm mostly asking other devs to look and weigh in.
15:40:40 <shulabramble> jeffdavis++
15:40:49 <abneiman> jeffdavis++ thanks, I am asking that as well
15:41:02 <abneiman> anyway, I cede the floor to redavis and point releases now
15:41:04 <eeevil> yes, please, more eyes!
15:41:04 <Bmagic> eeevil++ # I will install that patch and run some stuff
15:41:12 <shulabramble> #topic Point Releases
15:41:13 <redavis> Recopying - Maintenance releases 3.14.4 and 3.13.9 were released in February with very little drama. Many thanks to the release team.
15:41:13 <redavis> Maintenance releases 3.14.5 and 3.13.10 are currently scheduled for March 19. Currently there are 4 commits for 3.14.5 and 2 for 3.13.10. With the upcoming major release of 3.15, could/should these releases be postponed?
15:41:51 <mantis> postpone++ if there are few commits personally
15:41:57 <redavis> And, whether they are postponed or not, we need volunteers. Sign up today...tomorrow...yesterday...
15:42:06 <redavis> https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:42:13 <Dyrcona> I'd say it depends on if we think more bug fixes will go in after and if we think enough hands will be available to roll them out.
15:42:48 <shulabramble> redavis++ dyrcona++
15:42:55 <abneiman> no opinion on postponement, but noting that this will put April 16th as releaseapalooza with 3.15.0 as well as point releases slated for the same day. Not a blocker, just an observation.
15:43:01 <redavis> Well, the other question is who is going to have time given the very close proximity to 3.15. I will roll either way.
15:44:06 <jeffdavis> I wonder if bug 2073561 (on the agenda under new business) warrants a point release sooner rather than later?
15:44:07 <pinesol> Launchpad bug 2073561 in Evergreen "Incorrect content in the config.coded_value_map after applying the upgrade script from 3.12.3 to 3.13.0" [High,Confirmed] https://launchpad.net/bugs/2073561
15:44:37 <Dyrcona> jeffdavis: Will a month make much difference?
15:45:18 <Dyrcona> I think that's what we're looking at 3 to 4 weeks later for the releases, right?
15:46:02 <redavis> The next date for maintenance releases would be April 16
15:46:22 <jeffdavis> I don't know if it makes much difference.
15:46:45 <jeffdavis> We are upgrading to 3.14 less than a month from now, but we are familiar enough with the issue that we're already incorporating the fix.
15:46:55 <Dyrcona> We could try to roll with the 3.15-beta release.
15:47:06 <redavis> my two cents are that we either postpone this month or next.
15:47:23 <jeffdavis> We do want the fix in the next point releases whenever those are. I will defer to the folks actually doing the release work on scheduling.
15:47:45 <Dyrcona> So, basically skip this month, which is what i was originally thinking.
15:48:31 <redavis> I'm cool with that, but I would still encourage people to, then, sign up to help with what would be April maintenance releases.
15:48:45 <redavis> So far, it's no one.
15:48:46 <Dyrcona> Does anyone here install monthly updates and have an opinion that we're not hearing?
15:49:02 <abneiman> yes, definitely sign up - since several release people will be tied up with 3.15 during the same time period!
15:49:08 <Dyrcona> Well, there's the issue of volunteers, too.
15:49:14 <shulabramble> #info sign ups are needed for point releases https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:49:16 <redavis> (always)
15:49:29 <mantis> if it's for sure postponed, I don't mind filling in for the point releases
15:50:01 <Dyrcona> Sounds to me like we're postponing.
15:50:02 <redavis> Let's say that it's for sure postponed
15:50:25 <redavis> mantis++
15:50:36 <mantis> redavis++
15:50:37 <redavis> bmagic++
15:50:42 <shulabramble> #info point releases for march postponed until april
15:50:48 <mantis> bmagic++
15:50:49 <shulabramble> redavis++ bmagic++ mantis++
15:51:11 <shulabramble> We've got ten minutes left in the hour, so let's clip along
15:51:20 <shulabramble> #topic Documentation
15:51:48 <redavis> mmorgan++
15:51:58 <shulabramble> #info DIG met on March 6
15:52:10 <shulabramble> #info Quick meeting, updates on individuals' documentation projects and questions
15:52:19 <shulabramble> #info Also got an update on TEP Board's discussion of AI/LLM use with/for documentation. Broader community discussion planned by the Board for Hackfest.
15:52:27 <shulabramble> #info Debbie will be working to get previous meeting recordings up on the YouTube site
15:52:35 <shulabramble> #info Next meeting, April 3
15:52:45 <shulabramble> #info https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meetings
15:53:00 <shulabramble> Any other documentation info to be discussed?
15:53:10 <sleary> not DIG's purview, but--
15:53:34 <sleary> we have an updated VPAT/ACR for 3.14 and it's a vast improvement since 3.11 https://wiki.evergreen-ils.org/doku.php?id=accessibility:vpat
15:53:43 <shulabramble> sleary++
15:53:44 <sleary> for anyone who needs that documentation!
15:53:51 <mantis> sleary++
15:54:06 <shulabramble> #info we have an updated VPAT/ACR for 3.14 and it's a vast improvement since 3.11 https://wiki.evergreen-ils.org/doku.php?id=accessibility:vpat
15:54:19 <redavis> sleary++
15:54:44 <abneiman> sleary++ indeed
15:54:54 <sleary> thanks to the Board for commissioning that
15:55:02 <redavis> It's definitely a feel good doc this time around. Or a "feel better" doc.
15:55:02 <shulabramble> board++
15:55:35 <shulabramble> now everyone brace for the wall of text
15:55:38 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:55:39 <shulabramble> #topic Snapshot
15:55:39 <shulabramble> #info Open Bugs - 3250
15:55:40 <shulabramble> #info Pullrequests - 83
15:55:40 <shulabramble> #info Signedoff - 21
15:55:41 <shulabramble> #info Needswork - 88
15:55:41 <shulabramble> #info Needstestplan - 2
15:55:42 <shulabramble> #info Needsrebase - 26
15:55:42 <shulabramble> #topic Updates Since Last Meeting
15:55:43 <shulabramble> #info Bugs Added - 77
15:55:43 <shulabramble> #info Pullrequest tag Added - 26
15:55:44 <shulabramble> #info Signedoff tag Added - 15
15:55:44 <shulabramble> #info Needswork tag Added - 4
15:55:45 <shulabramble> #info Needstestplan tag Added - 0
15:55:45 <shulabramble> #info Needsrebase tag Added - 1
15:55:46 <shulabramble> #info Fix Committed - 11
15:56:35 <shulabramble> #topic New Business
15:56:57 <shulabramble> #topic https://bugs.launchpad.net/evergreen/+bug/2073561 Action before next point releases?
15:56:58 <pinesol> Launchpad bug 2073561 in Evergreen "Incorrect content in the config.coded_value_map after applying the upgrade script from 3.12.3 to 3.13.0" [High,Confirmed]
15:57:18 <mmorgan> Wanted to put this out there since it's an important bug, and needs to be addressed before the next releases.
15:57:45 <shulabramble> mmorgan++
15:58:11 <mmorgan> Does anyone have concerns about Bmagic's branch?
15:58:44 <sleary> Bmagic IIRC you said that it would overwrite people's local CCVM data rather than just leaving it as it was before the upgrade?
15:59:14 <Bmagic> confirmed: it will truncate your table. But it's clear from the release notes
16:00:20 <shulabramble> bmagic++
16:00:46 <csharp_> what a mess
16:00:53 <mmorgan> I think I read it incorrectly then. Does it not just remove the upgrade script and see data and leave the tables as they were before upgrade?
16:01:02 <mmorgan> /see/seed
16:01:12 <kmlussier> I need to run to another meeting, but i just wanted to add my two cents that my main concern is that the upgrade script be removed so that no more EG libraries create a mess of this table.
16:01:44 <shulabramble> kmlussier++
16:01:57 <sleary> kmlussier++
16:01:58 <Bmagic> My branch does remove the upgrade script, as well as the 961 file
16:02:30 <Dyrcona> I'd like to look at it more closely, but I agree we should just drop the 1416 upgrade.
16:02:55 <Bmagic> https://git.evergreen-ils.org/?p=working/Evergreen.git;a=blobdiff;f=Open-ILS/src/sql/Pg/upgrade/1416.data.updated_marc_tag_tables.sql;h=d91c0b6007095d5c7cf54d22052940c8e42a5491;hp=497e2f5a9af547ecec23a40e50664cdaf57c4fd4;hb=41a25170491f727c815ceb7b5bdc283a009d5259;hpb=7b18b3bd51fc72e1b4fba68391085c02d9b92bad
16:03:02 <Bmagic> that probably got clipped
16:03:17 <csharp_> Bmagic: maybe add a \qecho or RAISE NOTICE notifying an admin to see the bug report or the docs/release notes?
16:03:23 * mmorgan would lean toward dropping the upgrade script, and not touching the tables.
16:03:46 <Dyrcona> Yeah, but I don't have time to come to an opinion right now. I think we could avoid replacing ccvm if the previous upgrade has not been run.
16:03:59 <csharp_> include the script as an example/option?
16:04:12 <csharp_> (data truncate/replacement script, I mean)
16:04:23 <Bmagic> https://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=41a25170491f727c815ceb7b5bdc283a009d5259
16:05:33 <Dyrcona> Looks like the fix is optional, but I still want to look at the whole thing.
16:05:43 <Bmagic> right: optional
16:05:55 <shulabramble> dyrcona++
16:06:14 <mmorgan> We can continue discussion on the lp bug, and now have a little more breathing room before releases.
16:06:44 <shulabramble> mmorgan++
16:06:53 <Dyrcona> I've assigned the bug to myself. I'll take a look this week.
16:07:02 <csharp_> Dyrcona++
16:07:03 <mmorgan> Dyrcona++
16:07:23 <shulabramble> #action Dyrcona will look at https://bugs.launchpad.net/evergreen/+bug/2073561
16:07:24 <pinesol> Launchpad bug 2073561 in Evergreen "Incorrect content in the config.coded_value_map after applying the upgrade script from 3.12.3 to 3.13.0" [High,Confirmed] - Assigned to Jason Stephenson (jstephenson)
16:07:36 <shulabramble> #topic Announcements
16:07:48 <shulabramble> #info Next Meeting is April 8, 2025
16:07:57 <shulabramble> anything else?
16:07:59 <csharp_> I have something
16:08:11 * shulabramble cedes the floor to csharp_
16:08:34 <csharp_> those of you watching IRC within the last couple of weeks saw my misadventures with Mailman...
16:08:41 <csharp_> bug 2062960
16:08:42 <pinesol> Launchpad bug 2062960 in mailman-suite (Ubuntu) "ubuntu 24.04 mailman3-web fails install on clean system" [Undecided,Confirmed] https://launchpad.net/bugs/2062960
16:08:42 * redavis nods
16:09:13 <csharp_> current status is that the mail side of the lists are functional, and we can admin/moderate directly on the server for the moment
16:09:59 <shulabramble> csharp++
16:10:04 <mmorgan> csharp_++
16:10:04 <csharp_> we have a firewall change ticket in with ITS that I should hear back about this week, which will allow us to use LetsEncrypt to install SSL certs and finally get the web stuff going
16:10:11 <shulabramble> csharp_++ even
16:10:23 <redavis> csharp_++
16:10:29 <csharp_> sorry for the trouble - 20.04 is going out of support and I don't like having things linger
16:10:51 <csharp_> would have planned it properly if I had done a tiny bit of research
16:11:11 <shulabramble> no trouble at all, these things happen and there's been A Lot Going On
16:11:36 <Dyrcona> What about switching to Debian?
16:12:03 <csharp_> Dyrcona: I looked at that - similar issues on currently-supported Debian stable releases
16:12:31 <csharp_> basically there are gaps between OS releases even having a Mailman package to install at all
16:12:52 <csharp_> 24.04 is basically current sid, or maybe testing
16:13:25 <csharp_> so kind of a bad situation from top to bottom
16:15:25 <shulabramble> csharp_++
16:15:29 <shulabramble> anything else?
16:15:56 <shulabramble> in that case
16:15:58 <Bmagic> what about installing from source? Or was that already covered?>
16:16:10 <redavis> shulabramble++
16:16:14 <csharp_> Bmagic: I used Python pip to install it
16:16:24 <csharp_> which has worked fine
16:16:39 <Bmagic> cool
16:16:41 <csharp_> the web side needs valid SSL to proceed
16:16:45 <csharp_> it's close
16:16:53 <Bmagic> so, really, it's all setup, just need certs now?
16:16:57 <csharp_> yeahp
16:17:23 <Bmagic> shulabramble: sorry, continue
16:17:31 <shulabramble> it's okay!
16:17:45 <shulabramble> I was just going to say
16:17:47 <shulabramble> #endmeeting