15:00:11 <shulabramble> #startmeeting 2025-04-08 - Developer Meeting
15:00:11 <pinesol> Meeting started Tue Apr  8 15:00:11 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:11 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <pinesol> The meeting name has been set to '2025_04_08___developer_meeting'
15:00:23 <shulabramble> #topic Introductions
15:00:36 <shulabramble> #info Shula Link - Greater Clarks Hill Regional Library
15:00:54 <redavis> #info redavis = Ruth Frasur Davis, Evergreen Collaborative Development Initiative (ECDI)
15:01:02 <terranm> #info terranm = Terran McCanna, PINES
15:01:06 <berick> #info berick Bill Erickson, KCLS
15:01:09 <terranm> I almost spelled my own name wrong just now
15:01:09 <collum> #info collum = Garry Collum, KCPL
15:01:11 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:01:18 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:19 <csharp_> #info csharp = Chris Sharp, GPLS
15:01:23 <abneiman> terranm: saaaame
15:01:35 <mantis> #info mantis = Gina Monti, Bibliomation
15:01:44 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:01:49 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:50 <sleary> #info sleary = Stephanie Leary, Equinox
15:02:10 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:03:02 <shulabramble> Latecomers feel free to continue introductions!
15:03:10 <shulabramble> #topic Action Items from Last Meeting
15:03:14 <briank> #info briank = Brian Kennedy, BCLC
15:03:27 <shulabramble> #topic eeevil will open a bug for cross-column stats targets
15:05:16 <jeffdavis> Should we maybe remove that one as an action item?
15:05:28 <shulabramble> maybe we should.
15:05:38 <shulabramble> general opinion of the room?
15:06:19 <abneiman> +1 to remove
15:06:55 <sleary> +1
15:06:57 <berick> can always add it back
15:07:04 <collum> +1
15:07:35 <terranm> +1
15:07:57 <shulabramble> #agree remove the action item cf. the cross-column stats targets bug for now
15:08:12 <shulabramble> #topic Dyrcona will look into bug 2051946
15:08:13 <pinesol> Launchpad bug 2051946 in Evergreen 3.14 "institute a Git commit message template" [Wishlist,Fix committed] https://launchpad.net/bugs/2051946
15:09:19 <shulabramble> as dyrcona isn't here, let's kick that along
15:09:25 <shulabramble> #action Dyrcona will look into bug 2051946
15:09:26 <pinesol> Launchpad bug 2051946 in Evergreen 3.14 "institute a Git commit message template" [Wishlist,Fix committed] https://launchpad.net/bugs/2051946
15:09:26 <mmorgan> Fix has been committed for that
15:09:44 <shulabramble> OH I never learned to read, apparently.
15:09:57 <mmorgan> :)
15:10:05 <shulabramble> moving on!
15:10:06 <mmorgan> Dyrcona++
15:10:16 <shulabramble> #topic abneiman will follow up with gmcharlt cf. git POeditor integration
15:10:46 <abneiman> this has been done and I believe gmcharlt followed up with appripriate parties - Dyrcona, can you confirm?
15:11:05 <redavis> Dyrcona isn't here.
15:11:22 <shulabramble> abneiman++
15:11:31 <abneiman> oh well, "not-reading is fundamental" is today's theme >_<
15:11:49 <abneiman> anyway I think this is done, unless told to the contrary
15:12:04 <shulabramble> yay!
15:12:15 <shulabramble> #topic Bmagic will look into transferring POeditor account ownership to a generic EG account
15:12:45 <Bmagic> I did some poking around
15:13:04 <Bmagic> defer for next time
15:13:17 <shulabramble> #action Bmagic will look into transferring POeditor account ownership to a generic EG account
15:13:27 <shulabramble> #topic sleary and sandbergja will report progress on test writing wiki pages next month
15:13:39 <sleary> still in progress, actual progress being made, still not done
15:13:48 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month
15:14:23 <shulabramble> #topic abneiman will discuss moving the developer's meeting with shulabramble and poll the community
15:14:30 <abneiman> we discussed this!
15:14:56 <abneiman> and we will table this till later since as of now, Shula is the dev meeting leader & without av computer things
15:15:07 <abneiman> so, this can be struck for now
15:15:20 <shulabramble> this may be changing, with luck.
15:15:30 <abneiman> and you know, maybe next time it won't take me six months to talk about it
15:16:27 <shulabramble> if my situation changes, I'll bring up moving the meeting so we won't have to wait six months :)
15:16:35 <sleary> abneiman++ shulabramble++
15:16:36 <abneiman> shulabramble++
15:17:08 <shulabramble> #topic Dyrcona will look at https://bugs.launchpad.net/evergreen/+bug/2073561
15:17:09 <pinesol> Launchpad bug 2073561 in Evergreen 3.14 "Incorrect content in the config.coded_value_map after applying the upgrade script from 3.12.3 to 3.13.0" [High,Fix committed]
15:17:29 <shulabramble> Okay, fix committed!
15:17:34 <shulabramble> Dyrcona++
15:17:52 <shulabramble> #topic Updates
15:18:46 <shulabramble> #topic Evergreen
15:18:57 <shulabramble> #topic Thanks to Terran et al. for a very successful Feedback Fest! FBF stats
15:19:08 <shulabramble> #topic 3.15-rc built this morning (thank you Galen!) and is being tested this afternoon, with release announcement & merge un-pause expected later today
15:19:17 <shulabramble> #topic No merges to 3.15 branch unless they are critical bugfixes, lint fixes, or documentation
15:19:20 <terranm> Yay Feedback Festers!
15:19:26 <terranm> Festers doesn't sound nice
15:19:30 <shulabramble> #topic 3.15.0 is slated for release next Wednesday 16th, as is 3.14.5 and 3.13.10
15:19:39 <shulabramble> Festers sounds awful but I kinda like it
15:19:42 <sleary> terranm++ # Thank you for managing Feedback Fest!
15:19:48 <redavis> terranm++
15:19:48 <shulabramble> terranm++
15:19:56 <shulabramble> release_team_3.15++
15:20:01 <redavis> gmcharlt++ abneiman++
15:20:05 <abneiman> terranm++ feedback-festers++
15:20:13 <shulabramble> gmcharlt++ abneiman++
15:20:15 <collum> terranm++
15:20:27 <terranm> And Bmagic++ and JBoyer++ for building test servers!
15:20:36 <shulabramble> bmagic++ jboyer++
15:20:38 <abneiman> do we want to talk about point releases next week?
15:20:41 <redavis> Bmagic++ JBoyer++
15:20:55 <redavis> abneiman, honestly? I'm not sure. Just one sec.
15:21:35 <redavis> Okay, so we have volunteers for everything. Basically
15:22:16 <shulabramble> redavis++
15:22:28 <redavis> I do think it would be good to coordinate a little in terms of the uploading. We needs someone with lupin access to step forward.
15:23:02 <redavis> Unless Bmagic has it - and he does
15:23:22 <Bmagic> I'll do it
15:23:25 <redavis> So he might also be able to do the 3.15.0 uploads as well.
15:23:30 <shulabramble> bmagic++
15:23:31 <redavis> Bmagic++
15:23:35 <abneiman> Bmagic++
15:24:07 <redavis> If possible, it would be nice to have a joint meeting of release teams, recognizing there's some overlap. Just to make sure we're not getting into one another's way(s).
15:24:52 <abneiman> there's at least three of us on both
15:24:59 <abneiman> redavis, mantis, me
15:25:45 <redavis> Exactly. So the choreography will be both beautiful and potentially crazy.
15:25:59 <shulabramble> a Bob Fosse release.
15:26:02 <terranm> lol
15:26:16 * sleary shimmies
15:26:17 <redavis> There will be two point releases - to 3.14.5 and 3.13.10
15:26:27 <redavis> And, of course, 3.15.0
15:26:59 <redavis> abneiman, can we poll for a meeting at the beginning of next week?
15:27:29 <abneiman> redavis: yeah I'll do that *jazz hands*
15:27:45 <redavis> or whenever *waves hands vaguely at an imaginary calendar and time as a construct*
15:27:53 <redavis> abneiman++
15:27:59 <shulabramble> abneiman++
15:28:16 <redavis> It'll be action packed. Tell your friends. Wear sensible shoes and bring a waterproof jacket.
15:28:37 <shulabramble> correction, tap shoes and a sequin jacket that'll sparkle under the stage lights.
15:28:51 <abneiman> I was gonna say, I thought we were going for crazy / beautiful
15:28:56 <abneiman> I'll wear the sequins
15:29:00 <terranm> This is why we need video meetings
15:29:09 <abneiman> :-D
15:29:29 * shulabramble has her fingers crossed for potential news and changes.
15:29:32 <redavis> I mean...that could work. Crazy/beautiful for me often includes manure and a fingernail brush.
15:29:53 <sleary> that movie had a great soundtrack...
15:30:01 <sleary> ANYWAY
15:30:05 <redavis> lol!!!
15:30:59 <shulabramble> any further point release/3.15 business to discuss?
15:31:11 <redavis> Not unless you want more :D
15:31:49 <shulabramble> only if we're sticking with the theatrical theme. my b.a. is in drama, after all.
15:32:03 <shulabramble> but otherwise, please prepare for a wall of text.
15:32:21 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:32:22 <shulabramble> #topic Snapshot
15:32:22 <shulabramble> #info Open Bugs - 3257
15:32:23 <shulabramble> #info Pullrequests - 62
15:32:24 <shulabramble> #info Signedoff - 36
15:32:24 <shulabramble> #info Needswork - 98
15:32:24 <shulabramble> #info Needstestplan - 3
15:32:25 <shulabramble> #info Needsrebase - 25
15:32:26 <shulabramble> #topic Updates Since Last Meeting
15:32:26 <shulabramble> #info Bugs Added - 82
15:32:26 <shulabramble> #info Pullrequest tag Added - 74
15:32:27 <shulabramble> #info Signedoff tag Added - 77
15:32:27 <shulabramble> #info Needswork tag Added - 18
15:32:28 <shulabramble> #info Needstestplan tag Added - 1
15:32:28 <shulabramble> #info Needsrebase tag Added - 10
15:32:29 <shulabramble> #info Fix Committed - 67
15:32:51 * mmorgan added a last minute Hatch topic: bug 2076921
15:32:52 <pinesol> Launchpad bug 2076921 in Evergreen "Hatch: Chrome Extension Requires Redevelopment" [High,Confirmed] https://launchpad.net/bugs/2076921 - Assigned to Jeff Godin (jgodin)
15:33:09 <shulabramble> Ooops!
15:33:15 <shulabramble> #topic Hatch
15:33:23 <shulabramble> #topic Can bug 2076921 be marked Fix Released or is there more to do? https://bugs.launchpad.net/evergreen/+bug/2076921
15:33:37 <jeff> I believe that's done and fixed, new release is deployed, nothing exploded!
15:33:43 <jeff> I'll mark it as such.
15:33:51 <mmorgan> jeff++
15:33:59 <sleary> jeff++ berick++
15:34:05 <shulabramble> jeff++ berick++
15:34:05 <mmorgan> berick++
15:34:08 <jeff> Since there weren't changes required to Evergreen itself, there's no real "included in release X"
15:34:11 <jeff> berick++
15:34:31 <berick> the Hatch branch still needs merging
15:35:23 <jeff> ah. drat. ok, I'll do that also. did we need/want to bump the version in the Firefox extension "store"? I don't think anything needed to change...
15:35:45 <berick> oh yeah which may mean modifing the Firefox build docs
15:35:57 <berick> sicne there's an alternate manifest
15:36:33 <jeff> I'll wrap things up in the next few days with berick's help, as soon as Launchpad stops throwing ISEs.
15:36:45 <shulabramble> jeff++
15:36:52 <berick> jeff++ # i'm around
15:37:01 <shulabramble> berick++
15:37:03 <jeff> berick++ again
15:38:07 <jeff> ah. #launchpad topic says: "Launchpad DB OS upgrade - planned outage coming up, some services stopped in preparation"
15:38:20 <abneiman> jeff++ berick++
15:38:28 <abneiman> launchpad--
15:39:50 <shulabramble> Okay, moving on then?
15:39:55 <shulabramble> #topic New Business
15:39:58 * jeff nods
15:40:02 <shulabramble> Any last minute new business?
15:41:35 <abneiman> conference developer update?
15:41:43 <abneiman> as in, any volunteers to do said?
15:41:53 <abneiman> since this is our last mtg before the conference
15:41:57 * redavis watches and reads.
15:42:41 <redavis> abneiman, would you be willing?
15:43:09 <abneiman> sure, but happy to hand it off if anyone else would like to do it
15:43:13 <redavis> cuz you have so much free time (this is not true)
15:43:24 <abneiman> looooooooollllllllllllsssssooooobbbbb
15:44:16 <abneiman> well if anyone gets a compelling urge to do the dev update let me know, otherwise I'll pencil it in
15:44:16 <shulabramble> abneiman++ (infinite)
15:44:27 <redavis> abneiman++
15:44:34 <mmorgan> abneiman++
15:45:20 <jeff> historically, the last dev meeting before the conference is quite early for selecting who speaks. ;-)
15:45:51 <redavis> historically. unprecidented times, these.
15:45:59 <abneiman> jeff, this is a fair point
15:46:03 * shulabramble is missing the conference this year because of unprecedented times locally.
15:46:29 <abneiman> and I recall more than a few conferences where slides were slapped together the night before, perhaps with an assist from some alcohol
15:46:39 <redavis> unprecedented? (IRC, why no spellcheck for the redavises?)
15:46:48 <abneiman> unpresidented
15:46:51 <shulabramble> alcohol++
15:47:01 <sleary> procrastination++
15:47:01 <terranm> abneiman I thought that was part of the tradition
15:47:20 <abneiman> listen, if y'all want to take it back in the name of Tradition, I will NOT stand in the way
15:47:37 * redavis invokes alfred e. neuman.
15:47:49 * shulabramble starts singing "Tradition".
15:48:03 <shulabramble> ...like a developer on the roof.
15:48:08 <redavis> (and still 13 minutes to go)
15:48:13 <redavis> (12)
15:48:35 <shulabramble> okay, moving on then...
15:48:41 <shulabramble> #topic Announcements
15:48:47 <abneiman> and who writes dev updates
15:48:48 <abneiman> while drinking all the beer?
15:48:48 <abneiman> delivering some slides
15:48:48 <abneiman> that might not all be clear
15:48:48 <abneiman> the developerrrrrrrrrrrrrrrrrrrrrrrrrs the developers! Tradition!
15:48:53 <shulabramble> #info Next Meeting is 13 May 2025
15:48:57 <shulabramble> lol!!!
15:49:00 <shulabramble> abneiman++
15:49:04 <terranm> abneiman++
15:49:07 <redavis> abneiman++
15:50:27 <shulabramble> Any further announcements?
15:50:46 * shulabramble sings "Signoff, rebase, signoff, rebase, swiftly go the bugs..."
15:51:17 <abneiman> shulabramble: we can 100% do a Fiddler-themed developer update
15:51:38 <redavis> shulabramble++
15:51:54 <shulabramble> theatrics++
15:52:12 <shulabramble> okay, if there are no further announcements, then with eight minutes remaining.
15:52:15 <shulabramble> #endmeeting