15:00:21 <shulabramble> #startmeeting 2025-05-15 - Developer Meeting
15:00:21 <pinesol> Meeting started Thu May 15 15:00:21 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <pinesol> The meeting name has been set to '2025_05_15___developer_meeting'
15:00:30 <shulabramble> #topic Intros
15:00:49 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:01:00 <shulabramble> Let's set it off.
15:01:08 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:01:36 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:44 <mmorgan1> #info mmorgan = Michele Morgan, NOBLE
15:01:46 <berick> #info berick Bill Erickson, KCLS
15:01:48 <sleary> #info sleary = Stephanie Leary, Equinox
15:02:08 <eeevil> #info eeevil = Mike Rylander, EOLI
15:02:41 <collum> #info collum = Garry Collum, KCPL
15:02:45 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:03:24 <csharp_> #info csharp = Chris Sharp, GPLS
15:04:22 <shulabramble> latecomers can keep up the intros as we get going
15:04:26 <abneiman> #info abneiman = Andrea Buntz Neiman, Equinox
15:04:38 <smayo> #info smayo = Steven Mayo, PINES
15:04:38 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:04:48 <terranm> #info terranm = Terran McCanna, PINES
15:05:01 <shulabramble> #topic Action Items from Last Meeting
15:05:26 <shulabramble> #topic bmagic will look into transferring POeditor account ownership to a generic EG account
15:07:18 <shulabramble> this might be a really short meeting since everyone's doing conference stuff. since bmagic didn't do an intro, we'll kick this to next month unless anyone has any news
15:07:40 <shulabramble> #action Bmagic will look into transferring POeditor account ownership to a generic EG account
15:08:08 <shulabramble> #topic sleary and sandbergja will report progress on test writing wiki pages next month
15:08:28 <sleary> I will regroup with sandbergja in the next few days and probably toss this out for wider participation!
15:08:35 <shulabramble> sleary++
15:09:10 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month
15:09:21 <shulabramble> #topic Updates
15:09:34 <shulabramble> There's nothing on the agenda, so the floor is open.
15:09:48 <redavis> I have an update for releases.
15:09:52 <shulabramble> redavis++
15:10:01 <redavis> Three point releases are due out next week on Wednesday, May 21. They are 3.13.11, 3.14.6, and 3.15.1. There aren't a ton of commits to any of them, but there are several that are high priority so this is an important maintenance release cycle. Volunteers are needed for the release team. Please fill out the buildmaster spreadsheet if you're able and willing.
15:10:11 <redavis> https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:10:21 <shulabramble> #topic Releases
15:10:38 <shulabramble> #info Volunteers needed for the release team
15:11:02 <shulabramble> #info Please fill out the buildmaster spreadsheet if you're willing and able -- https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:11:02 <redavis> Also, I can't remember when the last anything happened, so, Evergreen 3.15.0, was released on time and underbudget last month. As were point releases, 3.14.5, and 3.13.10.
15:11:17 <shulabramble> redavis++
15:11:28 <redavis> There will be one more point release for 3.13 (next month), and then it will be security only.
15:12:02 <redavis> Shoutout to abneiman for RMing the 3.15 release cycle. And ALL of the many, many contributors.
15:12:24 <shulabramble> #info 3.15.0, 3.14.5, and 3.13.10 released on time and under budget
15:12:27 <redavis> And shoutout to the many people who were on all the release teams.
15:12:35 <shulabramble> abneiman++
15:12:38 <shulabramble> release_teams++
15:13:15 <redavis> There were also MANY sessions about many of the new features during the conference and slides and recordings will be available soon.
15:13:24 <shulabramble> conference++
15:13:38 <abneiman> question: do we have an RM for 4.0 yet?
15:13:44 <redavis> Not yet
15:13:46 <abneiman> 'cause we need one
15:13:52 <redavis> Indeed
15:13:53 <abneiman> 123 not it
15:14:16 <redavis> And, are we confident that 4.0 is next? and not 3.16?
15:14:43 <abneiman> I, personally, am not confident about that at this time
15:14:54 <abneiman> though we, collectively, seemed confident at hackaway
15:15:02 <redavis> abneiman++
15:15:05 <abneiman> ultimately I think that's an RM / Release Team call
15:15:10 <shulabramble> abneiman++
15:15:50 <shulabramble> #info Release Manager needed for next major release
15:15:56 <abneiman> but, someone needs to step up else it's not gonna happen. Any volunteers? Voluntells?
15:16:17 <redavis> Let's leave the RM for one more month. I have some things to sort between now and the next dev meeting and could possibly do it.
15:16:21 <redavis> But can't say today.
15:16:32 <abneiman> redavis++
15:16:32 <redavis> And would LOVE someone else to have the opportunity.
15:17:02 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:17:12 <shulabramble> redavis++
15:17:25 <shulabramble> #action Release Manager needed for next major release
15:17:47 <shulabramble> now it's on the agenda for next month.
15:18:04 <redavis> Also, thanks to those who have volunteered for the May point releases. We need a builder or builders still. And someone with lupin access. Could be the same person, but not necessarily necessary.
15:19:05 <Dyrcona> I'll see what I can do. I am out sick today and I think my schedule is pretty busy next week. I should know tomorrow if I can help
15:19:17 <shulabramble> Dyrcona++
15:19:18 <redavis> So, there's also news about the 2025 Hackaway. It's going to be hosted by MOBIUS in Columbia, Missouri. Dates are TBD
15:19:24 <redavis> Dyrcona++
15:19:27 <shulabramble> Mobius++
15:19:47 <shulabramble> #info 2025 Hackaway is hosted by MOBIUS in Columbia, Missouri
15:20:33 <dluch> :-)
15:20:34 <jeff> mobius++ hackaway++ hack-a-way++
15:20:43 <redavis> And the 2026 International Conference has also been scheduled and will be in Renton, Washington and hosted by KCLS. Dates are April 8-11, 2026 https://evergreen-ils.org/2026-evergreen-international-conference/
15:21:11 <Dyrcona> kcls++ mobius++
15:21:24 <shulabramble> #info 2026 International Conference in Renton Washington, hosted by KCLS, April 8-11, 2026 https://evergreen-ils.org/2026-evergreen-international-conference/
15:21:28 <jeff> kcls++ conf++
15:21:29 <redavis> (though I'm loathe to say "conference" again for 2.5 days)
15:21:38 <abneiman> kcls++ mobius++
15:22:03 <redavis> And that's all I have
15:22:10 <shulabramble> redavis++
15:22:22 <mmorgan> redavis++
15:22:24 <Dyrcona> redavis++
15:22:53 <redavis> Except, I recently found out that pickleball is essentially wiffleball tennis (with a slightly different "wiffle" ball), and I'm a little shook.
15:22:54 <terranm> kcls++ mobius++
15:22:59 <shulabramble> alright, anything else? speak now before the Wall of Text.
15:23:24 <shulabramble> redavis I'm so tempted to put that in the official minutes.
15:23:30 <redavis> lol
15:23:40 <berick> @band add Pickle Wiffle
15:23:40 <pinesol> berick: Band 'Pickle Wiffle' added to list
15:23:42 <berick> (sorry)
15:23:52 <abneiman> haaaaaaaaaa
15:23:53 <redavis> oh my, LOL
15:24:00 <redavis> I can't with that
15:24:12 <shulabramble> do NOT look up Pickle Wiffle in the Urban Dictionary.
15:24:19 <redavis> please no
15:24:33 <berick> uh oh is that a thing? dang
15:24:34 <shulabramble> okay, wall of text to erase pickle wiffle incoming
15:24:35 <shulabramble> https://evergreen-ils.org/2026-evergreen-international-conference/
15:24:39 <shulabramble> ....
15:24:45 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:24:46 <shulabramble> #topic Snapshot
15:24:46 <shulabramble> #info Open Bugs - 3247
15:24:47 <shulabramble> #info Pullrequests - 93
15:24:47 <shulabramble> #info Signedoff - 30
15:24:48 <shulabramble> #info Needswork - 99
15:24:48 <shulabramble> #info Needstestplan - 3
15:24:49 <shulabramble> #info Needsrebase - 24
15:24:49 <shulabramble> #topic Updates Since Last Meeting
15:24:50 <shulabramble> #info Bugs Added - 52
15:24:50 <shulabramble> #info Pullrequest tag Added - 39
15:24:51 <shulabramble> #info Signedoff tag Added - 4
15:24:51 <shulabramble> #info Needswork tag Added - 3
15:24:52 <shulabramble> #info Needstestplan tag Added - 0
15:24:52 <shulabramble> #info Needsrebase tag Added - 1
15:24:53 <shulabramble> #info Fix Committed - 12
15:25:10 <shulabramble> #topic New Business
15:25:18 <shulabramble> Anything new to discuss?
15:25:34 <redavis> berick, not sure. but not googling
15:25:42 <sleary> I updated the branches on the Angular 18 upgrade this morning; see bug 2043490
15:25:42 <pinesol> Launchpad bug 2043490 in Evergreen "Angular 18 Upgrade" [Wishlist,New] https://launchpad.net/bugs/2043490
15:25:51 <redavis> sleary++
15:25:52 <shulabramble> sleary++
15:25:54 <sleary> would appreciate eyes on that and opinions on whether we should go to 19
15:26:13 <sleary> see also the other things we will need to update in order to take advantage of speed improvements, as outlined in Jane's comments
15:26:57 <eeevil> I have an eyeball request for https://bugs.launchpad.net/evergreen/+bug/2091748
15:26:57 <pinesol> Launchpad bug 2091748 in Evergreen "Concurrent browse entry update/insert" [Wishlist,New]
15:27:01 <shulabramble> #info sleary updated the Angular 18 upgrade branches this morning (LP2043490); eyes appreciated and input on if we should move to Angular 19
15:27:12 <redavis> eeevil++
15:27:27 <shulabramble> #info eeevil requests eyeballs on LP2091748
15:27:51 <eeevil> thanks, Gina, for attempting to test, also. (I'm blanking on your IRC nick, sorry!)
15:28:02 <redavis> mantis++
15:28:11 <shulabramble> mantis++
15:28:14 <shulabramble> eeevil++
15:28:15 <jeff> sleary++ berick++ sandbergja++ gmcharlt++ (angular upgrade bug)
15:28:20 <eeevil> mantis++
15:28:25 <shulabramble> gmcharlt++ berick++ sandbergja++
15:29:09 <shulabramble> #info Next meeting is 10 June 2025
15:29:19 <shulabramble> anything else?
15:29:54 <abneiman> we all have conference mush-brain today
15:29:57 <shulabramble> if not, i'm just waiting to have as close to a perfect 30 minute meeting as possible.
15:30:10 <shulabramble> mush-brain++
15:30:19 <shulabramble> #endmeeting