15:00:08 <shulabramble> #startmeeting 2025-06-10 - Developer Meeting
15:00:08 <pinesol> Meeting started Tue Jun 10 15:00:08 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <pinesol> The meeting name has been set to '2025_06_10___developer_meeting'
15:00:17 <shulabramble> #topic Intros
15:00:33 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:35 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:00:37 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:00:45 <Rogan> #info rogan = Rogan Hamby, EOLI
15:00:49 <redavis> #info redavis = Ruth Frasur Davis, ECDI
15:00:51 <terranm> #info terranm = Terran McCanna, PINES
15:00:55 <sleary> #info sleary = Stephanie Leary, EOLI
15:00:56 <eeevil> #info eeevil = Mike Rylander, EOLI
15:01:00 <mmorgan2> #info mmorgan = Michele Morgan, NOBLE
15:01:09 <briank> #info briank = Brian Kennedy, BCLC
15:01:10 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:11 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:01:38 <smayo> #info smayo = Steven Mayo, PINES
15:02:38 <shulabramble> Let's get rolling, and latecomers can introduce themselves as they arrive
15:02:52 <shulabramble> #topic Action Items from Last Meeting
15:03:02 <shulabramble> #topic Bmagic will look into transferring POeditor account ownership to a generic EG account
15:03:44 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS
15:04:13 <shulabramble> since Bmagic doesn't look to be around, does anyone else have any updates on this?
15:05:00 <shulabramble> in that case
15:05:01 <abneiman> I imagine this task may be transferred to the nascent Infrastructure Committee, when that is officially formed
15:05:09 <shulabramble> abneiman++
15:05:53 <shulabramble> #action Bmagic will look into transferring POeditor account ownership to a generic EG account/moving this task to the nascent Infrastructure Committee
15:06:12 <shulabramble> #topic sleary and sandbergja will report progress on test writing wiki pages next month
15:06:23 <sleary> oof, please carry forward
15:06:42 <shulabramble> #action sleary and sandbergja will report progress on test writing wiki pages next month
15:06:59 <shulabramble> #topic Release Manager needed for next major release
15:07:25 <shulabramble> Though I think that also falls under New Business at the end with the assembly of a team for 4.0/Fall Release
15:07:43 <redavis> yes
15:08:04 <shulabramble> Alrighty then, we'll address all that together at the end.
15:08:21 <shulabramble> #topic Updates
15:08:29 <shulabramble> #topic Release Info
15:08:40 <redavis> k, just a moment
15:08:47 <shulabramble> redavis++
15:08:50 <redavis> Evergreen 3.14.6 and 3.15.1 were released on May 21. Thanks to Bmagic, abneiman, mdriscoll, and mmorgan for their work on the maintenance release team.
15:09:32 <redavis> There were 24 LP tickets for 3.15.1 with fixes released and 22 LP tickets for 3.14.6 with fixes released.
15:10:10 <redavis> The maintenance releases for this month (June) are due next Wednesday, June 18, and we need volunteers for that. You can sign up on the buildmaster spreadsheet.
15:10:16 <redavis> https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:10:52 <redavis> There is one critical fix to be released for both 3.15.2 and 3.14.7 among other less critical stuff.
15:11:09 <abneiman> (also 3.13.11)
15:11:10 <redavis> And that concludes my part of the release info
15:11:20 <redavis> Oh, we're doing that as a security release?
15:11:32 <abneiman> no, there was a 3.13.11 in May
15:11:46 <redavis> Oh, yes. there was. My apologies.
15:12:07 <abneiman> IIRC that was the last planned (non-security) 3.13
15:12:21 <redavis> abneiman++ # that's correct
15:12:29 <shulabramble> bmagic++ abneiman++ mdriscoll++ mmorgan++ redavis++
15:12:35 <shulabramble> thanks y'all!
15:12:41 <redavis> This month will have only two versions to release.
15:12:46 <shulabramble> small wall of text incoming
15:12:47 <shulabramble> #topic Evergreen
15:12:48 <shulabramble> #info Evergreen 3.14.6 and 3.15.1 were released on May 21. Thanks to Bmagic, abneiman, mdriscoll, and mmorgan for their work on the maintenance release team.
15:12:48 <shulabramble> #info There were 24 LP tickets for 3.15.1 with fixes released and 22 LP tickets for 3.14.6 with fixes released.
15:12:49 <shulabramble> #info The maintenance releases for this month (June) are due next Wednesday, June 18, and we need volunteers for that. You can sign up on the buildmaster spreadsheet.
15:12:49 <shulabramble> #info https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:12:50 <shulabramble> #info There is one critical fix to be released for both 3.15.2 and 3.14.7 among other less critical stuff.
15:13:12 <Dyrcona> bmagic++ abneiman++ mdriscoll++ mmorgan++ redavis++
15:13:59 <shulabramble> anything of note for OpenSRF, Hatch, or Docs releases?
15:14:11 <jeff> anyone have the launchpad bug for the "one critical fix" mentioned above?
15:14:22 <redavis> yeah, jeff, just a sec
15:14:43 <redavis> https://bugs.launchpad.net/evergreen/+bug/2112185
15:14:44 <pinesol> Launchpad bug 2112185 in Evergreen main "Pre-Cats can no longer be re-checked out" [Critical,Fix committed]
15:15:09 <jeff> thanks!
15:16:05 <redavis> mp
15:16:19 <abneiman> meep
15:16:33 <redavis> lol, noice
15:16:39 <shulabramble> meep meep wall of text meep meep
15:16:43 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:16:43 <shulabramble> #topic Snapshot
15:16:44 <shulabramble> #info Open Bugs - 3250
15:16:44 <shulabramble> #info Pullrequests - 89
15:16:45 <shulabramble> #info Signedoff - 16
15:16:45 <shulabramble> #info Needswork - 96
15:16:46 <shulabramble> #info Needstestplan - 3
15:16:46 <shulabramble> #info Needsrebase - 24
15:16:47 <shulabramble> #topic Updates Since Last Meeting
15:16:47 <shulabramble> #info Bugs Added - 38
15:16:48 <shulabramble> #info Pullrequest tag Added - 26
15:16:48 <shulabramble> #info Signedoff tag Added - 18
15:16:49 <shulabramble> #info Needswork tag Added - 1
15:16:49 <shulabramble> #info Needstestplan tag Added - 0
15:16:50 <shulabramble> #info Needsrebase tag Added - 1
15:16:50 <shulabramble> #info Fix Committed - 29
15:17:17 <shulabramble> #topic New Business
15:17:30 <shulabramble> #topic Fall 2025 / 4.0 Release Team selection
15:18:13 <shulabramble> Anyone want to volunteer for this?
15:19:33 <redavis> I'm unable to volunteer at this point in time. I might be able to next month if no one has to that point.
15:19:44 <shulabramble> redavis++
15:20:04 <eeevil> I'm considering ... but, basically what rdavis said
15:20:36 <redavis> eeevil++
15:20:38 <shulabramble> my plate is gonna be full for the next six months due to system restructuring, so i'm out
15:20:44 <shulabramble> eeevil++
15:21:26 <sleary> outlook hazy, ask again later
15:21:27 <terranm> I'm also unavailable due to big projects and I'm going to be short-staffed
15:21:28 <redavis> I think it will stil be in a timely enough manner to revisit this next month and let the committing keep on committing.
15:21:34 <jeff> Would anyone on the most recent team like to hazard a guess as to the time committment that you all experienced?
15:21:51 <abneiman> if anyone's willing to take on the manager/wrangler role now, the team can be fleshed out next month?
15:22:17 <redavis> abneiman, that was the role that I need to wait a little longer to commit to.
15:23:29 <redavis> jeff, it really depends on what role you're taking. I suspect that for the builder, it might actually be about 15 hours spread over about a month's time including any meetings and build/etc. time.
15:24:07 <abneiman> jeff: in the non-technical wrangler role, I probably did 15-20 hours between Jan and April - mostly weighted towards April
15:24:11 <abneiman> redavis++
15:24:12 <redavis> Someone please correct me if I'm wrong though. For other things like release notes and translations, about 10 hours over that same period of time...
15:24:39 <redavis> For release manager, yes...as abneiman says...about 20 hours.
15:24:42 <sleary> I tend to spend more time than that, but mostly on shepherding specific bugs (feedback, rebasing, etc.)
15:25:02 <sleary> it very much depends
15:25:05 <redavis> sleary, as builder? or for what role in the release?
15:25:21 <sleary> redavis I do not recall what role I had last time
15:25:30 <sleary> I was not The Builder
15:25:52 <redavis> There's WAY more time spent from committers and testers...and Terran wrangling BSW and FF...and yeah.
15:26:25 <mdriscoll> Testing tarballs took me about 10 hours from Jan - April
15:26:28 <abneiman> yeah, and relteam members who are also core committers are probably going to spend more time on reviews / commits than on team activities
15:26:50 <redavis> mdriscoll++
15:27:30 <shulabramble> mdriscoll++
15:28:28 <sleary> as website updater, the time commitment is more like an hour or two the week of release
15:29:13 <shulabramble> so is the consensus that we're gonna revisit this next month barring a sudden volunteer to head up the team?
15:29:13 <redavis> Those times are all pretty bare minimum estimates and don't account for what sleary is describing - which is often untracked and substantial.
15:29:32 <redavis> shulabramble, I think so.
15:29:43 <shulabramble> redavis++
15:30:01 <shulabramble> #action Fall 2025 / 4.0 Release Team selection
15:30:09 <redavis> Also, just a note that those time estimates are for a feature release. They're a little shorter for maintenance releases (so please volunteer for this month).
15:30:24 <shulabramble> redavis++
15:30:55 <redavis> (a LOT shorter? how do I sell this quickly?)
15:31:44 <mdriscoll> I'll test tarballs again.
15:32:10 <redavis> mdriscoll++
15:32:12 <shulabramble> People who volunteer for maintenance releases receive the blessings of Githulhu for at least a week.
15:32:42 <redavis> Oh, up until the next maintenance release cycle.
15:33:13 <shulabramble> What those blessings entail are unknown, but you'll have them.
15:33:32 <phasefx> you can count me in for testing too, and emergency commit bit
15:33:46 <shulabramble> mdriscoll++ phasefx++
15:33:50 <redavis> only Githulhu knows.
15:33:54 * phasefx needs to remember that he volunteered...
15:33:55 <redavis> phasefx++
15:34:49 <abneiman> I have short weeks this week and next so I might not be able to do point release notes ... but ... I'll toss in myself as a maybe
15:34:50 <redavis> I've added you to the spreadsheet, phasefx, which will remind me to email you later this week.
15:34:56 <shulabramble> abneiman++
15:35:04 <phasefx> redavis++
15:35:09 <shulabramble> redavis++
15:35:17 <redavis> abneiman++
15:35:31 <abneiman> anyone else may feel entirely free to boot me and take over release notes
15:35:36 <shulabramble> Githulhu is pleased by this.
15:36:12 <shulabramble> any other maintenance volunteers?
15:36:29 <redavis> We still need a builder and translations person. I will be sending out an email solicitation tomorrow to the dev list.
15:36:38 <shulabramble> redavis++
15:37:48 <shulabramble> #topic Announcements
15:38:09 <shulabramble> #topic Next Meeting 8 July 2025
15:38:10 <terranm> #topic Next Bug Squashing Week will be July 7-11, 2025
15:38:17 <shulabramble> terranm++
15:38:33 <redavis> terranm++
15:38:35 <abneiman> terranm++
15:39:45 <shulabramble> any other announcements?
15:40:00 <sleary> terranm++
15:40:22 <shulabramble> In that case, by the power granted me by Great Githulhu
15:40:24 <shulabramble> #endmeeting