15:00:16 <shulabramble> #startmeeting 2025-07-08 - Developer Meeting
15:00:16 <pinesol> Meeting started Tue Jul  8 15:00:16 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <pinesol> The meeting name has been set to '2025_07_08___developer_meeting'
15:00:24 <csharp_> shulabramble++
15:00:31 <shulabramble> Okay, y'all!
15:00:36 <shulabramble> #topic Intros
15:00:49 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:58 <redavis> #info redavis = Ruth Frasur Davis, ECDI and my own open-source ILS lovin' self.
15:00:59 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:04 <Rogan> #info Rogan = Rogan Hamby, EOLI
15:01:06 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:01:07 <collum> #info collum = Garry Collum, KCPL
15:01:10 <sleary> #info sleary = Stephanie Leary, EOLI
15:01:11 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:13 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:17 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:30 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:01:41 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:49 <terranm> #info terranm = Terran McCanna, PINES
15:02:21 <shulabramble> We've got potentially lengthy discussions at the end of this so lets forge on, people can continue introductions as they filter in
15:02:30 <csharp_> #info csharp = Chris Sharp, GPLS
15:02:42 <shulabramble> #topic Action Items from Last Meeting
15:02:56 <shulabramble> #topic sleary and sandbergja will report progress on test writing wiki pages next month
15:03:16 <sleary> updates! I added a couple links to the agenda
15:03:40 <shulabramble> #info https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa#common_things_that_break_angular_unit_tests
15:03:58 <shulabramble> #info custom ESLint rules, e.g. #lp2019139
15:04:04 <shulabramble> #info custom ESLint rules, e.g. lp2019139
15:04:08 <abneiman> sleary++ sandbergja++
15:04:12 <sleary> sandbergja and I are working on adding some common "if you changed X in your code, you'll need to do Y in the unit tests" examples; if you've run across test-breaking things, we'd love your input
15:04:20 <shulabramble> sleary++ sandbergja++
15:04:28 <sleary> we are also working on custom lint rules as described in that LP bug
15:04:29 <redavis> sleary++ sandbergja++
15:04:37 <terranm> sleary++ sandbergja++
15:05:28 <shulabramble> y'all want to keep this as an action item still? provide updates every month on progress?
15:05:36 <sleary> sure
15:06:02 <shulabramble> #action sleary and sandbergja will report further progress on test writing wiki pages next month
15:06:14 <shulabramble> #topic Bmagic will look into transferring POeditor account ownership to a generic EG account/moving this task to the nascent Infrastructure Committee
15:06:15 <sandbergja> sounds good!
15:06:29 <jeff> sleary++ sandbergja++
15:07:22 <gmcharlt> one note that the POEditor account is already under a generic evergreen-ils.org account
15:07:31 <shulabramble> gmcharlt++
15:08:13 <jeff> anything more to share/point to on "nascent Infrastructure Committee"?
15:08:44 <gmcharlt> I'll be calling a organizing meeting shortly
15:09:16 <jeff> shulabramble++ gmcharlt++
15:09:23 <sandbergja> gmcharlt++
15:09:26 <shulabramble> gmcharlt++ again
15:10:02 <shulabramble> #action gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee
15:10:05 <redavis> gmcharlt++
15:10:27 <shulabramble> Now we get into Big Topic 1!
15:10:40 <shulabramble> #topic Fall 2025 / 4.0 Release Team selection
15:11:04 * redavis glances at eeevil
15:11:06 <shulabramble> anyone jumping on board?
15:11:16 <redavis> https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0
15:11:51 * gmcharlt also is putting my name forward
15:11:53 <redavis> Here's the buildmaster spreadsheet. There are several already signed up. We need a manager, release notes person and translations people.
15:12:14 * mmorgan can help with translations
15:12:30 <redavis> Please add your name to the appropriate cell(s) on the spreadsheet.
15:12:45 <shulabramble> redavis++ for the spreadsheet
15:12:49 <shulabramble> mmorgan++
15:13:03 <redavis> np. I just linked it though :D.
15:13:17 <redavis> gmcharlt, are you putting your name forth to manage the release?
15:13:25 <gmcharlt> I am
15:13:28 <redavis> Yes!! I see it.
15:13:35 <redavis> Sorry, needed to horizontal scroll.
15:13:39 <jeff> I'll release the notes.
15:13:39 <shulabramble> gmcharlt++
15:13:43 <shulabramble> jeff++
15:14:02 <jeff> I suspect there will be a few.
15:14:03 <mmorgan> gmcharlt++
15:14:16 <redavis> And thank you to those who just added yourselves for the July point releases as well.
15:14:21 <sandbergja> gmcharlt++
15:14:34 <sandbergja> jeff++
15:14:45 <shulabramble> progress++
15:15:09 <sandbergja> mmorgan++
15:15:13 <sandbergja> berick++
15:15:17 <redavis> And that fill out the release teams for both 4.0 and July 3.15.3 and 3.14.8
15:15:18 <sandbergja> sleary++
15:15:27 <sandbergja> mdriscoll++
15:15:32 <shulabramble> berick++ sleary++ mdriscoll++
15:15:35 <sandbergja> redavis++
15:15:41 <sandbergja> abneiman++
15:15:49 <sandbergja> mantis++
15:15:54 <redavis> whew, go team!
15:15:58 <shulabramble> what a productive action item!
15:16:03 <shulabramble> team++
15:16:04 <shulabramble> mantis++
15:16:10 <shulabramble> abneiman++
15:16:27 <shulabramble> Moving right along...
15:16:33 <shulabramble> #topic Updates
15:16:51 <shulabramble> what news do we have?
15:17:14 <redavis> 3.14.7 and 3.15.2 were released on June 18
15:17:37 <shulabramble> #topic Evergreen
15:17:52 <shulabramble> #info 3.14.7 and 3.15.2 were released on June 18
15:19:06 <redavis> Bugsquashing is also ongoing.
15:19:22 <redavis> terranm++
15:19:40 <terranm> bugsquashers++
15:19:46 <mmorgan> terranm++
15:19:47 <shulabramble> #info Bugsquashing week in progress 7-7-2025 to 13-7-2025
15:19:50 <shulabramble> terranm++
15:19:56 <abneiman> terranm++
15:20:09 <gmcharlt> terranm++
15:20:16 <sandbergja> terranm++
15:20:51 <collum> terranm++
15:21:20 <shulabramble> any documentation updates to mention?
15:22:02 <abneiman> based on github traffic, DIG was busy last week! DIG++
15:22:09 <shulabramble> dig++
15:22:19 <terranm> dig++
15:22:36 <sandbergja> dig++
15:23:22 <shulabramble> if there's nothing more from updates, then we'll move on.
15:23:43 <shulabramble> to everyone's favorite moment -- the wall of text
15:23:54 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:23:54 <shulabramble> #topic Snapshot
15:23:55 <shulabramble> #info Open Bugs - 3324
15:23:55 <shulabramble> #info Pullrequests - 115
15:23:56 <shulabramble> #info Signedoff - 31
15:23:56 <shulabramble> #info Needswork - 95
15:23:57 <shulabramble> #info Needstestplan - 3
15:23:57 <shulabramble> #info Needsrebase - 24
15:23:58 <shulabramble> #topic Updates Since Last Meeting
15:23:58 <shulabramble> #info Bugs Added - 92
15:23:59 <shulabramble> #info Pullrequest tag Added - 60
15:23:59 <shulabramble> #info Signedoff tag Added - 26
15:24:00 <shulabramble> #info Needswork tag Added - 1
15:24:00 <shulabramble> #info Needstestplan tag Added - 0
15:24:01 <shulabramble> #info Needsrebase tag Added - 1
15:24:01 <shulabramble> #info Fix Committed - 17
15:24:30 <shulabramble> #topic New Business
15:24:53 <shulabramble> #topic Can we start accepting code pull requests via github as an option?
15:25:10 <shulabramble> #info DIG's github procedure - https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:github-workflow
15:25:26 <shulabramble> #info Pros: reviewers and contributors can see some test and lint results before committing, a nice UI for reviewers to see what has changed
15:25:38 <shulabramble> #info Cons: yet another workflow to learn and deal with, github is not a FOSS platform
15:26:37 <sandbergja> This was from me!  As a reviewer, I find it much easier to review contributions to projects in Github or Gitlab.  There has been various talk in the community about whether moving EVERYTHING to github or gitlab might be desirable.  I wanted to propose this as an incremental step to test the waters a bit more
15:26:37 <shulabramble> Anyone have input on this? opinions?
15:26:51 <shulabramble> sandbergja++
15:27:08 <sandbergja> I am sure the pros and cons lists are woefully short, apologies
15:27:55 <mmorgan> ls
15:28:02 <mmorgan> Oops.
15:28:17 <gmcharlt> speaking as somebody assuming some additional specific responsiblity for patch review this cycle:
15:28:55 <gmcharlt> 1. I think most of the benefit would be in a whole-sale move to a new platform, but to me the ergonomics of the bug reporting likely matter more
15:28:56 <jeff> sandbergja: how do you see the process working? would the idea being that the person reviewing would take responsibility for ensuring that launchpad was updated? would launchpad be involved at all? given a contribution with no associated launchpad bug (say, if someone submits a PR gia github without reference to / mention of a launchpad bug at all), would the commits be amended/rewritten to reference LP?
15:29:40 <gmcharlt> 2. I wouldn't ignore GitHub PRs per se, but I don't think we're ready to actively encourage it
15:29:48 <jeff> (sorry, that's a bunch of questions, several of which probably don't require answers, depending on what the overall proposal is)
15:30:00 <abneiman> I'm not against it per se, however, thinking about release notes and recordkeeping: LP is an imperfect (we all know git is canonical) but still reasonably complete accounting of what goes into each release. So I'd want to see a way to make sure we're not "losing" that info to github.
15:30:06 <gmcharlt> 3. I do think that most of the conventions in place should stay in place for now
15:30:26 <gmcharlt> i.e., commit message stays the same, including the LP bug reference
15:30:51 <gmcharlt> and patches are expected to apply cleanly with a focus on retaining a linear history
15:30:58 <shulabramble> abneiman++ gmchart++ jeff++
15:31:06 <shulabramble> gmcharlt++, even
15:31:07 <gmcharlt> i.e., I would not be inclined to do merge commits
15:31:41 <gmcharlt> shulabramble: yeah, be careful with that gmchart dude - he's Edward Tufte's public enemy number one, even over barchart! ;)
15:31:58 <shulabramble> will do XD
15:32:26 <abneiman> that was a terrible joke gmcharlt. I cackled.
15:32:52 <sandbergja> jeff: good questions.  I definitely think we would need to make sure to keep the lp bug links, and would need to amend commits that did not refer to an lp.  The DIG procedure does not currently involve pressing the Big Green Button in the github ui, but cherry-picking the relevant commits, so there is ample opportunity to check them while committing
15:32:58 <redavis> gmcharlt, that was delightful.
15:34:19 <gmcharlt> I think there may be an initial compromise formulation
15:34:38 <gmcharlt> namely, for now, leaning into the review functionality in particular
15:35:15 <gmcharlt> i.e., turning a normal pull request into a GH one specifically for the purpose of doing a Fisk-style review or running the tests
15:35:28 <gmcharlt> as long as there are cross-references between GH and LP
15:35:43 <shulabramble> question: is this something that might be best discussed in an email thread and revisited next month?
15:35:44 <gmcharlt> and that sort of pull request could be done by anybody, not just the original submitter
15:36:09 <abneiman> ^^ ensuring cross refs to LP is my biggest concern
15:36:20 <gmcharlt> @shulabramble most likely, I'd say
15:36:20 <pinesol> gmcharlt: Have you tried throwing it across the room?
15:36:25 <jeff> I'd participate in such an email thread.
15:36:41 <jeff> pinesol: pay attention. server hurling was earlier.
15:36:41 <pinesol> jeff: The horror... The horror...
15:37:18 <jeff> (server flinging, rather)
15:37:20 <shulabramble> might get some more community input as well. any volunteers to kick off the discussion on the developer list?
15:37:33 <jeff> sandbergja: you game?
15:37:59 <jeff> (or is there already a thread there and that's what led to this agenda item?)
15:37:59 <sandbergja> sure!  thanks for the discussion here, looking forward to more
15:38:24 <jeff> sandbergja++
15:38:51 <shulabramble> #action sandbergja will start a discussion on the developer's listserv concerning moving to github/gitlab
15:39:14 <shulabramble> sandbergja++
15:39:24 <sleary> sandbergja++
15:39:36 <mmorgan> sandbergja++
15:39:58 <shulabramble> #topic Updates on possible changes to where we have dev meetings
15:40:47 <shulabramble> okay. so. until January 2026 we'll be meeting on IRC for sure. without going into too many details, I have no idea if I'm going to have a steady work location come January 2026.
15:42:04 <shulabramble> so that's where we stand right now; IRC through 2025, 2026 might require a new person running these meetings depending on how the situation here shakes out.
15:42:44 <terranm> Good luck, Shula!
15:43:03 <shulabramble> terranm i have so many things i wish to say, but will not right now.
15:43:10 <terranm> shulabramble++
15:43:13 <abneiman> shulabramble++
15:43:20 <mmorgan> shulabramble++
15:43:29 <terranm> FOIA--
15:43:41 <shulabramble> FOIA--
15:43:57 <sleary> shulabramble++
15:44:15 <shulabramble> to my credit, I haven't been reading any of the details of the news here and my therapist is very proud of me.
15:44:27 <shulabramble> I just get the scuttlebutt through the grapevine.
15:44:32 <terranm> Good!
15:44:52 <redavis> shulabramble++
15:45:20 <shulabramble> anyway, that's all the news we have right now. i'll hold off on further stuff until the meeting is closed.
15:45:32 <shulabramble> #topic Launchpad hygiene: targets for 4.0-beta even though it's not branched? add a new series for "4.next" to replace 3.next?
15:45:51 <abneiman> this was me
15:45:59 <redavis> seems like a great idea
15:46:12 <shulabramble> abneiman++ yeah, that seems like a good idea.
15:46:14 <abneiman> just a thought as I was spending a lot of time on targets recently (sleary++ for the 80 million pullrequests)
15:46:22 <redavis> lol
15:46:28 <gmcharlt> one thought: the 4.0-beta LP target can certain exist well before a branch does
15:46:44 <jeff> any benefit to renaming the 3.next target to 4.next, or should those bugs not be automatically moved without individual attention/etc?
15:46:48 <abneiman> I, and others, have been inconsitent about 4.0-beta targets. Realistically, it's just a tracking mechanism - as Galen notes, it's independent from the branch
15:46:59 <redavis> gmcharlt++
15:47:10 <gmcharlt> and plain old "next" or "future" rather than "3.next" would work - but I think we should also consider simply not assigning a target for such bugs
15:47:14 <abneiman> I'm more asking about what SHOULD be targeted to 4.0-beta, if there's a preference or a best practice
15:47:38 <gmcharlt> ah - current practice is new features and enhancements would get beta targets
15:47:41 * mmorgan would also like to hear best practices.
15:47:54 <gmcharlt> normal bugs fixes that get merged would just get the relevant 3.x.y targets
15:48:16 * redavis needs to move on to next things right now, but will catch up on the minutes/log.
15:48:26 <shulabramble> redavis++
15:48:32 <shulabramble> gmcharlt++
15:48:34 <abneiman> yeah that's what I thought, but it seems that a few of us (self included) were not following that. I will correct mine own behaviour and shake a stick at the rest of you, lol
15:48:40 <abneiman> gmcharlt++
15:48:53 <gmcharlt> generally, pure bugfixes that end up in 4.0-beta would be _just_ things that affect the main branch only
15:49:04 <gmcharlt> e.g., cleanup of a new feature that was previously committed for inclusion in 4.0-beta
15:49:24 <abneiman> ah
15:49:43 <abneiman> what about something like this? https://bugs.launchpad.net/evergreen/+bug/2115535
15:49:44 <pinesol> Launchpad bug 2115535 in Evergreen 3.15 "OPAC basket dropdown should be a nav landmark" [Low,Fix committed]
15:50:03 <abneiman> should that have a 4.0 target or not, since it's just going into main as a "general bugfix" at this point?
15:50:04 <gmcharlt> and to articulate an organizing principle that I think has been only tacit until now: the idea (or at least, my idea) is that a bug target represents the _first_ time that it shows up in any release
15:50:32 <gmcharlt> abneiman: for that example, it should not have a 4.0-beta target
15:50:36 <abneiman> ok, thanks
15:50:48 <abneiman> that clarifies it for me
15:50:55 <abneiman> and I'll go cleanup my LP detritus :)
15:51:09 <gmcharlt> abneiman: what's that band's genre? ;)
15:51:20 <terranm> Punk for sure
15:51:28 <sleary> that does clarify it, but leaves us without an efficient way to indicate the destination of the fix rather than just the origin of the bug
15:51:31 <sleary> if that makes sense
15:51:36 <csharp_> @band add abneiman's LP detritus
15:51:36 <pinesol> csharp_: Band 'abneiman's LP detritus' added to list
15:51:41 <abneiman> lol
15:51:47 <abneiman> and, sleary's point is well taken
15:52:36 <shulabramble> abneiman++ sleary++ csharp++
15:52:40 <jeffdavis> Is there a list of requirements for 4.0? Like "a 4.0 release should contain the following features"? Or has it just already been decided that 4.0 is the next one?
15:52:49 <shulabramble> csharp_++
15:53:24 <shulabramble> jeffdavis++
15:53:25 <abneiman> jeffdavis: I think the original intent was to have full angular circ for 4.0, however I do not think that is realistic at this point
15:53:37 <abneiman> so the answer to your question would be "the latter"
15:53:47 <gmcharlt> sleary: I think the current practice basically assumes that the LP milestone target is purely about the destination of the fix. There isn't an equivalent to (e.g.) Koha's Bugzilla that has fields to indicate all release streams where the bug is/was present
15:53:58 <gmcharlt> (if I'm understanding your point correctly)
15:54:08 <sleary> gmcharlt you are. thanks.
15:54:43 <shulabramble> we're running up on the hour, so do we wanna action item this for further discussion?
15:54:58 <shulabramble> and we still have one more piece of business
15:55:00 <terranm> I remember angular circ being the original target for 4.0 as well.
15:55:23 <jeffdavis> I can email the dev list about "what even is a 4.0" if we want to continue that discussion elsewhere
15:55:35 <gmcharlt> likewise, but regardless, we'll nonetheless make 4.0 a release to remember :)
15:55:39 <shulabramble> jeffdavis++
15:56:00 <gmcharlt> (nothing that I say this as somebody who has a very strong preference for keeping debates about version numbering as short as possible)
15:56:19 <shulabramble> #action jeffdavis will email the dev list about launchpad hygiene for 4.0-beta etc
15:56:35 <shulabramble> #topic Feedback requested: QA checklist for grids (with potential automated tests highlighted) - https://docs.google.com/document/d/1RDNU4d78wX9wfQjdFsY2PHjLQwjTXbSXLqZdHXrjBNk/edit?usp=sharing
15:57:05 <sleary> ah, this is me. Based on gmcharlt's excellent checklist for database tables and columns, here is one for grids!
15:57:26 <sandbergja> sleary++
15:57:27 <sleary> sandbergja and I have noted which ones seem like candidates for automated testing
15:58:15 <jeff> "This checklist. I like it. ANOTHER!"
15:58:21 <jeff> sleary++
15:58:23 <sleary> feel free to comment on the checklist and/or assign yourself to experiment with writing a test
15:58:33 <sleary> I will migrate this to the wiki eventually
15:58:34 <shulabramble> sleary++
15:59:07 <terranm> sleary++
15:59:22 <shulabramble> #info feel free to comment on the checklist and/or assign yourself to experiment with writing a test - https://docs.google.com/document/d/1RDNU4d78wX9wfQjdFsY2PHjLQwjTXbSXLqZdHXrjBNk/edit?usp=sharing
15:59:44 <shulabramble> #topic Announcements
15:59:59 <shulabramble> #topic Next Meeting is 12 August 2025
16:00:09 <shulabramble> We got anything more?
16:00:48 <shulabramble> in that case, solidly on the hour -
16:00:51 <shulabramble> #endmeeting