15:00:15 <shulabramble> #startmeeting 2025-08-12 - Developer Meeting
15:00:15 <pinesol> Meeting started Tue Aug 12 15:00:15 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:15 <pinesol> The meeting name has been set to '2025_08_12___developer_meeting'
15:00:27 <shulabramble> Time to roll!
15:00:33 <shulabramble> #topic Intros
15:00:42 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:49 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:01:05 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:12 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:28 <collum> #info collum = Garry Collum, KCPL
15:01:32 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:41 <terranm> #info terranm = Terran McCanna, PINES
15:02:55 <sleary> #info sleary = Stephanie Leary, EOLI
15:04:15 <shulabramble> Latecomers can introduce themselves as they enter
15:04:25 <smayo> #info smayo = Steven Mayo, PINES
15:04:27 <shulabramble> #topic Action Items from Last Meeting
15:04:40 <shulabramble> #topic sleary and sandbergja will report further progress on test writing wiki pages next month
15:04:55 <sandbergja> There's this puppy, feedback very welcome: https://wiki.evergreen-ils.org/doku.php?id=qa:preventing_regressions
15:05:10 <shulabramble> sandbergja++
15:05:17 <sleary> sandbergja has made great progress on improving the tests themselves; see bugs.launchpad.net/evergreen/+bugs?field.searchtext=&orderby=-date_last_updated
15:05:47 <shulabramble> #info feedback appreciated on https://wiki.evergreen-ils.org/doku.php?id=qa:preventing_regressions
15:05:47 <sleary> ... paste fail, sorry, that's http://bugs.launchpad.net/evergreen/+bugs?field.searchtext=&orderby=-date_last_updated
15:06:41 <sleary> we are working on more custom lint rules, and will update the wiki accordingly
15:06:48 <shulabramble> sleary++
15:07:08 <shulabramble> wanna do a further update next month?
15:07:12 <sandbergja> sleary++ # indeed
15:07:14 <sleary> absolutely
15:07:31 <shulabramble> #action sleary and sandbergja will report further progress on test writing wiki pages next month
15:07:41 <shulabramble> yay! moving on.
15:07:55 <shulabramble> #topic gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee
15:08:48 <sleary> I belive gmcharlt is out today
15:09:01 <shulabramble> sleary++ we'll kick that
15:09:05 <shulabramble> #action gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee
15:09:20 <shulabramble> #topic sandbergja will start a discussion on the developer's listserv concerning moving to github/gitlab
15:10:07 <sandbergja> This happened!  And Dyrcona and Bmagic discussed!
15:10:26 <shulabramble> sandbergja++ dyrcona++ and bmagic++
15:10:47 <shulabramble> I remember that happening! good job!
15:11:25 <shulabramble> any points of further discussion on that right now?
15:13:12 <shulabramble> no? then we keep going.
15:13:19 <shulabramble> #topic jeffdavis will email the dev list about launchpad hygiene for 4.0-beta etc
15:15:37 <jeffdavis> I did that! I think it's taken care of.
15:15:48 <shulabramble> jeffdavis++
15:15:56 <shulabramble> hooray!
15:16:04 <shulabramble> moving right along
15:16:11 <shulabramble> #topic Updates
15:17:01 <shulabramble> #topic Evergreen
15:17:01 <shulabramble> #info Thanks to Andrea, Gina, and Blake for volunteering for the team
15:17:02 <shulabramble> #topic The monthly release team is still in need of someone to do translations for 3.14.9 and 3.15.4
15:17:18 <shulabramble> Any volunteers?
15:17:28 * mmorgan has volunteered on the spreadsheet
15:17:40 <shulabramble> mmorgan++
15:17:46 <sandbergja> mmorgan++
15:18:47 <shulabramble> Any other news on updates this month?
15:19:55 <shulabramble> if not, then we get a wall of text.
15:20:01 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:20:02 <shulabramble> #topic Snapshot
15:20:02 <shulabramble> #info Open Bugs - 3317
15:20:03 <shulabramble> #info Pullrequests - 109
15:20:03 <shulabramble> #info Signedoff - 52
15:20:04 <shulabramble> #info Needswork - 94
15:20:04 <shulabramble> #info Needstestplan - 4
15:20:05 <shulabramble> #info Needsrebase - 22
15:20:05 <shulabramble> #topic Updates Since Last Meeting
15:20:06 <shulabramble> #info Bugs Added - 46
15:20:06 <shulabramble> #info Pullrequest tag Added - 58
15:20:07 <shulabramble> #info Signedoff tag Added - 58
15:20:07 <shulabramble> #info Needswork tag Added - 9
15:20:08 <shulabramble> #info Needstestplan tag Added - 1
15:20:09 <shulabramble> #info Needsrebase tag Added - 0
15:20:09 <shulabramble> #info Fix Committed - 40
15:20:28 <shulabramble> #topic New Business
15:20:45 <shulabramble> there's no new business on the agenda, so any last-minute additions?
15:21:26 <mmorgan> We have a schedule for Release 3.16: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:21:57 <sleary> I will note that there are lots of open PRs, and since Launchpad's filtering is terrible, I've added some prefab filtered links here: https://wiki.evergreen-ils.org/doku.php?id=dev:code_review and added a link to that page to the roadmap
15:22:03 <shulabramble> #topic Schedule for 3.16 is available here: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:22:40 <shulabramble> #topic filtered links for code review here: https://wiki.evergreen-ils.org/doku.php?id=dev:code_review
15:24:01 <shulabramble> last call for new business, because we might knock this out in under thirty minutes.
15:24:02 <terranm> sleary++
15:24:07 <shulabramble> sleary++ mmorgan++
15:24:13 <sleary> release dates are on the community calendar. Release team meetings are not yet, but will happen on Tuesdays throughout October
15:24:33 <shulabramble> #info release dates are on the community calendar. Release team meetings are not yet, but will happen on Tuesdays throughout October
15:24:44 <csharp_> can we schedule something like a community vote on the github question?
15:24:45 <mmorgan> sleary++
15:25:06 <shulabramble> csharp_++ sounds like a good idea to me.
15:25:22 <csharp_> it's like we're all kind of in favor of it but maybe no one's excited enough to actually do it?
15:25:42 <sandbergja> csharp_++
15:25:48 <sleary> csharp_ I think we're still hung up on moving the translation infrastructure
15:25:57 <csharp_> ah
15:26:07 <csharp_> then maybe voting is premature
15:26:07 <sleary> but otherwise yes, everyone appears to be in favor, or at least neutral :)
15:26:37 <shulabramble> sleary++
15:26:42 <sleary> this is a job for the nascent infrastructure committee
15:26:54 <csharp_> hey! I'm on that!
15:27:50 <csharp_> at least we've anubis-ized the current git server so we shouldn't see outages anymore (for now)
15:28:03 <sandbergja> anubis++
15:28:08 <sleary> anubis++
15:28:11 <shulabramble> csharp_++ nascent_infrastructure_committee++
15:28:20 <shulabramble> anpu++
15:29:08 <shulabramble> alrighty! Then we have announcements
15:29:14 <shulabramble> #topic Announcements
15:29:23 <shulabramble> #info Next Meeting is 9 September 2025
15:29:28 <shulabramble> Anything more?
15:30:47 <shulabramble> then in just about thirty minutes flat...
15:30:52 <shulabramble> #endmeeting