15:00:05 <shulabramble> #startmeeting 2025-09-09 - Developer Meeting
15:00:05 <pinesol> Meeting started Tue Sep  9 15:00:05 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:05 <pinesol> The meeting name has been set to '2025_09_09___developer_meeting'
15:00:15 <shulabramble> #topic Intros
15:00:30 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:00:44 <redavis> #info redavis = Ruth Frasur Davis, free agent mostly
15:01:06 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:10 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:10 <abneiman> #info abneiman, Equinox
15:01:13 <csharp_> #info csharp = Chris Sharp, GPLS
15:01:14 <collum> #info collum = Garry Collum, KCPL
15:01:16 <sleary> #info sleary = Stephanie Leary, Equinox
15:01:16 <smayo> #info smayo = Steven Mayo, GPLS
15:01:19 <gmcharlt__> #info gmcharlt = Galen Charlton, Equinox
15:01:20 <abneiman> er lemme try again
15:01:23 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:37 <abneiman> #info abneiman = Andrea Buntz Neiman, still Equinox, needs more coffee
15:01:39 <csharp_> abneiman: yeah, who even are you?
15:01:48 <abneiman> csharp_: I don't even know dude
15:01:53 <redavis> lol
15:01:56 <csharp_> abneiman++
15:02:04 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:02:08 <shulabramble> We've got a sparse agenda, unless we're adding abneiman having an existential crisis to the plans.
15:02:19 <terranm> #info terranm = Terran McCanna, PINES
15:02:20 <shulabramble> if so, it's going under New Business.
15:02:34 <abneiman> I did add something to the agenda, but it was not my existential crisis
15:02:59 <shulabramble> abneiman++ thanks for the heads up
15:03:20 <shulabramble> latecomers can continue introductions
15:03:28 <shulabramble> #topic Action Items from Last Meeting
15:03:40 <shulabramble> #topic sleary and sandbergja will report further progress on test writing wiki pages next month
15:04:03 <sleary> you may have noticed that we've been adding custom lint rules (and I have one more in the works)
15:04:09 <sleary> info on lint: https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa#angular_lint
15:04:22 <sleary> there's a link there to a commit that can be checked out to use as a template for writing your own rules
15:04:39 <sandbergja> I also have a question for the group: we used to have a twice-daily update from the test-runner about whether tests were passing or failing.  That came to this IRC channel.
15:04:47 <shulabramble> sleary++
15:05:05 <sandbergja> would anybody find that (or something similar) useful?
15:06:01 * mmorgan would say Yes.
15:06:03 <sleary> I would, but sandbergja knew that :)
15:06:15 <shulabramble> i think it'd be useful information
15:06:29 <sandbergja> and IRC would be a good place?
15:06:50 <Bmagic> #info Bmagic, MOBIUS
15:07:06 <mmorgan> +1 to IRC
15:07:42 <sandbergja> cool, thanks all
15:07:50 <shulabramble> sandbergja++
15:08:36 <mmorgan> sandbergja++
15:08:40 <mmorgan> sleary++
15:09:02 <shulabramble> do y'all want to report on this again next month, or do you feel like the test-writing wiki page is good as of now?
15:09:21 <sandbergja> I could go either way
15:09:24 <sandbergja> sleary?
15:09:39 <sleary> I think we will have a discussion item later about using git hooks, but that can be a separate agenda item
15:09:45 <sleary> I think we can retire this one for now
15:09:56 <shulabramble> sleary++ sandbergja++
15:09:57 <Bmagic> IRC rocks
15:10:11 <shulabramble> next item!
15:10:25 * csharp_ mumbles dad joke about IRC rocks
15:10:33 <shulabramble> #topic gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee
15:10:38 <shulabramble> i'll have my irc on the rocks.
15:11:09 <gmcharlt__> the infrastrucutre committee is formally established and operating
15:11:25 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:11:30 <shulabramble> gmcharlt_++
15:11:41 <sandbergja> infrastructure++
15:11:47 <mmorgan> gmcharlt++
15:11:52 <sleary> gmcharlt++
15:11:52 <sandbergja> gmcharlt++
15:12:21 <shulabramble> gmcharlt++
15:12:32 <Bmagic> gmcharlt++
15:12:43 <redavis> gmcharlt++
15:12:46 <shulabramble> folks, both of our action items from last month are done. wow.
15:12:59 <csharp_> ahem... speaking of infrastructure, sleary alerted me of the need to upgrade PHP on the webserver, which has led into a thorny set of migration issues - currently trying to reverse-engineer the many symlinks and non-cruft
15:13:18 <shulabramble> csharp++ and good luck.
15:13:29 <shulabramble> csharp_++ even
15:13:34 <csharp_> we have had a destination server available for this migration for literally *years*, so I'm trying to persevere
15:13:38 <Bmagic> csharp_++ # fight the good fight
15:13:57 <sandbergja> csharp_++
15:13:58 <sleary> csharp_ I've been holding off on the Dokuwiki update, since you're busy with that. Good luck!
15:14:04 <csharp_> no changes to the public site will happen before the replacement is ready
15:14:08 * shulabramble recites "Charge of the Light Brigade"
15:14:26 * redavis has some release stuff whenever you're ready
15:14:28 <csharp_> unless.... we just decide to upgrade Debian in place and kick the can down the road :-)
15:14:28 <Bmagic> I had a server once
15:14:48 <csharp_> no need to not update the site content, btw
15:14:49 <shulabramble> Moving on!
15:14:56 <shulabramble> #topic Updates
15:15:00 <shulabramble> #topic Release Info
15:15:07 <shulabramble> redavis, take it away
15:15:31 <redavis> I'll be quick in case there's also news for 3.16 from gmcharlt
15:15:43 <redavis> Evergreen 3.15.4 was released on August 21 along with 3.14.9. It included 18 fixes for 3.15.4 and 14 for 3.14.9.
15:15:55 <redavis> Next point releases are scheduled for September 17 and we're in need of release team members. You can sign up on the Buildmaster spreadsheet which is on the agenda and available here - https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:16:04 <shulabramble> redavis++
15:16:42 <redavis> That is all I have
15:17:06 <redavis> And thank you to the August release team of abneiman, mmorgan, gmonti, bmagic
15:17:07 <gmcharlt> as far as 3.16 is concerned, bit of a slow ramp-up, but per https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap, please note a couple key dates
15:17:26 <abneiman> noting a pending critical fix for 3.15.5 at lp2122448
15:17:29 <gmcharlt> namely - 2025-10-08 for feature slush
15:17:45 <gmcharlt> 2025-11-06 for general release
15:17:59 <gmcharlt> and between those, a feedback fest the week of 2025-10-13
15:19:04 <shulabramble> abneiman++ gmcharlt++
15:19:12 <Bmagic> abneiman++ gmcharlt++
15:19:31 <shulabramble> mmorgan++ gmonti++ bmagic++ as well
15:19:54 <shulabramble> #topic Evergreen
15:20:34 <shulabramble> #info Evergreen 3.15.4 was released on August 21 along with 3.14.9. It included 18 fixes for 3.15.4 and 14 for 3.14.9.
15:20:34 <shulabramble> #info Next point releases are scheduled for September 17 and we're in need of release team members. You can sign up on the Buildmaster spreadsheet which is on the agenda and available here - https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:21:04 <shulabramble> #info please note 3.16 roadmap dates on https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:21:29 <shulabramble> Any more release info today?
15:21:40 <gmcharlt> that's it from me
15:21:58 <shulabramble> then we have the wall of text.
15:22:04 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:22:04 <shulabramble> #topic Snapshot
15:22:05 <shulabramble> #info Open Bugs - 3353
15:22:05 <shulabramble> #info Pullrequests - 120
15:22:06 <shulabramble> #info Signedoff - 57
15:22:06 <shulabramble> #info Needswork - 98
15:22:07 <shulabramble> #info Needstestplan - 4
15:22:07 <shulabramble> #info Needsrebase - 22
15:22:08 <shulabramble> #topic Updates Since Last Meeting
15:22:08 <shulabramble> #info Bugs Added - 41
15:22:09 <shulabramble> #info Pullrequest tag Added - 24
15:22:09 <shulabramble> #info Signedoff tag Added - 18
15:22:10 <shulabramble> #info Needswork tag Added - 4
15:22:10 <shulabramble> #info Needstestplan tag Added - 0
15:22:11 <shulabramble> #info Needsrebase tag Added - 0
15:22:11 <shulabramble> #info Fix Committed - 21
15:22:22 <shulabramble> #topic New Business
15:22:24 <sandbergja> Noting that this is the highest backlog of prs + signedoffs we've had in over 4 years.  On the one hand, it's great to see so many contributions.  But I'm worried that, without some more action from committers, that a lot of the work that went into them will be wasted.
15:22:41 <shulabramble> #topic September point release team needed
15:22:44 <shulabramble> sandbergja++
15:23:00 <mmorgan> sandbergja++
15:23:04 <abneiman> sandbergja++
15:23:16 <abneiman> also, I retract my agenda item as redavis beat me to it :)
15:23:18 <Bmagic> sandbergja++ # I'll try to merge more!
15:23:31 <sandbergja> Bmagic++
15:23:40 <shulabramble> bmagic++
15:23:44 <redavis> Oh, abneiman, my apologies.
15:23:52 <shulabramble> redavis++ on the interception.
15:23:53 <mmorgan> Bmagic++
15:24:01 <abneiman> no worries :)
15:24:16 <shulabramble> Any other new business? I heard mention of git hooks at the top of the hour?
15:24:16 <sandbergja> (and of course, thanks to all who commit and review!)
15:24:24 <shulabramble> committers++
15:24:24 <redavis> and thank you for adding it to the agenda.
15:24:26 <sleary> there are several high priority bugs with pull requests that need review; https://wiki.evergreen-ils.org/doku.php?id=dev:code_review has the roundup as well as some filtered Launchpad links.
15:24:32 <sleary> git hooks -- another time!
15:24:33 <Bmagic> 57 pullrequest is quite a few
15:24:43 <shulabramble> sleary++
15:24:53 <Bmagic> signoff rather
15:25:20 <shulabramble> #topic there are several high priority bugs with pull requests that need review; https://wiki.evergreen-ils.org/doku.php?id=dev:code_review has the roundup as well as some filtered Launchpad links.
15:26:04 <sleary> I'm sure a bunch of those are OPAC accessibility bugs. I'll be happy to answer any questions about how to test those once  bug 2122448 is behind us.
15:26:06 <pinesol> Launchpad bug 2122448 in Evergreen "Clearing the shelving location in the holdings editor crashes the browser" [Critical,Confirmed] https://launchpad.net/bugs/2122448 - Assigned to Stephanie Leary (stephanieleary)
15:26:17 <shulabramble> sleary++
15:27:00 <shulabramble> If there's no more new business, then --
15:27:06 <shulabramble> #topic Announcements
15:27:14 <shulabramble> #info Next Meeting is 14 October 2025
15:27:25 <shulabramble> anything else to be announced?
15:27:38 <Bmagic> just one thing: Evergreen is the best ILS in the world!
15:27:59 <abneiman> #info hackaway room block is available
15:28:14 <shulabramble> bmagic++ abneiman++
15:28:26 <abneiman> can't find it on the wiki, but an email went out
15:28:34 <abneiman> dluch++ Rogan++
15:28:41 <Bmagic> The wiki does need a 2025 hack-a-way page
15:28:57 <shulabramble> dluch++ rogan++
15:29:14 <terranm> Does flying into St. Louis make the most sense?
15:29:16 <Rogan> I will add the wiki page today or tomorrow, it's been on my to do list just been backlogged after being sick a bit.
15:29:26 <Bmagic> Rogan++
15:29:40 <Bmagic> St. Louis is likely going to be cheaper than COU
15:29:54 <shulabramble> #action rogan will add the 2025 hack-a-way page to the wiki
15:30:00 <shulabramble> rogan++
15:30:10 <gmcharlt> I can confirm that STL (or maybe Kansas City) will likely be better than trying to get direct to COU
15:30:16 <terranm> rogan++ Bmagic++ dluch++
15:30:24 <Bmagic> but there's the 1.5 hour Highway 70 problem. Which is solved by a shuttle service called MOex https://moexpress.com/mox_ml/home.aspx?L=EN
15:30:43 * Dyrcona is flying to Kansas City, 'cause that's what the travel site picked.
15:31:03 <Bmagic> Dyrcona: did you have a plan for KC->Columbia?
15:31:17 <Dyrcona> No, not yet.
15:31:31 <terranm> If we shuttle in from the airport, are there plenty of restaurants within walking distance?
15:31:48 <Dyrcona> I didn't get offered flights to Columbia, didn't know if there was an airport.
15:32:10 <Bmagic> dluch and I were talking about picking people up with the MOBIUS car but I think we will need more information from everyone to make a plan
15:32:18 <Dyrcona> I put in Columbia, Missouri and KC and STL were all that came up.
15:32:34 <Dyrcona> I sent dluch my arrival and departures.
15:32:56 <Bmagic> terranm: not sure what you're asking? Eating at the airport in STL? Or Columbia?
15:33:09 <terranm> Bmagic While we're in Columbia
15:33:20 <Bmagic> oh yeah, that's gonna be the best part
15:33:50 <Bmagic> downtown Columbia is gonna blow your socks off. Don't want to hype it too much though, lol
15:33:56 <terranm> :D
15:34:21 <gmcharlt> I can give a non-Missourian endorsement of Columbia as actually a pretty decent place for food
15:34:57 <shulabramble> columbia-mo-food-scene++
15:35:07 <Bmagic> :) yeah, there's something for everyone
15:35:38 <shulabramble> i mean, i guess. i've never been, and being of stolid North Carolina extraction i give the BBQ out there a little side-eye.
15:35:51 <Bmagic> I'm not sure where that leaves us, as far as this convo. But I believe the outstanding issue seems to be STL->Columbia and/or KC->Columbia
15:36:44 <shulabramble> i think that transportation issue is the main thing now.
15:36:48 <Bmagic> Maybe when the wiki page exists, we can have a column for folks to mark down a landing time and KC/STL so we can study our options
15:37:30 <gmcharlt> (might be best managed in a private spreadsheet - not everybody will necessarily want to put their travel arrangements on a public website)
15:37:44 <Bmagic> that'll work too :)
15:38:02 <Bmagic> I'll stub one, just a sec
15:38:03 <shulabramble> gmcharlt++ bmagic++
15:38:50 <Bmagic> https://docs.google.com/spreadsheets/d/1bsSh8wrBZHZYgmaO0P173BtrEmt9r0aTfzu4f0l6DNY/edit?usp=sharing
15:39:12 <Bmagic> Google and their usual workflow antics: "Request access"
15:40:10 <shulabramble> hooray! anything more to discuss today?
15:41:34 <Bmagic> I got nothing
15:41:37 <Bmagic> shulabramble++
15:41:42 <gmcharlt> shulabramble++
15:41:54 <shulabramble> then with that
15:41:56 <shulabramble> #endmeeting