15:00:35 <shulabramble> #startmeeting 2025-10-14 - Developer Meeting
15:00:35 <pinesol> Meeting started Tue Oct 14 15:00:35 2025 US/Eastern.  The chair is shulabramble. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <pinesol> The meeting name has been set to '2025_10_14___developer_meeting'
15:00:46 <shulabramble> #topic Intros
15:00:56 <Dyrcona> #info Dyrcona = Jason Stephenson, CW MARS.
15:00:59 <shulabramble> #info shulabramble = Shula Link, GCHRL
15:01:16 <redavis> #info redavis = Ruth Frasur Davis, lately of ECDI
15:01:18 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:22 <briank> #info briank = Brian Kennedy, BCLC
15:01:24 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:01:27 <sandbergja> #info sandbergja = Jane Sandberg, PUL
15:01:28 <csharp_> #info csharp = Chris Sharp, GPLS
15:01:41 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:01:45 <collum> #info collum = Garry Collum, KCPL
15:02:25 <shulabramble> people can continue their intros as we get going.
15:02:45 <shulabramble> #topic Action Items
15:03:01 <shulabramble> #topic rogan will add the 2025 hack-a-way page to the wiki
15:03:39 <eeevil> #info eeevil = Mike Rylander, EOLI
15:04:20 <Dyrcona> I'd say that's done: https://wiki.evergreen-ils.org/doku.php?id=hack-a-way:hack-a-way-2025
15:04:22 <smayo> #info smayo = Steven Mayo, GPLS
15:04:27 <shulabramble> it looks like rogan -- yeah
15:04:33 <shulabramble> so rogan++
15:04:42 <shulabramble> that's the only action item from last time.
15:04:53 * redavis just updated the agenda with a monthly maintenance release note
15:05:06 <redavis> https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2025-10-14#evergreen
15:05:17 <shulabramble> redavis++
15:05:30 <shulabramble> #topic Updates
15:05:50 <shulabramble> #topic Evergreen
15:05:53 <shulabramble> #info Monthly maintenance releases moved to Oct. 22; 3.14.11 and 3.15.6
15:06:03 <redavis> Please sign up at https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 to help
15:06:19 <redavis> And thanks go mantis for signing up to build.
15:06:27 <shulabramble> #info Please sign up at https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 to help
15:06:29 <redavis> mantis++
15:06:32 <shulabramble> mantis++
15:07:16 <shulabramble> anything more on updates for this round?
15:07:16 <redavis> gcharlt has also proposed a change to the 3.16 release schedule
15:07:36 <shulabramble> #topic 3.16
15:07:51 <shulabramble> #info gmcharlt has proposed a change to the 3.16 release schedule
15:08:06 <redavis> https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap has not yet been updated. Just one sec
15:08:17 <redavis> Revised feature slush: 10/17
15:08:17 <redavis> Feature freeze: 10/27
15:08:17 <redavis> Beta release: 10/29
15:08:17 <redavis> String freeze: 11/3
15:08:18 <redavis> RC release: 11/6
15:08:18 <redavis> General release: 11/12 (during the hack-a-way)
15:09:15 <shulabramble> gmcharlt++
15:09:29 <shulabramble> is the release team moving forward on the updated release schedule?
15:09:42 <redavis> Yes.
15:09:56 <redavis> I'll update the wiki.
15:10:12 <shulabramble> #info please see https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap for updated 3.16 schedule
15:10:16 <shulabramble> redavis++
15:10:26 <mmorgan> redavis++
15:11:17 <shulabramble> anyone have any other notes on updates for OpenSRF, etc?
15:11:25 <Dyrcona> is it too late to sneak in support for Debian 13?
15:11:49 <csharp_> Dyrcona: testing that is on my to-do this week
15:12:01 <Dyrcona> csharp_++
15:12:57 <shulabramble> csharp_++
15:13:09 <shulabramble> okay, wall o' text incoming.
15:13:18 <shulabramble> #topic Launchpad Status (as of noon Eastern)
15:13:18 <shulabramble> #topic Snapshot
15:13:19 <shulabramble> #info Open Bugs - 3376
15:13:19 <shulabramble> #info Pullrequests - 116
15:13:20 <shulabramble> #info Signedoff - 52
15:13:20 <shulabramble> #info Needswork - 99
15:13:21 <shulabramble> #info Needstestplan - 3
15:13:21 <shulabramble> #info Needsrebase - 23
15:13:22 <shulabramble> #topic Updates Since Last Meeting
15:13:22 <shulabramble> #info Bugs Added - 44
15:13:23 <shulabramble> #info Pullrequest tag Added - 27
15:13:23 <shulabramble> #info Signedoff tag Added - 19
15:13:24 <shulabramble> #info Needswork tag Added - 5
15:13:24 <shulabramble> #info Needstestplan tag Added - 1
15:13:25 <shulabramble> #info Needsrebase tag Added - 1
15:13:25 <shulabramble> #info Fix Committed - 31
15:13:59 <csharp_> so, 31 down, 3376 to go, I guess
15:14:02 <eeevil> I've been buried in bigger things, but I expect to have a few small fixes for opensrf soon. things like object initialization thinkos ... oh, missed the topic. (no worries, just informational for some near future)
15:14:23 <shulabramble> just to revisit next month #action csharp_ is going to work on debian 13 support
15:14:32 <shulabramble> eeevil++
15:14:55 <redavis> Dyrcona++ csharp_++ eeevil++
15:14:57 <shulabramble> (I'm working from home today so my normal flow is thrown off a little)
15:15:57 <shulabramble> #topic New Business
15:16:40 <shulabramble> #topic eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)
15:16:41 <pinesol> Launchpad bug 2116980 in OpenSRF "Use Redis STREAMs for HA/LB" [Wishlist,New]
15:16:58 <eeevil> That's from me, just looking for eyes
15:17:18 <shulabramble> got any volunteer eyes willing to give it a look?
15:17:30 <Dyrcona> Does anyone use Redis in production?  Every time we've tried it has resulted in heart break.
15:17:46 <csharp_> Dyrcona: we do, very happily
15:17:53 <eeevil> right now, I think there is a segfault or use-after free when ALL services are dereg'd, causing the routers to croak. otherwise, it's been working well for me in my dev env for ~3mo
15:18:08 <shulabramble> csharp++ pines_team++
15:18:36 <Dyrcona> I have no trouble in dev. In prod or testing we quickly run out of drones.
15:18:54 <eeevil> in particular, I would like to invoke berick's name ... he def knows the redis rewrite's guts best
15:19:18 <csharp_> @seen berick
15:19:18 <pinesol> csharp_: berick was last seen in #evergreen 5 days, 5 hours, 38 minutes, and 6 seconds ago: <berick> Dyrcona: heh, you tell me.  my 2006 goggles are on the fritz
15:19:29 <Dyrcona> :)
15:20:00 <redavis> berick is on the road today.
15:20:07 <shulabramble> redavis++
15:20:12 <eeevil> Dyrcona: there are cross-domain reg issues in the current "mainline" redis branch. there's a specific commit in mine about that, and I wonder if that would help you? (not if you're not cross-registering, though)
15:20:46 <Dyrcona> No, I don't think we're going cross domain.
15:20:53 <eeevil> kk
15:20:56 <csharp_> we are not cross registering - just single app servers that don't know about the others
15:21:56 <eeevil> csharp_: if you have test-env tuits, I'm glancing longingly in your direction ... ;)
15:21:57 <Dyrcona> I can't promise anything. I'm terribly swamped lately.
15:22:25 * csharp_ bats eyelashes
15:22:35 <shulabramble> #action eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)
15:22:36 <pinesol> Launchpad bug 2116980 in OpenSRF "Use Redis STREAMs for HA/LB" [Wishlist,New]
15:22:42 <eeevil> in any case, the more eyes the merrier, with thanks in advance
15:22:50 <shulabramble> just to revisit next month in case anyone has some comments.
15:22:53 <shulabramble> eeevil++
15:22:55 <eeevil> +1
15:23:22 <shulabramble> Okay, anyone got any last minute new business?
15:24:05 <shulabramble> #topic Announcements
15:24:07 <shulabramble> #info Next Meeting is 11 November 2025
15:24:11 <redavis> newp - not over here. release dates are updated on roadmap wiki page. Please sign up for maintenance release team
15:24:29 <redavis> mmorgan++
15:24:52 <shulabramble> mmorgan++
15:25:16 <shulabramble> #info Hack-A-Way is Nov 10-12
15:25:24 <mmorgan> November 11 is a US holiday, should we reschedule?
15:25:45 <shulabramble> oh, dang. yeah, i'm off that day.
15:25:58 <Dyrcona> Well, it's during the hack-away.
15:26:15 <Dyrcona> So, holiday or not, many of us will be working.
15:27:11 <shulabramble> anyone want to volunteer to run the meeting that day?
15:27:15 <csharp_> @decide holiday or hackaway
15:27:15 <pinesol> csharp_: go with hackaway
15:27:45 <Dyrcona> I should be able to run the meeting.
15:27:53 <shulabramble> dyrcona++
15:28:11 <shulabramble> #info Special Guest Host for Nov 11 Meeting is Dyrcona
15:28:43 <shulabramble> so with that all sorted.
15:29:01 <shulabramble> thank you, Dyrcona
15:29:02 <redavis> Dyrcona++
15:29:11 <redavis> shulabramble++
15:29:11 <mmorgan> Dyrcona++
15:29:16 <csharp_> A Very Special Dev Meeting
15:29:45 <shulabramble> the real surprise -- musical guest, Bad Bunny somehow?
15:29:54 <shulabramble> #endmeeting