15:06:40 <gmcharlt> #startmeeting 2025-11-11 Evergreen Development Meeting
15:06:40 <pinesol> Meeting started Tue Nov 11 15:06:40 2025 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:40 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:40 <pinesol> The meeting name has been set to '2025_11_11_evergreen_development_meeting'
15:06:53 <gmcharlt> so, this will be a bit of a hybrid, so to speak
15:07:00 <gmcharlt> but anyway
15:07:06 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2025-11-11
15:07:10 <gmcharlt> #topic Introductions
15:07:31 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:07:37 <gmcharlt> please go ahead an introduce yourselfs
15:07:47 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:07:47 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:07:49 <berick> #info berick Bill Erickson KCLS
15:08:24 <collum> #info collum = Garry Collum, KCPL
15:08:25 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:09:11 <gmcharlt> #topic Action items from previous meetings
15:09:21 <dluch> #info dluch = Debbie Luchenbill, MOBIUS
15:09:23 <JBoyer> #info JBoyer = Jason Boyer, EOLI
15:09:50 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:09:55 <gmcharlt> #info the RediSRF stream based has received testing during the hack-a-way; various bugfixes under way
15:10:34 <Rogan> #info Rogan = Rogan Hamby, EOLI
15:10:35 <gmcharlt> #info The Debian 13 compatibility branch has been committed to main
15:11:24 <ying_h> #info ying_h Ying-Hsiang Huang, KCLS
15:12:12 <gmcharlt> #info 314.1, 3.16.6, and 3.16-bbeta and 3.16-rc released
15:12:22 <gmcharlt> #info 3.16.0 will be released tomorrow, 2025-11-12
15:13:08 <gmcharlt> #info DIG had a working meeting on November 6, decided on standard terminology for some common words/phrases in the docs, and updated the style guide.
15:13:52 <gmcharlt> #topic New business
15:14:01 <gmcharlt> #topic Proposal for 2026 releases
15:14:50 <gmcharlt> proposal discussed at hack-a-way is to plan for the entirety of 2026
15:15:04 <gmcharlt> to wit, 3.17 in the spring as a "normal" release
15:15:25 <gmcharlt> 4.0 as the autumn release with Angular Circ as the big release/community goal
15:15:39 <gmcharlt> thoughts? questions? tomatos?
15:15:57 <Rogan> I'll formally voice my support for the plan.
15:16:00 <Bmagic> If you're on zoom, feel free to use the mic
15:16:13 <dluch> *applause*
15:16:27 <csharp_> @band add Silent Applause
15:16:27 <pinesol> csharp_: Band 'Silent Applause' added to list
15:16:29 <abneiman> is the idea to appoint the 4.0 team early to ensure meaningful progress on Angular Circ?
15:16:32 <Bmagic> https://us02web.zoom.us/j/83241056280?pwd=A02S7K8UkHmxUwssG5xg0b7gwCQgcp.1
15:16:52 <dluch> abneiman: Yes!
15:17:00 <gmcharlt> abneiman: certainly to appoint 3.17 ASAP, and yeah, doing 4.0 sooner is reasonable
15:17:16 <gmcharlt> and of course, could easily be overlap between the two
15:17:31 <abneiman> I'd strongly encourage 4.0's team to be (Almost)ASAP
15:17:41 <abneiman> since there's a lot of pieces still out there for angcirc
15:22:27 <gmcharlt> #action gmcharlt will issue call for 3.17 and 4.0 release teams right after 3.16.0 is relased
15:23:45 <sandbergja> is there any way to enable automatic closed captions in the zoom?  It's hard for me to hear, and being able to enable those for myself would probably help me catch a few more words.
15:24:19 <csharp_> I imagine it would be difficult to translate them accurately with low volume
15:24:42 <abneiman> sandbergja: same, I have my volume all the way up and I'm still only catching Galen really
15:24:47 <csharp_> hold please, we're working on it
15:24:58 <sandbergja> thank you!
15:25:20 <csharp_> turn it on on your end, re Bmagic
15:25:50 <csharp_> hybrid_meetings--
15:26:20 <csharp_> 3x in this case, Zoom, IRC, in-person
15:26:33 * berick queues elevator music
15:26:47 * csharp_ hums Burt Bacharach
15:28:01 <smayo> #info smayo = Steven Mayo, GPLS
15:28:43 <gmcharlt> #topic Translation infrastructure
15:29:23 <terranm> #info terranm = Terran McCanna, PINES
15:29:26 <gmcharlt> Upshot - LP's move away from Bazaar without them (yet) adjusting their translation infrastruture to work with only Git is kinda pulling the rug out from underneath us
15:29:38 <gmcharlt> I started a discussion on evergreen-dev
15:29:50 <gmcharlt> but upshot: I think it's time for us to seriously look for alternatives
15:29:58 <gmcharlt> a couple that come to mind are
15:30:15 <gmcharlt> POEditor (but that's been a bit dicey at times as an offering)
15:30:22 <gmcharlt> Weblate (used by the Koha project, looks promising)
15:30:58 <gmcharlt> but in any event: for the moment, 3.16 translations can creak along for a bit from main, but that will shortly diverge
15:31:38 <gmcharlt> so I recommend that we form a working group to evaluate alternatives, including trialing Weblate, perhaps, and seeking an alternative in the next few months
15:32:21 <abneiman> is this something that should be bourght to the board as well?
15:32:29 <gmcharlt> I can issue that call, but any feedback (or other systems to evaluate?)
15:33:07 <JBoyer> I do like looking into Weblate since Koha is using it. Doubly so if it can be used for the Angular translations over POEditor
15:33:19 <berick> i'll give Weblate a try as well
15:33:56 <Bmagic> can I be in the working group?
15:33:57 <Rogan> I'm willing to help evaluate systems from the viewpoint of a new user to them. I do like the idea of trying Weblate since it's known to work for a project with a lot of similarities.
15:34:02 <gmcharlt> this potentially turns into a funding request to the board, particularly onnce concrete options are identified
15:34:35 <gmcharlt> there's also going need to be Infrastructure Commitee work on the buy vs. self-host recommendation
15:37:11 <Bmagic> 37 Euro's a month it looks like ? https://weblate.org/en/hosting/
15:38:00 <Bmagic> we have more than 10k strings I think
15:38:25 <gmcharlt> yeah - more pricing info here: https://weblate.org/en/hosting/#hosted
15:38:35 <gmcharlt> we'd have to count strings
15:38:59 <gmcharlt> but in any event, unless there's other feedback, I'll issue a call for a working group
15:39:08 <csharp_> gmcharlt++
15:39:21 <gmcharlt> #action gmcharlt will raise a call for a working group to recommend translation infrastructure changes
15:39:38 <gmcharlt> #topic GitHub
15:39:49 <gmcharlt> another stream of discussion from the hack-a-way this morning
15:40:12 <gmcharlt> but upshot is that interest in switching to GitHub for code hosting and pull requests only for now seems to have solidified
15:40:29 <sandbergja> woo hoo!
15:40:32 <gmcharlt> so at this point I think it's going to be a matter of working out some details
15:40:50 <smayo> woohoo++
15:41:03 <gmcharlt> e.g., one Infrastructure Committee/Board thing of pursuing the free GitHub for nonprofits upgrade
15:41:15 <gmcharlt> figuring out the configs we want for the repo
15:41:24 <gmcharlt> deciding when/if to clone the current working repo to GH
15:41:46 <gmcharlt> and firguring out how permissions and teams in GH will work for us, including the docs committers
15:41:57 <gmcharlt> as well as establishing some contributor guidelines for making pull requests
15:42:21 <gmcharlt> so some work, but IMO not a ton, and we can iterate
15:42:46 <gmcharlt> but another aspect of that discussion is this: not plannign to adopt Github for _issues_ right away
15:42:58 <gmcharlt> instead sticking with LP (and turning off GH's issues)
15:43:07 <abneiman> is this also being taken up by the infrastructure committee or is it a separate working group?
15:44:32 <gmcharlt> a bit of both - the GH plan is an infra comm thing, but establishing and implementing guidelines for the contribution process itself is necessarily a broader contributor concern
15:44:42 <csharp_> +1
15:45:11 <Bmagic> +1
15:46:28 <Rogan> +1
15:47:04 <gmcharlt> in any event, I think concretely next immedaite step is an email announcement/call
15:47:25 <gmcharlt> but before I do that, any other feedback?
15:47:32 <gmcharlt> or objections?
15:47:38 <Bmagic> none from me
15:47:44 <dluch> ++
15:48:10 <eeevil> I WOULD LIKE TO REGISTER A COMPLAINT
15:48:17 <eeevil> no, none from me
15:48:23 <JBoyer> +1
15:48:28 <gmcharlt> eeevil: I only accept complaints fromm goood
15:48:58 <gmcharlt> #action gmcharlt will initiate thread/call to action on the GitHub transition
15:49:39 <gmcharlt> and I think a corollary to that is starting a discussion about long-term plans for the bug tracker
15:50:06 <goood> so, as I was saying...
15:50:13 <ying_h> lol
15:50:19 <berick> heh
15:50:26 <gmcharlt> noting a suggestion that dluch made to consider carving out time at the conference in Seattle for a discussion re bug-reporting
15:51:05 <Rogan> I wonder if a scheduled session at the conference to discuss options would get more eyes on it than a meeting
15:51:12 <abneiman> +1 to a scheduled session
15:51:25 <dluch> +1 to that, definitely
15:51:39 <mmorgan> +1
15:52:06 <dluch> Preferably unopposed, if that's possible
15:52:43 <gmcharlt> dluch: or against "Why we should just wing it: an argument for not tracking bugs at all" ;)
15:53:05 <dluch> loll
15:53:05 <Rogan> "our new reporting system will utilize the akashic records"
15:53:12 <gmcharlt> but seriously, something to pitch to the conference committee
15:53:22 <abneiman> unopposed would be great but a cage match would be funnier
15:53:30 <dluch> oooo
15:54:01 <gmcharlt> dluch: will you take an action item to pitch the conference session?
15:54:17 <dluch> Sure!
15:54:40 <dluch> We have a conf comm meeting...tomorrow?
15:54:48 <gmcharlt> #action dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference
15:55:16 <gmcharlt> #topic Upcoming releases
15:55:28 <gmcharlt> #info  Release team needed for November point releases 3.16.1, 3.15.7 & 3.14.12 (?), due Nov 19 - sign up on the Buildmaster Spreadsheet
15:55:31 <gmcharlt> #info https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:55:36 <gmcharlt> noting a couple question marks
15:56:05 <gmcharlt> first, I'm proposing a quick 3.16.1 to include bugfixes that aren't in the RC but were merged to rel_3_16
15:56:48 <gmcharlt> I put down 11/19, but could be flexible; I just feel that shooting for sooner than mid-December might be good
15:57:04 <gmcharlt> and my other question mark is concerning 3.14.12
15:57:33 <gmcharlt> 3.14.x technically ended normal bugfix support last month, and there are currently just two fix-committed bugs targetted to that milestone in LP
15:57:48 <abneiman> 3.14.12 is arguably .... yes, security only
15:57:56 <gmcharlt> so I'm curious how much appetite there is for doing an extra normal bugfix release for 3.14
15:58:02 <abneiman> I put it in because I wasn't sure what the sense was about that
15:58:25 <Dyrcona> Are there sites running 3.14 that would upgrade to 3.14.12?
16:00:16 <abneiman> I'm not seeing anything critical on 3.14.12, and the one High-importance bug might be invalid at this point anyway (needs more testing tho IMO)
16:00:55 <dluch> I'd say cut it off, then
16:00:56 <abneiman> that being lp 2107346
16:00:57 <pinesol> Launchpad bug 2107346 in Evergreen 3.15 "Enhanced MARC Editor - Field tags, indicators, and subfield tags not saving consistently" [High,Incomplete] https://launchpad.net/bugs/2107346
16:01:16 <gmcharlt> OK. My feeling is that if people volunteer to build it, doesn't hurt, but that otherwise any other non-security backports can be cut off
16:01:34 <Dyrcona> +1
16:01:37 <dluch> sounds reasonable
16:01:39 <abneiman> gmcharlt: since I have stepped into Ruth's wrangling shoes, my OfficialTM opinion is cut it off. relatedly, are you going to wrangle for 3.16
16:01:41 <JBoyer> +1
16:01:46 <abneiman> er, 3.16.1?
16:02:42 <gmcharlt> abneiman: no objection to cutting of 3.14.2, and confirmed, I'll deal with wrangling 3.16.1
16:03:38 <abneiman> sounds good - I'll email dev list for more 3.15.7 contributors
16:03:51 <abneiman> Bmagic++ for getting his name out there already
16:04:02 <dluch> abneiman++
16:04:22 <gmcharlt> ok, then that moves us to
16:04:26 <gmcharlt> #topics Announcements
16:04:31 <gmcharlt> #topic Announcements
16:05:01 <gmcharlt> #info Next meeting is 12 December 2025
16:05:13 <gmcharlt> any other last minute topics or announcements?
16:06:20 <gmcharlt> hearing none...
16:06:22 <gmcharlt> #endmeeting