15:00:03 <shulaprime> #startmeeting 2025-12-09 - Developer's Meeting
15:00:03 <pinesol> Meeting started Tue Dec  9 15:00:03 2025 US/Eastern.  The chair is shulaprime. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:03 <pinesol> The meeting name has been set to '2025_12_09___developer_s_meeting'
15:00:14 <shulaprime> #topic Intros
15:00:37 <shulaprime> #info shulaprime = Shula Link, GCHRL for 22 more days
15:00:45 <goood> #info goood = Mike Rylander, EOLI
15:00:52 <collum> #info collum = Garry Collum, KCPL
15:01:03 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Coop (Sitka)
15:01:21 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:01:34 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:34 <hdarcy> #info hdarcy = Hannah Darcy, new dev volunteer
15:01:54 <phasefx> phasefx = Jason Etheridge, Equinox
15:02:45 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:03:22 <shulaprime> Latecomers can continue to do intros as they come in.
15:03:32 <briank> #info briank = Brian Kennedy, BC Libraries Coop (Sitka)
15:03:41 <shulaprime> #topic Action Items from Last Meeting
15:03:45 <shulaprime> #topic eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)
15:03:46 <pinesol> Launchpad bug 2116980 in OpenSRF "Use Redis STREAMs for HA/LB" [Wishlist,New]
15:04:19 <shulaprime> Do we have any commentary on this?
15:05:02 <goood> my dev system is happy with it... </commentary> ;)
15:05:26 <shulaprime> goood++
15:05:34 <jeff> "Works on [miker's] Machine!"
15:05:49 <gmcharlt> "quick, everybody grab that machine!'
15:05:58 <jeff> And thus, Docker was born.
15:06:15 <shulaprime> lol jeff++ for beating me to the joke.
15:06:22 <goood> ew, jeff. ew.
15:06:23 <jeff> miker: is everything needed to test/eval included in that bug?
15:06:51 * jeff belatedly realizes why his attempts to tab-complete "miker" were failing...
15:07:26 <goood> jeff: should be, yes. the key is --reset-message-bus --hard to start
15:07:33 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:08:41 <shulaprime> the vibe i'm getting is we should revisit this next month when there are more eyes; a situation i'm sure is likely during the holiday season ;)
15:09:13 <goood> seems likely, yeah
15:09:36 <shulaprime> goood++
15:09:42 <shulaprime> #action eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)
15:09:43 <pinesol> Launchpad bug 2116980 in OpenSRF "Use Redis STREAMs for HA/LB" [Wishlist,New]
15:10:00 <goood> @later tell Dyrcona was your earlier redis test with my branch or current main?
15:10:00 <pinesol> goood: The operation succeeded.
15:10:15 <goood> (for the "more eyes" tally)
15:10:23 <shulaprime> #topic csharp_ will look at Debian 13 compatibility
15:11:26 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:11:43 <shulaprime> since csharp_ doesn't appear to be here, this is another kick to next month
15:11:48 <shulaprime> #action csharp_ will look at Debian 13 compatibility
15:12:07 <shulaprime> #topic gmcharlt will issue call for 3.17 and 4.0 release teams right after 3.16.0 is relased
15:12:44 <gmcharlt> that will need to be punted, but just to an hour from now
15:12:51 <gmcharlt> i.e., I'll issue that call this afternoon
15:13:10 <shulaprime> gmcharlt++
15:13:32 <shulaprime> #action gmcharlt will issue call for 3.17 and 4.0 release teams in an hour or so
15:13:46 <shulaprime> #topic gmcharlt will raise a call for a working group to recommend translation infrastructure changes
15:13:59 <gmcharlt> again, tardy, but will do so today as well
15:14:24 <shulaprime> #action gmcharlt will raise a call for a working group to recommend translation infrastructure changes
15:14:40 <shulaprime> #topic gmcharlt will initiate thread/call to action on the GitHub transition
15:15:03 <shulaprime> third verse, same as the first two?
15:15:05 <shulaprime> :)
15:15:18 <gmcharlt> I'm very predictable today, it seems
15:15:36 <shulaprime> no worries, it's that time of year
15:15:41 <shulaprime> #action gmcharlt will initiate thread/call to action on the GitHub transition
15:15:59 <shulaprime> #topic dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference
15:16:46 <shulaprime> dluch is not around, it seems, so we punt
15:16:51 <shulaprime> #action dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference
15:17:04 <shulaprime> #topic Updates
15:17:13 <shulaprime> What have we got to discuss?
15:17:53 <shulaprime> if anything
15:20:06 <shulaprime> judging from the silence, i'll take that as a no current discussion points.
15:20:17 <shulaprime> and that means it's time for the wall of text
15:20:31 <shulaprime> once again, mmorgan++ for getting the agenda together.
15:20:39 <shulaprime> #topic Launchpad Status (as of noon Eastern)
15:20:40 <shulaprime> #topic Snapshot
15:20:40 <shulaprime> #info Open Bugs - 3327
15:20:41 <shulaprime> #info Pullrequests - 118
15:20:41 <shulaprime> #info Signedoff - 17
15:20:42 <shulaprime> #info Needswork - 100
15:20:42 <shulaprime> #info Needstestplan - 2
15:20:43 <shulaprime> #info Needsrebase - 23
15:20:43 <shulaprime> #topic Updates Since Last Meeting
15:20:44 <shulaprime> #info Bugs Added - 40
15:20:44 <shulaprime> #info Pullrequest tag Added - 21
15:20:45 <shulaprime> #info Signedoff tag Added - 10
15:20:45 <shulaprime> #info Needswork tag Added - 0
15:20:46 <shulaprime> #info Needstestplan tag Added - 0
15:20:46 <shulaprime> #info Needsrebase tag Added - 1
15:20:47 <shulaprime> #info Fix Committed - 29
15:21:11 <shulaprime> #topic New Business
15:21:14 <shulaprime> #topic Release team needed for December point releases 3.16.2, 3.15.8, due Dec. 31 - sign up on the Buildmaster Spreadsheet
15:21:38 <shulaprime> #info Buildmaster Spreadsheet link: https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:21:58 <shulaprime> any other new business?
15:22:12 * mmorgan is wondering if point releases should be delayed. 12/31 isn't a great date for releasing.
15:22:33 <abneiman> I think that's an error and they're actually expected 12/17
15:22:54 <gmcharlt> agreeed
15:23:11 <gmcharlt> (Evergreen: The Bubbly Release, anyone?)
15:23:19 <mmorgan> Oh, indeed. Guess I'm not good at reading calendars!
15:23:33 <shulaprime> says 12/17 on the spreadsheet, so that seems like a definite error
15:23:39 <abneiman> a bottle for every member of the release team, what could possibly go wrong
15:23:57 <mmorgan> Someone else can load that release first!
15:24:04 <abneiman> anyway I'm willing to wrangle for a 12/17 release but I have other plans on 12/31 ;-)
15:24:38 <shulaprime> abneiman++
15:25:06 <jeff> They're only regressions if they're from the Regression region of France. Otherwise they're just sparkling bugs.
15:25:10 <gmcharlt> I've signed up for the the building-related tasks for 3.16.2; I can do it for 3.15.8 as well but would prefer that the work be more spread out
15:25:31 * mmorgan can do the translations for 3.15.8.
15:25:34 <abneiman> jeff++
15:25:57 <shulaprime> jeff++ mmorgan++ gmcharlt++
15:26:06 <abneiman> gmcharlt++ mmorgan++
15:26:20 <abneiman> I'll give another day or two for other volunteers then I'll send out an email
15:26:35 * mdriscoll will test tarballs
15:26:37 <abneiman> mdriscoll++
15:26:40 <shulaprime> abneiman++ sounds like a plan
15:26:44 <shulaprime> mdriscoll++
15:28:30 <shulaprime> #info abneiman will request volunteers if willing subjects do not step forward
15:28:45 <shulaprime> #topic Announcements
15:29:04 <shulaprime> #topic Next Meeting -- 2026-01-13
15:29:53 <shulaprime> anything more at present?
15:30:47 <shulaprime> then with the power vested in me...
15:30:51 <shulaprime> #endmeeting