15:01:55 <Dyrcona> #startmeeting 2026-01-13 Development Meeting
15:01:55 <pinesol> Meeting started Tue Jan 13 15:01:55 2026 US/Eastern.  The chair is Dyrcona. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:55 <pinesol> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:55 <pinesol> The meeting name has been set to '2026_01_13_development_meeting'
15:02:10 <Dyrcona> #topic Introductions
15:02:28 <gmcharlt> #info Galen Charlton, Equinox
15:02:29 <Dyrcona> #info Dyrcona = Jason Stephenson, CWMARS
15:02:30 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:02:46 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:03:12 <mmorgan> #info mmorgan = Michele Morgan, NOBLE
15:03:33 <mdriscoll> #info mdriscoll = Martha Driscoll, NOBLE
15:03:53 <Dyrcona> I'll give another minute or so, and others can introduce themselves as they join.
15:04:03 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:04:31 <mantis> #info mantis = Gina Monti, Bibliomation
15:05:02 <Dyrcona> #topic Action Items from Last Meeting
15:05:32 <Dyrcona> #info eyes wanted on Redis Stream-based HA/LB branch
15:05:55 <Dyrcona> #info Dyrcona (me) has been looking at it without load balancing and it's working so far.
15:06:24 <Dyrcona> I'll update the bug later this week. I'd like to test it with load balancing if I can figure that out.
15:07:00 <Dyrcona> I don't think there's much else to say about that, so...
15:07:07 <Dyrcona> #info csharp_ will look at Debian 13 compatibility
15:07:26 <Dyrcona> #info That's also done and in the main branches for both Evergreen and OpenSRF.
15:07:42 <Dyrcona> It think it went in before the December meeting.
15:08:02 <Dyrcona> Now, for the good stuff. :)
15:08:07 <Dyrcona> #info gmcharlt will issue call for 3.17 and 4.0 release teams in an hour or so
15:08:17 <gmcharlt> call issued!
15:08:28 <gmcharlt> updates later in the agenda
15:08:48 <Dyrcona> Ok, moving on then.
15:09:17 <Dyrcona> I'm going to put the next two together since they also involve gmcharlt.
15:09:34 <Dyrcona> #info gmcharlt will raise a call for a working group to recommend translation infrastructure changes
15:09:41 <Dyrcona> #info gmcharlt will initiate thread/call to action on the GitHub transition
15:09:52 <gmcharlt> both working groups established and held their innaugural meetings
15:10:08 <gmcharlt> a bit more to say about both later in the agenda
15:10:18 <Dyrcona> OK.
15:10:32 <Dyrcona> #info dluch will propose a session on bug-reporting tools and possible transitions for the 2026 Evergreen Conference
15:11:39 <Dyrcona> Not sure if dluch is paying attention, but I'm not sure this needs to be carried forward to the next meeting.
15:11:51 <Dyrcona> We'll just assume that she did.
15:12:21 <Dyrcona> Moving on in a moment.
15:12:44 <Dyrcona> #topic OpenSRF Release Info
15:13:01 <Dyrcona> I don't think we have anything for this, but thought that I'd ask.
15:14:35 <Dyrcona> #topic Evergreen Release Info
15:14:52 <Dyrcona> #info 3.17 release manager - Galen Charlton (gmcharlt)
15:15:15 <Dyrcona> #info Call for 3.17 release team members
15:15:32 <Dyrcona> #info Proposed general release date: 29 April 2026
15:15:43 <Dyrcona> Anything, you want to add gmcharlt?
15:15:56 <gmcharlt> I'll also send the call to mailing list, but anybody wants to volunteer to join the 3.17 release now, feel free!
15:16:23 <Dyrcona> I already volunteered, I think, but if I forgot I'm volunteering now.
15:16:42 <gmcharlt> thanks!
15:16:48 <Dyrcona> #action gmcharlt to call for 3.17 release volunteers on the mailing lists
15:17:32 <Dyrcona> Anything else to add before we move on to 4.0?
15:17:46 <gmcharlt> no
15:17:50 <Dyrcona> OK.
15:18:01 <Dyrcona> #info 4.0 release manager - Jason Stephenson (Dyrcona)
15:18:05 <Dyrcona> Hey, that's me! ;)
15:18:45 <Dyrcona> I'm hoping it will be a smashing release with all the new features and OpenSRF merged into Evergreen.
15:19:14 <Dyrcona> If not, we may rename it to 3.18, but I remain optimistic.
15:19:53 <Dyrcona> I feel like I should take an action item, but it seems a bit early. Maybe later we'll set up a roadmap.
15:20:19 <Dyrcona> Is there anything to say bout the December releases or upcoming January releases?
15:22:07 <abneiman> we need a team for Jan
15:22:17 <abneiman> https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:22:22 <abneiman> sign ups ^^
15:23:05 <Dyrcona> #info Volunteers for the January release requested.
15:23:40 <Dyrcona> #info sign up at the usual google sheet: https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing
15:24:00 <Dyrcona> Thanks, abneiman! I'll see if I have time to do something.
15:24:08 <abneiman> Dyrcona++
15:24:10 <csharp_> and just like that, all the slots are magically filled
15:24:10 <abneiman> appreciated
15:24:41 <csharp_> I'm always willing in case someone isn't able to help
15:24:50 <Dyrcona> Hey! They are filled.
15:24:53 <abneiman> gmcharlt++ mmorgan++ gmonti++ phasefx++ mjdriscoll++
15:24:58 <Dyrcona> abneiman++
15:24:58 <abneiman> y'all are the best
15:25:13 <csharp_> y'all++
15:25:37 <Dyrcona> gmcharlt++ mmorgan++ mantis++ phasefx++ mjdriscoll++
15:25:55 <Dyrcona> #topic Hatch Release Info
15:26:04 <mmorgan> gmcharlt++ abneiman++ mantis++ phasefx++ mjdriscoll++
15:26:26 <Dyrcona> It's on the agenda, but there's usually nothing to discuss, so I'll wait a short minute before moving on.
15:27:41 <Dyrcona> #topic Documentation
15:28:00 <Dyrcona> Anything from DIG or otherwise documentation-related?
15:29:45 <Dyrcona> Ok. then, prepare for the statistics flood. I hope it's up to date. I didn't check.
15:30:03 <Dyrcona> #topic Launchpad Status (as of noon Eastern)
15:30:03 <Dyrcona> #info Snapshot
15:30:03 <Dyrcona> #info Open Bugs - 3362
15:30:03 <Dyrcona> #info Pullrequests - 129
15:30:03 <Dyrcona> #info Signedoff - 16
15:30:05 <Dyrcona> #info Needswork - 100
15:30:05 <mmorgan> It should be up to date.
15:30:07 <Dyrcona> #info Needstestplan - 2
15:30:09 <Dyrcona> #info Needsrebase - 21
15:30:11 <Dyrcona> #info Updates Since Last Meeting
15:30:13 <Dyrcona> #info Bugs Added - 46
15:30:15 <Dyrcona> #info Pullrequest tag Added - 6
15:30:17 <Dyrcona> #info Signedoff tag Added - 3
15:30:19 <Dyrcona> #info Needswork tag Added - 1
15:30:21 <Dyrcona> #info Needstestplan tag Added - 0
15:30:23 <Dyrcona> #info Needsrebase tag Added - 1
15:30:25 <Dyrcona> #info Fix Committed - 6
15:30:44 <Dyrcona> mmorgan++
15:31:08 <Dyrcona> OK. On to the better stuff. ;)
15:31:17 <Dyrcona> #topic New Business
15:31:35 <Dyrcona> #info GitHub Implementation Working Group update
15:31:59 <gmcharlt> the working group held its first meeting on 1/6
15:32:09 <Dyrcona> gmcharlt, I think that's you again
15:32:11 <gmcharlt> documents of the WG can be found here: https://drive.google.com/drive/folders/1reBTYZ2JpkRiNTwfaRqhBDdpUlTN8XNE
15:33:17 <gmcharlt> timeframe we're shooting for is to have completed documentation in hand for a transition in March to have GitHub be the primary place for making pull requests
15:33:25 <Dyrcona> I'm going to info that to get it in the minutes.
15:34:06 <Dyrcona> #info documents of the GitHub WG can be found here: https://drive.google.com/drive/folders/1reBTYZ2JpkRiNTwfaRqhBDdpUlTN8XNE
15:34:10 <csharp_> github_working_group++
15:35:41 <Dyrcona> Anything else, before we move on?
15:36:00 <gmcharlt> no
15:36:03 <Dyrcona> We did have a good first meeting.
15:36:06 <Dyrcona> OK..
15:36:16 <Dyrcona> #info Translation Tools Working Group update
15:36:43 <gmcharlt> first meeting was held 1/7
15:37:06 <gmcharlt> #info Documents of the Translation ToolS WG can be found here: https://drive.google.com/drive/folders/1z4v3x4ZNlL9upqpjS3-xPZcC5IPeRnTW
15:37:23 <Dyrcona> gmcharlt++
15:37:23 <gmcharlt> we're working on requirements-gathering and identifying some services to try
15:37:47 <gmcharlt> we may be stuck with LP for 3.17; we'll see if that can be made to work
15:38:35 <gmcharlt> also, I received confirmation from the LP powers that be that they have no plans on providing support for automated translation branch management for Git repos, so reproducing the bzr-based workflow will not be an option
15:38:53 <csharp_> eww
15:38:54 <gmcharlt> that's my update unless there are questions
15:38:55 <Dyrcona> :(
15:40:01 <Dyrcona> Well, I guess we pre-empted the next one ealier, but I'll throw it in the minutes anyway. (I should have read the agenda more carefully before starting the meeting.)
15:40:10 <Dyrcona> #topic Point Releases next week
15:40:39 <Dyrcona> Looks like the assignments are already filled.
15:40:55 <Dyrcona> So, moving on..... to
15:41:09 <Dyrcona> #topic Announcements
15:41:24 <Dyrcona> #info Next Meeting is 10 February 2026
15:41:56 <Dyrcona> Anyone have anything they'd like to announce? Any cool projects? Just happy to be here?
15:43:02 <gmcharlt> Noting that if anybody has any last minute ideas to present at the Evergreen Conference this year, the proposal deadline is today
15:43:10 <csharp_> berick: ^^
15:43:49 <Dyrcona> #info Evergreen conference session proposal deadline is today 13 January 2026
15:43:53 <Dyrcona> gmcharlt++
15:44:29 <Dyrcona> Anyone have the link handy? I know there was an email with it earlier this week.
15:44:54 <gmcharlt> #info Conference proposal form is at https://docs.google.com/forms/d/e/1FAIpQLSeOxvA0H0couIb61m9JmnqZnJ7dxUgZpw7JlDknjYrnlu6cPg/viewform?usp=sharing&ouid=115637895465765706482
15:45:09 <gmcharlt> also
15:45:23 <gmcharlt> #info Super Early Bird Registraiton ends on 15 January 2026
15:45:43 <gmcharlt> miss that, and you'll have to content yourself with being a Plain Old Normal Early Bird
15:45:48 <csharp_> @band add Super Early Bird
15:45:48 <pinesol> csharp_: Band 'Super Early Bird' added to list
15:46:02 <Dyrcona> @band add Early and the Birds
15:46:02 <pinesol> Dyrcona: Band 'Early and the Birds' added to list
15:46:44 <Dyrcona> Anything else?
15:47:01 <abneiman> @band add Plain Old Normal Early Bird
15:47:01 <pinesol> abneiman: Band 'Plain Old Normal Early Bird' added to list
15:47:15 <csharp_> abneiman++
15:48:19 <Dyrcona> Ok, not hearing any more announcements or new business. I'm calling this meeting to an end.
15:48:25 <Dyrcona> #endmeeting