#evergreen: 2025-04-08 - Developer Meeting

Meeting started by shulabramble at 15:00:11 US/Eastern (full logs).

Meeting summary

  1. Introductions (shulabramble, 15:00:23)
    1. Shula Link - Greater Clarks Hill Regional Library (shulabramble, 15:00:36)
    2. redavis = Ruth Frasur Davis, Evergreen Collaborative Development Initiative (ECDI) (redavis, 15:00:54)
    3. terranm = Terran McCanna, PINES (terranm, 15:01:02)
    4. berick Bill Erickson, KCLS (berick, 15:01:06)
    5. collum = Garry Collum, KCPL (collum, 15:01:09)
    6. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:01:11)
    7. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:18)
    8. csharp = Chris Sharp, GPLS (csharp_, 15:01:19)
    9. mantis = Gina Monti, Bibliomation (mantis, 15:01:35)
    10. Bmagic = Blake GH, MOBIUS (Bmagic, 15:01:44)
    11. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:49)
    12. sleary = Stephanie Leary, Equinox (sleary, 15:01:50)
    13. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:02:10)

  2. Action Items from Last Meeting (shulabramble, 15:03:10)
    1. briank = Brian Kennedy, BCLC (briank, 15:03:14)

  3. eeevil will open a bug for cross-column stats targets (shulabramble, 15:03:27)
    1. AGREED: remove the action item cf. the cross-column stats targets bug for now (shulabramble, 15:07:57)

  4. Dyrcona will look into bug 2051946 (shulabramble, 15:08:12)
    1. ACTION: Dyrcona will look into bug 2051946 (shulabramble, 15:09:25)

  5. abneiman will follow up with gmcharlt cf. git POeditor integration (shulabramble, 15:10:16)
  6. Bmagic will look into transferring POeditor account ownership to a generic EG account (shulabramble, 15:12:15)
    1. ACTION: Bmagic will look into transferring POeditor account ownership to a generic EG account (shulabramble, 15:13:17)

  7. sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:13:27)
    1. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:13:48)

  8. abneiman will discuss moving the developer's meeting with shulabramble and poll the community (shulabramble, 15:14:23)
  9. Dyrcona will look at https://bugs.launchpad.net/evergreen/+bug/2073561 (shulabramble, 15:17:08)
  10. Updates (shulabramble, 15:17:52)
  11. Evergreen (shulabramble, 15:18:46)
  12. Thanks to Terran et al. for a very successful Feedback Fest! FBF stats (shulabramble, 15:18:57)
  13. 3.15-rc built this morning (thank you Galen!) and is being tested this afternoon, with release announcement & merge un-pause expected later today (shulabramble, 15:19:08)
  14. No merges to 3.15 branch unless they are critical bugfixes, lint fixes, or documentation (shulabramble, 15:19:17)
  15. 3.15.0 is slated for release next Wednesday 16th, as is 3.14.5 and 3.13.10 (shulabramble, 15:19:30)
  16. Launchpad Status (as of noon Eastern) (shulabramble, 15:32:21)
  17. Snapshot (shulabramble, 15:32:22)
    1. Open Bugs - 3257 (shulabramble, 15:32:22)
    2. Pullrequests - 62 (shulabramble, 15:32:23)
    3. Signedoff - 36 (shulabramble, 15:32:24)
    4. Needswork - 98 (shulabramble, 15:32:24)
    5. Needstestplan - 3 (shulabramble, 15:32:24)
    6. Needsrebase - 25 (shulabramble, 15:32:25)

  18. Updates Since Last Meeting (shulabramble, 15:32:26)
    1. Bugs Added - 82 (shulabramble, 15:32:26)
    2. Pullrequest tag Added - 74 (shulabramble, 15:32:26)
    3. Signedoff tag Added - 77 (shulabramble, 15:32:27)
    4. Needswork tag Added - 18 (shulabramble, 15:32:27)
    5. Needstestplan tag Added - 1 (shulabramble, 15:32:28)
    6. Needsrebase tag Added - 10 (shulabramble, 15:32:28)
    7. Fix Committed - 67 (shulabramble, 15:32:29)

  19. Hatch (shulabramble, 15:33:15)
  20. Can bug 2076921 be marked Fix Released or is there more to do? https://bugs.launchpad.net/evergreen/+bug/2076921 (shulabramble, 15:33:23)
  21. New Business (shulabramble, 15:39:55)
  22. Announcements (shulabramble, 15:48:41)
    1. Next Meeting is 13 May 2025 (shulabramble, 15:48:53)


Meeting ended at 15:52:15 US/Eastern (full logs).

Action items

  1. Dyrcona will look into bug 2051946
  2. Bmagic will look into transferring POeditor account ownership to a generic EG account
  3. sleary and sandbergja will report progress on test writing wiki pages next month


Action items, by person

  1. Bmagic
    1. Bmagic will look into transferring POeditor account ownership to a generic EG account
  2. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month


People present (lines said)

  1. shulabramble (87)
  2. abneiman (38)
  3. redavis (33)
  4. jeff (11)
  5. sleary (10)
  6. terranm (10)
  7. mmorgan (8)
  8. pinesol (7)
  9. berick (6)
  10. Bmagic (4)
  11. collum (3)
  12. csharp_ (1)
  13. mdriscoll (1)
  14. mantis (1)
  15. briank (1)
  16. jeffdavis (1)


Generated by MeetBot 0.1.4.