#evergreen: 2025-05-15 - Developer Meeting

Meeting started by shulabramble at 15:00:21 US/Eastern (full logs).

Meeting summary

  1. Intros (shulabramble, 15:00:30)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:49)
    2. redavis = Ruth Frasur Davis, ECDI (redavis, 15:01:08)
    3. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:36)
    4. mmorgan = Michele Morgan, NOBLE (mmorgan1, 15:01:44)
    5. berick Bill Erickson, KCLS (berick, 15:01:46)
    6. sleary = Stephanie Leary, Equinox (sleary, 15:01:48)
    7. eeevil = Mike Rylander, EOLI (eeevil, 15:02:08)
    8. collum = Garry Collum, KCPL (collum, 15:02:41)
    9. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:02:45)
    10. csharp = Chris Sharp, GPLS (csharp_, 15:03:24)
    11. abneiman = Andrea Buntz Neiman, Equinox (abneiman, 15:04:26)
    12. smayo = Steven Mayo, PINES (smayo, 15:04:38)
    13. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:04:38)
    14. terranm = Terran McCanna, PINES (terranm, 15:04:48)

  2. Action Items from Last Meeting (shulabramble, 15:05:01)
  3. bmagic will look into transferring POeditor account ownership to a generic EG account (shulabramble, 15:05:26)
    1. ACTION: Bmagic will look into transferring POeditor account ownership to a generic EG account (shulabramble, 15:07:40)

  4. sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:08:08)
    1. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:09:10)

  5. Updates (shulabramble, 15:09:21)
    1. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (redavis, 15:10:11)

  6. Releases (shulabramble, 15:10:21)
    1. Volunteers needed for the release team (shulabramble, 15:10:38)
    2. Please fill out the buildmaster spreadsheet if you're willing and able -- https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (shulabramble, 15:11:02)
    3. 3.15.0, 3.14.5, and 3.13.10 released on time and under budget (shulabramble, 15:12:24)
    4. Release Manager needed for next major release (shulabramble, 15:15:50)
    5. dluch = Debbie Luchenbill, MOBIUS (dluch, 15:17:02)
    6. ACTION: Release Manager needed for next major release (shulabramble, 15:17:25)
    7. 2025 Hackaway is hosted by MOBIUS in Columbia, Missouri (shulabramble, 15:19:47)
    8. 2026 International Conference in Renton Washington, hosted by KCLS, April 8-11, 2026 https://evergreen-ils.org/2026-evergreen-international-conference/ (shulabramble, 15:21:24)
    9. https://evergreen-ils.org/2026-evergreen-international-conference/ (shulabramble, 15:24:35)

  7. Launchpad Status (as of noon Eastern) (shulabramble, 15:24:45)
  8. Snapshot (shulabramble, 15:24:46)
    1. Open Bugs - 3247 (shulabramble, 15:24:46)
    2. Pullrequests - 93 (shulabramble, 15:24:47)
    3. Signedoff - 30 (shulabramble, 15:24:47)
    4. Needswork - 99 (shulabramble, 15:24:48)
    5. Needstestplan - 3 (shulabramble, 15:24:48)
    6. Needsrebase - 24 (shulabramble, 15:24:49)

  9. Updates Since Last Meeting (shulabramble, 15:24:49)
    1. Bugs Added - 52 (shulabramble, 15:24:50)
    2. Pullrequest tag Added - 39 (shulabramble, 15:24:50)
    3. Signedoff tag Added - 4 (shulabramble, 15:24:51)
    4. Needswork tag Added - 3 (shulabramble, 15:24:51)
    5. Needstestplan tag Added - 0 (shulabramble, 15:24:52)
    6. Needsrebase tag Added - 1 (shulabramble, 15:24:52)
    7. Fix Committed - 12 (shulabramble, 15:24:53)

  10. New Business (shulabramble, 15:25:10)
    1. sleary updated the Angular 18 upgrade branches this morning (LP2043490); eyes appreciated and input on if we should move to Angular 19 (shulabramble, 15:27:01)
    2. eeevil requests eyeballs on LP2091748 (shulabramble, 15:27:27)
    3. Next meeting is 10 June 2025 (shulabramble, 15:29:09)


Meeting ended at 15:30:19 US/Eastern (full logs).

Action items

  1. Bmagic will look into transferring POeditor account ownership to a generic EG account
  2. sleary and sandbergja will report progress on test writing wiki pages next month
  3. Release Manager needed for next major release


Action items, by person

  1. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month
  2. UNASSIGNED
    1. Bmagic will look into transferring POeditor account ownership to a generic EG account
    2. Release Manager needed for next major release


People present (lines said)

  1. shulabramble (68)
  2. redavis (31)
  3. abneiman (12)
  4. pinesol (6)
  5. sleary (5)
  6. jeff (4)
  7. berick (4)
  8. Dyrcona (4)
  9. eeevil (4)
  10. dluch (2)
  11. terranm (2)
  12. smayo (1)
  13. mmorgan1 (1)
  14. csharp_ (1)
  15. collum (1)
  16. mdriscoll (1)
  17. mmorgan (1)


Generated by MeetBot 0.1.4.