#evergreen: 2025-06-10 - Developer Meeting

Meeting started by shulabramble at 15:00:08 US/Eastern (full logs).

Meeting summary

  1. Intros (shulabramble, 15:00:17)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:33)
    2. phasefx = Jason Etheridge, EOLI (phasefx, 15:00:35)
    3. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:00:37)
    4. rogan = Rogan Hamby, EOLI (Rogan, 15:00:45)
    5. redavis = Ruth Frasur Davis, ECDI (redavis, 15:00:49)
    6. terranm = Terran McCanna, PINES (terranm, 15:00:51)
    7. sleary = Stephanie Leary, EOLI (sleary, 15:00:55)
    8. eeevil = Mike Rylander, EOLI (eeevil, 15:00:56)
    9. mmorgan = Michele Morgan, NOBLE (mmorgan2, 15:01:00)
    10. briank = Brian Kennedy, BCLC (briank, 15:01:09)
    11. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:10)
    12. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:01:11)
    13. smayo = Steven Mayo, PINES (smayo, 15:01:38)

  2. Action Items from Last Meeting (shulabramble, 15:02:52)
  3. Bmagic will look into transferring POeditor account ownership to a generic EG account (shulabramble, 15:03:02)
    1. Dyrcona = Jason Stephenson, CW MARS (Dyrcona, 15:03:44)
    2. ACTION: Bmagic will look into transferring POeditor account ownership to a generic EG account/moving this task to the nascent Infrastructure Committee (shulabramble, 15:05:53)

  4. sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:06:12)
    1. ACTION: sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:06:42)

  5. Release Manager needed for next major release (shulabramble, 15:06:59)
  6. Updates (shulabramble, 15:08:21)
  7. Release Info (shulabramble, 15:08:29)
    1. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (redavis, 15:10:16)

  8. Evergreen (shulabramble, 15:12:47)
    1. Evergreen 3.14.6 and 3.15.1 were released on May 21. Thanks to Bmagic, abneiman, mdriscoll, and mmorgan for their work on the maintenance release team. (shulabramble, 15:12:48)
    2. There were 24 LP tickets for 3.15.1 with fixes released and 22 LP tickets for 3.14.6 with fixes released. (shulabramble, 15:12:48)
    3. The maintenance releases for this month (June) are due next Wednesday, June 18, and we need volunteers for that. You can sign up on the buildmaster spreadsheet. (shulabramble, 15:12:49)
    4. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (shulabramble, 15:12:49)
    5. There is one critical fix to be released for both 3.15.2 and 3.14.7 among other less critical stuff. (shulabramble, 15:12:50)
    6. https://bugs.launchpad.net/evergreen/+bug/2112185 (redavis, 15:14:43)

  9. Launchpad Status (as of noon Eastern) (shulabramble, 15:16:43)
  10. Snapshot (shulabramble, 15:16:43)
    1. Open Bugs - 3250 (shulabramble, 15:16:44)
    2. Pullrequests - 89 (shulabramble, 15:16:44)
    3. Signedoff - 16 (shulabramble, 15:16:45)
    4. Needswork - 96 (shulabramble, 15:16:45)
    5. Needstestplan - 3 (shulabramble, 15:16:46)
    6. Needsrebase - 24 (shulabramble, 15:16:46)

  11. Updates Since Last Meeting (shulabramble, 15:16:47)
    1. Bugs Added - 38 (shulabramble, 15:16:47)
    2. Pullrequest tag Added - 26 (shulabramble, 15:16:48)
    3. Signedoff tag Added - 18 (shulabramble, 15:16:48)
    4. Needswork tag Added - 1 (shulabramble, 15:16:49)
    5. Needstestplan tag Added - 0 (shulabramble, 15:16:49)
    6. Needsrebase tag Added - 1 (shulabramble, 15:16:50)
    7. Fix Committed - 29 (shulabramble, 15:16:50)

  12. New Business (shulabramble, 15:17:17)
  13. Fall 2025 / 4.0 Release Team selection (shulabramble, 15:17:30)
    1. ACTION: Fall 2025 / 4.0 Release Team selection (shulabramble, 15:30:01)

  14. Announcements (shulabramble, 15:37:48)
  15. Next Meeting 8 July 2025 (shulabramble, 15:38:09)


Meeting ended at 15:40:24 US/Eastern (full logs).

Action items

  1. Bmagic will look into transferring POeditor account ownership to a generic EG account/moving this task to the nascent Infrastructure Committee
  2. sleary and sandbergja will report progress on test writing wiki pages next month
  3. Fall 2025 / 4.0 Release Team selection


Action items, by person

  1. sleary
    1. sleary and sandbergja will report progress on test writing wiki pages next month
  2. UNASSIGNED
    1. Bmagic will look into transferring POeditor account ownership to a generic EG account/moving this task to the nascent Infrastructure Committee
    2. Fall 2025 / 4.0 Release Team selection


People present (lines said)

  1. shulabramble (70)
  2. redavis (39)
  3. abneiman (13)
  4. sleary (9)
  5. jeff (4)
  6. phasefx (4)
  7. pinesol (4)
  8. mdriscoll (3)
  9. terranm (3)
  10. Dyrcona (2)
  11. eeevil (2)
  12. mmorgan2 (1)
  13. Rogan (1)
  14. briank (1)
  15. smayo (1)


Generated by MeetBot 0.1.4.