#evergreen: 2025-07-08 - Developer Meeting

Meeting started by shulabramble at 15:00:16 US/Eastern (full logs).

Meeting summary

  1. Intros (shulabramble, 15:00:36)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:49)
    2. redavis = Ruth Frasur Davis, ECDI and my own open-source ILS lovin' self. (redavis, 15:00:58)
    3. sandbergja = Jane Sandberg, PUL (sandbergja, 15:00:59)
    4. Rogan = Rogan Hamby, EOLI (Rogan, 15:01:04)
    5. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:01:06)
    6. collum = Garry Collum, KCPL (collum, 15:01:07)
    7. sleary = Stephanie Leary, EOLI (sleary, 15:01:10)
    8. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:11)
    9. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:01:13)
    10. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:17)
    11. phasefx = Jason Etheridge, EOLI (phasefx, 15:01:30)
    12. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:41)
    13. terranm = Terran McCanna, PINES (terranm, 15:01:49)
    14. csharp = Chris Sharp, GPLS (csharp_, 15:02:30)

  2. Action Items from Last Meeting (shulabramble, 15:02:42)
  3. sleary and sandbergja will report progress on test writing wiki pages next month (shulabramble, 15:02:56)
    1. https://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa#common_things_that_break_angular_unit_tests (shulabramble, 15:03:40)
    2. custom ESLint rules, e.g. #lp2019139 (shulabramble, 15:03:58)
    3. custom ESLint rules, e.g. lp2019139 (shulabramble, 15:04:04)
    4. ACTION: sleary and sandbergja will report further progress on test writing wiki pages next month (shulabramble, 15:06:02)

  4. Bmagic will look into transferring POeditor account ownership to a generic EG account/moving this task to the nascent Infrastructure Committee (shulabramble, 15:06:14)
    1. ACTION: gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee (shulabramble, 15:10:02)

  5. Fall 2025 / 4.0 Release Team selection (shulabramble, 15:10:40)
    1. https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 (redavis, 15:11:16)

  6. Updates (shulabramble, 15:16:33)
  7. Evergreen (shulabramble, 15:17:37)
    1. 3.14.7 and 3.15.2 were released on June 18 (shulabramble, 15:17:52)
    2. Bugsquashing week in progress 7-7-2025 to 13-7-2025 (shulabramble, 15:19:47)

  8. Launchpad Status (as of noon Eastern) (shulabramble, 15:23:54)
  9. Snapshot (shulabramble, 15:23:54)
    1. Open Bugs - 3324 (shulabramble, 15:23:55)
    2. Pullrequests - 115 (shulabramble, 15:23:55)
    3. Signedoff - 31 (shulabramble, 15:23:56)
    4. Needswork - 95 (shulabramble, 15:23:56)
    5. Needstestplan - 3 (shulabramble, 15:23:57)
    6. Needsrebase - 24 (shulabramble, 15:23:57)

  10. Updates Since Last Meeting (shulabramble, 15:23:58)
    1. Bugs Added - 92 (shulabramble, 15:23:58)
    2. Pullrequest tag Added - 60 (shulabramble, 15:23:59)
    3. Signedoff tag Added - 26 (shulabramble, 15:23:59)
    4. Needswork tag Added - 1 (shulabramble, 15:24:00)
    5. Needstestplan tag Added - 0 (shulabramble, 15:24:00)
    6. Needsrebase tag Added - 1 (shulabramble, 15:24:01)
    7. Fix Committed - 17 (shulabramble, 15:24:01)

  11. New Business (shulabramble, 15:24:30)
  12. Can we start accepting code pull requests via github as an option? (shulabramble, 15:24:53)
    1. DIG's github procedure - https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:github-workflow (shulabramble, 15:25:10)
    2. Pros: reviewers and contributors can see some test and lint results before committing, a nice UI for reviewers to see what has changed (shulabramble, 15:25:26)
    3. Cons: yet another workflow to learn and deal with, github is not a FOSS platform (shulabramble, 15:25:38)
    4. ACTION: sandbergja will start a discussion on the developer's listserv concerning moving to github/gitlab (shulabramble, 15:38:51)

  13. Updates on possible changes to where we have dev meetings (shulabramble, 15:39:58)
  14. Launchpad hygiene: targets for 4.0-beta even though it's not branched? add a new series for "4.next" to replace 3.next? (shulabramble, 15:45:32)
    1. ACTION: jeffdavis will email the dev list about launchpad hygiene for 4.0-beta etc (shulabramble, 15:56:19)

  15. Feedback requested: QA checklist for grids (with potential automated tests highlighted) - https://docs.google.com/document/d/1RDNU4d78wX9wfQjdFsY2PHjLQwjTXbSXLqZdHXrjBNk/edit?usp=sharing (shulabramble, 15:56:35)
    1. feel free to comment on the checklist and/or assign yourself to experiment with writing a test - https://docs.google.com/document/d/1RDNU4d78wX9wfQjdFsY2PHjLQwjTXbSXLqZdHXrjBNk/edit?usp=sharing (shulabramble, 15:59:22)

  16. Announcements (shulabramble, 15:59:44)
  17. Next Meeting is 12 August 2025 (shulabramble, 15:59:59)


Meeting ended at 16:00:51 US/Eastern (full logs).

Action items

  1. sleary and sandbergja will report further progress on test writing wiki pages next month
  2. gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee
  3. sandbergja will start a discussion on the developer's listserv concerning moving to github/gitlab
  4. jeffdavis will email the dev list about launchpad hygiene for 4.0-beta etc


Action items, by person

  1. gmcharlt
    1. gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee
  2. jeffdavis
    1. jeffdavis will email the dev list about launchpad hygiene for 4.0-beta etc
  3. sandbergja
    1. sleary and sandbergja will report further progress on test writing wiki pages next month
    2. sandbergja will start a discussion on the developer's listserv concerning moving to github/gitlab
  4. sleary
    1. sleary and sandbergja will report further progress on test writing wiki pages next month


People present (lines said)

  1. shulabramble (98)
  2. gmcharlt (33)
  3. abneiman (24)
  4. redavis (23)
  5. sandbergja (19)
  6. jeff (17)
  7. sleary (14)
  8. terranm (11)
  9. mmorgan (9)
  10. pinesol (7)
  11. csharp_ (3)
  12. collum (2)
  13. jeffdavis (2)
  14. Rogan (1)
  15. phasefx (1)
  16. mdriscoll (1)


Generated by MeetBot 0.1.4.