#evergreen: 2025-08-12 - Developer Meeting

Meeting started by shulabramble at 15:00:15 US/Eastern (full logs).

Meeting summary

  1. Intros (shulabramble, 15:00:33)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:42)
    2. phasefx = Jason Etheridge, EOLI (phasefx, 15:00:49)
    3. sandbergja = Jane Sandberg, PUL (sandbergja, 15:01:05)
    4. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:12)
    5. collum = Garry Collum, KCPL (collum, 15:01:28)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:32)
    7. terranm = Terran McCanna, PINES (terranm, 15:01:41)
    8. sleary = Stephanie Leary, EOLI (sleary, 15:02:55)
    9. smayo = Steven Mayo, PINES (smayo, 15:04:25)

  2. Action Items from Last Meeting (shulabramble, 15:04:27)
  3. sleary and sandbergja will report further progress on test writing wiki pages next month (shulabramble, 15:04:40)
    1. feedback appreciated on https://wiki.evergreen-ils.org/doku.php?id=qa:preventing_regressions (shulabramble, 15:05:47)
    2. ACTION: sleary and sandbergja will report further progress on test writing wiki pages next month (shulabramble, 15:07:31)

  4. gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee (shulabramble, 15:07:55)
    1. ACTION: gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee (shulabramble, 15:09:05)

  5. sandbergja will start a discussion on the developer's listserv concerning moving to github/gitlab (shulabramble, 15:09:20)
  6. jeffdavis will email the dev list about launchpad hygiene for 4.0-beta etc (shulabramble, 15:13:19)
  7. Updates (shulabramble, 15:16:11)
  8. Evergreen (shulabramble, 15:17:01)
    1. Thanks to Andrea, Gina, and Blake for volunteering for the team (shulabramble, 15:17:01)

  9. The monthly release team is still in need of someone to do translations for 3.14.9 and 3.15.4 (shulabramble, 15:17:02)
  10. Launchpad Status (as of noon Eastern) (shulabramble, 15:20:01)
  11. Snapshot (shulabramble, 15:20:02)
    1. Open Bugs - 3317 (shulabramble, 15:20:02)
    2. Pullrequests - 109 (shulabramble, 15:20:03)
    3. Signedoff - 52 (shulabramble, 15:20:03)
    4. Needswork - 94 (shulabramble, 15:20:04)
    5. Needstestplan - 4 (shulabramble, 15:20:04)
    6. Needsrebase - 22 (shulabramble, 15:20:05)

  12. Updates Since Last Meeting (shulabramble, 15:20:05)
    1. Bugs Added - 46 (shulabramble, 15:20:06)
    2. Pullrequest tag Added - 58 (shulabramble, 15:20:06)
    3. Signedoff tag Added - 58 (shulabramble, 15:20:07)
    4. Needswork tag Added - 9 (shulabramble, 15:20:07)
    5. Needstestplan tag Added - 1 (shulabramble, 15:20:08)
    6. Needsrebase tag Added - 0 (shulabramble, 15:20:09)
    7. Fix Committed - 40 (shulabramble, 15:20:09)

  13. New Business (shulabramble, 15:20:28)
  14. Schedule for 3.16 is available here: https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap (shulabramble, 15:22:03)
  15. filtered links for code review here: https://wiki.evergreen-ils.org/doku.php?id=dev:code_review (shulabramble, 15:22:40)
    1. release dates are on the community calendar. Release team meetings are not yet, but will happen on Tuesdays throughout October (shulabramble, 15:24:33)

  16. Announcements (shulabramble, 15:29:14)
    1. Next Meeting is 9 September 2025 (shulabramble, 15:29:23)


Meeting ended at 15:30:52 US/Eastern (full logs).

Action items

  1. sleary and sandbergja will report further progress on test writing wiki pages next month
  2. gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee


Action items, by person

  1. sandbergja
    1. sleary and sandbergja will report further progress on test writing wiki pages next month
  2. sleary
    1. sleary and sandbergja will report further progress on test writing wiki pages next month


People present (lines said)

  1. shulabramble (66)
  2. sleary (12)
  3. sandbergja (7)
  4. csharp_ (6)
  5. mmorgan (4)
  6. pinesol (3)
  7. terranm (2)
  8. smayo (1)
  9. phasefx (1)
  10. collum (1)
  11. mdriscoll (1)
  12. jeffdavis (1)


Generated by MeetBot 0.1.4.