#evergreen: 2025-09-09 - Developer Meeting

Meeting started by shulabramble at 15:00:05 US/Eastern (full logs).

Meeting summary

  1. Intros (shulabramble, 15:00:15)
    1. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:30)
    2. redavis = Ruth Frasur Davis, free agent mostly (redavis, 15:00:44)
    3. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:06)
    4. sandbergja = Jane Sandberg, PUL (sandbergja, 15:01:10)
    5. abneiman, Equinox (abneiman, 15:01:10)
    6. csharp = Chris Sharp, GPLS (csharp_, 15:01:13)
    7. collum = Garry Collum, KCPL (collum, 15:01:14)
    8. sleary = Stephanie Leary, Equinox (sleary, 15:01:16)
    9. smayo = Steven Mayo, GPLS (smayo, 15:01:16)
    10. gmcharlt = Galen Charlton, Equinox (gmcharlt__, 15:01:19)
    11. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:23)
    12. abneiman = Andrea Buntz Neiman, still Equinox, needs more coffee (abneiman, 15:01:37)
    13. phasefx = Jason Etheridge, Equinox (phasefx, 15:02:04)
    14. terranm = Terran McCanna, PINES (terranm, 15:02:19)

  2. Action Items from Last Meeting (shulabramble, 15:03:28)
  3. sleary and sandbergja will report further progress on test writing wiki pages next month (shulabramble, 15:03:40)
    1. Bmagic, MOBIUS (Bmagic, 15:06:50)

  4. gmcharlt will be calling an organizing meeting for the nascent Infrastructure Committee (shulabramble, 15:10:33)
    1. Dyrcona = Jason Stephenson, CWMARS (Dyrcona, 15:11:25)

  5. Updates (shulabramble, 15:14:56)
  6. Release Info (shulabramble, 15:15:00)
  7. Evergreen (shulabramble, 15:19:54)
    1. Evergreen 3.15.4 was released on August 21 along with 3.14.9. It included 18 fixes for 3.15.4 and 14 for 3.14.9. (shulabramble, 15:20:34)
    2. Next point releases are scheduled for September 17 and we're in need of release team members. You can sign up on the Buildmaster spreadsheet which is on the agenda and available here - https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?usp=sharing (shulabramble, 15:20:34)
    3. please note 3.16 roadmap dates on https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap (shulabramble, 15:21:04)

  8. Launchpad Status (as of noon Eastern) (shulabramble, 15:22:04)
  9. Snapshot (shulabramble, 15:22:04)
    1. Open Bugs - 3353 (shulabramble, 15:22:05)
    2. Pullrequests - 120 (shulabramble, 15:22:05)
    3. Signedoff - 57 (shulabramble, 15:22:06)
    4. Needswork - 98 (shulabramble, 15:22:06)
    5. Needstestplan - 4 (shulabramble, 15:22:07)
    6. Needsrebase - 22 (shulabramble, 15:22:07)

  10. Updates Since Last Meeting (shulabramble, 15:22:08)
    1. Bugs Added - 41 (shulabramble, 15:22:08)
    2. Pullrequest tag Added - 24 (shulabramble, 15:22:09)
    3. Signedoff tag Added - 18 (shulabramble, 15:22:09)
    4. Needswork tag Added - 4 (shulabramble, 15:22:10)
    5. Needstestplan tag Added - 0 (shulabramble, 15:22:10)
    6. Needsrebase tag Added - 0 (shulabramble, 15:22:11)
    7. Fix Committed - 21 (shulabramble, 15:22:11)

  11. New Business (shulabramble, 15:22:22)
  12. September point release team needed (shulabramble, 15:22:41)
  13.  there are several high priority bugs with pull requests that need review; https://wiki.evergreen-ils.org/doku.php?id=dev:code_review has the roundup as well as some filtered Launchpad links. (shulabramble, 15:25:20)
  14. Announcements (shulabramble, 15:27:06)
    1. Next Meeting is 14 October 2025 (shulabramble, 15:27:14)
    2. hackaway room block is available (abneiman, 15:27:59)
    3. ACTION: rogan will add the 2025 hack-a-way page to the wiki (shulabramble, 15:29:54)
    4. https://docs.google.com/spreadsheets/d/1bsSh8wrBZHZYgmaO0P173BtrEmt9r0aTfzu4f0l6DNY/edit?usp=sharing (Bmagic, 15:38:50)


Meeting ended at 15:41:56 US/Eastern (full logs).

Action items

  1. rogan will add the 2025 hack-a-way page to the wiki


Action items, by person

  1. Rogan
    1. rogan will add the 2025 hack-a-way page to the wiki


People present (lines said)

  1. shulabramble (77)
  2. Bmagic (28)
  3. sandbergja (13)
  4. sleary (12)
  5. abneiman (12)
  6. redavis (11)
  7. csharp_ (9)
  8. gmcharlt (9)
  9. mmorgan (8)
  10. Dyrcona (6)
  11. terranm (6)
  12. pinesol (4)
  13. gmcharlt__ (2)
  14. smayo (1)
  15. Rogan (1)
  16. jeff (1)
  17. phasefx (1)
  18. collum (1)


Generated by MeetBot 0.1.4.