#evergreen: 2025-10-14 - Developer Meeting

Meeting started by shulabramble at 15:00:35 US/Eastern (full logs).

Meeting summary

  1. Intros (shulabramble, 15:00:46)
    1. Dyrcona = Jason Stephenson, CW MARS. (Dyrcona, 15:00:56)
    2. shulabramble = Shula Link, GCHRL (shulabramble, 15:00:59)
    3. redavis = Ruth Frasur Davis, lately of ECDI (redavis, 15:01:16)
    4. mdriscoll = Martha Driscoll, NOBLE (mdriscoll, 15:01:18)
    5. briank = Brian Kennedy, BCLC (briank, 15:01:22)
    6. mmorgan = Michele Morgan, NOBLE (mmorgan, 15:01:24)
    7. sandbergja = Jane Sandberg, PUL (sandbergja, 15:01:27)
    8. csharp = Chris Sharp, GPLS (csharp_, 15:01:28)
    9. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:01:41)
    10. collum = Garry Collum, KCPL (collum, 15:01:45)

  2. Action Items (shulabramble, 15:02:45)
  3. rogan will add the 2025 hack-a-way page to the wiki (shulabramble, 15:03:01)
    1. eeevil = Mike Rylander, EOLI (eeevil, 15:03:39)
    2. smayo = Steven Mayo, GPLS (smayo, 15:04:22)
    3. https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2025-10-14#evergreen (redavis, 15:05:06)

  4. Updates (shulabramble, 15:05:30)
  5. Evergreen (shulabramble, 15:05:50)
    1. Monthly maintenance releases moved to Oct. 22; 3.14.11 and 3.15.6 (shulabramble, 15:05:53)
    2. Please sign up at https://docs.google.com/spreadsheets/d/1aKffVGU_vIWbtFR_vpoHsqodSw-Kdd5yn65RpfkMKKA/edit?gid=0#gid=0 to help (shulabramble, 15:06:27)

  6. 3.16 (shulabramble, 15:07:36)
    1. gmcharlt has proposed a change to the 3.16 release schedule (shulabramble, 15:07:51)
    2. https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap has not yet been updated. Just one sec (redavis, 15:08:06)
    3. please see https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap for updated 3.16 schedule (shulabramble, 15:10:12)

  7. Launchpad Status (as of noon Eastern) (shulabramble, 15:13:18)
  8. Snapshot (shulabramble, 15:13:18)
    1. Open Bugs - 3376 (shulabramble, 15:13:19)
    2. Pullrequests - 116 (shulabramble, 15:13:19)
    3. Signedoff - 52 (shulabramble, 15:13:20)
    4. Needswork - 99 (shulabramble, 15:13:20)
    5. Needstestplan - 3 (shulabramble, 15:13:21)
    6. Needsrebase - 23 (shulabramble, 15:13:21)

  9. Updates Since Last Meeting (shulabramble, 15:13:22)
    1. Bugs Added - 44 (shulabramble, 15:13:22)
    2. Pullrequest tag Added - 27 (shulabramble, 15:13:23)
    3. Signedoff tag Added - 19 (shulabramble, 15:13:23)
    4. Needswork tag Added - 5 (shulabramble, 15:13:24)
    5. Needstestplan tag Added - 1 (shulabramble, 15:13:24)
    6. Needsrebase tag Added - 1 (shulabramble, 15:13:25)
    7. Fix Committed - 31 (shulabramble, 15:13:25)

  10. New Business (shulabramble, 15:15:57)
  11. eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980) (shulabramble, 15:16:40)
    1. ACTION: eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980) (shulabramble, 15:22:35)

  12. Announcements (shulabramble, 15:24:05)
    1. Next Meeting is 11 November 2025 (shulabramble, 15:24:07)
    2. Hack-A-Way is Nov 10-12 (shulabramble, 15:25:16)
    3. Special Guest Host for Nov 11 Meeting is Dyrcona (shulabramble, 15:28:11)


Meeting ended at 15:29:54 US/Eastern (full logs).

Action items

  1. eyes wanted on Redis Stream-based HA/LB branch (https://bugs.launchpad.net/opensrf/+bug/2116980)


People present (lines said)

  1. shulabramble (65)
  2. redavis (22)
  3. Dyrcona (12)
  4. eeevil (10)
  5. csharp_ (9)
  6. pinesol (7)
  7. mmorgan (4)
  8. smayo (1)
  9. sandbergja (1)
  10. mdriscoll (1)
  11. briank (1)
  12. collum (1)
  13. abneiman (1)


Generated by MeetBot 0.1.4.