#evergreen: 2012-07-16 - Developer Meeting
Meeting started by dbwells at 14:08:05 US/Eastern
(full logs).
Meeting summary
- 
  - denials is Dan Scott, Laurentian
    University (denials,
    14:09:05)
- berick is Bill Erickson, Equinox (berick,
    14:09:16)
- dbwells is Dan Wells, Calvin College
    (dbwells,
    14:09:32)
- jamesrf is James Fournie, BC Libraries
    Cooperative / Sitka (jamesrf,
    14:09:44)
- tsbere is Thomas Berezansky, MVLC (tsbere,
    14:10:01)
- Dyrcona is Jason Stephenson, MVLC (Dyrcona,
    14:10:17)
- senator is Lebbeous Fogle-Weekley (senator,
    14:10:28)
- bshum is Ben Shum, Bibliomation (bshum,
    14:10:42)
- wolf29 is Wolf Halton, LYRASIS (wolf29,
    14:11:11)
- remingtron is Remington Steed, Calvin
    College (remingtron,
    14:11:23)
 
 
- Action Items from Last Meeting (dbwells, 14:11:44)
  - jon_scott is Jon Scott, LYRASIS (j_scott,
    14:12:03)
- denials to review i18n branch from senator
    prior to 2.2.0 release - DONE (dbwells,
    14:13:14)
- ACTION: denials still
    going to write up �How to set up an alias for cherry-picking w/
    signoff in tig� (dbwells,
    14:14:53)
- echo "bind generic C !git cherry-pick -s
    %(commit)" > ~/.tigrc # adds a cherry-pick alias to tig for "C"
    key (denials,
    14:15:50)
- denials and senator will work out schema
    conflicts re:0691 - DONE (dbwells,
    14:18:32)
- http://git.evergreen-ils.org/?p=Evergreen.git;a=commitdiff;h=b28f3a10
    (dbwells,
    14:20:01)
- berick to review OpenSRF CORS patch -
    Pending (dbwells,
    14:20:55)
- CORS
    https://bugs.launchpad.net/opensrf/+bug/1002028 (berick,
    14:23:26)
 
 
- GSoC Reports (dbwells, 14:24:53)
  - All the students passed their mid-term
    evaluations! (denials,
    14:25:33)
- Pranjal has a reasonably working general
    purpose opensrf php binding including fieldmapperized/encoding
    decoding. remaining work to be done: cleanup, corner cases, suitable
    packaging for PEAR or similar repository (senator,
    14:28:12)
- https://github.com/pranjal710/osrf
    Pranjal's repo (dbwells,
    14:30:49)
- drizea has moved development from his user
    branch to a much cleaner collab branch
    http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/drizea/android
    (dbwells,
    14:33:14)
- we are targeting what amounts to a '0.1'
    release at some point this week (dbwells,
    14:34:20)
- what works - basic search, org_unit limit
    selection, authentication, checkouts, holds (dbwells,
    14:35:33)
- what needs work - UI consistency, other search
    limiters, renews, copy displays (and general bug fixes) (dbwells,
    14:37:07)
- Joseph has made it through most of the dojo
    grids and should be looking into broken widgets soon, including
    building unit tests to figure out where they are broken. He has
    started pushing his work into branches on the repo made for him last
    year: http://git.evergreen-ils.org/?p=evergreen/joelewis.git
    (tsbere,
    14:40:50)
- ACTION: eeevil will
    report via the list on GSoC student progress (dbwells,
    14:47:30)
 
 
- Releases (dbwells, 14:48:16)
  - ACTION: berick to
    announce alpha2 release on general/dev list (berick,
    15:01:10)
- AGREED: 2.3 alpha2 to
    be released on Wedneday, July 18 (dbwells,
    15:05:33)
 
 
- Evergreen Issues (dbwells, 15:06:28)
  - ACTION: denials will
    open bug to track TPAC locale selector needs (dbwells,
    15:14:41)
- https://bugs.launchpad.net/evergreen/+bug/1024095
    (dbwells,
    15:16:07)
- ACTION: senator will
    update the bug with an outline of what could be changed for more
    speed (dbwells,
    15:18:22)
- AGREED: Evergreen
    2.0.x to be marked as deprecated on downloads page (dbwells,
    15:28:41)
- ACTION: bshum /
    moodaepo will mark Evergreen 2.0.x as deprecated, and style it to
    look as dead and unappealing as possible (dbwells,
    15:29:44)
 
 
- Announcements (dbwells, 15:32:20)
  - bshum has customized IRC bots (new paste tool,
    commit auto links), and is looking for feedback (dbwells,
    15:33:56)
 
Meeting ended at 15:34:20 US/Eastern
(full logs).
Action items
  - denials still going to write up �How to set up an alias for cherry-picking w/ signoff in tig�
- eeevil will report via the list on GSoC student progress
- berick to announce alpha2 release on general/dev list
- denials will open bug to track TPAC locale selector needs
- senator will update the bug with an outline of what could be changed for more speed
- bshum / moodaepo will mark Evergreen 2.0.x as deprecated, and style it to look as dead and unappealing as possible
Action items, by person
  -  berick 
    - berick to announce alpha2 release on general/dev list
 
-  bshum 
    - bshum / moodaepo will mark Evergreen 2.0.x as deprecated, and style it to look as dead and unappealing as possible
 
-  denials 
    - denials still going to write up �How to set up an alias for cherry-picking w/ signoff in tig�
- denials will open bug to track TPAC locale selector needs
 
-  senator 
    - senator will update the bug with an outline of what could be changed for more speed
 
People present (lines said)
  - dbwells (55)
- denials (37)
- berick (31)
- bshum (17)
- senator (14)
- pinesol_green (9)
- tsbere (7)
- jamesrf (5)
- j_scott (2)
- wolf29 (2)
- kmlussier (1)
- remingtron (1)
- Dyrcona (1)
Generated by MeetBot 0.1.4.