#evergreen: 2014-04-08 - Developer Meeting

Meeting started by jeff at 14:01:55 US/Eastern (full logs).

Meeting summary

    1. Agenda is at http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-04-08 (jeff, 14:02:19)

  1. Introductions (jeff, 14:02:29)
    1. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 14:02:36)
    2. berick Bill Erickson, ESI (berick, 14:02:39)
    3. RoganH Rogan Hamby, SCLENDS (RoganH, 14:02:50)
    4. Kathy Lussier, MassLNC (kmlussier, 14:02:57)
    5. Galen Charlton, ESI (gmcharlt, 14:03:03)
    6. Dan Scott, Laurentian University (dbs, 14:03:17)
    7. Ben Shum, Bibliomation (bshum, 14:03:18)
    8. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 14:03:24)
    9. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 14:03:31)
    10. eeevil is Mike Rylander, ESI (eeevil, 14:03:37)
    11. (dkyle, 14:04:00)

  2. Past Action Items (jeff, 14:05:45)
    1. ACTION: bshum to summarize bug tracking based on feedback from developers (jeff, 14:05:49)
    2. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan. (jeff, 14:06:32)
    3. ACTION: eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan. (jeff, 14:06:52)
    4. dbwells to backport bugfix for Encode.pm (bug 1242999) issues to rel_2_5, feedback requested on backporting to earlier releases (jeff, 14:06:59)
    5. done (dbwells, 14:07:14)
    6. bshum to go through and update the bug statuses to ?fix released? for things that are done in milestones for 2.4.5 and 2.4.6 (jeff, 14:07:36)
    7. done (jeff, 14:08:29)
    8. dbwells to add RM dates to dev calendar (jeff, 14:08:33)
    9. done, but in a lazy and lackluster fashion (dbwells, 14:08:55)
    10. dbwells to summarize Evergreen 2.6 aspects of PostgreSQL 9.3 support in future 2.6 RM reports (jeff, 14:09:16)
    11. done! (jeff, 14:09:42)
    12. jeff to start dev:hackfest:eg2014 wiki page and announce on dev list, solicit ideas and further discussion (jeff, 14:09:44)
    13. not done, no longer relevant (jeff, 14:10:07)

  3. Release info - OpenSRF (jeff, 14:10:59)
    1. OpenSRF 2.3.0 is now available (gmcharlt, 14:11:13)
    2. OpenSRF 2.3.0 required for Evergreen 2.6, functionality release that introduces a new control script, osrf_control, and significantly improves one?s ability to stop, start, reload, and manage OpenSRF services. It also adds the ability to run multiple OpenSRF instances simultaneously on a single server. (jeff, 14:12:28)
    3. http://evergreen-ils.org/documentation/release/OpenSRF/RELEASE_NOTES_2_3_0.html OpenSRF 2.3.0 Release Notes (jeff, 14:12:45)
    4. OpenSRF rel_2_3 branch maintenance-only, focus is on 2.4.0 for early summer 2014: web sockets, CORS, removal of deprecated osrf_ctl.sh, improvements for recent Perl versions and stricter C compiler settings (jeff, 14:14:16)
    5. OpenSRF 2.4 also to focus on improved chunking/bundling, to avoid some currently required ejabberd config changes (jeff, 14:15:43)
    6. ACTION: jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well (jeff, 14:16:45)

  4. Release Info - Evergreen (jeff, 14:17:32)
    1. Evergreen 2.6 release status (jeff, 14:18:13)
    2. https://bugs.launchpad.net/evergreen/+milestone/2.6.0 Outstanding bugs targeted at Evergreen 2.6.0 (jeff, 14:19:58)
    3. Blockers (jeff, 14:21:03)
    4. https://bugs.launchpad.net/evergreen/+bug/1304559 acq and cataloging loader broken in 2.6-rc (jeff, 14:21:18)
    5. https://bugs.launchpad.net/evergreen/+bug/1303940 Bogus data can lead to null values, breaking indexing (jeff, 14:21:26)
    6. Evergreen 2.6.0 provisionally on calendar for tomorrow, April 9 with 2.6.1 to follow two weeks later. (jeff, 14:26:48)
    7. Please review the acknowledgements for Evergreen 2.6 and make any additions/updates (jeff, 14:29:03)
    8. https://bugs.launchpad.net/evergreen/+bug/1302113 bug 1302113 - acknowledgments in release notes (jeff, 14:29:18)
    9. Evergreen 2.5 bug fixes? (jeff, 14:29:59)
    10. Evergreen 2.5 maintenance release planned for April 16 (jeff, 14:32:50)
    11. Evergreen 2.4 - final release? (jeff, 14:33:10)
    12. Final planned Evergreen 2.4 maintenance release scheduled for April 16 (jeff, 14:34:15)

  5. New Business (jeff, 14:39:00)
    1. Release Manager proposal for Evergreen 2.7 (jeff, 14:39:16)
    2. RM 2.7 email - http://markmail.org/message/b23u62e6rhebjkhk (bshum, 14:39:58)
    3. ACTION: jeff to call for RM 2.7 vote on open-ils-dev within the next few days (jeff, 14:49:01)

  6. Feedback for New Features Under Development (jeff, 14:49:11)
    1. Metabib display fields (jeff, 14:49:25)
    2. https://launchpad.net/bugs/1251394 Metabib Display Fields (jeff, 14:49:36)
    3. Smart Float (jeff, 14:56:51)
    4. http://markmail.org/message/736mp25legftvjld [OPEN-ILS-DEV] Smart Float: Self balancing floating collections (jeff, 14:57:09)
    5. https://launchpad.net/evergreen/+milestone/2.next bugs currently targeting Evergreen 2.next (jeff, 15:00:35)
    6. http://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:dev_notes Browser Staff Client Development Notes (jeff, 15:02:48)


Meeting ended at 15:04:22 US/Eastern (full logs).

Action items

  1. bshum to summarize bug tracking based on feedback from developers
  2. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  3. jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well
  4. jeff to call for RM 2.7 vote on open-ils-dev within the next few days


Action items, by person

  1. bshum
    1. bshum to summarize bug tracking based on feedback from developers
  2. eeevil
    1. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  3. jeff
    1. jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well
    2. jeff to call for RM 2.7 vote on open-ils-dev within the next few days


People present (lines said)

  1. jeff (89)
  2. dbwells (29)
  3. bshum (22)
  4. gmcharlt (20)
  5. pinesol_green (12)
  6. kmlussier (9)
  7. dkyle (8)
  8. eeevil (8)
  9. Dyrcona (5)
  10. berick (2)
  11. RoganH (1)
  12. remingtron (1)
  13. dbs (1)
  14. jboyer-isl (1)
  15. asimon (1)


Generated by MeetBot 0.1.4.