#evergreen: 2014-05-19 - Developer Meeting

Meeting started by jeff at 14:07:31 US/Eastern (full logs).

Meeting summary

  1. Introductions (jeff, 14:07:36)
    1. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 14:07:48)
    2. Dyrcona is Jason Stephenson, MVLC (Dyrcona, 14:07:59)
    3. tsbere is Thomas Berezansky, MVLC (tsbere, 14:08:03)
    4. DPearl is Dan Pearl, C/W MARS (DPearl, 14:08:12)
    5. remingtron is Remington Steed, Hekman Library (Calvin College) (remingtron, 14:08:14)
    6. eeevil is Mike Rylander, Equinox (eeevil, 14:09:09)
    7. http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-05-19 Agenda (jeff, 14:09:10)
    8. csharp is Chris Sharp, GPLS (mostly absent today, but will read the logs) (csharp, 14:09:41)
    9. phasefx is Jason Etheridge, Equinox (phasefx, 14:09:51)
    10. RoganH is Rogan Hamby, SCLENDS (RoganH, 14:09:56)

  2. #topic Past Action Items (jeff, 14:10:45)
    1. ACTION: bshum to summarize bug tracking based on feedback from developers (jeff, 14:10:52)
    2. gmcharlt is Galen Charlton, Equinox (gmcharlt, 14:10:56)
    3. bshum reports this is done-ish (jeff, 14:11:05)
    4. http://wiki.evergreen-ils.org/doku.php?id=dev:bug_wrangler:faq Evergreen Bug Wrangler FAQ (jeff, 14:11:28)
    5. ACTION: jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well (jeff, 14:12:46)
    6. Reviewing (barely), haven't sought feedback/review from others yet. If you're interested, let me know here (now, later) or on the bug. (jeff, 14:13:16)
    7. jeff to call for RM 2.7 vote on open-ils-dev within the next few days (jeff, 14:13:26)
    8. berick Bill Erickson, ESI (berick, 14:13:28)
    9. ACTION: eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan. (jeff, 14:15:50)
    10. pending (jeff, 14:16:29)

  3. Release info - OpenSRF (jeff, 14:16:47)
    1. gmcharlt is now thinking mid-summer for an OpenSRF 2.4.0 (gmcharlt, 14:17:12)
    2. OpenSRF rel_2_3 branch maintenance-only, focus is on 2.4.0 for mid summer 2014: web sockets, CORS, removal of deprecated osrf_ctl.sh, improvements for recent Perl versions and stricter C compiler settings (jeff, 14:18:06)
    3. More testers for WebSockets branch would be great (jeff, 14:18:39)

  4. Release info - Evergreen (jeff, 14:18:51)
    1. Evergreen 2.4.7 released May 8, final planned release in 2.4 series (jeff, 14:19:50)
    2. Evergreen 2.5.4 released April 23 (jeff, 14:20:13)
    3. Evergreen 2.6.0 released April 15 (jeff, 14:20:29)
    4. dbwells says 2.6.1 will probably be released this week (remingtron, 14:21:43)

  5. New Business (jeff, 14:22:05)
  6. Brief Discussion abour Release Notes (jeff, 14:22:14)
    1. developers can send any feedback to the DIG email list (remingtron, 14:26:14)

  7. Feedback for New Features Under Development (jeff, 14:29:16)


Meeting ended at 14:41:46 US/Eastern (full logs).

Action items

  1. bshum to summarize bug tracking based on feedback from developers
  2. jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well
  3. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.


Action items, by person

  1. eeevil
    1. eeevil After 2.6.0 is cut, eeevil to publish detailed plan about freezing baseline schemas between EG releases and using deprecates/supersedes in database upgrade scripts. This will go on the mailing list and the thread should structure further discussion of pros and cons of eeevil's plan.
  2. jeff
    1. jeff to review OpenSRF bug 1109301 for consideration, may solicit the review of others as well


People present (lines said)

  1. jeff (51)
  2. RoganH (9)
  3. remingtron (7)
  4. gmcharlt (5)
  5. pinesol_green (4)
  6. Dyrcona (4)
  7. berick (3)
  8. eeevil (3)
  9. DPearl (1)
  10. csharp (1)
  11. phasefx (1)
  12. tsbere (1)


Generated by MeetBot 0.1.4.