#evergreen: 2014-10-06 - Developer Meeting

Meeting started by jeff at 15:00:56 US/Eastern (full logs).

Meeting summary

    1. http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-10-06 meeting agenda here (jeff, 15:01:00)

  1. Introductions (jeff, 15:01:05)
    1. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:05)
    2. bshum is Ben Shum, Bibliomation (bshum, 15:01:22)
    3. phasefx is Jason Etheridge, Equinox Software (phasefx, 15:01:25)
    4. tsbere is Thomas Berezansky, MVLC (tsbere, 15:01:28)
    5. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:01:31)
    6. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:01:36)
    7. remingtron is Remington Steed, Hekman Library (Calvin College) (remingtron, 15:01:40)
    8. berick Bill Erickson KCLS (berick, 15:02:07)
    9. Jason Stephenson, MVLC (Dyrcona, 15:03:14)

  2. Action items from last meeting (jeff, 15:03:45)
    1. kmlussier and others to make time to test the latest branch (negative balances). (jeff, 15:03:46)
    2. dbwells to work on display ideas for negative balance branch (jeff, 15:04:58)
    3. DPearl = Dan Pearl, C/W MARS (DPearl, 15:06:22)
    4. https://bugs.launchpad.net/evergreen/+bug/1198465 Support for Conditional Negative Balances (jeff, 15:07:09)
    5. ACTION: dbwells to update Conditional Negative Balances bug 1198465 with links to new branches, etc. (jeff, 15:08:49)
    6. jeff and csharp to test websockets work by the end of this week. (jeff, 15:09:22)
    7. gmcharlt to cut alpha of OpenSRF the middle of next week (week of Aug. 4th) (jeff, 15:09:43)
    8. kmlussier to move Sandbox discussion to dev list (jeff, 15:10:56)
    9. berick to add an LP bug for web based circ client with notes on pre-reqs and a list of existing client interfaces that need special attention. (jeff, 15:11:16)

  3. Development Updates (jeff, 15:12:35)
  4. Release info - OpenSRF (jeff, 15:12:45)
    1. dbs is Dan Scott, Laurentian University (3 hours of meetings and counting) (dbs, 15:13:09)
    2. ACTION: gmcharlt to release OpenSRF 2.4 when ready (jeff, 15:17:26)
    3. https://bugs.launchpad.net/opensrf/+bug/1369169 OpenSRF README updates to be considered for 2.4 release (jeff, 15:17:59)
    4. ldw is Liam Whalen Sitka (ldw, 15:18:09)

  5. Release info - Evergreen (jeff, 15:18:27)
    1. Testing of Evergreen 2.7 with OpenSRF 2.3 would be appreciated -- pass feedback to bshum (jeff, 15:19:10)
    2. bshum to push things to rel_2_7 in preparation for scheduled 2.7.1 maintenance release (jeff, 15:21:16)
    3. bshum pulling updated translations for tpac (and other areas) into 2.7.1 (jeff, 15:21:57)
    4. targeting, testing/signoff of bugs against 2.7.1 appreciated as always (jeff, 15:22:43)

  6. New Business (jeff, 15:23:26)
  7. Bug Squashing Day Wrap-Up (jeff, 15:23:27)
    1. http://evergreen-ils.org/bug-squashing-day-wrap-up/ bug squashing day wrapup (jeff, 15:23:57)
    2. ACTION: kmlussier to schedule another Bug Squashing Day (jeff, 15:29:11)

  8. Feedback for New Features Under Development (jeff, 15:31:26)
  9. Evergreen participation in OPW - Outreach Program for Women (jeff, 15:38:26)
    1. http://wiki.evergreen-ils.org/doku.php?id=opw Project Ideas for Outreach Program for Women (jeff, 15:40:10)
    2. https://wiki.gnome.org/OutreachProgramForWomen (jeff, 15:41:25)

  10. Evergreen 2.8 Release Manager (jeff, 15:47:40)
    1. see https://docs.google.com/document/d/1lL9S07c8X_zfXSexXfnwzRllnvVvJsW0qf65QxGtH7A/edit - "2.next" discussion (csharp, 15:49:30)
    2. http://markmail.org/message/5cba3zdvshegq2fx (bshum, 15:50:05)

  11. 2014 Hack-a-way Summary (jeff, 15:55:23)
    1. https://docs.google.com/a/tadl.org/document/d/1lL9S07c8X_zfXSexXfnwzRllnvVvJsW0qf65QxGtH7A/edit 2014 Hackaway Collaboration document (jeff, 15:55:36)
    2. http://www.roganhamby.com/evergreen/2014/9/27/hack-a-way-2014-wrapup-and-photos (bshum, 15:57:47)
    3. http://www.roganhamby.com/evergreen/2014/9/27/hack-a-way-2014-wrapup-and-photos 2014 Hack-a-way wrap-up from Rogan (jeff, 15:58:22)


Meeting ended at 16:02:00 US/Eastern (full logs).

Action items

  1. dbwells to update Conditional Negative Balances bug 1198465 with links to new branches, etc.
  2. gmcharlt to release OpenSRF 2.4 when ready
  3. kmlussier to schedule another Bug Squashing Day


Action items, by person

  1. dbwells
    1. dbwells to update Conditional Negative Balances bug 1198465 with links to new branches, etc.
  2. kmlussier
    1. kmlussier to schedule another Bug Squashing Day


People present (lines said)

  1. jeff (86)
  2. bshum (63)
  3. kmlussier (44)
  4. csharp (12)
  5. dbwells (12)
  6. ldw (9)
  7. pinesol_green (8)
  8. berick (6)
  9. Dyrcona (5)
  10. dbs (5)
  11. Bmagic (2)
  12. DPearl (1)
  13. phasefx (1)
  14. remingtron (1)
  15. tsbere (1)


Generated by MeetBot 0.1.4.