#evergreen: 2015-02-17 - Developer Meeting

Meeting started by bshum at 15:00:22 US/Eastern (full logs).

Meeting summary

  1. Welcome and introductions (bshum, 15:00:36)
    1. bshum = Ben Shum, Bibliomation (bshum, 15:00:41)
    2. gmcharlt = Galen Charlton, ESI (gmcharlt, 15:00:53)
    3. berick Bill Erickson, KCLS (berick, 15:01:01)
    4. DPearl = Dan Pearl, C/W MARS (DPearl, 15:01:01)
    5. julialima_ = Julia Lima. UI Style Guide (OPW), Argentina. (julialima_, 15:01:05)
    6. Agenda: http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-02-17 (bshum, 15:01:09)
    7. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:09)
    8. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:01:26)
    9. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:01:31)
    10. phasefx = Jason Etheridge, ESI (phasefx, 15:01:40)

  2. Action items from last meeting (bshum, 15:03:11)
    1. dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing (bshum, 15:03:17)
    2. kmlussier is Kathy Lussier - MassLNC (kmlussier, 15:03:19)
    3. dbwells posted collab/dbwells/1198465_cstore_fines_gen -- I have not done any testing yet (berick, 15:03:49)
    4. eeevil = Mike Rylander, ESI (eeevil, 15:04:13)
    5. bmagic is Blake GH - MOBIUS (Bmagic, 15:04:17)
    6. Testing to continue. (bshum, 15:05:05)
    7. dbs = Dan Scott, Laurentian University (dbs, 15:08:50)

  3. OpenSRF release (bshum, 15:12:01)
    1. gmcharlt with new WIP for improving osrf_control --diagnostic and pound proxy example config for websockets in upcoming OpenSRF release. (bshum, 15:15:31)
    2. ACTION: gmcharlt will cut OpenSRF 2.4.1 in March once new features are pushed. (bshum, 15:18:33)

  4. Evergreen release (web client help) (bshum, 15:19:04)
    1. HELP: Looking for intrepid folks interested to help in rewriting certain embedded interfaces to angularjs. (like the user editor/registration screen, user permission editor) (bshum, 15:23:58)
    2. http://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:dev_sprints is the current best resource for "these are the things that are planned to be worked on", but I don't know if that's the place for coordination. (jeff, 15:26:40)

  5. Evergreen 2.8 (bshum, 15:35:02)
    1. 2.8 Beta *features* merge cut-off is Friday, February 20, 2015. (bshum, 15:36:11)
    2. Beta release cut on Wednesday, February 25 (bshum, 15:45:32)
    3. HELP: Please help test between beta deadline and cut to minimize bugs in beta. And also help with bug fixes in general. (bshum, 15:45:57)

  6. OPW Progress Report (bshum, 15:46:26)
    1. Style guide: https://github.com/JuliaLima/Evergreen/tree/patch-1/docs/style_guide (bshum, 15:49:29)
    2. Blog: http://lima-julia.tumblr.com/EG-style-guide (bshum, 15:49:42)
    3. ACTION: julialima_ will send a similar update with links to the mailing list (dbwells, 15:51:03)

  7. Google Summer of Code 2015 (bshum, 15:54:25)


Meeting ended at 16:09:10 US/Eastern (full logs).

Action items

  1. gmcharlt will cut OpenSRF 2.4.1 in March once new features are pushed.
  2. julialima_ will send a similar update with links to the mailing list


Action items, by person

  1. gmcharlt
    1. gmcharlt will cut OpenSRF 2.4.1 in March once new features are pushed.
  2. julialima_
    1. julialima_ will send a similar update with links to the mailing list


People present (lines said)

  1. bshum (65)
  2. berick (28)
  3. eeevil (24)
  4. kmlussier (23)
  5. gmcharlt (22)
  6. jeff (17)
  7. dbs (13)
  8. dbwells (11)
  9. pinesol_green (8)
  10. julialima_ (7)
  11. Bmagic (5)
  12. jeffdavis (5)
  13. DPearl (1)
  14. phasefx (1)
  15. remingtron (1)


Generated by MeetBot 0.1.4.