#evergreen: 2015-07-01 Developers' Meeting

Meeting started by Dyrcona at 15:02:41 US/Eastern (full logs).

Meeting summary

  1. Introductions (Dyrcona, 15:02:51)
    1. csharp = Chris Sharp, GPLS (csharp, 15:03:05)
    2. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:03:06)
    3. bshum = Ben Shum, Bibliomation (bshum, 15:03:06)
    4. yboston = Yamil Suarez: Berklee College of Music (yboston, 15:03:15)
    5. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:03:18)
    6. Stompro = Josh Stompro, Lake Agassiz Regional Library, MN (Stompro, 15:03:18)
    7. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:03:22)
    8. miker = Mike Rylander, ESI (miker, 15:03:23)
    9. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 15:03:30)
    10. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:03:40)
    11. jboyer-isl = Jason Boyer, Evergreen Indiana (jboyer-isl, 15:03:59)

  2. Action Items from Last Meeting (Dyrcona, 15:05:21)
    1. Dyrcona to add series and milestone(s) for 2.9 in Launchpad. Done. (Dyrcona, 15:06:29)
    2. Dyrcona to create 2.9 road map and add it to DokuWiki at http://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap is also done. (Dyrcona, 15:07:25)
    3. http://evergreen-ils.org/dokuwiki/doku.php?id=faqs:evergreen_roadmap:2.9 is the Evergreen 2.9 roadmap. (Dyrcona, 15:07:49)
    4. gmcharlt and eeevil to organize a webstaff client hacking day in July (Dyrcona, 15:08:09)
    5. ACTION: gmcharlt and eeevil to organize a webstaff client hacking day in July (Dyrcona, 15:11:01)

  3. OpenSRF (Dyrcona, 15:13:37)
    1. OpenSRF 2.4.1 was tagged and released by gmcharlt last week (bshum, 15:13:51)

  4. Evergreen (Dyrcona, 15:16:55)
    1. JavaScript circ and hold rules removed as of July 1, 2015. (Dyrcona, 15:17:41)
    2. RM will look into removing old self check interface. (Dyrcona, 15:20:14)
    3. http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2015-07-01 (yboston, 15:20:45)
    4. ACTION: jeff will look into removing old self check interface. (Dyrcona, 15:23:34)
    5. ACTION: jeff will look at removing old JSPAC code. (Dyrcona, 15:24:33)
    6. AGREED: release notes are a good idea. (Dyrcona, 15:32:46)
    7. Query dbwells on the conditional negative balances work. (Dyrcona, 15:44:12)
    8. ACTION: dbwells will hopefully write more neg balances tests and push whatever he has ready on July 10 (dbwells, 15:51:14)
    9. ACTION: kmlussier to complete her testing on the negative balance branch by July 8 (kmlussier, 15:51:21)
    10. ACTION: Dyrcona will follow up with negative balance branch after July 10. (Dyrcona, 15:52:18)

  5. New and Old Business (Dyrcona, 15:54:22)
    1. ACTION: jeff will articulate ideas on merge vs cherry-pick and start discussion/proposal on dev list (jeff, 15:56:59)
    2. ACTION: yboston to followup with ldw about a testing day. (Dyrcona, 15:59:11)
    3. ACTION: bshum to work with berick and others on crafting more information about release maintaining and schedules (bshum, 16:02:00)


Meeting ended at 16:04:54 US/Eastern (full logs).

Action items

  1. gmcharlt and eeevil to organize a webstaff client hacking day in July
  2. jeff will look into removing old self check interface.
  3. jeff will look at removing old JSPAC code.
  4. dbwells will hopefully write more neg balances tests and push whatever he has ready on July 10
  5. kmlussier to complete her testing on the negative balance branch by July 8
  6. Dyrcona will follow up with negative balance branch after July 10.
  7. jeff will articulate ideas on merge vs cherry-pick and start discussion/proposal on dev list
  8. yboston to followup with ldw about a testing day.
  9. bshum to work with berick and others on crafting more information about release maintaining and schedules


Action items, by person

  1. berick
    1. bshum to work with berick and others on crafting more information about release maintaining and schedules
  2. bshum
    1. bshum to work with berick and others on crafting more information about release maintaining and schedules
  3. dbwells
    1. dbwells will hopefully write more neg balances tests and push whatever he has ready on July 10
  4. Dyrcona
    1. Dyrcona will follow up with negative balance branch after July 10.
  5. jeff
    1. jeff will look into removing old self check interface.
    2. jeff will look at removing old JSPAC code.
    3. jeff will articulate ideas on merge vs cherry-pick and start discussion/proposal on dev list
  6. kmlussier
    1. kmlussier to complete her testing on the negative balance branch by July 8
  7. yboston
    1. yboston to followup with ldw about a testing day.


People present (lines said)

  1. Dyrcona (94)
  2. jeff (39)
  3. bshum (27)
  4. kmlussier (19)
  5. miker (13)
  6. dbwells (10)
  7. yboston (9)
  8. jboyer-isl (7)
  9. pinesol_green (5)
  10. csharp (2)
  11. remingtron (1)
  12. berick (1)
  13. Stompro (1)


Generated by MeetBot 0.1.4.