#evergreen: Evergreen Dev Meeting 2015-08-05

Meeting started by ldw at 15:07:09 US/Eastern (full logs).

Meeting summary

    1. http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-08-05 (berick, 15:08:28)
    2. ldw=Liam Whalen BC Libraries Cooperative (ldw, 15:08:58)
    3. RoganH = Rogan Hamby, SCLENDS (RoganH, 15:09:21)
    4. berick King County Library System (berick, 15:09:23)
    5. phasefx = Jason Etheridge, ESI (phasefx, 15:09:24)
    6. yboston = Yamil Suarez: Berklee College of Music (yboston, 15:09:30)
    7. Dyrcona = Jason Stephenson, Merrimack Valley Library Consortium (Dyrcona, 15:09:54)
    8. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:09:57)
    9. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:10:19)
    10. miker = Mike Rylander, ESI (miker, 15:10:27)
    11. gmcharlt = Galen Charlton, ESI (gmcharlt, 15:10:28)
    12. jlitrell = Jake Litrell, MassLNC (jlitrell, 15:10:30)

  1. Action Items from Last Meeting (ldw, 15:10:57)
    1. terran = Terran McCanna, PINES (terran, 15:11:01)
    2. gmcharlt and eeevil to organize a webstaff client hacking day in July (ldw, 15:12:16)
    3. ACTION: gmcharlt to organize webstaff client hacking day in September (ldw, 15:14:20)
    4. jeff will look into removing old self check interface. (ldw, 15:14:49)
    5. ACTION: ldw will follow up with jeff about removing old self check interface status (ldw, 15:16:21)
    6. jeff will look at removing old JSPAC code. (ldw, 15:16:51)
    7. ACTION: ldw will follow up with jeff about removing old JSPAC code status (ldw, 15:17:13)
    8. dbwells will hopefully write more neg balances tests and push whatever he has ready on July 10 (ldw, 15:17:27)
    9. dbwells done got wrote'em (ldw, 15:18:54)
    10. remingtron, too. (Dyrcona, 15:19:09)
    11. kmlussier to complete her testing on the negative balance branch by July 8 (ldw, 15:21:33)
    12. kmlussier's negative balance testing is complete. Remaining issues have been reported in bug 1479107 and bug 1479110 (kmlussier, 15:21:37)
    13. Dyrcona will follow up with negative balance branch after July 10. (ldw, 15:22:05)
    14. done did by bshum (Dyrcona, 15:22:41)
    15. jeff will articulate ideas on merge vs cherry-pick and start discussion/proposal on dev list (ldw, 15:22:44)
    16. ACTION: ldw will follow up with jeff on merge vs cherry-pick discussion (ldw, 15:24:04)
    17. ACTION: ldw will looking into integrating neg. balance tests on test writing day (ldw, 15:24:43)
    18. : (ldw, 15:24:53)
    19. : (ldw, 15:25:05)
    20. yboston to followup with ldw about a testing day. (ldw, 15:25:11)
    21. bshum to work with berick and others on crafting more information about release maintaining and schedules (ldw, 15:25:33)
    22. ACTION: berick will work with bshum on crafting more information about release maintaining and schedules (ldw, 15:27:16)
    23. OpenSRF release info (ldw, 15:28:45)
    24. Galen is expecting to cut another OpenSRF release in the next 6 weeks (gmcharlt, 15:29:04)

  2. OpenSRF relase info (ldw, 15:30:09)
    1. ACTION: gmcharlt will cut an OpenSRF release in the next 6 weeks (ldw, 15:30:49)

  3. Evergreen 2.8.3 planned for Aug. 19. (ldw, 15:31:12)
  4. QA Proposal (ldw, 15:31:58)
    1. go back to Evergreen 2.9 update, will resume QA Proposal after (ldw, 15:32:41)

  5. Evergreen 2.9 update (ldw, 15:32:49)
    1. The 2.9 alpha was postponed indefinitely because of questions about the negative balance branch and its release notes. (Dyrcona, 15:33:37)
    2. dbs = Dan Scott, Laurentian University (dbs, 15:37:59)
    3. ACTION: kmlussier to update setting descriptions and then update the release notes to reflect consensus (ldw, 15:38:41)
    4. Dyrcona protests an alpha action item ;P (ldw, 15:46:27)
    5. ACTION: Dyrcona to investigate sprint2's integration with an alpha release (ldw, 15:51:48)
    6. ACTION: Dyrcona to determine if sprint2 can be merged into an alpha release, and will set a date for a release or skip the release depending on his findings. (ldw, 15:56:26)

  6. QA Proposal - http://georgialibraries.markmail.org/thread/dl7xemr5zzzcfi6f (ldw, 15:57:26)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:57:53)
    2. revised QA guideline (ldw, 16:10:15)
    3. VOTE: Voted on "Should we accept gmcharlt revised QA guideline?" Results are, Yes: 10 (ldw, 16:17:04)

  7. Code sanity check appreciated for https://bugs.launchpad.net/evergreen/+bug/1468422 (ldw, 16:17:25)
    1. ACTION: dbwells will attempt to explode berick's Password Managment and Authentication improvements (ldw, 16:22:29)


Meeting ended at 16:26:16 US/Eastern (full logs).

Action items

  1. gmcharlt to organize webstaff client hacking day in September
  2. ldw will follow up with jeff about removing old self check interface status
  3. ldw will follow up with jeff about removing old JSPAC code status
  4. ldw will follow up with jeff on merge vs cherry-pick discussion
  5. ldw will looking into integrating neg. balance tests on test writing day
  6. berick will work with bshum on crafting more information about release maintaining and schedules
  7. gmcharlt will cut an OpenSRF release in the next 6 weeks
  8. kmlussier to update setting descriptions and then update the release notes to reflect consensus
  9. Dyrcona to investigate sprint2's integration with an alpha release
  10. Dyrcona to determine if sprint2 can be merged into an alpha release, and will set a date for a release or skip the release depending on his findings.
  11. dbwells will attempt to explode berick's Password Managment and Authentication improvements


Action items, by person

  1. berick
    1. berick will work with bshum on crafting more information about release maintaining and schedules
    2. dbwells will attempt to explode berick's Password Managment and Authentication improvements
  2. bshum
    1. berick will work with bshum on crafting more information about release maintaining and schedules
  3. dbwells
    1. dbwells will attempt to explode berick's Password Managment and Authentication improvements
  4. Dyrcona
    1. Dyrcona to investigate sprint2's integration with an alpha release
    2. Dyrcona to determine if sprint2 can be merged into an alpha release, and will set a date for a release or skip the release depending on his findings.
  5. gmcharlt
    1. gmcharlt to organize webstaff client hacking day in September
    2. gmcharlt will cut an OpenSRF release in the next 6 weeks
  6. kmlussier
    1. kmlussier to update setting descriptions and then update the release notes to reflect consensus
  7. ldw
    1. ldw will follow up with jeff about removing old self check interface status
    2. ldw will follow up with jeff about removing old JSPAC code status
    3. ldw will follow up with jeff on merge vs cherry-pick discussion
    4. ldw will looking into integrating neg. balance tests on test writing day


People present (lines said)

  1. ldw (65)
  2. berick (34)
  3. gmcharlt (29)
  4. Dyrcona (25)
  5. kmlussier (24)
  6. dbwells (20)
  7. pinesol_green (14)
  8. miker (7)
  9. yboston (7)
  10. bshum (4)
  11. dbs (4)
  12. jlitrell (3)
  13. phasefx (3)
  14. terran (3)
  15. RoganH (2)
  16. pastebot (1)
  17. Bmagic (1)


Generated by MeetBot 0.1.4.