#evergreen: 2015-09-02 - Developer Meeting

Meeting started by Dyrcona at 15:00:43 US/Eastern (full logs).

Meeting summary

    1. agenda at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2015-09-02 (Dyrcona, 15:01:10)

  1. Introductions (Dyrcona, 15:01:28)
    1. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 15:01:44)
    2. gmcharlt = Galen Charlton, ESI (gmcharlt, 15:01:51)
    3. Stompro = Josh Stompro, LARL MN (Stompro, 15:02:30)
    4. berick = Bill Erickson, KCLS (berick, 15:02:30)
    5. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:02:52)
    6. isl-jasonb = Jason Boyer, IN State Lib (Eg IN) (jboyer-isl, 15:03:23)
    7. dbs = Dan Scott, Laurentian University (dbs, 15:04:03)
    8. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:04:25)
    9. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:04:29)

  2. Action Items from Last Meeting (Dyrcona, 15:05:37)
    1. gmcharlt to organize webstaff client hacking day in September (Dyrcona, 15:06:04)
    2. yboston is Yamil Suarez - Berklee.edu (yboston, 15:06:07)
    3. We've now picked a date: Wednesday, 16 September 2015. Will discuss at dev meeting. (Dyrcona, 15:06:22)
    4. miker = Mike Rylander, ESI (miker, 15:08:54)
    5. AngularJS Day will be scheduled for 17 September 2015 (gmcharlt, 15:13:43)
    6. ldw will follow up with jeff about removing old self check interface status -- Done! (Dyrcona, 15:14:11)
    7. ldw will follow up with jeff about removing old JSPAC code status - Done! (Dyrcona, 15:15:04)
    8. ldw will follow up with jeff on merge vs cherry-pick discussion (Dyrcona, 15:15:43)
    9. Bmagic = Blake GH, MOBIUS (Bmagic, 15:17:45)
    10. ldw = Liam Whalen, Sitka (ldw, 15:17:49)
    11. AGREED: drop it for now. :) (Dyrcona, 15:19:26)
    12. ldw will looking into integrating neg. balance tests on test writing day (Dyrcona, 15:19:49)
    13. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:21:09)
    14. done (Dyrcona, 15:23:07)
    15. berick will work with bshum on crafting more information about release maintaining and schedules (Dyrcona, 15:23:25)
    16. gmcharlt will cut an OpenSRF release in the next 6 weeks-- Will cut on Tuesday, 2015-09-08 (Dyrcona, 15:26:00)
    17. kmlussier to update setting descriptions and then update the release notes to reflect consensus -- Done! (Dyrcona, 15:27:23)
    18. Dyrcona to investigate sprint2's integration with an alpha release -- Done: Sprint 2 was integrated for the beta release. (Dyrcona, 15:28:16)
    19. ACTION: Dyrcona to update README/INSTALL for master to include web staff client installation instructions for developers by 2.9.0 release date. (Dyrcona, 15:30:35)
    20. Dyrcona to determine if sprint2 can be merged into an alpha release, and will set a date for a release or skip the release depending on his findings. (Dyrcona, 15:32:00)
    21. Done: alpha release was skipped and beta was released on time. (Dyrcona, 15:32:22)
    22. dbwells will attempt to explode berick's Password Managment and Authentication improvements (Dyrcona, 15:34:20)
    23. ACTION: dbwells will attempt to explode berick's Password Managment and Authentication improvements (Dyrcona, 15:36:26)

  3. OpenSRF Release (Dyrcona, 15:37:20)
    1. ACTION: gmcharlt to release OpenSRF version 2.4.2 on 8 September 2015. (Dyrcona, 15:38:53)

  4. Evergreen Release(s) (Dyrcona, 15:39:24)
    1. ACTION: Dyrcona to release 2.9-rc after the meeting. (Dyrcona, 15:39:51)

  5. Translations: Should we include metadata changes or not? (Dyrcona, 15:48:16)
  6. New Business (Dyrcona, 15:53:07)


Meeting ended at 16:02:03 US/Eastern (full logs).

Action items

  1. Dyrcona to update README/INSTALL for master to include web staff client installation instructions for developers by 2.9.0 release date.
  2. dbwells will attempt to explode berick's Password Managment and Authentication improvements
  3. gmcharlt to release OpenSRF version 2.4.2 on 8 September 2015.
  4. Dyrcona to release 2.9-rc after the meeting.


Action items, by person

  1. berick
    1. dbwells will attempt to explode berick's Password Managment and Authentication improvements
  2. dbwells
    1. dbwells will attempt to explode berick's Password Managment and Authentication improvements
  3. Dyrcona
    1. Dyrcona to update README/INSTALL for master to include web staff client installation instructions for developers by 2.9.0 release date.
    2. Dyrcona to release 2.9-rc after the meeting.
  4. gmcharlt
    1. gmcharlt to release OpenSRF version 2.4.2 on 8 September 2015.


People present (lines said)

  1. Dyrcona (92)
  2. jeff (11)
  3. gmcharlt (11)
  4. berick (9)
  5. pinesol_green (4)
  6. dbwells (4)
  7. jboyer-isl (4)
  8. kmlussier (3)
  9. ldw (3)
  10. Bmagic (2)
  11. Stompro (2)
  12. dbs (2)
  13. miker (1)
  14. remingtron (1)
  15. yboston (1)


Generated by MeetBot 0.1.4.