#evergreen: Evergreen Development Meeting, 10 August 2016

Meeting started by kmlussier at 15:01:20 US/Eastern (full logs).

Meeting summary

    1. http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2016-08-10 (kmlussier, 15:01:41)
    2. miker = Mike Rylander, ESI (miker, 15:01:57)
    3. DPearl = Dan Pearl, C/W MARS (DPearl, 15:02:01)
    4. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:02:05)
    5. agoben is Anna Goben, Evergreen Indiana (agoben, 15:02:17)
    6. berick Bill Erickson, KCLS (berick, 15:02:21)
    7. JBoyer Jason Boyer, Evergreen Indiana (JBoyer, 15:02:40)
    8. gmcharlt = Galen Charlton, ESI (gmcharlt, 15:02:43)
    9. Dyrcona Jason Stephenson, C/W MARS (Dyrcona, 15:02:43)
    10. dbwells is Dan Wells, Hekman Library (Calvin College) (dbwells, 15:02:58)
    11. remingtron is Remington Steed, Hekman Library (Calvin College) (remingtron, 15:03:02)

  1. Action Items from Last Meeting (kmlussier, 15:04:14)
    1. developers to continue looking at Sqitch, particularly release-building options. Bug #1521693 has been updated. berick is putting it on the back-burner for now. (kmlussier, 15:04:53)
    2. ACTION: gmcharlt will cut OpenSRF 2.5-alpha on 12 August (gmcharlt, 15:06:02)
    3. miker emailed a 2.11 schedule to the list and is working through pending bugs/pullrequests. (kmlussier, 15:08:07)
    4. ACTION: miker will build a "please look at these list" of pullrequests. (kmlussier, 15:08:40)
    5. dbwells sent an introductory email to the 2.11 release manager and buildmasters (kmlussier, 15:10:24)
    6. ACTION: gmcharlt and Dyrcona to create guidelines on the wiki to determine what is a bug fix vs. new feature. (kmlussier, 15:12:10)
    7. dbwells created a bug report with proposed changes for ingest speed improvements. The changes have been pushed. (kmlussier, 15:12:58)

  2. OpenSRF Release Info (kmlussier, 15:14:19)
    1. OpenSRF 2.5-alpha to be cut 12 August (gmcharlt, 15:14:59)
    2. ACTION: gmcharlt to move the mod_perl dependency from OpenSRF to the Evergreen side in time for the 2.5.0 release (kmlussier, 15:22:40)

  3. Evergreen 2.11 update (kmlussier, 15:23:54)
    1. http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/gmcharlt/webstaff-sprint3 (miker, 15:25:52)
    2. ACTION: miker to send message to e-mail list announcing alpha release. (kmlussier, 15:29:04)
    3. dbs is Dan Scott, Laurentian University (dbs, 15:30:26)
    4. ACTION: miker to send message to list seeking help to test web client sprint 3 (kmlussier, 15:37:07)
    5. New 2.11 beta release date to be August 24. (kmlussier, 15:41:33)

  4. 2016 Hack-a-way update (kmlussier, 15:42:51)
    1. http://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2016 (kmlussier, 15:46:40)

  5. Mentoring new developers in the community (kmlussier, 15:50:40)
    1. http://markmail.org/message/xts3sxx2zakad7mw (kmlussier, 15:55:57)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 16:04:21)

  6. Volunteer to organize / lead the September 7, 2016 meeting (kmlussier, 16:05:42)
    1. ACTION: gmcharlt will lead the September 2016 meeting. (kmlussier, 16:06:59)


Meeting ended at 16:08:02 US/Eastern (full logs).

Action items

  1. gmcharlt will cut OpenSRF 2.5-alpha on 12 August
  2. miker will build a "please look at these list" of pullrequests.
  3. gmcharlt and Dyrcona to create guidelines on the wiki to determine what is a bug fix vs. new feature.
  4. gmcharlt to move the mod_perl dependency from OpenSRF to the Evergreen side in time for the 2.5.0 release
  5. miker to send message to e-mail list announcing alpha release.
  6. miker to send message to list seeking help to test web client sprint 3
  7. gmcharlt will lead the September 2016 meeting.


Action items, by person

  1. Dyrcona
    1. gmcharlt and Dyrcona to create guidelines on the wiki to determine what is a bug fix vs. new feature.
  2. gmcharlt
    1. gmcharlt will cut OpenSRF 2.5-alpha on 12 August
    2. gmcharlt and Dyrcona to create guidelines on the wiki to determine what is a bug fix vs. new feature.
    3. gmcharlt to move the mod_perl dependency from OpenSRF to the Evergreen side in time for the 2.5.0 release
    4. gmcharlt will lead the September 2016 meeting.
  3. miker
    1. miker will build a "please look at these list" of pullrequests.
    2. miker to send message to e-mail list announcing alpha release.
    3. miker to send message to list seeking help to test web client sprint 3


People present (lines said)

  1. kmlussier (88)
  2. miker (43)
  3. gmcharlt (21)
  4. Dyrcona (13)
  5. JBoyer (10)
  6. agoben (8)
  7. dbwells (8)
  8. bshum (7)
  9. pinesol_green (6)
  10. DPearl (4)
  11. jeff (2)
  12. berick (2)
  13. Bmagic (1)
  14. remingtron (1)
  15. dbs (1)


Generated by MeetBot 0.1.4.