#evergreen: Evergreen Development Meeting, 6 October 2016

Meeting started by gmcharlt at 15:00:53 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2016-10-05 (gmcharlt, 15:01:03)

  1. Introductions (gmcharlt, 15:01:06)
    1. gmcharlt = Galen Charlton, Equinox (gmcharlt, 15:01:16)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 15:01:27)
    3. dyrcona = Jason Stephenson, C/W MARS (Dyrcona, 15:01:27)
    4. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:01:37)
    5. jeff is Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:01:39)
    6. abowling = Adam Bowling, Emerald Data Networks (abowling, 15:01:48)
    7. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:02:31)
    8. miker = Mike Rylander, Equinox (miker, 15:02:39)
    9. csharp = Chris Sharp, GPLS (csharp, 15:02:58)
    10. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:03:11)
    11. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:03:17)
    12. phasefx = Jason Etheridge, Equinox (phasefx, 15:04:01)
    13. bshum = Ben Shum, evergreener (bshum, 15:04:10)
    14. berick Bill Erickson King County (KCLS) (berick, 15:04:18)

  2. Action items from previous meeting (gmcharlt, 15:04:22)
    1. gmcharlt has not yet cut OpenSRF 2.5-alpha; am now targetting a release of the alpha before the Hack-a-way, with goal of releasing 2.5.0 during it (gmcharlt, 15:05:12)
    2. ACTION: gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way (gmcharlt, 15:05:28)
    3. miker coordinated some pullrequest review during the 2.11 release process (gmcharlt, 15:07:46)
    4. dbs = Dan Scott, Laurentian University (dbs, 15:09:40)
    5. Creating guidelines for distinguishing bugfixes from new features is now on the hackaway agenda (gmcharlt, 15:10:21)

  3. OpenSRF release info (gmcharlt, 15:14:17)
    1. gmcharlt has not yet cut OpenSRF 2.5-alpha; am now targetting a release of the alpha before the Hack-a-way, with goal of releasing 2.5.0 during it (gmcharlt, 15:14:36)
    2. ACTION: gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way (gmcharlt, 15:14:36)
    3. the window for OpenSRF pullrequests for inclusion in 2.5.0-alpha will be open until 24 October (gmcharlt, 15:15:12)
    4. https://www.youtube.com/watch?v=0Wi8Fv0AJA4 (gmcharlt, 15:17:31)

  4. Evergreen release (gmcharlt, 15:17:56)
    1. ACTION: gmcharlt will post blog announcement of 2.11 this afternoon (gmcharlt, 15:22:17)
    2. ACTION: kmlussier will start sending the press release out thereafter (gmcharlt, 15:22:29)
    3. 2.11.1 and 2.10.8 will be released on 10/19 (gmcharlt, 15:28:34)

  5. Hack-a-away (gmcharlt, 15:28:51)
    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2016-agenda (gmcharlt, 15:29:08)
    2. The hack-a-way will arrange time so that periods before lunch and mid-afternoon are reserved for individual and small-group activities (easing ability of EOB members to meet) (gmcharlt, 15:38:32)

  6. Evergreen.next release manager (gmcharlt, 15:38:53)
    1. https://en.wikipedia.org/wiki/Belling_the_cat explains all (jeffdavis, 15:47:52)
    2. ACTION: gmcharlt will send out a call for RM nominations on 10/17, closing on 10/28, with voting to occur second day of hack-a-way (gmcharlt, 15:51:18)

  7. Feedback request - bug 1629108 (gmcharlt, 15:51:49)
    1. https://bugs.launchpad.net/evergreen/+bug/1629108 (gmcharlt, 15:51:57)
    2. https://bugs.launchpad.net/evergreen/+bug/1403907/comments/24 (Bmagic, 15:55:14)


Meeting ended at 16:00:45 US/Eastern (full logs).

Action items

  1. gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way
  2. gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way
  3. gmcharlt will post blog announcement of 2.11 this afternoon
  4. kmlussier will start sending the press release out thereafter
  5. gmcharlt will send out a call for RM nominations on 10/17, closing on 10/28, with voting to occur second day of hack-a-way


Action items, by person

  1. gmcharlt
    1. gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way
    2. gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way
    3. gmcharlt will post blog announcement of 2.11 this afternoon
    4. gmcharlt will send out a call for RM nominations on 10/17, closing on 10/28, with voting to occur second day of hack-a-way
  2. kmlussier
    1. kmlussier will start sending the press release out thereafter


People present (lines said)

  1. gmcharlt (81)
  2. miker (45)
  3. kmlussier (20)
  4. dbwells (14)
  5. Bmagic (11)
  6. csharp (8)
  7. pinesol_green (7)
  8. abowling (5)
  9. Dyrcona (5)
  10. jeff (4)
  11. jeffdavis (3)
  12. remingtron (2)
  13. phasefx (2)
  14. dbs (2)
  15. berick (1)
  16. bshum (1)


Generated by MeetBot 0.1.4.