#evergreen: Evergreen development meeting, 4 October 2017

Meeting started by gmcharlt at 15:02:06 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-10-04 (gmcharlt, 15:02:11)

  1. Introductions (gmcharlt, 15:02:15)
    1. gmcharlt = Galen Charlton, Equinox, 3.0 release manager (gmcharlt, 15:02:28)
    2. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:02:30)
    3. DPearl is Dan Pearl, C/W MARS Inc. (DPearl, 15:02:31)
    4. miker == Mike Rylander, EOLI (miker, 15:02:34)
    5. phasefx = Jason Etheridge, EOLI (phasefx, 15:02:47)
    6. abneiman = Andrea Buntz Neiman, EOLI (abneiman, 15:02:58)
    7. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:03:03)
    8. JBoyer = Jason Boyer, IN State Library (JBoyer, 15:03:17)
    9. Bmagic = Blake GH, MOBIUS (Bmagic, 15:03:48)
    10. rhamby_ = Rogan Hamby, Equinox (rhamby_, 15:03:53)
    11. berick Bill Erickson, KCLS (berick, 15:03:59)

  2. Old business (gmcharlt, 15:05:08)
    1. Dyrcona = Jason Stephenson C/W MARS (Dyrcona, 15:05:40)
    2. ACTION: gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF (gmcharlt, 15:06:55)
    3. ACTION: berick and gmcharlt will get a shared Google Web Store account started (gmcharlt, 15:07:01)
    4. ACTION: kmlussier will wrangle creation of necessary icons/logos for the store and Hatch app (gmcharlt, 15:07:09)

  3. OpenSRF (gmcharlt, 15:08:07)
    1. OpenSRF 3.0.0 is available; it's essentially OpenSRF 2.5.x + Stretch support + renaming shared libraries for C services (gmcharlt, 15:08:42)
    2. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:11:22)
    3. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:11:39)
    4. cesardv = Cesar Velez, EOLI (cesardv, 15:12:04)

  4. Evergreen (gmcharlt, 15:17:24)
    1. Evergreen 3.0.0 was released on 3 October (gmcharlt, 15:17:39)
    2. Evergreen 3.0.1 will be released along with the other maintenance releases on 18 October (gmcharlt, 15:18:01)

  5. Selecting next release manager (gmcharlt, 15:22:02)
    1. AGREED: Call for 3.1 release manager nominations will be made on 10/9 and close on 10/20 with IRC vote to be held on 10/25 (gmcharlt, 15:26:11)

  6. 2.12 and 3.0 rmaints (gmcharlt, 15:26:50)
    1. AGREED: kmlussier will continue on as 2.12 release maintainer (gmcharlt, 15:32:42)
    2. AGREED: gmcharlt will serve as 3.0 release maintainer (gmcharlt, 15:32:53)
    3. ACTION: dbwells will send out a call for additional buildmasters (gmcharlt, 15:38:09)

  7. 2017 hack-a-way (gmcharlt, 15:39:20)
    1. https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017 (gmcharlt, 15:39:34)
    2. Hack-a-way agenda is https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017-agenda (gmcharlt, 15:39:48)
    3. https://docs.google.com/forms/d/e/1FAIpQLSdepNIDR_hkjozA7TcL2IUAv6r-GTCZ6Rtn4x_5UkdJ_iabKA/viewform (berick, 15:45:02)


Meeting ended at 15:51:21 US/Eastern (full logs).

Action items

  1. gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
  2. berick and gmcharlt will get a shared Google Web Store account started
  3. kmlussier will wrangle creation of necessary icons/logos for the store and Hatch app
  4. dbwells will send out a call for additional buildmasters


Action items, by person

  1. berick
    1. berick and gmcharlt will get a shared Google Web Store account started
  2. dbwells
    1. dbwells will send out a call for additional buildmasters
  3. gmcharlt
    1. gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
    2. berick and gmcharlt will get a shared Google Web Store account started
  4. kmlussier
    1. kmlussier will wrangle creation of necessary icons/logos for the store and Hatch app


People present (lines said)

  1. gmcharlt (83)
  2. berick (15)
  3. JBoyer (15)
  4. kmlussier (12)
  5. miker (11)
  6. dbwells (8)
  7. pinesol_green (6)
  8. Bmagic (6)
  9. Dyrcona (5)
  10. rhamby_ (4)
  11. jeff (3)
  12. cesardv (3)
  13. phasefx (3)
  14. remingtron (2)
  15. agoben (2)
  16. abneiman (1)
  17. DPearl (1)
  18. jeffdavis (1)


Generated by MeetBot 0.1.4.